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FOREWORD 

NX is one of the world’s most advanced and tightly integrated CAD/CAM/CAE product 

development solution from Siemens PLM Software. Spanning the entire range of product 

development, NX delivers immense value to enterprises of all sizes. It simplifies complex product 

development, thus speeding up the process of introducing products to the market. 

The NX software integrates multidisciplinary principles, conceptual design, 3D modeling, 

documentation, engineering analysis, graphic simulation, and concurrent engineering. The 

software has powerful hybrid modeling capabilities by integrating constraint-based feature 

modeling and explicit geometric modeling. In addition to modeling standard geometry parts, it 

allows the user to design complex freeform shapes such as airfoils and manifolds. It also merges 

solid and surface modeling techniques into one powerful toolset. 

This self-guided tutorial provides a step-by-step approach for users to learn NX 12. It is intended 

for those with no previous experience with NX. However, users of previous versions of NX may 

also find this tutorial useful for them to learn the new user interfaces and functions. The user will 

be guided from starting an NX 12 session to creating models and designs that have various 

applications. Each chapter has components explained with the help of various dialog boxes and 

screenshots. These components are later used in the assembly modeling, machining and finite 

element analysis. The files of components are also available online to download and use. We first 

released the tutorial for Unigraphics 18 and later updated for NX 2 followed by the updates for 

NX 3, NX 5, NX 7, NX 9 and NX 10. This write-up further updates to NX 12. 

Our previous efforts to prepare the NX self-guided tutorial were funded by the National Science 

Foundation’s Advanced Technological Education Program and by the Partners of the 

Advancement of Collaborative Engineering Education (PACE) program. 

If you have any questions or comments about this tutorial, please email Ming C. Leu at 

mleu@mst.edu or Wenjin Tao at wt6c2@mst.edu. The models and all the versions of the tutorial 

are available at http://web.mst.edu/~mleu. 
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CHAPTER 1 – INTRODUCTION 

The modern manufacturing environment can be characterized by the paradigm of delivering 

products of increasing variety, smaller batches and higher quality in the context of increasing 

global competition. Industries cannot survive worldwide competition unless they introduce new 

products with better quality, at lower costs and with shorter lead-time. There is intense 

international competition and decreased availability of skilled labor. With dramatic changes in 

computing power and wider availability of software tools for design and production, engineers are 

now using Computer Aided Design (CAD), Computer Aided Manufacturing (CAM) and Computer 

Aided Engineering (CAE) systems to automate their design and production processes. These 

technologies are now used every day for all sorts of different engineering tasks. Below is a brief 

description of how CAD, CAM, and CAE technologies are being used during the product 

realization process. 

1.1 PRODUCT REALIZATION PROCESS 

The product realization process can be roughly divided into two phases: design and manufacturing. 

The design process starts with identification of new customer needs and design variables to be 

improved, which are identified by the marketing personnel after getting feedback from the 

customers. Once the relevant design information is gathered, design specifications are formulated. 

A feasibility study is conducted with relevant design information and detailed design and analyses 

are performed. The detailed design includes design conceptualization, prospective product 

drawings, sketches and geometric modeling. Analysis includes stress analysis, interference 

checking, kinematics analysis, mass property calculations and tolerance analysis, and design 

optimization. The quality of the results obtained from these activities is directly related to the 

quality of the analysis and the tools used for conducting the analysis. 

The manufacturing process starts with the shop-floor activities beginning from production 

planning, which uses the design process drawings and ends with the actual product. Process 

planning includes activities like production planning, material procurement, and machine 

selection. There are varied tasks like procurement of new tools, NC programming and quality 

checks at various stages during the production process. Process planning includes planning for all 
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the processes used in manufacturing of the product. Parts that pass the quality control inspections 

are assembled functionally tested, packaged, labeled, and shipped to customers. 

A diagram representing the Product Realization Process (Mastering CAD/CAM, by Ibrahim Zeid, 

McGraw Hill, 2005) is shown below. 

 

1.2 BRIEF HISTORY OF CAD/CAM DEVELOPMENT 

The roots of current CAD/CAM technologies go back to the beginning of civilization when 

engineers in ancient Egypt recognized graphics communication. Orthographic projection practiced 

today was invented around the 1800s. The real development of CAD/CAM systems started in the 

1950s. CAD/CAM went through four major phases of development in the last century. The 1950s 

was known as the era of interactive computer graphics. MIT’s Servo Mechanisms Laboratory 

demonstrated the concept of numerical control (NC) on a three-axis milling machine. Development 

in this era was slowed down by the shortcomings of computers at the time. During the late 1950s 
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the development of Automatically Programmed Tools (APT) began and General Motors explored 

the potential of interactive graphics. 

The 1960s was the most critical research period for interactive computer graphics. Ivan Sutherland 

developed a sketchpad system, which demonstrated the possibility of creating drawings and 

altercations of objects interactively on a cathode ray tube (CRT). The term CAD started to appear 

with the word ‘design’ extending beyond basic drafting concepts. General Motors announced their 

DAC-1 system and Bell Technologies introduced the GRAPHIC 1 remote display system. 

During the 1970s, the research efforts of the previous decade in computer graphics had begun to 

be fruitful, and potential of interactive computer graphics in improving productivity was realized 

by industry, government and academia. The 1970s is characterized as the golden era for computer 

drafting and the beginning of ad hoc instrumental design applications. National Computer 

Graphics Association (NCGA) was formed and Initial Graphics Exchange Specification (IGES) 

was initiated. 

In the 1980s, new theories and algorithms evolved and integration of various elements of design 

and manufacturing was developed. The major research and development focus was to expand 

CAD/CAM systems beyond three-dimensional geometric designs and provide more engineering 

applications. 

The present day CAD/CAM development focuses on efficient and fast integration and automation 

of various elements of design and manufacturing along with the development of new algorithms. 

There are many commercial CAD/CAM packages available for direct usages that are user-friendly 

and very proficient. 

Below are some of the commercial packages in the present market. 

 Solid Edge, AutoCAD, Inventor and TurboCAD are some affordable CAD software 

systems. 

 NX, Pro-E, CATIA and SolidWorks are high-end modeling and designing software 

systems that are costlier but more powerful. These software systems also have computer 

aided manufacturing and engineering analysis capabilities. 

 Onshape and Fusion 360 are cloud based CAD software, which provide CAD capabilities 

via user’s browser. 
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 ANSYS, ABAQUS, NASTRAN and COMSOL are packages mainly used for CAE 

purposes. 

1.3 DEFINITION OF CAD/CAM/CAE 

Following are the definitions of some of the terms used in this tutorial. 

1.3.1 Computer Aided Design – CAD 

CAD is technology concerned with using computer systems to assist in the creation, modification, 

analysis, and optimization of a design. Any computer program that embodies computer graphics 

and an application program facilitating engineering functions in design process can be classified 

as CAD software. 

The most basic role of CAD is to define the geometry of design – a mechanical part, a product 

assembly, an architectural structure, an electronic circuit, a building layout, etc. The greatest 

benefits of CAD systems are that they can save considerable time and reduce errors caused by 

otherwise having to redefine the geometry of the design from scratch every time it is needed. 

1.3.2 Computer Aided Manufacturing – CAM 

CAM technology involves computer systems that plan, manage, and control the manufacturing 

operations through computer interface with the plant’s production resources.   

One of the most important areas of CAM is numerical control (NC). This is the technique of using 

programmed instructions to control a machine tool, which cuts, mills, grinds, punches or turns raw 

stock into a finished part. Another significant CAM function is in the programming of robots. 

Process planning is also a target of computer automation. 

1.3.3 Computer Aided Engineering – CAE 

CAE technology uses a computer system to analyze the functions of a CAD-created product, 

allowing designers to simulate and study how the product will behave so that the design can be 

refined and optimized. 

CAE tools are available for a number of different types of analyses. For example, kinematic 

analysis programs can be used to determine motion paths and linkage velocities in mechanisms. 

Dynamic analysis programs can be used to determine loads and displacements in complex 

assemblies such as automobiles. One of the most popular methods of analyses is using a Finite 
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Element Method (FEM). This approach can be used to determine stress, deformation, heat transfer, 

magnetic field distribution, fluid flow, and other continuous field problems that are often too tough 

to solve with any other approach. 

1.4. SCOPE OF THIS TUTORIAL 

This tutorial is written for students and engineers who are interested in learning how to use NX 12 

for designing mechanical components and assemblies. Learning to use NX 12 will also be valuable 

for learning how to use other CAD systems such as PRO-E and CATIA. This tutorial provides a 

systematic approach for learning NX 12. 

Chapter 2 includes the NX 12 essentials from starting a session to getting familiar with the NX 

12 layout by practicing basic functions such as Print, Save, and Exit. It also gives a brief description 

of the Coordinate System, Layers, various toolboxes and other important commands, which will 

be used in later chapters. 

Chapter 3 presents the concept of sketching. It describes how to create sketches and to give 

geometric and dimensional constraints. This chapter is very important since present-day 

components are very complex in geometry and difficult to model with only basic features. 

The actual designing and modeling of parts begins with chapter 4. It describes different features 

such as reference features, swept features and primitive features and how these features are used 

to create designs. Various kinds of feature operations are performed on features. 

You will learn how to create a drawing from a part model in chapter 5. In this chapter, we 

demonstrate how to create a drawing by adding views, dimensioning the part drawings, and 

modifying various attributes in the drawing such as text size, arrow size and tolerance. 

Chapter 6 teaches the concepts of Assembly Modeling and its terminologies. It describes Top-

Down modeling and Bottom-Up modeling. We will use Bottom-Up modeling to assemble 

components into a product. 

Chapter 7 introduces free-form modeling. The method of modeling curves and smooth surfaces 

will be demonstrated.  

Chapter 8 is capsulated into a brief introduction to Design Simulations available in NX 12 for the 

Finite Element Analysis. 
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Chapter 9 will be a real-time experience of implementing a designed model into a manufacturing 

environment for machining. This chapter deals with generation, verification and simulation of Tool 

Path to create CNC (Computer Numerical Codes) to produce the designed parts from multiple axes 

and even advanced CNC machines. 

The examples and exercise problems used in each chapter are so designed that they will be finally 

assembled in the chapter. Due to this distinctive feature, you should save all the models that you 

have generated in each chapter. 
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CHAPTER 2 – GETTING STARTED  

Let’s begin with starting of an NX 12 session. This chapter will provide the basics required to use 

any CAD/CAM package. You will learn the preliminary steps to start, to understand and to use the 

NX 12 package for modeling, drafting, etc. It contains five sub-sections a) Opening an NX 12 

session, b) Printing, saving, and closing part files, c) getting acquainted with the NX 12 user 

interface d) Using layers and e) Understanding important commands and dialogs. 

2.1 STARTING AN NX 12 SESSION AND OPENING FILES 

2.1.1 Start an NX 12 Session 

 From the Windows desktop screen, click on Start → Program List →Siemens NX 12 → 

NX 12 
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The main NX 12 Screen will open. This is the Gateway for the NX 12 software. The NX 12 blank 

screen looks like the figure shown below. There will be several tips displayed on the screen about 

the special features of the current version. The Gateway also has the Standard Toolbar that will 

allow you to create a new file or open an existing file. On the left side of the Gateway screen, there 

is a toolbar called the Resource Bar that has menus related to different modules and the ability to 

define and change the Role of the software, view History of the software use and so on. This will 

be explained in detail later in this chapter. 

 

2.1.2 Open a New File 

Let’s begin by learning how to open a new part file in NX 12. To create a new file there are three 

options. 

 Click on the New button  on top of the screen 

OR 

 Go through the File drop-down menu at the top-left of the screen and click New 

OR 
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 Press <Ctrl> + N 

This will open a new session, asking for the type, name and location of the new file to be created.  

There are numerous types of files in NX 12 to select from the Templates dialogue box located at 

the center of the window. The properties of the selected file are displayed below the Preview on 

the right side. Since we want to work in the modeling environment and create new parts, only 

specify the units (inches or millimeters) of the working environment and the name and location of 

the file. The default unit is millimeters. 

 Enter an appropriate name and location for the file and click OK 

 

2.1.3 Open a Part File 

There are several ways to open an existing file. 

 Click on the Open or Open a Recent Part button on top of the screen 
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OR  

 Go through the File drop-down menu at the top-left of the screen and click Open 

OR 

 Press <Ctrl> + O 

The Open Part File dialog will appear. You can see the preview of the files on the right side of the 

window. You can disable the Preview by un-clicking the box in front of the Preview button. 

 Click Cancel to exit the window 
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2.2 PRINTING, SAVING AND CLOSING FILES 

2.2.1 Print an NX 12 Image  

To print an image from the current display, 

 Click File →Print 

The following figure shows the Print dialog box. Here, 

you can choose the printer to use or specify the number 

of copies to be printed, size of the paper and so on. 

You can also select the scale for all the three 

dimensions. You can also choose the method of 

printing, i.e. wireframe, solid model by clicking on the 

Output drop down-menu as shown in the Figure on right 

side 

 Click Cancel to exit the window 

2.2.2 Save Part Files 

It is imperative that you save your work frequently. If 

for some reasons, NX 12 shuts down and the part is not 

saved, all the work will be lost. To save the part files, 

 Click File →Save 

There are five options to save a file: 

Save: This option will save the part on screen with the 

same name as given before while creating the part file. 

Save Work Part Only: This option will only save the 

active part on the screen. 

Save As: This option allows you to save the part on screen using a different name and/or type. The 

default type is .prt. However,  you can save your file as IGES (.igs), STEP 203 (.stp), STEP 214 

(.step), AutoCAD DXF (.dxf), AutoCAD DWG (.dwg), CATIA Model (.model) and CATIA V5 

(.catpart). 

Save All: This option will save all the opened part files with their existing names. 
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Save Bookmark: This option will save a screenshot and context of the present model on the screen 

as a .JPEG file and bookmarks. 

 

2.2.3 Close Part Files 

You can choose to close the parts that are 

visible on screen by  

 Click File →Close 

If you close a file, the file will be cleared from 

the working memory and any changes that are 

not saved will be lost. Therefore, remember 

to select Save and Close, Save As and Close, 

Save All and Close or Save All and Exit. In 

case of the first three options, the parts that 

are selected or all parts will be closed but the 

NX 12 session keeps on running. 
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2.2.4 Exit an NX 12 Session 

 Click File →Exit 

 

If you have files open and have made changes to them without saving, the message will ask you if 

you really want to exit. 

 Select No, save the files and then Exit 

2.3 NX 12 INTERFACE 

The user interface of NX 12 is made very simple through the use of different icons. Most of the 

commands can be executed by navigating the mouse around the screen and clicking on the icons. 

The keyboard entries are mostly limited to entering values and naming files.  

2.3.1 Mouse Functionality 

2.3.1.1 Left Mouse Button (MB1) 

The left mouse button, named Mouse Button 1 (MB1) in NX, is used for Selection of icons, menus, 

and other entities on the graphic screen. Double clicking MB1 on any feature will automatically 

open the Edit Dialog box. Clicking MB1 on an object enables the user to have quick access to 

several options shown below. These options will be discussed in next chapters. 
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2.3.1.2 Middle Mouse Button (MB2) 

The middle mouse button (MB2) or the scroll button is used to Rotate the object by pressing, 

holding and dragging. The model can also be rotated about a single axis. To rotate about the axis 

horizontal to the screen, place the mouse pointer near the right edge of the graphic screen and 

rotate. Similarly, for the vertical axis and the axis perpendicular to the screen, click at the bottom 

edge and top edge of the screen respectively and rotate. If you keep pressing the MB2 at the same 

position for a couple of seconds, it will fix the point of rotation (an orange circle symbol appears) 

and you can drag around the object to view. 

If it is a scroll button, the object can be zoomed in and out by scrolling. Clicking the MB2 will 

also execute the OK command if any pop-up window or dialog box is open. 

 

2.3.1.3 Right Mouse Button (MB3) 

MB3 or Right Mouse Button is used to 

access the user interface pop-up 

menus. You can access the subsequent 

options that pop up depending on the 

selection mode and Application. The 

figure shown below is in Sketch 

Application. Clicking on MB3 when a 

feature is selected will give the options 

related to that feature (Object/Action 

Menu). 
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Clicking MB3 and holding the button will display a set of icons around the feature. 

These icons feature the possible commands that can be applied to the feature.  

2.3.1.4 Combination of Buttons 

Zoom In /Out: 

 Press and hold both MB1 and MB2 simultaneously and drag 

OR 

 Press and hold <Ctrl> button on the keyboard and then press and drag the MB2 

OR 

 

Pan: 

 Press and hold both the MB2 and MB3 simultaneously and drag 

OR 

 Press and hold <Shift> button on the keyboard and press and drag the MB2  

 

Shortcut to menus: 

 Press and hold <Ctrl> + <Shift> and MB1, MB2 and MB3 to see shortcuts to Feature, 

Direct Sketch, and Synchronous Modeling groups, respectively 
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2.3.2 NX 12 Gateway  

The following figure shows the typical layout of the NX 12 window when a file is opened. This is 

the Gateway of NX 12 from where you can select any module to work on such as modeling, 

manufacturing, etc. It has to be noted that these toolbars may not be exactly on the same position 

of the screen as shown below. The toolbars can be placed at any location or position on the screen. 

Look out for the same set of icons. 

 

2.3.2.1 Ribbon Bar 

The ribbon bar interface gives the user the ability to access the different commands easily without 

reducing the graphics window area. Commands are organized in ribbon bars under different tabs 

and groups for easy recognition and accessibility. 

Resource Bar 

Cue Line 

Tabs 

Graphic Window 

Ribbon Bar 

Top-border 

Groups 

Quick Access Toolbar 

Command Finder 



NX 12 for Engineering Design 18 Missouri University of Science and Technology 

 

For example in the ribbon bar shown in the figure above, we have home, curve, etc. tabs. In the 

home tab, we have direct sketch, feature, synchronous modeling and surface groups. And in each 

group, we have a set of featured commands. 

2.3.2.2 Quick Access Toolbar 

The quick access toolbar has most commonly used buttons (save, undo, redo, cut, copy, paste and 

recent commands) to expedite the modeling process. You may easily customize these buttons as 

shown in the figure below. 

 

2.3.2.3 Command Finder 

If you do not know where to find a command, use Command Finder. Let’s say we have forgotten 

where the Styled Sweep is.  

 Type sweep in the Command Finder 

 Hover the mouse over Styled Sweep 

 NX will show you the path to the command: Menu →Insert →Sweep →Styled Sweep 

OR 
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 Type sweep in the Command Finder 

 Click on Styled Sweep in the Command Finder window 

 

2.3.2.4 Top-border 

The most important button in the top-border is the menu button. Most of the features and functions 

of the software are available in the menu. The Selection Bar displays the selection options. These 

options include the Filters, Components/Assembly, and Snap Points for selecting features. Most 

common buttons in the View tab are also displayed in the Top-border. 

2.3.2.5 Resource Bar 

The Resource Bar features icons for a number of pages in one place using very little user interface 

space. NX 12 places all navigator windows (Assembly, Constraint and Part) in the Resource Bar, 

as well as the Reuse Library, HD3D Tools, Web Browser, History Palette, Process Studio, 

Manufacturing Wizards, Roles and System Scenes. Two of the most important widows are 

explained below. 
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Part Navigator 

 Click on the Part Navigator icon, the third 

icon from the top on the Resource bar 

The Part Navigator provides a visual representation 

of the parent-child relationships of features in the 

work part in a separate window in a tree type format. 

It shows all the primitives, entities used during 

modeling. It allows you to perform various editing 

actions on those features. For example, you can use 

the Part Navigator to Suppress or Unsuppress the 

features or change their parameters or positioning 

dimensions. Removing the green tick mark will 

‘Suppress’ the feature. The software will give a 

warning if the parent child relationship is broken by 

suppressing any particular feature. 

The Part Navigator is available for all NX 

applications and not just for modeling. However, you can only perform feature-editing operations 

when you are in the Modeling module. Editing a feature in the Part Navigator will automatically 

update the model. Feature editing will be discussed later. 

History 

 Click on the History icon, the seventh from the top on the Resource bar 

The History Palette provides fast access to recently opened files or other palette entries. It can be 

used to reload parts that have been recently worked on or to repeatedly add a small set of palette 

items to a model. 

The History Palette remembers the last palette options that were used and the state of the session 

when it was closed. NX stores the palettes that were loaded into a session and restores them in the 

next session. The system does not clean up the History Palette when parts are moved. 
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To re-use a part, drag and drop it from the History 

Palette to the Graphics Window. To reload a part, 

click on a saved session bookmark. 

2.3.2.6 Cue Line 

The Cue Line displays prompt messages that indicate 

the next action that needs to be taken. To the right of 

the Cue line, the Status Line is located which 

displays messages about the current options or the 

most recently completed function. 

The Progress Meter is displayed in the Cue Line 

when the system performs a time-consuming 

operation such as loading a large assembly. The 

meter shows the percentage of the operation that has 

been completed. When the operation is finished, the 

system displays the next appropriate cue. 

2.3.3 Geometry Selection 

You can filter the selection method, which facilitates 

easy selection of the geometry in a close cluster. In 

addition, you can perform any of the feature 

operation options that NX 12 intelligently provides 

depending on the selected entity. Selection of items can be based on the degree of the entity like, 

selection of Geometric entities, Features and Components. The selection method can be opted by 

choosing one of the icons in the Selection Toolbar. 

2.3.3.1 Feature Selection 

Clicking on any of the icons lets you select the features in the part file. It will not select the basic 

entities like edges, faces etc. The features selected can also be applied to a part or an entire 

assembly depending upon the requirement. 
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Besides that, the filtering of the features can be further narrowed down by 

selecting one of the desired options in the drop-down menu as shown in the 

figure. For example, selecting Curve will highlight only the curves in the 

screen. The default is No Selection Filter. 

2.3.3.2 General Object Selection 

Navigate the mouse cursor closer to the entity until it is highlighted with a 

magenta color and click the left mouse button to select any geometric entity, 

feature, or component. 

If you want to select an entity that is hidden behind the displayed geometry, 

place the mouse cursor roughly close to that area on the screen such that the 

cursor ball occupies a portion of the hidden geometry projected on the 

screen. After a couple of seconds, the ball cursor turns into a plus symbol 

as shown in the figure. Click the left mouse button (MB1) to get a Selection 

Confirmation dialog box as shown in the 

following figure below. This QuickPick 

menu consists of the list of entities 

captured within the ball of the cursor. The 

entities are arranged in ascending order of 

the degree of the entity. For example, 

edges and vertices are assigned lower 

numbers while solid faces are given 

higher numbers. By moving the cursor on 

the numbers displayed, NX 12 will 

highlight the corresponding entity on the screen in a magenta color.  

2.3.4 User Preferences 

 Choose Preferences on the Menu button (located to top left of the main window) to find 

the various options available 
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User Preferences are used to define the display parameters of 

new objects, names, layouts, and views. You can set the layer, 

color, font, and width of created objects. You can also design 

layouts and views, control the display of object and view 

names and borders, change the size of the selection ball, 

specify the selection rectangle method, set chaining tolerance 

and method, and design and activate a grid. Changes that you 

make using the Preferences menu override any counterpart 

customer defaults for the same functions. 

2.3.4.1 User Interface 

 Choose Preferences →User Interface to find the 

options in the dialog box 

The User Interface option customizes how NX works and 

interacts to specifications you set. You can control the 

location, size and visibility status of the main window, 

graphics display, and information window. You can set the 

number of decimal places (precision) that the system uses for 

both input text fields and data displayed in the information 

window. You can also specify a full or small dialog for file 

selection. You can also set macro options and enable a 

confirmation dialog for Undo operations. 

 The Layout tab allows you to select the User Interface Environment 

 The Touch tab lets you use touch screens 

 The Options tab allows you, among others, to set the precision level (in the Information 

Window) 

 The Journal tab in the Tools allows you to use several programming languages  

 The Macro tab in the Tools allows you to set the pause while displaying animation 
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2.3.4.2 Visualization 

 Choose Preferences →Visualization to find the 

options in the dialog box 

This dialog box controls attributes that affect the display in 

the graphics window. Some attributes are associated with 

the part or with particular Views of the part. The settings for 

these attributes are saved in the part file. For many of these 

attributes, when a new part or a view is created, the setting 

is initialized to the value specified in the Customer Defaults 

file. Other attributes are associated with the session and 

apply to all parts in the session. The settings of some of 

these attributes are saved from session to session in the 

registry. For some session attributes, the setting can be 

initialized to the value specified by customer default, an 

environment variable. 

 Choose Preferences →Color Pallet to find the 

options in the dialog box 
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 Click on Preferences →Background to get 

another pop up Dialog box. You can change 

your background color whatever you want 

The background color refers to the color of the 

background of the graphics window. NX supports 

graduated backgrounds for all display modes. You can 

select background colors for Shaded or Wireframe 

displays. The background can be Plain or Graduated. 

Valid options for all background colors are 0 to 255. 

You can change and observe the Color and 

Translucency of objects. 

 Click Preferences →Object 

This will pop up a dialog window Object Preferences. 

You can also apply this setting to individual entities of 

the solid. For example, you can click on any particular 

surface of the solid and apply the Display settings. 

2.3.5 Applications 

Applications can be opened using the File option 

located at the top left corner of the main window OR 

the Applications tab above the Ribbon bar. You can 

select the type of application you want to run. For 

example, you can select Modeling, Drafting, 

Assembly, and so on as shown in the figure. The default Application that starts when you open a 

file or start a new file is Modeling. We will introduce some of these Application in the next 

chapters. 
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2.4 LAYERS 

Layers are used to store objects in a file, and work like containers to collect the objects in a 

structured and consistent manner. Unlike simple visual tools like Show and Hide, Layers provide 

a permanent way to organize and manage the visibility and selectability of objects in your file. 

2.4.1 Layer Control 

With NX 12, you can control whether objects are visible or selectable by using Layers. A Layer is 

a system-defined attribute such as color, font, and width that all objects in NX 12 must have. There 

are 256 usable layers in NX 12, one of which is always the Work Layer. Any of the 256 layers can 

be assigned to one of four classifications of status. 

 Work 

 Selectable 

 Visible Only 

 Invisible 

The Work Layer is the layer that objects are created ON and is 

always visible and selectable while it remains the Work Layer. 

Layer 1 is the default Work Layer when starting a new part file. 

When the Work Layer is changed to another type of layer, the 

previous Work Layer automatically becomes Selectable and can 

then be assigned a status of Visible Only or Invisible. 

The number of objects that can be on one layer is not limited. You 

have the freedom to choose whichever layer you want to create 

the object on and the status of that layer.  

To assign a status to a layer or layers,  

 Choose View →Layer Settings 

However, it should be noted that the use of company standards in 

regards to layers would be advantageous to maintain a consistency 

between files. 
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2.4.2 Commands in Layers 

We will follow simple steps to practice the commands in Layers. First, we will create two objects 

(Solids) by the method as follows. The details of Solid Modeling will be discussed in the next 

chapter. The solids that we draw here are only for practice in this chapter. 

 Choose File →New 

Name the file and choose a folder in which to save it. Make 

sure you select the units to be millimeters in the drop-down 

menu. Choose the file type as Model  

 Choose Menu →Insert →Design Feature 

→Cone 

 Choose Diameter and Height under Type 

 Click OK 

 Right-click on the screen and choose Orient View 

→Trimetric 

 Right-click on the screen and choose Rendering 

Style →Shaded 

You will be able to see a solid cone similar to the picture 

on right. 

Now let us practice some Layer Commands. 

 Choose View →Move to Layer 

You will be asked to select an object 

 Move the cursor on to the Cone and click on it so that it becomes highlighted 

 Click OK 
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 In the Destination Layer or Category space at the top of the window, type 25 and Click 

OK 

The Cone has now gone to the 25th layer. It can no longer be 

seen in Layer 1. 

 To see the Cone, click View →Layer Settings 

 You can see that Layer 25 has the object whereas the 

default Work Layer 1 has no objects. 

The Cone will again be seen on the screen. Save the file as we 

will be using it later in the tutorial. 
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2.5 COORDINATE SYSTEMS 

There are different coordinate systems in NX. A three-axis symbol is used to identify the 

coordinate system. 

2.5.1 Absolute Coordinate System 

The Absolute Coordinate System is the coordinate system from which 

all objects are referenced. This is a fixed coordinate system and the 

locations and orientations of every object in NX 12 modeling space are 

related back to this system. The Absolute Coordinate System (or 

Absolute CSYS) also provides a common frame of reference between 

part files. An absolute position at X=1, Y=1, and Z=1 in one part file is 

the same location in any other part file. 

The View Triad on the bottom-left of the Graphics window is ONLY a visual 

indicator that represents the ORIENTATION of the Absolute Coordinate System 

of the model. 

2.5.2 Work Coordinate System 

The Work Coordinate System (WCS) is what you will use for construction when you want to 

determine orientations and angles of features. The axes of the WCS are denoted XC, YC, and ZC. 

(The “C” stands for “current”). It is 

possible to have multiple coordinate 

systems in a part file, but only one of them 

can be the work coordinate system. 

2.5.3 Moving the WCS 

Here, you will learn how to translate and 

rotate the WCS.  

 Choose Menu →Format →WCS 

2.5.3.1 Translate the WCS 

This procedure will move the WCS origin 

to any point you specify, but the 
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orientation (direction of the axes) of the WCS will remain the same. 

 Choose Menu →Format →WCS →Origin 

The Point Constructor dialog is displayed. You either can 

specify a point from the drop down menu at the top of the 

dialog box or enter the X-Y-Z coordinates in the XC, YC, 

and ZC fields. 

The majority of the work will be in relation to the Work 

Coordinate System rather than the Absolute Coordinate 

System. The default is the WCS.  

2.5.3.2 Rotate the WCS 

You can also rotate the WCS around one of its axes. 

 Choose Menu → Format →WCS →Rotate 

The dialog shows six different ways to rotate the WCS 

around an axis. These rotation procedures follow the right-

hand rule of rotation. You can also specify the angle to which the 

WCS be rotated. 

You can save the current location and orientation of the WCS to use 

as a permanent coordinate system. 

 Choose Menu →Format →WCS →Save 

2.6 TOOLBARS 

Toolbars contain icons, which serve as shortcuts for many functions. 

The figure on the right shows the main Toolbar items normally 

displayed. However, you can find many more icons for different 

feature commands, based on the module selected and how the 

module is customized. 
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 Right-Clicking anywhere on the existing toolbars gives a list of other Toolbars. You can 

add any of the toolbars by checking them. 

Normally, the default setting should be sufficient for most operations but during certain operations, 

you might need additional toolbars. If you want to add buttons pertaining to the commands and 

toolbars,  

 Click on the pull-down arrow on any of the Toolbars and choose Customize. 

 

This will pop up a Customize dialog window with all the Toolbars and commands pertaining to 

each Toolbar under Commands tab. To add a command, 

 Choose a category and drag the command from the Commands list to the desired location. 
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You can customize the settings of your NX 12 interface by 

clicking on the Roles tab on the Resource Bar. 

The Roles tab has different settings of the toolbar menus 

that are displayed on the NX 12 interface. It allows you to 

customize the toolbars you desire to be displayed in the 

Interface. 
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CHAPTER 3 – TWO DIMENSIONAL SKETCHING 

In this chapter, you will learn how to create and edit sketches in NX 12. You can directly create a 

sketch on a Plane in Modeling application. In most cases, Modeling starts from a 2D sketch and 

then Extrude, Revolve or Sweep the sketch to create solids. Many complex shapes that are 

otherwise very difficult to model can easily be drawn by sketching. In this chapter, we will see 

some concepts of sketching and then proceed to sketch and model some parts. 

3.1 OVERVIEW 

An NX 12 sketch is a named set of curves joined in a string that when swept, form a solid. The 

sketch represents the outer boundary of that part. The curves are created on a plane in the sketcher. 

In the beginning, these curves are drawn without any exact dimensions. Then, Dimensional 

Constraints as well as Geometric Constraints are applied to fully constrain the sketch. These will 

be discussed in detail later in this chapter. 

After sketching is completed, there are different ways to use them to generate 3D parts: 

 A sketch can be revolved 

 

 

 

 A sketch can be extruded 

 

 

 

 

 

 A sketch can be swept along a guide (line): 

 

 

Features created from a sketch are associated with it; i.e., if 

the sketch changes so do the features. 
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The advantages of using sketching to create parts are: 

 The curves used to create the profile outline are very flexible and can be used to model 

unusual shapes. 

 The curves are parametric, hence associative and they can easily be changed or removed. 

 If the plane in which the sketch is drawn is changed, the sketch will be changed 

accordingly. 

 Sketches are useful when you want to control an outline of a feature, especially if it may 

need to be changed in the future. Sketches can be edited very quickly and easily. 

3.2 SKETCHING ENVIRONMENT 

In NX 12 you can create sketch using two ways. 

The first method creates the Sketch in the current 

environment and application. For this, 

 Choose Menu →Insert →Sketch 

In the other method you can create Sketch using 

 Choose Sketch in Home toolbar 

In either case, a dialog box pop-ups asking you 

to define the Sketch Plane. The screen will 

display the sketch options. You can choose the 

Sketch Plane, direction of sketching and type of 

plane for sketching. When you create a sketch using the Create Sketch dialog box, you can choose 

the plane on which the sketch can be created by clicking on the coordinate frame as shown. This 

will highlight the plane you have selected. The default plane selected is 

XC-YC. However, you can choose to sketch on another plane. If there are 

any solid features created in the model beforehand, any of the flat surfaces 

can also be used as a sketching plane. 

 Choose the XC-YC plane and click OK 

The sketch plane will appear and the X-Y directions will be marked. 



NX 12 for Engineering Design 35 Missouri University of Science and Technology 

 

The main screen will change to the Sketching Environment. The XY plane is highlighted as the 

default plane for sketching. This is the basic sketch window. There is also a special Sketch Task 

Environment in NX 12 which displays all sketch tools in the main window. For accessing the 

Sketch Task Environment, 

 Click the More option in the direct sketch tool bar area 

 Click on Open in Sketch Task Environment as shown below 

 

There are three useful options next to the Finish Flag. You can change 

the name of the sketch in the box. The next one is Orient to Sketch 

which orients the view to the plane of the sketch. If the model file is 

rotated during the process of sketching, click on this icon to view the 

sketch on a plane parallel to the screen Reattach attaches the sketch to a different planar face, 

datum plane, or path, or changes the sketch orientation. It allows you to reattach the sketch to the 

desired plane without recreating all the curves, dimensions, and constraints. 

3.3 SKETCH CURVE TOOLBAR 

This toolbar contains icons for creating the common types of 

curves and spline curves, editing, extending, trimming, 

filleting etc. Each type of curve has different methods of 

selection and methods of creation. Let us discuss the most 

frequently used options. 
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 Profile 

This option creates both straight lines as well as arcs depending on the icon you select in the pop-

up toolbar. You can pick the points by using the coordinate system or by entering the length and 

angle of the line as shown in the following figures. 

  

 Line 

This option will selectively create only straight lines. 

 Arc 

This option creates arcs by either of two methods. The first option creates arc with three sequential 

points as shown below. 

  

The second option creates the arc with a center point, radius and sweep angle or by center point 

with a start point and end point. The illustration is shown below. 

  

 Circle 

Creating a circle is similar to creating an arc, except that circle is closed. 
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 Quick Trim 

This trims the extending curves from the points of intersection of the curves. This option reads 

every entity by splitting them if they are intersected by another entity and erases the portion 

selected.  

 Studio Spline 

You can create basic spline curves (B-spline and Bezier) with poles or through points with the 

desired degree of the curve. The spline will be discussed in detail in the seventh chapter (Freeform 

Features). 

 

3.4 CONSTRAINTS TOOLBAR 

All the curves are created by picking points. For example, a straight line is created with two points. 

In a 2D environment, any point has two degrees of freedom, one along X and another along Y 

axis. The number of points depends on the type of curve being created. Therefore, a curve entity 

has twice the number of degrees of freedom than the number of points it comprises. These degrees 

of freedom can be removed by creating a constraint with a fixed entity. In fact, it is recommended 

that you remove all these degrees of freedom (making the sketch Fully Constrained) by relating 

the entities directly or indirectly to the fixed entities. It can be done by giving dimensional or 

geometric properties like Parallelity, Perpendicularity, etc. 
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In NX 12 smart constraints are applied automatically, i.e. automatic dimensions or geometrical 

constraints are interpreted by NX 12. You can turn this option off by clicking on Continuous Auto 

Dimensioning as shown below. The following paragraphs show how to manually apply constraints. 

 

 Dimensional Constraints 

The degrees of freedom can be eliminated by giving dimensions with fixed entities like axes, 

planes, the coordinate system or any existing solid geometries created in the model. These 

dimensions can be linear, radial, angular etc. You can edit the dimensional values at any time 

during sketching by double-clicking on the dimension. 
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 Geometric Constraints 

Besides the dimensional constraints, some geometric constraints can be given to eliminate the 

degrees of freedom. They include parallel, perpendicular, collinear, concentric, horizontal, 

vertical, equal length, etc. The software has the capability to find the set of possible constraints for 

the selected entities. As an example, a constraint is applied on the line in the below picture to be 

parallel to the left side of the rectangle (the line was originally at an angle with the rectangle). 

 

 Display Sketch Constraints 

Clicking this icon will show all the options pertaining to the entities in that particular sketch in 

white. 

 Show/Remove Constraints 

This window lists all the constraints and types of constraints pertaining to any entity selected. You 

can delete any of the listed constraints or change the sequence of the constraints. 

The number of degrees of freedom that are not constrained are displayed in the Status Line. All 

these should be removed by applying the constraints to follow a disciplined modeling. 
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3.5 EXAMPLES 

3.5.1 Arbor Press Base 

 Create a new file and save it as Arborpress_base.prt 

 Click on the Sketch button and click OK 

 Choose Menu →Insert →Sketch Curve →

Profile or click on the Profile icon in the Direct 

Sketch group (remember to deactivate 

Continuous Dimensioning) 

 Draw a figure similar to the one shown on right. 

While making continuous sketch, click on the Line 

icon on the Profile dialog box to create straight 

lines and the Arc icon to make the semicircle. 

(Look at the size of the XY plane in the figure. Use 

that perspective for the approximate zooming). 

Once the sketch is complete, we constrain the sketch. It is 

better to apply the geometric constraints before giving the 

dimensional constraints. 

 Choose Insert →Geometric Constraints or click 

on the Constraints icon in the side toolbar  

Now we start by constraining between an entity in the sketch and a datum or a fixed reference. 

First, place the center of the arc at the origin. This creates a reference for the entire figure. We can 

use the two default X and Y axes as a datum reference. 

 Select Point on Curve constraint 

 Select the Y-axis and then the center of the arc 

 Repeat the same procedure to place the center of the arc on the X-axis 
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Do not worry in case the figure gets crooked. The figure will come back to proper shape once all 

the constraints are applied. However, it is better to take into consideration the final shape of the 

object when you initially draw the unconstrained figure. 

 Select the two slanted lines and make them Equal Length 

 

 Similarly select the two long vertical lines and make them Equal Length 

 Select the bottom two horizontal lines and make them Collinear and then click on the same 

lines and make them Equal Length 

 

If you DO NOT find the two Blue circles (Tangent Constraints) near the 

semicircle as shown in the figure, follow the below steps. Otherwise, you 

can ignore this. 

 Select the circular arc and one of the two vertical lines connected to its endpoints 

 Select the Tangent icon  

If the arc and line is already tangent to each other, the icon will be grayed out. If that is the case  

 Click on Edit →Selection →Deselect All. Repeat the same procedure for the arc and the 

other vertical line. 
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 Select the two vertical lines and make them Equal 

 Similarly select the two small horizontal lines at the top of the profile and make them 

Collinear and Equal 

 Similarly select the two vertical lines and make them Equal 

Note: At times after applying a constraint, the geometric 

continuity of the sketch may be lost like shown. In such 

conditions, click the exact end points of the two line and 

click the Coincident constraint as shown. 

So far, we have created all the Geometric constraints. Now we have to create the Dimensional 

constraints. If there is any conflict between the Dimensional and Geometric constraints, those 

entities will be highlighted in yellow. 

 Choose the Rapid Dimension icon  in the Constraints toolbar 

 Add on all the dimensions as shown in the following figure without specifying the values 
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For example, to create a dimension for the top two corners,  

 Click somewhere near the top of the two diagonal lines to select them 

While dimensioning, if you find the dimensions illegible, but do not worry about editing the 

dimensions now. 

Now we edit all the dimension values one by one. It is highly recommended to start editing from 

the biggest dimension first and move to the smaller dimensions. Once enough number of 

dimensions are provided, sketch color changes indicating it is fully defined. 

 Edit the values as shown in the figure below. Double click on each dimension to change 

the values to the values as shown in figure below 

 

 Click on the Finish Flag  on the top left corner or bottom right of the screen when 

you are finished  

 Click on the sketch and select Extrude (this Feature is explained in details in the next 

sections) 



NX 12 for Engineering Design 44 Missouri University of Science and Technology 

 

 

 Extrude this sketch in the Z-direction by 60 mm 

  

 Save and close the file 

3.5.2 Impeller Lower Casing 

 Create a new file in inches and save it as Impeller_lower_casing.prt 

 Click Menu →Insert →Sketch In Task Environment or click Sketch In Task 

Environment icon  from the ribbon bar 

 Set the sketching plane as the XC-YC plane 

 Make sure the Profile window is showing and draw the following curve 
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 Create a point at the origin (0, 0, 0) by clicking the plus sign in the Direct Sketch group 

Next, we will constrain the curve 

 Click on the Geometric Constraints icon  

 Select the point at the origin and click on the Fixed 

constraint icon  (if you cannot see this icon, click 

on Settings and check it as shown on the right) 

 Make all of the curve-lines and curve-curve joints 

Tangent 

 Apply the dimensional constraints as shown in the 

figure below 

 

Line 1 

Curve 2 

Curve 1 

Line 2 



NX 12 for Engineering Design 46 Missouri University of Science and Technology 

 

 Select all the dimensions.  

 Right click and Hide the dimensions 

 Choose Menu →Edit →Move Object or choose 

Move Curve from the ribbon bar 

 Select all the curves. You should see 4 objects being 

selected in Select Object 

 Specify the Motion to be Distance 

 Choose YC-Direction in the Specify Vector 

 Enter the Distance to be 0.5 inch 

 In the Result dialog box make sure you the click on 

the Copy Original radio button 

 Click OK 

 Then join the end-points at the two ends using the 

basic curves to complete the sketch 

 

The sketch is ready. 

 Choose Edit →Move Object or choose Move Curve from the ribbon bar 

 Select the outer curve. Be sure to select all the four parts of the curve 

 Move the lower curve in the Y-direction by -1.5 inches. This is the same as translating it 

in the negative YC-direction by 1.5 inches 

This will form a curve outside the casing. 
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 Using straight lines join this curve with the inside curve of the casing 

It will form a closed chain curve as shown. 

 

Now we will create the curve required for outside of the casing on the smaller side which will form 

the flange portion. 

 Choose Edit → Move Object 

 Select the outer line as shown in the figure below 

 

 Move the lower curve in the XC-direction by -0.5 inches. This is the same as translating it 

in the negative XC-direction by 0.5 inches 
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 Using straight lines join the two lines as shown in the figure on right side  

 Click on the Finish Flag  

 Save and Close the file 

We will use this sketching in the next chapter to model the Impeller Lower 

Casing. 

3.5.3 Impeller 

 Create a new file in inches and save it as Impeller_impeller.prt 

 Click on Sketch 

 Set the sketching plane as the XC-YC plane and click OK 

 Click on Menu →Insert →Datum/Point →Point or 

click Point from Direct Sketch group in the ribbon bar  

 Create two Points, one at the origin (0, 0, 0) and one at 

(11.75, 6, 0) 

 Click on the Arc icon on the side toolbar and click on the Arc by Center and Endpoints 

icon  in the pop-up toolbar 

 Click on the point at the origin and create an arc with a radius of 1.5 similar to the one 

shown in the figure below 

 Click on the point at (11.75, 6, 0) and create an arc with 

a radius of 0.5 

 Click on the Arc by 3 Points icon  in the pop-up 

toolbar 

 Select the top endpoints of the two arcs you just created 

and click somewhere in between to create another arc that connects them. Do the same for 

the bottom endpoints 
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 Click on the Constraints icon in the side toolbar and 

make sure that all the arcs are Tangent to one another 

at their endpoints 

 Click on the point at the origin and click on the Fixed 

icon 

 Then click on the Rapid Dimension icon 

 Give the Radius dimensions for each arc. Edit dimensions so that the two arcs on the end 

are 1.5 and 0.5 inches and the two middle 

arcs are 18 and 15 inches as shown in the 

figure below 

 Click on the Finish Flag   

 Save and Close the file. 

We will use this sketching in the next chapter to 

model the Impeller. 
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3.6 EXERCISES 

3.6.1 Circular Base 

One of models that we will use in several chapters of this manual for various purposes is a 

simplified arbor press having more than ten components. We modeled one of these components in 

example 3.5.1 of this chapter. Another component is a circular base used to hold a workpiece under 

the press. Use the dimensions given below to model the circular base (dimension in millimeters). 

 

3.6.2 Sketching of a Holder 

In one of the exercises in chapter 4, you will be asked to model a holder. Multiple 2D sketches 

will be required to model the 3D holder. As a starting point for that exercise, model the 2D 

sketching shown in the figure below and save the file (all dimensions are in inches). 
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CHAPTER 4 – THREE DIMENSIONAL MODELING 

This chapter discusses the basics of three dimensional (3D) modeling in NX 12. We will discuss 

what a feature is, what the different types of features are, what primitives are, and how to model 

features in NX 12 using primitives. This will give a head start to the modeling portion of NX 12 

and develop an understanding of the use of Form Features for 3D modeling. Once these features 

are introduced, we will focus on Feature Operations which are functions that can be applied to the 

faces and edges of a solid body or features you have created. These include taper, edge blend, face 

blend, chamfer, trim, etc. After explaining the feature operations, the chapter will walk you through 

some examples. 

In NX 12, Features are a class of objects that have a defined parent. Features are associatively 

defined by one or more parents and the order of their creation and modification retain within the 

model, thus capturing it through the History. Parents can be geometrical objects or numerical 

variables. Features include primitives, surfaces and/or solids and certain wire frame objects (such 

as curves and associative trim and bridge curves). For example, some common features include 

blocks, cylinders, cones, spheres, extruded bodies, and revolved bodies. 

Commonly Features can be classified as follows: 

- Body: A class of objects containing solids and sheets 

- Solid Body: A collection of faces and edges that enclose a volume 

- Sheet Body: A collection of one or more faces that do not enclose a volume 

- Face: A region on the outside of a body enclosed by edges 

4.1 TYPES OF FEATURES 

There are six types of Form Features: Primitives, Reference features, Swept features, Remove 

features, Extract features, and User-defined features. Similar to previous versions, NX 12 stores 

all the Form Features under the Insert menu option. The form features are also available in the 

Form Features Toolbar. 

 Click Insert on the Menu 
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As you can see, the marked menus in the figure on the right side contain the commands of Form 

Features. The Form Feature icons are grouped in the Home Toolbar as shown below. You can 

choose the icons that you use frequently. 

 Click on the drop down arrow in Home Toolbar 

 Choose Feature Group 

 

4.1.1 Primitives  

They let you create solid bodies in the form of generic building shapes. Primitives include: 

 Block 

 Cylinder 

 Cone 

 Sphere 

Primitives are the primary entities. Hence, we will begin with a short description of primitives and 

then proceed to modeling various objects. 

4.1.2 Reference Features 

These features let you create reference points, reference axes, reference plane, or reference 

coordinates, which can be used for constructing other features. 
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 Click on Menu →Insert →Datum/Point or click on Datum Plane in Feature group in 

the ribbon bar to view the different Reference Feature options: Datum Plane, Datum 

Axis, Datum CSYS, and Point 

  

4.1.3 Swept Features 

These features let you create bodies by extruding or revolving sections. Swept Features include: 

 Extruded Body 

 Revolved Body 

 Sweep along Guide 

 Tube 

 Styled Sweep 

To select a swept feature you can do the following: 

 Click on Insert →Design Feature for Extrude and Revolve or click on Extrude in 

Feature group in the ribbon bar 

OR 

  Click on Insert →Sweep or click on More in Feature group in the ribbon bar to find all 

the options available including Sweep 
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4.1.4 Remove Features  

Remove Features let you create bodies by removing 

solid part from other parts.  

 Click on Insert →Design Feature  

Remove Features include: 

 Hole 

 Pocket 

 Slot 

 Groove 

4.1.5 Extract Features 

These features let you create bodies by extracting 

curves, faces and regions. These features are widely 

spaced under Associative Copy and Offset/Scale 

menus. Extract Features include: 

 Extract 

 Solid to Shell  

 Thicken Sheet 

 Bounded plane 

 Sheet from curves 

 Click on Insert →Associative Copy →Extract for Extract options or click on More in 

Feature group in the ribbon bar to find Extract Geometry 

 

 Click on Insert →Offset/Scale for Solid to Shell and Thicken Sheet Assistant or click on 

More in Feature group in the ribbon bar to find Offset/Scale options 
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 Click on Insert →Surface for Bounded Plane and Sheet from curves 

 

4.1.6 User-Defined features 

These features allow you to create your own form features to automate commonly used design 

elements. You can use user-defined features to extend the range and power of the built-in form 

features.  

 Click on Insert →Design Feature →User Defined 

4.2 PRIMITIVES 

Primitive features are base features from which many other 

features can be created. The basic primitives are blocks, 

cylinders, cones and spheres. Primitives are non-associative 

which means they are not associated to the geometry used to 

create them. 

Note that usually Swept Features are used to create 

Primitives instead of the commands mentioned here. 

4.2.1 Model a Block 

 Create a new file and name it as 

Arborpress_plate.prt 
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 Choose Insert →Design Feature →Block or click on the Block icon in the Form Feature 

Toolbar 

The Block window appears. There are three main things to define a block, which are the Type, 

Origin and the Dimensions of the block. To access the Types, scroll the drop-down menu under 

Type. There are three ways to create a block primitive: 

 Origin and Edge Lengths  

 Height and Two Points 

 Two Diagonal Points 

 Make sure the Origin and Edge Lengths method is selected 

Now, we will choose the origin using the Point Constructor: 

 Click on the Point Dialog icon under the Origin 

The Point Constructor dialog box will open. The XC, YC, 

ZC points should have a default value of 0. 

 Click OK 

The Block window will reappear again. 

 Type the following dimensions in the window 

Length (XC) = 65 inches 

Width (YC) = 85 inches 

Height (ZC) = 20 inches 

 Click OK 

If you do not see anything on the screen,  

 Right-click and select FIT. You can also press <Ctrl> + F 

 Right-click on the screen and click on Orient View →Trimetric 
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You should be able to see the complete plate solid model. Save and close the part file. 

 

4.2.2 Model a Shaft 

Let’s move on to model a shaft having two cylinders and one 

cone joined together using Primitives. 

 Create a new file and save it as Impeller_shaft.prt 

 Choose Insert →Design Feature →Cylinder or 

click on More in Feature group in the ribbon bar to 

find Cylinder in Design Feature section 

Similar to the Block, there are three things that need to be 

defined to create a cylinder: Type, Axis & Origin, and 

Dimensions. 

A Cylinder can be defined by two types which can be 

obtained by scrolling the drop-down menu under Type 

 Axis, Diameter, and Height 

 Arc and Height 

 Select Axis, Diameter, and Height 



NX 12 for Engineering Design 58 Missouri University of Science and Technology 

 

 Click on the Vector Constructor icon next to Specify Vector and select the ZC Axis icon 

 Click on the Point Dialog icon next to Specify Point to set the origin of the cylinder 

 Set all the XC, YC, and ZC coordinates to be 0 

You can see that the selected point is the origin of WCS 

 In the next dialog box of the window, type in the following values  

Diameter = 4 inches 

Height = 18 inches 

 Click OK 

 Right-click on the screen, choose Orient View →Isometric 

The cylinder will look as shown on the right. Now we will create a cone at 

one end of the cylinder. 

 Choose Insert →Design Feature →Cone or click on More in Feature group in the ribbon 

bar to find Cone in Design Feature section 

Similar to Block and Cylinder, there are various ways to create a cone which can be seen by 

scrolling the drop-down menu in the Type box. 

 Diameters and Height 

 Diameters and Half Angle 

 Base Diameter, Height, and Half Angle 

 Top Diameter, Height, and Half Angle 

 Two Coaxial Arcs 

 Select Diameters and Height 

 Click on the Vector Constructor icon next to Specify Vector 

 Choose the ZC-Axis icon so the vector is pointing in the positive Z direction 
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 Click on the Point Constructor icon next to 

Specify Point to set the origin of the cylinder. 

The Point Constructor window will appear next. 

 Choose the Arc/Ellipse/Sphere Center icon on 

the dialog box and click on the top circular edge 

of the cylinder 

OR 

 For the Output Coordinates, type in the 

following values:  

XC = 0 

YC = 0 

ZC = 18 

 Click OK 

 In the Cone Window, type in the following values: 

Base Diameter = 4 inches 

Top Diameter = 6 inches 

Height = 10 inches 

 On the Boolean Operation window, choose Unite and select the cylinder 

 Click OK 

Now the cone will appear on top of the cylinder. The shaft is as shown on right. 

Now we will create one more cylinder on top of the cone. 

 Repeat the same procedure as before to create another Cylinder. The vector should be 

pointing in the positive ZC-direction. On the Point Constructor window, again click on 

the Center icon and construct it at the center point of the base of the cone. The cylinder 

should have a diameter of 6 inches and a height of 20 inches. Unite the cylinder with the 

old structure. 
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The complete shaft will look as shown below. Do not forget to save the model. 

4.3 REFERENCE FEATURES 

4.3.1 Datum Plane 

Datum Planes are reference features that can be 

used as a base feature in constructing other 

features. They assist in creating features on 

cylinders, cones, spheres, and revolved solid 

bodies which do not have a planar surface and 

also aid in creating features at angles other than 

normal to the faces of the target solid. We will follow some simple steps to practice Reference 

Features. For starters, we will create a Datum Plane that is offset from a base face as shown in the 

figure above. 

 Open the model Arborpress_plate.prt  

 Choose Insert →Datum/Point →Datum Plane  

The Datum Plane dialog can also be opened by clicking the icon as shown in the figure below 

from the Feature Toolbar. 
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The Datum Plane window allows you to choose the method of selection. However, NX 12 is smart 

enough to judge the method depending on the entity you select if you keep in Inferred option, 

which is also the Default option. 

 Click on the top surface of the block so that it becomes highlighted 

The vector displays the positive offset direction that the datum plane will be created in. If you had 

selected the bottom face, the vector would have pointed downward, away from the solid.  

 Set the Offset Distance value as 15 inches in the dialog box and click OK 

 

 If you don’t see the complete model and plane, right-click and select FIT 

4.3.2 Datum Axis 

In this part, you are going to create a Datum Axis. A Datum Axis is a reference feature that can be 

used to create Datum Planes, Revolved Features, Extruded Bodies, etc. It can be created either 

relative to another object or as a fixed axis (i.e., not referencing, and not constrained by other 

geometric objects). 
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 Choose Insert →Datum/Point →Datum Axis 

The Datum Axis dialog can also be opened by clicking the icon as shown in 

the figure on the right from the Feature toolbar. 

The next window allows you to choose the method of selecting the axis. Note 

that NX 12 can judge which method to use depending on the entity you select. 

There are various ways to make a Datum Axis. They include Point and 

Direction, Two Points, Two Planes, etc. 

 Select the two points on the block as shown in the figure 

on the right 

 Click OK 

The Datum Axis will be a diagonal as shown. 

4.4 SWEPT FEATURES 

Two important Swept Features (Extrude and Revolve) are introduced here using a practical 

example which is the continuation of the lower casing of the impeller which we started in the 

previous chapter. 

 Open the Impeller_lower_casing.prt 

In the previous section, we finished the two dimensional sketching of this part and it should look 

similar to the below figure. 
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 Click on Insert →Design Feature →Revolve 

OR 

 Click on the Revolve button in the Feature Group 

Make sure that the Selection Filter is set to Single Curve as shown below on the Selection Filter 

Toolbar 

 

 Click on each of the 10 curves as shown in the next figure 

 In the Axis dialog box , in the Specify Vector option choose the Positive XC-direction 
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 In the Specify Point option, enter the coordinates (0, 0, 0) so the curve revolves around 

XC-axis with respect to the origin 

 Keep the Start Angle as 0 and enter 180 as the 

value for the End Angle 

 Click OK 

The solid is shown on the right. Now, we will create the 

edges. 

 Click on Insert →Design Feature →Extrude 

OR 

 Click on the Extrude button in the Feature 

Group  

 Select the outer curve of the casing as shown in 

the figure below (again make sure that the 

Selection Filter is set to Single Curve). 
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Note: In case you are not able to select the proper lines, left-click and 

hold the mouse button and you will see a dialog box pop-up as shown 

which will provide you the options of which curve to select. 

 Extrude this piece in the negative Z-direction by 0.5 inches 

The final solid will be seen as follows. 

We will now use the Mirror option to create an edge on the other side. 

 Choose Edit →Transform  

 Select the solid edge as shown. For this 

you will have to change the Filter in the 

dialog box to Solid Body 

 Click OK 

 Choose Mirror Through a Plane  

 Select the Center Line as shown below 

 Click OK 

 Select Copy 

  

 Click Cancel 

The edge will be mirrored to the other side as shown below. 
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We will now create a flange at the smaller opening of the casing as shown. 

 

 Click on Insert →Design Feature →Revolve 

Again make sure that the Selection Filter is set to Single Curve. The default Inferred Curve option 

will select the entire sketch instead of individual curves. 

 Revolve this rectangle in the positive XC-direction relative to the Origin just like for the 

casing. The End Angle should be 180 

This will form the edge as shown below. 
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The lower casing is completed. Do not forget to save the model. 

4.5 REMOVE FEATURES 

Remove Features allow you to remove a portion of the existing object to create an object with 

additional features that are part of the design, which are illustrated below. 

4.5.1 General Hole 

This option lets you create Simple, Counterbored, Countersunk and Tapered holes in solid bodies. 

 

 Open the file Arborpress_plate.prt 

 Choose Insert →Design Features →Hole  

OR  

 Click on the icon in the Feature Toolbar as shown  
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The Hole window will open. There are various selections that need to be done prior to making the 

holes. First you need to select the Type of the hole. 

 Select the default General Hole 

Next, you need to define the points at which you need to make the 

holes. 

 Click on the Sketch icon in the Position dialog box and 

choose the top face of the plate as the Sketch Plane 

 

 Click OK 

This will take you to the Sketch Plane. 

 

 Click on the Point Dialog icon and specify all the points as given in the table below 

X Y Z 

11.25 10.00 0.00 

32.50 23.50 0.00 

53.75 10.00 0.00 

11.25 75.00 0.00 

32.50 61.50 0.00 

53.75 75.00 0.00 
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 Click OK after you enter the coordinates of each point 

 Click Close once you have entered all the points 

 Click on Finish flag in the top left corner of the window 

This will take you out of the Sketch mode and bring back to the 

original Hole window on the graphics screen. 

 In the Form dialog, choose the default option of 

Simple Hole 

 Enter the following values in the Dimensions 

window 

Diameter = 8 inches   

Depth = 25 inches   

Tip Angle = 118 degrees 

 Choose Subtract in the Boolean dialog box and click OK 

Make sure to save the model. 

4.5.2 Pocket 

This creates a cavity in an existing body. 

 Create a Block using default values 

 Choose Insert →Design Features →Pocket 

 Select Rectangular 

 Select the Face that you want to create the Pocket on 

 Select a Vertical Face to use as the reference for 

dimensioning 

 Enter the dimensions of the Pocket as shown 

 Change the Positioning if you want 
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4.5.3 Slot 

This option lets you create a passage through or into a solid 

body in the shape of a straight slot. An automatic subtract is 

performed on the current target solid. It can be rectangular, T-

slot, U-Slot, Ball end or Dovetail. An example is shown on 

the right. 

4.5.4 Groove 

This option lets you create a groove in a solid body, as if a 

form tool moved inward (from an external placement face) or outward (from an 

internal placement face) on a revolving part, as with a turning operation. An 

example is shown on the right. 

Note: Pocket, Slot, and Groove features are not commonly used in practice. All 

the models created using these features can be modeled using 2D Sketches and 

Extrude/Revolve. 

4.6 FEATURE OPERATIONS 

Feature Operations are performed on the basic Form Features to smooth corners, create tapers, 

make threads, do instancing and unite or subtract certain solids from other solids. Some of the 

Feature Operations are explained below. 

4.6.1 Edge Blend 

An Edge Blend is a radius blend that is tangent to the blended faces. This 

feature modifies a solid body by rounding selected edges. This command 

can be found under Insert →Detail Feature →Edge Blend. You can also 

click on its icon in the Feature Group. You need to select the edges to be 

blended and define the Radius of the Blend as shown below. 
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Similar to Edge Blend you can also do a Face Blend by selecting two adjacent faces. 

4.6.2 Chamfer 

The Chamfer Function operates very similarly to the Blend Function by adding or subtracting 

material relative to whether the edge is an outside chamfer or an inside chamfer. This command 

can be found under Insert →Detail Feature →Chamfer. You can also click on its icon in the 

Feature Group. You need to select the edges to be chamfered and define the Distance of the 

Chamfer as shown below. 

 

4.6.3 Thread 

Threads can only be created on cylindrical faces. The Thread Function lets you create Symbolic 

or Detailed threads (on solid bodies) that are right or left handed, external or internal, on cylindrical 

faces such as Holes, Bosses, or Cylinders. It also lets you select the method of creating the threads 

such as cut, rolled, milled or ground. You can create different types of threads such as metric, 

unified, acme and so on. To use this command, go to Insert →Design Feature →Thread. An 

example of a Detailed Thread is shown below. 
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For  Threaded Holes, it is recommended to use the 

Threaded Hole command instead of the Thread 

command: Insert →Design Feature →Hole 

 

 

4.6.4 Trim Body 

You can use the Trim Body 

function to trim a solid body with a 

sheet body or a Datum Plane, and 

at the same time retain parameters 

and associativity. To use this 

command, go to Insert →Trim 

→Trim Body or click on its icon in 

the Feature Group. An example is 

shown on the right. 
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4.6.5 Split Body 

A solid body can be split into two bodies 

by a plane or a sheet body. To use this 

command, go to Insert →Trim →Split 

Body or click on its icon in the Feature 

Group. An example is shown on the 

right. 

 

4.6.6 Mirror 

Mirror is a type of Associative Copy in which a solid body is created by mirroring the body with 

respect to a plane. To use this command, go to Insert →Associative Copy →Mirror Feature or 

click on its icon in the Feature Group. An example is shown below. 

 

4.6.7 Pattern 

A Design Feature or a Detail Feature can be made into dependent copies in the form of an Array. 

It can be Linear, Circular, Polygon, Spiral, etc. This particularly helpful feature saves plenty of 

time and modeling when you have similar features. For example threads of a gear or holes on a 

mounting plate, etc. This command can be found under Insert →Associative Copy →Pattern 

Feature. You can also click on its icon in the Feature Group. An example is shown below. 



NX 12 for Engineering Design 74 Missouri University of Science and Technology 

 

 

4.6.8 Boolean Operations 

There are three types of Boolean Operations: Unite, Subtract, 

and Intersect. These options can be used when two or more solid 

bodies share the same model space in the part file. To use this 

command, go to Insert → Combine or click on their icons in the 

Feature Group. Consider two solids given: a block and a 

cylinder are next to each other as shown on the right. 

4.6.8.1 Unite  

The unite command adds the Tool body with the Target body. For the above example, the output 

will be as follows if Unite option is used. 
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4.6.8.2 Subtract  

When using the subtract option, the Tool Body is subtracted from the 

Target Body. The following would be the output if the Block is used 

as the Target and the Cylinder as the Tool. 

4.6.8.3 Intersect  

This command leaves the volume that is common to both the Target 

Body and the Tool Body. The output is shown below. 

4.6.9 Move 

If you want to Move an object with respect to a fixed entity, 

 Click on Edit →Move Object 

You can select the type of motion from the Motion drop-down menu. 

The default option is Dynamic. With this you can move the object in 

any direction. There are several other ways of moving the object. 
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If you choose Distance you can move the selected object in the X-Y-Z direction by the distance 

that you enter. 

 

 Click on Specify Vector and select the direction. 

 For example, type 5 in the Distance box.  This will translate the cylinder a distance of 5 

inches along X-Axis 

 Click OK 

As you can see, we have moved the cylinder along the X-direction. Similarly, we can also copy 

the cylinder by a specified distance or to a specified location by selecting the Copy Original option 

in the Result. 
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4.7 EXAMPLES 

4.7.1 Hexagonal Screw 

 Create a new file and save it as Impeller_hexa-bolt.prt 

 Choose Insert →Design Feature →

Cylinder 

 The cylinder should be pointing in the 

Positive ZC-Direction with the center 

set at the Origin and with the following 

dimensions: 

Diameter = 0.25 inches 

Height = 1.5 inches 

Now create a small step cylinder on top of the 

existing cylinder. 

 Create a Cylinder with the following dimensions: 

Diameter = 0.387 inches 

Height = 0.0156 inches 

 Click on the top face of the existing cylinder 

 On the Point Constructor window, choose the 

Arc/Ellipse/Sphere Center icon from the drop-down Type menu 

 Click OK to close the Point Constructor window 

 Under the Boolean drop-down menu, choose Unite 

The two cylinders should look like the figure shown on the right. 

 Choose Insert →Curve →Polygon 

 Select the center of the top circle as the Center Point 

 On the Sides window, type 6 for the Number of Sides 



NX 12 for Engineering Design 78 Missouri University of Science and Technology 

 

There are three ways to draw the polygon. 

 Inscribed Radius 

 Circumscribed Radius 

 Side Length 

 Choose Side Length and enter the following dimensions: 

Length = 0.246 inches 

Rotation = 0.00 degree 

 Click OK 

 

Now we will extrude this polygon. 

 Choose Insert →Design Feature →Extrude 

 Choose the Hexagon to be extruded 

 Enter the End Distance as 0.1876 inches  

The model looks like the figure on the right after extrusion. 

 On top of the cylinder that has a diameter of 0.387 inches, 

insert another cylinder with the following dimensions. 

Diameter = 0.387 inches  

Height = 0.1875 inches 
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You will only be able to see this cylinder when the model is in Static Wireframe since the cylinder 

is inside the hexagon head. The model will look like the following. 

 

We will now use the feature operation Intersect. 

 Choose Insert →Design Feature →Sphere 

 Choose Center Point and Diameter 

 Select the bottom of the last cylinder drawn (which is inside the hexagon head and has a 

diameter of 0.387 inches and a height of 0.1875 inches) as shown below 

 

 Give 0.55 as the Diameter 

 Choose Intersect in the Boolean dialog box 



NX 12 for Engineering Design 80 Missouri University of Science and Technology 

 

It will ask you to select the Target Solid 

 Choose the hexagonal head 

 Click OK 

This will give you the hexagonal bolt as shown.  

Note: This blend feature on the bolt hat can be created 

also by revolving cut with a section about its axis, you 

can try it out. 

Now we will add Threading to the hexagonal bolt. 

 Choose Insert →Design Feature →Thread 

 Click on the Detailed radio button 

 Keep the Rotation to be Right Hand 

 Click on the bolt shaft (the long 

cylinder below the hexagon head) 

Once the shaft is selected, all the values will 

be displayed in the Thread window. Keep all 

these default values. 

 Click OK 

The hexagon bolt should now look like the figure on 

the right. Save the model. 

4.7.2 Hexagonal Nut 

 Create a new file and save it as 

Impeller_hexa-nut.prt 

 Choose Insert →Curve →Polygon 

 Input Number of Dides to be 6 

 Create a hexagon with each side measuring 0.28685 inches and constructed at the Origin 
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 Choose Insert →Design Feature →Extrude 

 Select the Hexagon to be extruded and enter 

the End Distance as 0.125 inches  

The figure of the model is shown. 

 Choose Insert →Design Feature →Sphere 

 Enter the Center Point location in the Point 

Dialog window as follows 

XC = 0; YC = 0; ZC = 0.125 

 Enter the Diameter value 0.57 inches 

 In the Boolean operations dialog box select 

Intersect and click OK 

The model will look like the following. We will now 

use a Mirror command to create the other side of the 

Nut. 

 Choose Edit →Transform  

 Select the model and click OK 

 Click Mirror Through a Plane  

 Click on the flat side of the model as shown. Be careful not to select any edges 
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 Click on OK 

 Click on Copy 

 Click Cancel 

You will get the following model.  

 Choose Insert →Combine Bodies →Unite  

 Select the two halves and Unite them 
 

 Insert a Cylinder with the vector pointing in the ZC-Direction and with the following 

dimensions: 

Diameter = 0.25 inches 

Height = 1 inch 

 Put the cylinder on the Origin and Subtract this cylinder 

from the hexagonal nut 

Now, we will chamfer the inside edges of the nut. 

 Choose Insert →Detail Feature →Chamfer 
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 Select the two inner edges as shown and click OK 

 Enter the Distance as 0.0436 inches and click OK  

You will see the chamfer on the nut. Save the model. 

4.7.3 L-Bar 

Here, we will make use of some Primitives and Feature Operations such as Edge Blend, Chamfer, 

and Subtract. It should be noted that the same model can be more efficiently created by 2D 

Sketching and Extruding, but Primitives are used here to familiarize the users with these features. 

 Create a new file and save it as Arborpress_L-bar 

 Choose Insert →Design Feature →Block  

 Create a Block with the following dimensions: 

Length = 65 inches 

Width = 65 inches 

Height = 285 inches 
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 Create the block at the Origin 

 Create a second block also placed at the origin with the following 

dimensions: 

Length = 182 inches 

Width = 65 inches 

Height = 85 inches 

We have to move the second block to the top of the first block: 

 Click Edit →Move Object 

 Select the second block (green) and click OK 

 Choose the Motion as Distance 

 Select the positive ZC in the Specify Vector dialog 

 Enter 200 as the Distance value 

 Make sure that Move Original button is checked and click OK 

 Click Move and then Cancel on the next window so that the 

operation is not repeated 

Now we will create a Hole. There are several ways to create a Hole. We 

will do so by first creating a cylinder and then using the Subtract function. 
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 Choose Insert →Design Feature 

→Cylinder 

 On the Specify Vector, select the 

YC Axis icon 

 In the Specify Point, enter the 

following values: 

XC = 130 

YC = -5 

ZC = 242 

 The cylinder should have the following dimensions: 

Diameter = 35 inches 

Height = 100 inches 

 Under the Boolean drop-down window, choose Subtract 

 Select the horizontal block at the top  

The hole should look like the one in the figure. Now we will create another 

cylinder and subtract it from the upper block. 

The cylinder should be pointing in the positive Y-direction set at the following point: XC = 130; 

YC = 22.5 and ZC = 242 and should have the following dimensions: Diameter = 66 inches; Height 

= 20 inches 

 Subtract this cylinder from the same block as before using the Boolean drop-down menu 

Now we will create a block. 

 Choose Insert →Design Feature →Block 

 Create a block with the following dimensions: 

Length = 25 inches 

Width = 20 inches 

Height = 150 inches 
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 Click on the Point Dialog icon in the Origin box and enter the 

following values: 

XC = 157; YC = 22.5; ZC = 180 

The model will look like the figure on the right. Now we will subtract this 

block from the block with the hole. 

 Choose Insert →Combine Bodies →Subtract 

 Click on the block with the two holes (green) as the Target 

 Select the newly created block as Tool 

 Click OK 

The model will be seen as shown. Now we will use the Blend function in 

the Feature Operations. We must first unite the two blocks. 

 Choose Insert →Combine Bodies →Unite 

 Click on the two blocks and click OK 

The two blocks are now combined into one solid model. 

 Choose Insert →Detail Feature →Edge Blend 

 Change the Radius to 60  

 Select the edge at the 

interface of the two blocks 

 Click OK 

Repeat the same procedure to Blend 

the inner edge of the blocks. This 

time, the Radius should be changed 

to 30. 

We will now make four holes in the model. You can create these holes by using the Hole option. 

However, to practice using Feature Operations, we will subtract cylinders from the block. 
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 Insert four cylinders individually. They should be pointing in the positive XC-direction 

and have the following dimensions. 

Diameter = 8 inches  

Height = 20 inches 

 Construct them in the XC-direction at the following point coordinates: 

Cylinder #1: X = 162; Y = 11.25; Z = 210 

Cylinder #2: X = 162; Y = 11.25; Z = 275 

Cylinder #3: X = 162; Y = 53.75; Z = 210 

Cylinder #4: X = 162; Y = 53.75; Z = 275 

 Subtract these cylinders from the block in the Boolean dialog 

box 

The last operation on this model is to create a block and subtract it from 

the top block. 

 Create a Block with the following dimensions: 

Length = 60 inches 

Width = 20 inches 

Height = 66 inches  

 Enter the following values in the Point Dialog as the Origin of 

the Block 

XC = 130 

YC = 22.5 

ZC = 209.5 

 After creating the block, subtract this block from the block at 

the top 

The final figure will look like this. Save and close the file.  

4.7.4 Rack 

 Create a new part file and save it as Arborpress_rack.prt 
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 Right-click, then choose Orient View →Isometric  

 Choose Insert →Curve →Rectangle 

The Point window will open. Note the Cue Line instructions. The Cue Line provides the step that 

needs to be taken next. You need to define the corner points for the Rectangle.  

For Corner Point 1, 

 Type in the coordinates XC = 0, YC = 0, ZC = 0 and click OK 

Another Point Constructor window will pop up, allowing you to define the 2nd Corner Point 

 Type in the coordinates XC = 240, YC = 25, ZC = 0 

and click OK and then Cancel 

 Right-click on the screen and choose FIT  

Note: We have three options for creating a rectangle: 

 Two point 

 Three points 

 By center 

The default option is By 2 Points. 

 Choose Insert →Design Feature →Extrude 

OR 

 Click on the Extrude icon on the Form Feature toolbar. 

The Extrude dialog box will pop up. 

 Click on the Rectangle. 

 Choose the default Positive ZC-direction as the Direction 

 In the Limits window, type in the following values: 

Start = 0 

End = 20 

 Click OK 
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The extruded body will appear as shown on the 

right. 

 Choose Insert →Design Feature →

Pocket 

 Choose Rectangular in the pop up 

window 

 Click on the top surface of the rack 

 Click on the edge as shown in the figure for the Horizontal Reference 

This will pop up the parameters window. 

 Enter the values of parameters as shown 

in the figure and choose OK 

 

 When the Positioning window pops up, 

choose the PERPENDICULAR option  

 Click on the edge of the solid and then 

click on the blue dotted line as shown 

below 
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 Enter the Expression value as 37.8 and Choose OK 

 Once again pick the Perpendicular option and then 

choose the other set of the edges along the Y-Axis, as 

shown on the right (the one perpendicular to the last blue 

line selected) 

 Enter the expression value as 10 and click OK 

 Click OK and then Cancel 

The model will now look as follows. 

Let us create the instances of the slot as the teeth of the Rack to 

be meshed with Pinion. 

 Click on Pattern Feature icon in the Feature Group 

 Click on the pocket created 

 Select Layout as Linear 

 Specify vector as positive XC direction 

 Choose Count and Pitch in Spacing option and enter value for Count as 19 and that for 

Pitch Distance as 9.4 

 Click OK 
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The model of the Rack will look as the one shown in the figure. 

 

We will now create a Hole at the center of the rectangular cross section. To determine the center 

of the cross-section of the rectangular rack, we make use of the Snap Points 
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 Choose Insert →Design Feature →Cylinder 

 Choose –XC-Direction in the Specify Vector dialog box 

 Click on the Point Dialog  

 In the Points dialog box select Between Two Points option and select 

the points as shown in the figure on the right (diagonally opposite 

points). The option selects the midpoint of the face for us 

 Click OK 

 Enter the following values in the Dimension dialog box 

Diameter = 10 inches 

Height = 20 inches 

 Choose Subtract in the Boolean dialog box 

The final model is shown below. Save and close the model. 

 

4.7.5 Impeller 

Open the Impeller_impeller.prt file you made in Chapter 3. It should like the figure below. 
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Now let us model a cone first. 

 Choose Insert →Design Feature →Cone 

 Select Diameters and Height 

 Select the –XC-Direction in the Specify Vector 

dialog box 

 In the Point Dialog, enter the coordinates (14, 0, 0). 

 Enter the following dimensions: 

Base Diameter = 15 inches 

Top Diameter = 8 inches 

Height = 16.25 inches 

The cone will be seen as shown below if you choose Static 

Wireframe View. 

 Extrude the Airfoil curve in the Z-direction by 12 

inches 

 Unite the two solids in the Boolean operation dialog 

box 

The model will be as follows. 

Now let us create five instances of this blade to make the 

impeller blades. 

 Click on Insert →Associative Copy →Pattern 

Feature 

 Select the Airfoil you just created 

 Select Circular layout 

 Select the XC-Direction for the Specify Vector and 

the Origin for the Specify Point  

 For Count, type in 5 and for Pitch Angle, enter 72 
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 Click OK 

 

Now, let us create two holes in the cone for the shaft and the locking pin. Note that these holes can 

also be created by Hole menu option. 

 Subtract a cylinder with a Diameter of 4 inches and a Height of 16 inches from the side 

of the cone with the larger diameter 

 Subtract another cylinder with a Diameter of 0.275 inches and a Height of 0.25 inches 

from the side of the cone with the 

smaller diameter 

The final model will look like the figure on the 

right. Save and close your work. 
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4.8 STANDARD PARTS LIBRARY 

A better and faster approach for modeling standard parts like bolts, nuts, pins, screws, and washers 

is using the Standard Parts Library. For example, to model a hexagonal bolt,  

 Choose Reuse Library →Reuse Examples →Standard Parts →ANSI Inch →Bolt  

 Right-click on Hex Head 

 Click on Open Source Folder 

 Open Hex Bolt, AI.prt 
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You can now go to Part Navigator to see all 

the steps taken toward modeling this part 

and modify any feature. For example to 

modify the length of the bolt, right-click on 

Extrude (8) “BODY_EXTRUDE” and 

choose Edit Parameters. 

4.9 SYNCHRONOUS TECHNOLOGY 

One of the important and unique features which NX offers apart from Design Features and 

Freeform Modeling is Synchronous Technology. With the options available in Synchronous 

Modeling group in the ribbon bar in the Modeling Application tab, the user can modify complex 

3D models without the model history tree and without knowing the feature relationships and 

dependencies. The “push-and-pull” options can be used to modify the 3D model using faces, edges 

and cross-sections. NX 12 supports the Synchronous Modeling to work with 3D models from 

CATIA, Pro/ENGINEER®, SolidWorks®, and Autodesk Inventor®, apart from the standard 

formats including IGES, ISO/STEP and JT. 

For the purpose of illustrating the options available in Synchronous Modeling, let us consider the 

impeller part modeled in the previous section and export it as standard STEP format and save it. 

 Open a new file in NX 

 Choose File →Import →Impeller_impeller.stp 

Observe here that the .stp file would not have any model history. 

We will explore some of the options available in the Synchronous 

Modeling group in the ribbon bar. Click More to view a 

comprehensive list of options available in synchronous modeling. 
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 Click Delete Face and select the faces of the blade to delete the blade 

 Repeat the process and delete all except one blade. The part should look as shown below. 

   

 Click Replace Face and select the end face of the blade with large blend radius as Face to 

Replace and select the flat surface of the cone with smaller diameter as the Replacement 

Face to delete the blade. 

The part should look as shown below. 
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 Click Move Face and select one side of the blade and enter distance -30 and angle 20 in 

the transform section 

 Click Resize Blend and select the blended surface of the blade and enter radius as 7 mm 

to sharpen the end 

  

 Click Offset Edge and select the top edge of the blade and choose the method along face 

and enter -5 mm in the distance to offset the top surface of the blade 

 Click Pattern Face and select four surfaces of the blade and choose Circular Layout and 

specify the conical axis as vector, center of the flat surface of the cone as point, count as 6 

and pitch angle as 60 radius to pattern six blades. 
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Therefore, it can be observed that a standard .stp file has been modified by increasing the number 

of blades and changing the blade profile. Similarly, the user can either modify any supported 3D 

model depending on the design need or create a new 3D model with synchronous modeling “push 

and pull” tools. 

  



NX 12 for Engineering Design 100 Missouri University of Science and Technology 

 

4.10 EXERCISES 

4.10.1 Rocker Arm 

A rocker arm is an oscillating lever conveying radial movement from the cam lobe to linear 

movement at the poppet valve. Use the following drawings to model a rocker arm (dimensions are 

in inches). 

 

4.10.2 Holder 

You have started to model a holder in chapter 3 by modeling a 2D sketching. Open your saved file 

and continue modeling this holder. Use the detailed drawing to replicate the part. 
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4.10.3 Impeller Upper Casing 

Model the upper casing of the Impeller as shown below. The dimensions of the upper casing are 

the same as for the lower casing, which is described in Section 4.4 in detail. The dimensions for 
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the manhole should be such that impeller blades can be seen and a hand can fit inside to clean the 

impeller. 

 

4.10.4 Die-Cavity 

Model the following part to be used for the Chapter 8 Manufacturing Module. Create a new file 

Die_cavity.prt with units in mm. Create a rectangular Block of 150, 100, 40 along X, Y and Z, 

respectively with the point construction value of (-75,-50,-80) about XC, YC and ZC. Create and 

Unite another block over the first one with 100, 80 and 40 along X, Y and Z and centrally located 

to the previous block. 

Create a sketch as shown below including the spline curve and add an Axis line. Dotted lines are 

reference lines. While sketching, create them as normal curves. Then right click on the curves and 

click convert to reference. Give all the constraints and dimensions as shown in the figure below. 
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Revolve the curves about the dashed axis as shown above, and subtract the cut with start angle and 

end angle as -45 and 45. 

Subtract a block of 70, 50, and 30 to create a huge cavity at the centre. Create and Unite 4 cylinders 

at the inner corners of the cavity with 20 inches diameter and 15 inches height. 

   

Add edge blends at the corners as shown in the final Model below. Keep the value of blend as 10 

radii for outer edges and 5mm radii for the inner edges. 
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CHAPTER 5 – DRAFTING 

The NX 12 Drafting application lets you create drawings, views, geometries, dimensions, and 

drafting annotations necessary for manufacturing as well as understanding of an industrial design. 

The goal of this chapter is to give the designer/draftsman enough knowledge of drafting tools to 

create a basic drawing of their design. The drafting application supports the drafting of engineering 

models in accordance with ANSI standards. After explaining the basics of the drafting application, 

we will go through a step-by-step approach for drafting some of the models created earlier. 

5.1 OVERVIEW 

The Drafting Application is designed to allow you produce and maintain industry standard 

engineering drawings directly from the 3D model or assembly part. Drawings created in the 

Drafting application are fully associative to the model and any changes made to the model are 

automatically reflected in the drawing. The Drafting application also offers a set of 2D drawing 

tools for 2D centric design and layout requirements. You can produce standalone 2D drawings. 

The Drafting Application is based on creating views from a solid model as illustrated below. 

Drafting makes it easy to create drawings with orthographic views, section views, imported view, 

auxiliary views, dimensions and other annotations. 
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Some of the useful features of the Drafting Application are: 

1) After you choose the first view, the other orthographic views can be added and aligned 

with the click of a few buttons. 

2) Each view is associated directly with the solid. Thus, when the solid is changed, the 

drawing will be updated directly along with the views and dimensions. 

3) Drafting annotations (dimensions, labels, and symbols with leaders) are placed directly on 

the drawing and updated automatically when the solid is changed. 

We will see how views are created and annotations are used and modified in the step-by-step 

examples. 

5.2 CREATING A DRAFTING 

 Open the file Arborpress_rack.prt  

 From the NX 12 Interface, choose File →Drafting as shown or choose Application tab 

and select Drafting 
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When you first open the Drafting Application, a window pops up asking for inputs like the 

Template, Standard Size or Custom Size, the units, and the angle of projection. 

Size 

Size allows you to choose the size of the Sheet. There are 

standard Templates that you can create for frequent use 

depending upon the company standards. There are several 

Standard sized Sheets available for you. You can also define 

a Custom sized sheet in case your drawings do not fit into a 

standard sized sheet. 

Preview 

This shows the overall design of the Template. 

Units 

Units follow the default units of the parent 3-D model. In case 

you are starting from the Drafting Application you need to 

choose the units here. 

Projection 

You can choose the Projection Method either First Angle or 

Third Angle method. 

To start using the Drafting Application we will begin by 

creating a Standard Sized sheet: 

 Click on the Standard Size radio button 

 In the drop-down menu on the Size window, select 

sheet B, which has dimensions 11 x 17 

 Change the Scale to 1:25 by using the drop-down 

menu and choosing the Custom Scale under the Scale 

 Click OK 
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This will open the Drafting Application and the following screen will be seen as below. Let us first 

look at the Drafting Application Interface. 

 

You will see a dialog box pops-up which will help you choose the parts, views and other options. 

 Change the options and views and click Finish 

 Choose Insert →View →Base or click on Base 

View in the View Group 

The Base View dialog box with the options of the View and the Scale will show up along with a 

floating drawing of the object. 

 Choose the View to be Front 

You can find the Front View projection on the screen. You can move the mouse cursor on the 

screen and click on the place where you want the view. 

Once you set the Front View another dialog box will pop-up asking you to set the other views at 

any location on the screen within the Sheet Boundary. 
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You can find different views by moving the cursor 

around the first view. If you want to add any 

orthographic views after closing this file or changing to 

other command modes  

 Choose Insert →View →Projected View or 

choose Projected View  icon from the View 

group 

Now, let us create all the other orthographic projected 

views and click on the screen at the desired position. 

 

 In case you have closed the Projected View dialog box you can reopen it by clicking on 

the Projected View icon in the View Group 

 

 Move the cursor and click to get the other views 

 Click Close on the Projected View dialog box or press <Esc> key on the keyboard to close 

the window 
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Before creating the dimensions, let us remove the borders in each view as it adds to the confusion 

with the entity lines. 

 Choose Menu →Preferences →Drafting or click on 

icon in the Quick Access toolbar to find the Drafting 

Preferences 

The Drafting Preferences window will pop up. 

 Click on the VIEW tab button 

 Uncheck the Tick mark on the Display Borders as shown in the figure below and click 

OK 

 

There are many other options like number of decimal places, hidden lines, angles, and threads that 

you can find here. For example, you can find options for hidden lines in Drafting Preferences →

View →Common →Hidden Lines 
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5.3 DIMENSIONING 

Now let’s move on to create the dimensions for these views. The dimensions can be inserted by 

either of the two ways as described below: 

 Choose Menu →Insert →Dimension 

OR 

 Click on the Dimension Toolbar as shown in the following figure 

 

 Click on Points and Edges, move the mouse and click on the appropriate location to draw 

dimensions 

The icons in this window are helpful for changing the properties 

of the dimensions. 

 Click on the Settings Button  

Here you will be able to modify the settings for dimensioning. A 

dialog appears as shown below. 
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The first list is for Lettering. This allows the user to justify and select the frame size. In the 

Line/Arrow section, you can vary the thickness of the arrow line, arrow head, angle format etc. 

The most important section is the Tolerance list. Here you can vary the tolerance to the designed 

value. 

 

The type of display, precision required for the digits and other similar options can be modified 

here. The next icon is the Text option, which you can use to edit the units, text style, font and other 

text related aspects. 
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 On the first view (Front View) that you created, click on the top left corner of the rack and 

then on the top right corner 

 

The dimension that represents the distance between these points will appear. You can put the 

location of the dimension by moving the mouse on the screen. Whenever you place your views in 

the Sheet take into consideration that you will be placing the dimensions around it. 

 To set the dimension onto the drawing sheet, place the dimension well above the view as 

shown and click the left mouse button 

Even after creating the dimension, you can edit the properties of the dimensions. 

 Right-click on the dimension you just created and choose Settings or Edit Display 

 You can modify font, color, style and other finer details here 

 Give dimensions to all other views as shown in the following figure  
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5.4 SECTIONAL VIEW 

Let us create a Sectional View for the same part to show the depth and profile of the hole. 

 Choose Insert →View →Section or click the View Section icon  from the View group 

in the ribbon bar 

 Click on the bottom of the Base View as shown in the figure. This will show a Phantom 

Line with two Arrow marks for the direction of the Section plane (orange dashed line with 

arrows pointing upwards). 

 

 Click on the middle of the View as shown. This will fix the position of the sectional line 

(Section Plane) 

Now move the cursor around the view to get the direction of the Plane of Section. Keep the arrow 

pointing vertically upwards and drag the sectional view to the bottom of the Base View. 

 

Adjust the positions of dimensions if they are interfering. The final drawing sheet should look like 

the one shown in the following figure. 
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Save and close your model. 

5.5 PRODUCT AND MANUFACTURING INFORMATION 

Product and Manufacturing Information (PMI) is one of the important applications in NX which 

provides annotation tools used to document products in a 3D environment. PMI application 

includes a comprehensive 3D annotation environment that allows design teams to share details 

such as Geometric Dimensioning and Tolerancing (GD&T), surface finish, welding information, 

material specifications, comments, government security information or proprietary information, 

etc. directly to the 3D model. PMI complies with industry standards for 3D product definition and 

therefore product teams working on collaborative projects would use 3D models as a legitimate 

method for fully documenting product and manufacturing information. 

In the below example, we will open a part file, create dimensions and comments on the 3D model 

in the PMI application and learn how to inherit the dimensions and comments to the Drafting 

application. This is only for the purpose of illustration. 

 Open the file Impeller_impeller.prt 

 From the NX 12 interface, choose File →PMI (turn on the check mark) 
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This should create an additional tab PMI in between Tools and Application tabs. Select the PMI 

tab to enter the PMI application which should look as shown below. 

 

The ribbon bar in this mode would have the Dimension, Annotation, Custom Symbols, 

Supplemental Geometry, Specialized and Security Marking groups. Each group has several options 

which could help describe the modeled 3D part. For example, dimensioning options in Dimension 

group, Surface Finish and Notes in Annotation group. 

 Click Rapid icon  

 Select the end surfaces of the impeller as first and second objects to insert the linear 

dimension or click the Linear icon to perform the same task 
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 Click the Radial icon in the Dimension group to insert the dimensions of the holes and 

curved surfaces on the impeller 

 Click the Centerline icon in the Supplemental Geometry group and select the 

inner surface of the impeller to insert the centerline for the part 

 Click the Note icon in Annotation group to provide any comments or Surface Finish icon, 

select the object, location of text and leader line to insert the specific surface finish details, 

if required 

The Trimetric view of the impeller after PMI dimensioning would look as shown below. 

 

 Save the file, select Application tab and click on Drafting icon in the ribbon bar 

 Follow the similar procedures explained in the previous section to create the Drawing sheet 

for the 3D part 

During the creation of the sheet, in the View Creation Wizard, select the Inherit PMI option, and 

select the Aligned to Drawing (Entire Part) and check the Inherit PMI onto Drawing option. This 

would inherit the dimensions of the 3D model and show on the drawing sheet including the 
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comments as shown below. The user has to select the appropriate views to reflect the dimensions 

on the drawing sheet. 

 

5.6 EXAMPLE 

 Open the model Impeller_hexa-bolt.prt 

 Choose File →Drafting or select Drafting in Application tab 

 On the Sheet window, select sheet E-34 X 44 and change the Scale value to 8.0 : 1.0 

 Click OK 

 Choose Insert →View →Base View or click the Base View icon  

 Add the Front view by repeating the same 

procedure explained in the last example 

 Add the Orthographic Views including the Right 

view and Top view 

 Choose Preferences →Drafting 

 Uncheck the box next to Display Borders under 

View Tab 

The screen will have the following three views. 
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To visualize the hidden lines, 

 Choose Preferences →Drafting →View  

OR 

 Select the views, right-click and choose Settings as shown below 

A window will pop up with various options pertaining to the views. 

 Click on the Hidden Lines tab 

 Change Process Hidden Lines to Dashed Lines as shown below and click OK 

  

You can see the hidden lines as shown in the picture on 

the right. 

Now we will proceed to dimensioning. 

 Choose Insert →Dimensions →Linear or 

click the Linear Dimension icon  in the 

Dimension group 

 Give vertical dimensions to all the distances 

shown below 



NX 12 for Engineering Design 119 Missouri University of Science and Technology 

 

 

 

For the threading, we will use a leader line. 

 Click on the Note icon shown in the Toolbar 

 In the Note window that opens, enter the following 

text. You can find Ø and the degree symbol on the 

Symbols tab 

Right Hand Ø 0.20 x 1.5 

Pitch 0.05, Angle 600 

 Click on the threaded shaft in the side view, hold 

the mouse and drag the Leader line next to the 

view. Let go of the mouse and click again to place 

the text. 
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 Close the Annotation Editor 

Since the height of the Lettering is small, we will enlarge the character size as well as the arrow 

size. 

 Right-click on the Leader and select Settings 

 Click on the Lettering tab 

 In the Text Parameter section, increase Height to make the leader legible 

 Click on the Line/Arrow tab 

 In the Format section, increase the Length of the Leader 

Now we will add additional dimensions and views. 

 Choose Insert →Dimensions →Radial or click the Radial Dimension icon in the 

Dimension group 

 Click the circle of the bolt in the top view to give the diameter dimension 

 Click Insert →View →Base View of click the Base View icon  

 Select the Isometric view and place the view somewhere on the screen 
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The final drawing is shown below. Remember to save. 

 

5.7 EXERCISE 

Perform Drafting and annotate dimensions for the parts that you modeled in chapter 4. 
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CHAPTER 6 – ASSEMBLY MODELING 

Every day, we see many examples of components that are assembled together into one model such 

as bicycles, cars, and computers. All of these products were created by designing and 

manufacturing individual parts and then fitting them together. The designers who create them have 

to carefully plan each part so that they all fit together perfectly in order to perform the desired 

function. 

In this chapter, you will learn two kinds of approaches used in Assembly modeling. We will 

practice assembly modeling using the impeller assembly as an example. Some parts of this 

assembly have already been modeled in earlier chapters. 

NX 12 Assembly is a part file that contains the individual parts. They are added to the part file in 

such a way that the parts are virtually in the assembly and linked to the original part. This 

eliminates the need for creating separate memory space for the individual parts in the computer. 

All the parts are selectable and can be used in the design process for information and mating to 

insure a perfect fit as intended by the designers. The following figure shows how components are 

added to make an assembly. 

 

6.1 TERMINOLOGY 

Assembly 

An assembly is a collection of pointers to piece parts and/or subassemblies. An assembly is a part 

file, which contains component objects. 

Component Object 

A component object is a non-geometric pointer to the part file that contains the component 

geometry. Component object stores information such as the Layer, Color, Reference set, position 

data for component relative to assembly and path of the component part on file system. 
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Component Part 

A component part is a part file pointed to by 

a component object within an assembly. The 

actual geometry is stored in the component 

part and is referenced, not copied by the 

assembly. 

Component Occurrences 

An occurrence of a component is a pointer to geometry in the component file. Use component 

occurrences to create one or more references to a component without creating additional geometry. 

Reference Set 

A reference set is a named collection of objects in a component part or subassembly that you can 

use to simplify the representation of the component part in higher level assemblies. 

6.2 ASSEMBLING APPROACHES 

There are two basic ways of creating any assembly model. 

 Top-Down Approach  

 Bottom-Up Approach  

6.2.1 Top-Down Approach 

In this approach, the assembly part file is created 

first and components are created in that file. Then 

individual parts are modeled. This type of 

modeling is useful in a new design. 

6.2.2 Bottom-Up Approach 

The component parts are created first in the 

traditional way and then added to the assembly 

part file. This technique is particularly useful, 

when part files already exist from the previous 

designs, and can be reused. 
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6.2.3 Mixing and Matching 

You can combine these two approaches, when 

necessary, to add flexibility to your assembly 

design needs. 

6.3 ASSEMBLY AND CONSTRAINT 

NAVIGATORS 

The Assembly Navigator and Constraint Navigator 

are located on top of the Part Navigator in the 

Resource Bar on the left of the screen. These 

navigators show you various things that form the 

assembly, including part hierarchy, the part name, 

information regarding the part such as whether the 

part is read only, count of objects, and the constraint status.  

6.4 MATING CONSTRAINTS 

After the Component Objects are added to the assembly part file, each Component Object is mated 

with the existing objects. By assigning the mating conditions on components of an assembly, you 

establish positional relationships, or constraints, among those components. These relationships are 

termed Mating Constraints. A mating condition is made up of one or more mating constraints. 

There are different mating constraints as explained below: 

Touch/Align: Planar objects selected to align will be coplanar but the normals to the planes 

will point in the same direction. Centerlines of cylindrical objects will be in line with each 

other. 

Concentric: Constrains circular or elliptical edges of two components so the centers are 

coincident and the planes of the edges are coplanar. 

Distance: This establishes a +/- distance (offset) value between two objects 

Parallel: Objects selected will be parallel to each other. 
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Perpendicular: Objects selected will be perpendicular to each other. 

Bond: Creates a weld and welds components together to move as a single object. 

Center: Objects will be centered between other objects, i.e. locating a cylinder along a slot 

and centering the cylinder in the slot. 

Angle: This fixes a constant angle between the two object entities chosen on the components 

to be assembled. 

6.5 EXAMPLE 

We will assemble the impeller component objects. You have modeled all the components in 

previous chapters. Now we have to insert them into the assembly environment and apply 

constraints to locate them relative to each other. Once the assembling is completed, we can create 

an exploded view and prepare the drafting. 

Before starting the assembly modeling, make three through-holes on each side of the Impeller-

lower-casing and Impeller-upper-casing (a total number of 6 holes for each casing) for the Hexa-

bolt. Diameter of the holes should be 0.25 and their location should be similar to the figure below. 

Make sure to create the holes in the same places for both lower and upper casing, so that when 

they are assembled they match. 
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6.5.1 Starting an Assembly 

 Create a new file 

 Choose Assembly under the Model tab 

 Set the Units to Inches 

 Name it as Impeller_assembly.prt 

 

OR, if you are in the Modeling Application and want to start assembling, 

 Turn on Assemblies option in Application tab and a new Assemblies tab shows up  

 

OR 
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 Click File →Assemblies as shown below 

 

 The Home menu bar will now display tools for assembly 

 

In the Components option,  

 Add option adds new component objects whose part files are already created. 

 Create New lets you create new component geometries inside the assembly file when you 

are using Top-Down approach of assembly. 

The Assembly Constraints allows you to create assembly constraints and Move Components allows 

you to reposition the components wherever you want them in the assembly. 
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6.5.2 Adding Components and Constraints 

 Choose Add 

The dialogue box shown on the right side will pop up. You 

can select the part files from those existing (should be already 

shown in Loaded Parts tab) or you can load the part files 

using the Open file options in the dialog box. This will load 

the selected part file into the Loaded Parts dialog box. 

 Click on the Open icon and select the file 

Impeller_upper-casing.prt  

 Click OK in the part name dialog box 

Then we need to set a location to place the coordinate system 

of the first component. In the Location group box, keep the 

default Snap for the Assembly Location option. 

 Click Select Object 

Now you should be able to see the part in a transparent mode, 

as shown in the figure on the right side.  

 Click the Point Dialog icon  and create the 

coordinates of [0, 0, 0] 

 Click OK to exit the Point Dialog 

Note: Feel free to play with the Cycle Orientation options to set different orientations. 

  

In the Placement group box, we can define where and how we place this component. In this case, 

we will leave the options as default. 

 Click OK to exit the Add Component Dialog 

Then, you will see a pop-up dialog appears as shown in the figure below. 
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 Click Yes to create a Fix constraint to this part. 

Now what you have should like the figure below. 

 

 

Let’s move on to add the second component, the lower casing. 

 Click on Add in the assembly section 

 Select the file Impeller_lower-casing.prt from the Loded Parts or Open 

 In the Location group box change the option to Absolute – Work Part to place the new 

part at the absolute origin of the current work part 

 In the Placement group box, first toggle the Move radio button and move the lower casing 

away from the upper casing to have enough space for selecting the mating surfaces. What 

you will have should like the figure below. 
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 Then, toggle the Constrain radio button.  

Now let’s mate the upper and the lower casings. 

You can access all the constraints in the drop-

down menu in the Constraint Type box. 

Here you can see the different Mating Types, 

which were explained above in the previous 

section. 

 Make sure the Touch Align icon  is 

selected in the Type dialog box 

 First, select the face that the arrow is 

pointing to as shown below in the figure on the left. 

 Click on the face of the upper casing in the screen as shown in the figure on the right.  



NX 12 for Engineering Design 131 Missouri University of Science and Technology 

 

 

You may have to adjust the view in order to select the faces. After you choose these two faces, the 

Touch Align constraint will be automatically added. 

Let’s add another Touch Align constraint.         

 Click on the Flange of the upper casing 

 Click on the Flange of the lower casing, you may need to inverse the direction of constraint 

by click on the Inverse icon  

         

Note: If it is difficult for you to select the faces because of the position of the parts, you can move 

them by toggling the Move in the Placement group box and manipulate its handler. 

Let’s add another Touch Align constraint. 

 Make sure you are still using Touch Align 
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 Click on the flat face of the upper casing as shown and then the corresponding face on the 

lower casing 

         

The two assembled components will be seen as shown in the figure below. 

  

The lower casing is constrained with respect to the upper casing. Now let us add the impeller.  

 Choose Assemblies →Component →Add to add a component to the current assembly 

 Open the file Impeller_impeller.prt 

 Click OK on the dialog box 
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 Choose Absolute – Work Part for Assembly Location  

 Toggle the Constrain button 

 Click on the Distance icon  in the Constraint Type box 

 Select the two faces, first on the impeller and then on the casing, as shown in the figure 

below 

         

 In the Distance box in the Placement group, enter the value of 3 

 Press Enter to preview the current assembly 

The preview may show the impeller oriented in the direction opposite to the one we want. 
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 To change the orientation of the part or the distance direction, in the Placement window, 

click on the Cycle Last Constraint  button in the Geometry to Constrain box, as 

shown below 

 

Check the assembly status from its preview, you may have to click on the  button for several 

times to get the desired result. Now the impeller will be oriented in the right direction.  

 

We will now add the shaft using the Center constraint. 

 Click on Assemblies →Components →Add 

 Open the file Impeller_shaft.prt 

 Click OK on the dialog box 

 Choose the Touch Align icon in the Constraint 

Type box 

 Choose the Infer Center/Axis option in the 

Geometry to Constrain box 
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 Select the two surfaces, first on the shaft and then on the impeller as shown in the figures 

below  

         

 Stay in the Touch Align constraint 

 Choose the Prefer Touch option in the Geometry to Constrain box 

 First, select the face on the shaft and then select the bottom face of the hole in the impeller 

as shown 

         

The assembly will now look like the figure below. 
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 Click on Assemblies →Components →Add 

 Open the file Impeller_hexa-bolt.prt 

 Choose the Touch Align constraint. Use the Infer Center/Axis option in the Geometry 

to Constrain box 

 First, select the outer cylindrical threading on the bolt and then select the inner surface of 

the hole on the upper casing as show in the figures below. 

          

 Again in the Touch Align constraint change the Geometry to Constrain option to Prefer 

Touch 

 Select the flat face on the bolt and the face on the rib of the upper casing as shown 
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 Click OK 

          

The assembly is shown below.  

  

 Repeat the same procedure to add bolts and nuts to all the holes in the assembly.  

This completes the assembly of the impeller. 

Note: There is a simpler way to assemble the bolt and nut set. Instead of adding the three parts 

individually, you can assemble these components separately in another file. This will be a sub-

assembly. You can insert this subassembly and mate it with the main assembly. 

The Final Assembly will look as the shown below. Save the Model. 
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6.5.3 Exploded View 

In this section, we are going to create an Exploded View of the assembly to show a separated part-

by-part picture of the components that make the assembly. In today’s industrial practice, these 

kind of views are very helpful on the assembly shop floor to get a good idea of which item fixes 

where. The user should understand that exploding an assembly does not mean relocation of the 

components, but only viewing the models in the form of disassembly. You can Unexplode the view 

at any time you want to regain the original assembly view. Let us explode the Impeller Assembly. 

 Choose Menu →Assemblies →Exploded Views →New Explosion 

This will pop up a dialog box asking for the name of 

the Explosion view to be created. You can leave name 

as the default name and choose OK 

Now the NX environment is in Exploded View 

environment though you do not find any difference. When we start exploding an assembly, we 

should decide upon a component to keep that component as the reference. This component should 

not be moved from its original position. In the case of the impeller assembly, the impeller will be 

the right option as it is central to the entire assembly. Now let us start exploding the components. 

 Right click on the upper casing and choose Edit Explosion 

The Edit Explosion window will pop up along with coordinate handles on the component.  
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 Click on the Z axis; hold the mouse and drag upwards until the reading in the Distance 

shows -20 (substitute +20 if you have designed in opposite direction)  

 Click OK 

 Right click on the lower casing and choose Edit Explosion 

Again, this will pop up a dialog window for Edit 

Explosion and a coordinate system on the component. 

 Click on the Z-axis; hold the mouse and drag 

downwards until the reading in the Distance 

shows 20 as shown in the figure on the right 

side.  

 Right click on the shaft and choose Edit 

Explosion 

 This time click on the X-axis; hold the button 

and drag to the right side until the reading in the 

distance shows -25 as shown in the following 

figure 
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 Choose OK 

  

 Select all the six hexagonal bolts in the assembly by clicking on them 

 Right click on one of them and choose Edit Explosion 

 This time click on the Z-axis; hold the button and drag upwards until the reading in the 

Distance shows 25 as shown in the following figure. This will move all the six bolts 

together to the same distance.  

 Choose OK 
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 Likewise, move the six washers and the six hexagonal nuts downwards to -30 and -35, 

respectively. 

This is the Exploded view of the assembly. You can rotate and see how it looks like. 

 

If you want to go back to the original unexploded view, 

 Click Exploded Views in the ribbon → choose (No Explosion) from the drop-down menu 

as shown below 

 

Or, you can Unexplode any component in the assembly, 

 Right click on the component and choose Unexplode. 

If you want to unexplode all the components, 

 Choose Assemblies → Exploded Views → Unexplode Component 
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 Select all the components and choose OK 

6.6 EXERCISES 

6.6.1 Arbor Press 

In the previous sections of this tutorial, we have modeled various parts, some of which are 

components of the arbor press shown below. Assemble the arbor press using the components that 

you have modeled in addition to ones that are provided to you, which you have not modeled before. 

The complete list of parts of the arbor press assembly is provided below. All these parts are 

provided in a folder that can be accessed along with this tutorial in the same internet address 

(https://web.mst.edu/~mleu/). 

 Allen Bolt 
 Allen Nut 
 Base 
 Circle base 
 End clip 
 Handle 
 Hexagonal Bolt 
 L-bar 
 Pin 
 Pinion 
 Pinion handle 
 Plate 
 Rack 
 Sleeve 

 

6.6.2 Butterfly Valve 

Butterfly valve is one of the most commonly used devices for controlling flow. The Butterfly valve 

consists of a rotating disk positioned in the pipe. The disc is attached to the shaft that is connected 

to an actuator on the outside of the valve. Rotating the actuator turns the disc either parallel or 

perpendicular to the flow. When the valve is closed, the disc is turned so that it completely blocks 

off the passageway. When the valve is fully open, the disc is rotated a quarter turn so that it allows 

an almost unrestricted passage of the fluid. The valve may also be opened incrementally to regulate 

flow.  
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In this exercise, you will model and assemble the Butterfly valve consisting of 9 different parts for 

a total of 12 components. The names, drawings and dimensions of the different part items, as well 

as how the various components fit together, are provided. The parts for which the drawings are not 

given are to be designed or selected, for example, the round head machine screw. All dimensions 

are in inches. 
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6.6.3 Jackscrew 

A jackscrew is a type of jack that is operated by turning a leadscrew. In this 

exercise, you are asked to model, assemble and prepare drawings of parts. All 

dimensions should be in millimeters. Create individual drafts for each 

component. Draft the final assembly and make a table, listing out individual 

components. The Assembly draft should have an exploded view. 
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NX 12 for Engineering Design 148 Missouri University of Science and Technology 

 

CHAPTER 7 – FREEFORM SURFACE MODELING 

In this chapter, you will learn how to create freeform surfaces in NX 12. Up to this point, you have 

learned different ways to create models by using Form Features or by Sketching. Freeform surface 

modeling involves creating models in the form of surfaces for aesthetic or functional purposes, 

such as car bodies and turbine blades. A few freeform features are shown below. 

 

To create Freeform Features, you first need a set of points, curves, edges of sheets or solids, faces 

of sheets or solids, or other objects. The following sections cover some of the methods that you 

can use to create models using freeform features. 

7.1 OVERVIEW 

In NX 12, the Freeform Features options are located at various places like Menu → Insert →

Surface/Mesh Surface/Sweep/Flange Surface and Menu → Edit → Surface for more advanced 

operations. There are a lot of ways in which you can create Freeform Features from the existing 

features you have like points, edges, curves, etc. A few of commonly used functions are discussed 

in the following sections. 

7.1.1 Creating Freeform Features from Points  

In the case where the geometry you are constructing or pre-existing data includes only points, you 

can try using one of the following three options to build a surface from the given points. 
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 From Menu, click on Insert → Surface 

  Four Point Surface: if you have four corner points. 

 Through Points: if the points form a rectangular array. 

  From Poles: if defined points form a rectangular array 

tangential to the lines passing through them. 

7.1.2 Creating Freeform Features from Section 

Strings  

If construction geometry contains strings of connected 

objects (curves and edges), you can use one of the following 

two options to create a freeform surface. 

 From Menu, click on Insert → Mesh Surface 

 

 

 Ruled: if you have two strings which are roughly 

parallel.  

 

 Through Curves: if three or more strings are roughly 

parallel. 

 

If the construction geometry contains two or more strings (curves, 

faces, edges) that are roughly parallel to each other, and one or more section strings that are roughly 

perpendicular to the first set of curves (guides), you can try using one of these following options 

to build a freeform surface. 
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 Through Curve Mesh: used if at least four section 

strings exist with at least two strings in each direction (parallel 

and perpendicular). 

 

 Swept: used if at least two section strings are roughly 

perpendicular (from Menu, choose Insert →Sweep). 

 

 

7.1.3 Creating Freeform Features from Faces 

If the construction geometry contains a sheet or face, you may be able to use one of the following 

two options to build the freeform surface.  

 Offset Surface: use this option if you have a face to offset. 

(From Menu, click on Insert →Offset/Scale) 

 Extension: use this option if you have a face and edges, 

edge curves, or curves on the face. (Click on the Insert →Flange Surface →Extension) 

 

7.2 FREEFORM FEATURE MODELING 

Let’s do some exercises on freeform modeling with structured points, a point cloud, curves and 

faces. Structured points are a set of point’s defined rows and columns. A point cloud has a set of 

scattered points that form a cloud. 
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7.2.1 Modeling with Points 

 Open the file freeform_thrupoints.prt 

 Right-click on the Toolbars and make sure the Surface Toolbar is checked 

 

You will see seven rows of points. 

  

 Choose Insert →Surface →Through Points 

OR 

 Click on the Icon   in the Toolbar 

The dialogue box will pop up as shown in the right. 

 For Patch Type, select Multiple 

 For Closed Along, select Neither 

 For Row Degree and Column Degree, enter 3. 

 Click OK  

The next dialogue box will be as shown in the right figure. 

 Click Chain from All 

 Select the top starting point and the bottom ending 

point of the left most row as shown in the following figure 
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The first row of points will be highlighted. 

 Repeat the same procedure to select the first four rows of points. 

After that, a window should pop-up asking if all points 

are specified or if you want to specify another row. 

 Select Specify Another Row until all rows are 

specified 

 When all the rows are specified, choose All Points Specified 

 Click Cancel on the Through Points window 

You will see the surface as shown below. 

 

7.2.2 Modeling with a Point Cloud 

 Open the file named freeform_cloud.prt 

The point cloud will be seen as follows. 
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 Choose Insert → Surface → Fit Surface 

OR 

 Click on this icon  on the Surface Toolbar 

The following dialogue box will appear. 

 Select all the points on the screen by clicking on 

the point cloud. 

 In the Fit Direction drop-down menu, choose 

Best Fit for. This matches the point cloud 

coordinate system with original system  

 Change the default values for U and V degrees to 

3 

 Click OK 

The final surface will look like the following.  
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7.2.3 Modeling with Curves 

 Open the file named freeform_thrucurves_parameter.prt  

The curves will be seen as in the figure below. 

 

 Choose Insert → Mesh Surface → Through Curves 

OR 

 Click on this Icon  on the Toolbar 

 Select the first section string as shown below. Be sure to select somewhere on the left side 

of the arc. 

A direction vector displays at the end of the string. 
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 Click the middle mouse button MB2 or click Add New 

Set  

 Click on the next curve similar to first one and click the 

middle mouse button MB2. You can see a surface 

generated between the two curves as shown in the figure 

 

 Repeat the same procedure to select the remaining 

strings. Remember to click MB2 (or Add New Set) 

after selecting each curve. 

 For Alignment, choose Parameter 

 For Patch Type, choose Single  

 For Construction, choose Simple  

When the Simple option is selected, the system tries to build the 

simplest surface possible and minimize the number of patches.  

 Click OK 
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7.2.4 Modeling with Curves and Faces 

 Open the file named freeform_thrucurves_faces.prt 

The curve and faces will be seen as shown on the 

right. 

 Choose Insert →Mesh Surface →Through 

Curves 

 Select edge-1 of the top plane 

 Select edge-2 and click MB2 

 Select edge-3 

 In the Dialog box, under the Alignment 

section, uncheck the Preserve Shape check 

box 

You would get the following shape displayed on your screen. 



NX 12 for Engineering Design 157 Missouri University of Science and Technology 

 

 

Make sure that all the arrows are pointing in the same direction (if they are not, double click on 

either of the arrows to flip its direction). 

 In the Alignment dialog box choose Parameter 

 In the Continuity dialog box, for First Section, select G2 (Curvature) option and select 

the two patches of the top surface 

 Click APPLY 

 

 Now select edge-3 and click MB2 

 Select the three edges of the lower plane 

 Change the option to G2 (Curvature) in the Continuity dialog box for First Section  

 Select the surface you just created and click MB2 
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 For Continuity of the Last Section, choose G2 (Curvature) and then select the bottom 

three patches as references 

 Click OK to exit 

The final freeform surface should be seen as shown below. 

 

7.3 EXERCISES 

7.3.1 An Exercise on Curves 

 

 

The above figure shows three curves created using points as “Control Points” or “Through Points”. 

The corresponding points and modeling type of each curve are listed in the following table. 
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 Curve 1 Curve 2 Curve 3 

Points 

(0, 0, 0) 

(0.117, -0.765, 0) 

(1.953, -0.525, 0) 

(2.5, -0.196, 0) 

(2.5, 0, 0) 

(-0.191, 0, 0.181) 

(-0.191, -0.757, 0.181) 

(1.435, -0.709, 0.577) 

(2.609, -0.415, 0.147) 

(2.610, 0, 0.147) 

(-0.191, 0, 0.181) 

(0.591, 0, 0.596) 

(1.632, 0, 0.622) 

(2.610, 0, 0.147) 

 

Type Control Points with 2nd degree Through Points with 2nd degree 

 

(a) Create the ruled surface between Curve-1 and Curve-2.  
(b) Extrude Curve-3 along the +Y direction to create a reference surface. Then create the 

surface between Curve-2 and Curve-3, this surface should have G1 (Tangent) continuity 
to the reference surface you just extruded.  

Tips: You can import those points from a text file to NX. First, save the points coordinates into 

a text file. Then, use NX File -> Import -> Points from File to import it. 

7.3.2 An Exercise on Surfaces 

 

Given 2 points sets that stored in the files of “Fit curve.pts” and “Fit surface.pts” (available in the 

file folder). 

(a) Import those two sets of points into NX. (Figure above shows the expected result) 
(b) Create a spline curve based on points in the file of “Fit curve.pts”. You can use Fit 

Curve to create it, adjust the number of Degree and Segments to get a better fitting. 
(c) Create a freeform surface based on points in the file of “Fit surface.pts”. You can use Fit 

Surface to create it, adjust the number of Degree and Patches to get a better fitting. 
(d) Use the spline curve as the boundary to trim the freeform surface along Z direction. The 

expected result is like the upper surface of a computer mouse. 
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7.3.3 Design a Computer Mouse 

Model a computer mouse similar to the one shown below (feel free to search for more images as 

references), or you can come up with a new design and then model it. As a hint, create some 

boundary curves on different datum planes and use them to create freeform surfaces. 

 

 

7.3.4 Design a Sport Water Bottle 

Design a sport water bottle and use freeform features in NX (curves and surfaces) to model it. 
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CHAPTER 8 – FINITE ELEMENT ANALYSIS 

Finite Element Analysis (FEA) is a practical application of the Finite Element Method (FEM) for 

predicting the response behavior of structures or fluids to applied factors such as forces, pressures, 

heats, and vibrations. Usually, the process starts with the creation of a geometric model. Then the 

model is subdivided (meshed) into small pieces (elements) of simple geometric shapes connected 

at specific node points. The material properties and the boundary conditions are applied to each 

element. Finally, software such as NX 12 solves this FEA problem and outputs results and 

visualizations. It helps engineers to have a better understanding of the product performance before 

it is fabricated and tested. 

Some of the applications of FEA are Structural Analysis, Thermal Analysis, Fluid Flow Dynamics, 

and Electromagnetic Compatibility. Of these, FEA is most commonly used in structural and solid 

mechanics applications for calculating the mechanical behavior (e.g. stresses and displacements). 

These are often critical to the performance of the hardware and can be used to predict failures. In 

this chapter, we are going to deal with the structural stress and strain analysis of a solid part. 

 

8.1 OVERVIEW 

8.1.1 Element Shapes and Nodes 

The elements can be classified into different types based on the number of dimensions and the 

number of nodes in an element. The following are some of the types of elements used for 

discretization. 

One-dimensional elements 
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Two-dimensional elements 

Triangular: 

 

Quadrilateral: 

 

Three-dimensional elements 

Tetrahedral (a solid with 4 triangular faces): 

 

Hexahedral (a solid with 6 quadrilateral faces): 
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Types of nodes 

Corner nodes 

Exterior nodes 

Side nodes 

Interior nodes 

Usually, FEA can have a more accurate solution as the size of finite element becomes smaller, but 

the computing time becomes longer as well. 

8.1.2 Solution Steps 

Starting the Simulation: You can select a solver from one of these: NX Nastran, NX Nastran 

Acoustic, NX Nastran Vibro-Acoustic, NX Nastran Design, Samcef, NX Thermal/Flow, 

Simcenter Electronic Systems Cooling, Simcenter Space Systems Thermal, NX Multiphysics, 

Simcenter Acoustics BEM, MSC Nastran, Ansys, Abaqus, and LS-DYNA. In addition, you can 

choose the type of analysis to be performed. In this tutorial, only Structural Analysis will be 

covered with NX Nastran Design. 

Choosing the Material Properties: This allows you to change the material properties that will be 

assigned to the model. For example, if we use steel to manufacture the impeller, we can enter the 

material properties such as density, Poisson’s ratio, etc. These material properties can also be saved 

in the library for future use or can be retrieved from Library of Materials. 

Applying the Loads: This option allows you to apply different types of loads, such as forces or 

pressures on the solid along with the directions and magnitudes. 

Applying the Boundary Conditions: Simply speaking, boundary conditions constrain the degrees 

of freedom of the elements. Some elements can be rotationally fixed and some can be constrained 

from translational movement. 

Meshing the Bodies: This is used to discretize the model into finite elements. Normally, we select 

tetrahedral shapes of elements for approximation. You can still select the 2-D and 1-D elements 

depending on the situation and requirements by choosing these options from the drop-down menu. 

Solution and Results: This is the command to solve all the governing equations by the selected 

solver and all the above options. This solves and gives the results of the analysis of the problem. 
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8.1.3 Simulation Navigator 

The Simulation Navigator provides the capability to activate 

existing solutions, create new ones, and use the created solution 

to build mechanisms by creating and modifying motion objects. 

To display the Simulation Navigator,  

 Click the Simulation Navigator tab in the Resource 

bar as shown in the figure 

It shows a list of the simulations created for the model. In each 

simulation, it displays a list of loads, boundary conditions, types 

of meshes, results, reports generated and so on. 

8.2 SIMULATION CREATION 

 Copy and paste the file Impeller_impeller.prt into a new folder to avoid changes being 

made to the assembly 

 Click on New → Simulations if the part is NOT already opened in the NX window 

  

 Open this newly copied file 
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 If the part is already opened in NX, then from the top ribbon bar, click on Application →

Design 

 

 

Or 

 click on File → All Applications → Simulation → Design Simulation 
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When you first open any file in Design Simulation module, it will automatically pop up the New 

FEM and Simulation dialog to create a simulation. 

 In the popup dialog, click OK to create a new simulation. 

Then in the next popup Solution window, you can select the Solver and the Analysis Type.  

The default Solver type is NX Nastran Design and Analysis type is Structural.   

 Choose OK to create a new Solution called Solution 1, which will be displayed in the 

Simulation Navigator. Here we keep the other items as default. 
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Now the Simulation Navigator will look like the following figure. 

  

8.3 MATERIAL PROPERTIES 

The next step is to assign the material properties to the solid model for this simulation. Because 

we do not have any data in the library to retrieve for standard material, we will create one. Let us 

assume that we will use steel to manufacture the impeller.  

 

 

 Click on Assign Materials from the ribbon bar shown above 
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The Assign Material window will pop up. You have the option 

of choosing the pre-defined materials from the Library or 

create a new material.  

 Select the Impeller for Select Body 

 Click on the Create icon to create a new material 

Enter the name and values as shown in the following figure. 

Pay attention to the units. 

(Note that 30e6 represents 30×106) 

 Choose OK to exit the Isotropic Material window 

Now we have assigned the material to the impeller model.  
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8.4 MESHING 

The Mesh option discretizes the model into small 

elements. 

 Click on the 3D Tetrahedral icon  

A window will pop up asking for the type and 

size of the elements.  

 First, click on the impeller model on the 

screen for Select Bodies. 

Then, there are two types of Tetrahedral 

Elements available in NX 12. One is 4-node and 

the other is 10-node. 

 Choose the Type to be TETRA(10) 

 Enter the Element Size as 1.0 inch  

 Click OK 

You can find the model with small tetrahedral 

elements. It will look like the figure shown 

below. 

Note: While meshing the solid, there is a trade-

off you need to consider. If you choose a smaller 

element with higher nodes you will get better accuracy in your analysis than larger element. 

However, the time required to solve the model with smaller elements will much greater than with 

larger element. Hence, based on the accuracy requirement of the study and how critical the 

component is in terms of the end product, choose the appropriate parameters for the elements and 

nodes. 
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8.5 LOADS 

The loads applied on the solid model should be input to the system. For the impeller, suppose the 

major force acts on the concave surfaces of the turbine blades. This loading can be approximated 

by normal pressure on all the five surfaces. Since we are not concerned about the magnitude of the 

load, let us take the value to be 100 lbf/in2 inch to exaggerate the deformation of the blades. 

 Click on Load Type and choose Pressure 

    

 Click on the five concave surfaces of the 

blades as shown in the following figure 

 Enter the value for Pressure as 100 and 

keep the unit as lbf/in2 (psi)  
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8.6 BOUNDARY CONDITIONS 

The impeller rotates about the axis of the cone with the shaft as you can see in the assembly in the 

previous chapters. It is not fixed but our concern is the deformation of the blades with respect to 

the core of the impeller. The conical core is relatively fixed and the deformations of the blades are 

to be analyzed accordingly. 

 Click on the 

Constraint Type icon 

 

 Select the Fixed 

Constraint   

This type of constraint will 

restrict the selected entity in six 

DOF from translating and rotating. You can see the different constraints available by clicking the 

Constraint Type drop-down menu on the toolbar. 

 Click on the conical surface of the impeller as shown in the following figure 



NX 12 for Engineering Design 172 Missouri University of Science and Technology 

 

 Click OK 

  

8.7 RESULT AND SIMULATION 

8.7.1 Solving the Simulation 

The Finite Element Model is now ready for solving and analysis. It is a good practice to first check 

for model completion before we get into solving the model. To check the model 

 Click on the Menu → Analysis →  Finite Element Mode Check  →  Model Setup or 

click the Model Setup icon in the Checks and Information group in the ribbon bar 

This will pop up a window as shown on the right.  

 Choose OK 

This will display the result of the Check operation. 

You will see any errors and warnings in a separate 

window. In case you get errors or warnings go back 

to the previous steps and complete the required 

things. If you do not get errors or warnings you are 

ready to solve the FEA problem. 
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 Click on the Solve icon   

This will open the Solve window.  

 Click OK without making any changes 
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It may take a while to solving the job. Wait until the 

Analysis Job Monitor window appears, showing the 

job to be Completed. While the solver is doing 

computations, the Analysis Job Monitor will show as 

In Progress  

 Click on Cancel when the Analysis Job 

Monitor window shows Completed 

 

8.7.2 FEA Result 

 From Simulation Navigator, double click on 

Structural under Results 

 You will be directed to the Post Processing Navigator 

The Post-Processing Navigator shows all the Solution you just solved. If you click the ‘+’ sign in 

front of the Solution, you will see the different analyses that have been performed on the model. 
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 Double-click on the Displacement-Nodal 

The screen will now appear as shown below. You can easily interpret the results from the color-

coding. The orange-red color shows the maximum deformation zones and the blue area shows the 

minimum deformation zones. You can observe that because the conical core is fixed, it experiences 

zero deformation. The analysis also shows that the maximum deformation experienced at the tip 

of the blades is approximately 1.9 × 10-3 inches. 

  

On the Post-Processing Navigator, you can keep changing the results by double clicking each 

option as shown below. You can click on the other inactive marks to see various results. Some of 

the other results are shown below. 
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8.7.3 Simulation and Animation 

Click on the Results tab from the top ribbon bar. A group for Animation can be seen on it as 

follows 

 

 Click on the Animate icon. 

 In the Animation window, change the number of 

frames to 10 and click on the Play button  to see the 

animation of the deformation  

You can now see an animation of how the impeller is 

deformed as the loads are applied to the blades.  

 To make any setting changes in the results display, 

click on the Edit Post View icon  

 Check the Show undeformed model and click OK  
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Now press on the Play button to see the animation. This will show the animation of deformation 

with the original shape in grey color, as shown in the figure below.  

 

 Click on the Stop button to stop the animation 

 Click on Return to Home to go back to the FEA model  

There are two ways to improve the accuracy of FEA results: 

 Reduce the size of element 

 Increase the order of interpolation polynomial (i.e. use quadratic or even cubic instead of 

linear polynomials) 

Let us try creating a simulation using different settings. 

 Right-click on Solution 1 in the Simulation Navigator  
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 Choose Clone to copy the first simulation 

 Once Copy of Solution 1 is created, 

rename it to Solution 2 

 From the Simulation Navigator, under 

3D Meshes, right click on the 3D Mesh 

(1) and click Edit 

 In the popup dialog, change the Type to 

TETRA4 

 Click OK 

 Click on the Solve icon  to solve the 

simulation  

 Click OK 

The Analysis Job Monitor should show the status 

of Solution 2 to be Completed. 

 Click Cancel  

 In the Simulation Navigator, double-click 

on Results for Solution 2 

The figure below shows the analysis. You can 

observe the change in the maximum value. Save 

all the simulations and close the files. 
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8.8 EXERCISES 

8.8.1 Arbor Press Bar 

Open the file ‘Arborpress_L-bar.prt’ and do a similar structure analysis, considering the material 

as steel. For the mesh, the element size and type should be ’10’ and ‘Tetra(10)’. For the loads, 

apply a normal pressure with a magnitude of 500 on the top surface as shown in the first figure 

below.  

For the boundary conditions, fix the three flat faces (the front highlighted face, the face parallel to 

it at the backside and the bottom face) as marked in the second figure below. 
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8.8.2 Rocker Arm 

In this exercise, you will examine the effect of element type and mesh size on the results of finite 

element analysis. Open the Rocker Arm you modeled in chapter 4. Assign the following material 

properties: Young’s modulus = 3.0 × 107 psi, Poisson’s ratio = 0.29, and mass density = 7.35 × 10-

4 slug/in3. Fix both the counter bore hole and the counter sunk hole (i.e. fix the cylindrical faces) 

as shown in the figure below and apply a pressure load of magnitude 600 psi normal to the face 

shown. For each of the four following cases, obtain the deflection contour and Von-Mises stress 

contour. 

a) Tetra 4 elements, element size – 0.2 

b) Tetra 4 elements, element size – 0.05 

c) Tetra 10 elements, element size – 0.2 

d) Tetra 10 elements, element size – 0.05 

Please answer the following questions: What are the maximum deflection and the maximum stress 

for each of the four cases? Which of the four cases provides the most accurate results? How are 

the FEA results affected by the type and size of elements? 
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CHAPTER 9 – MANUFACTURING 

As we discussed in Chapter 1 about the product realization process, the models and drawings 

created by designers will undergo manufacturing processes to get to the finished products, which 

is the essence of CAD/CAM integration. The most widely and commonly used technique is to 

generate control codes for CNC machines to mill the desired part. This technique reduces the 

amount of human programing in creating CNC codes, which facilitates the designers to create 

products with complex geometries. In this chapter, we will cover the Manufacturing Module of 

NX 12 to generate CNC codes for 3-Axis Vertical Machining Centers. This module allows us to 

program and do some post-processing on drilling, milling, turning and wire-cut EDM tool paths. 

9.1 GETTING STARTED 

A few preparatory steps need to be performed on every CAD model before moving it into the 

CAM environment. In this chapter, we are going to work with a model that was finished in the 

previous exercise problem. All the units are followed in millimeters in this model and 

manufacturing of the component. 

Before getting started, it would be helpful if you can get 

into a CAM Advanced Role. To do this, go to the Roles 

menu on the Resource Bar. Click Content and a list of 

choices will pop up in which the CAM Advanced role can 

be seen as shown in the figure.  

9.1.1 Creation of a Blank 

After completing the modeling, you should decide upon 

the raw material shape and size that need to be loaded on 

the machine for the actual fabricating. This data has to be 

the input in NX 12. It can be achieved in two ways. The 

first method is creating or importing the model of the raw 

material as a separate solid in the same file and assigning 

that solid as the Blank. The second method is letting NX 

decide the extreme dimensions of the designed part and 
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some offset values if needed. The later method allows a quick way of assigning the size details but 

it can only be used for prismatic shapes. 

 Open the file Die_cavity.prt for the exercise problem in Chapter 4 

 To create a Blank, Insert a block with the following dimensions 

Length = 150 mm 

Width = 100 mm 

Height = 80 mm 

 For the Origin option, choose the lower most corner of the base block, so that the new 

block created can wrap up the whole previous model as shown below 

      

This block encloses the entire design part so we need to change the display properties of the block 

to have a better visualization. 

 Click on the Edit Object Display icon in the Visualization group of the View tab  

 

 Select the block you just created and click OK 

 When a window pops up, change the display Color and change the Translucency to 50 

 click OK 
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 Hide the block you just created by right clicking on the block in the Part Navigator and 

click Hide (you may need to use Select from List… to choose the blank). This will make 

the raw block disappear from the working environment. 

9.1.2 Setting Machining Environment 

Now we are set to get into the Manufacturing module. 

 Select File → New → Manufacturing → Mill Turn 

 There are many different customized CAM templates available for different machining 

operations. Here, we are only interested in the milling operation. 
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9.1.3 Operation Navigator 

As soon as you get into the Manufacturing environment, you will notice many changes in the main 

screen such as new icons that are displayed. 

 Click on the Operation Navigator tab on the left on the Resource Bar 

The Operation Navigator gives information about the programs created and corresponding 

information about the cutters, methods, and strategies. A list of programs can be viewed in different 

categorical lists. There are four ways of viewing the list of programs in the Operation Navigator, 

which are Program Order view, Machine Tool view, Geometry view and Machining Method view. 

 Click on Geometry View  

9.1.4 Machine Coordinate System (MCS)  

 Click on the Create Geometry icon in the Insert group 

to initiate setup for programming 
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You will see a Create Geometry popup dialog. 

 Click OK 

Another popup window will allow you to set the MCS 

wherever you want. By default, NX 12 takes the original 

Absolute-CS as the MCS. 

 Click OK to select the default choice as the MCS 

 

9.1.5 Geometry Definition 

 Click on Geometry View 

 Expand MCS_MAIN_SPINDLE by clicking on the ‘+’ sign in the Operation Navigator 
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 Double click on WORKPIECE_MAIN in the Operation Navigator. If you do not see it, 

try clicking on related ‘+’ signs 

The popup window Workpiece Main 

appears. This is where you can assign the 

Part geometry, Blank geometry, and 

Check geometry. 

 Click on the Part icon 

 Select the design part and click 

OK 

Now we will select the Blank Geometry. 

 Click on the Blank icon 

This will open the Blank Geometry Window. As mentioned earlier there are several ways to define 

the Blank. You can use a solid geometry as the Blank or can allow the software to assign a prismatic 

block with desired offsets in the X, Y, and Z directions. As we have already created a block, here 

we can use that as the Blank geometry. 

 Click on the Block and press OK 

Now we are finished assigning the Part and Blank geometries. Sometimes it may be required to 

assign Check geometry. This option is more useful for shapes that are more complex or 5-Axes 

milling operations where the tool cutters have a higher chance of dashing with the fixtures. In our 

case, it is not necessary to assign a Check geometry. 

 Click OK to exit the Workpiece Main window 

9.2 CREATING OPERATION 

9.2.1 Creating a New Operation 

The manufacturing setup is now ready for us to work further with Programming Strategies. There 

are many different manufacturing strategies involved in programming and it takes practice to know 

which one is optimal. Here, the basic guidelines are given for the most widely and frequently used 
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strategies. This chapter will also cover some important parameters that are to be set for the 

programs to function properly. 

 Click on the Create Operation icon in the toolbar  

The Create Operation window will pop up. 

 Make sure the Type of Operation is Mill_Contour 

There are a set of different subtypes under Mill-Contour, namely Cavity Mill, Z-Level Follow 

Cavity, Follow Core, Fixed Contour, and so on. These 

different subtypes are used for different situations and 

profiles of the design part. As mentioned before, how you 

select a strategy for a certain situation depends on your 

knowledge and experience.  

 Click on the Cavity_Mill icon at the top left as 

shown in the figure 

 Choose the Program as 1234 

 Change the Geometry to WORKPIECE_MAIN 

 Click OK 

The program parameters window with Cavity Mill in the 

title bar will pop up. On this window, you can set all the 

parameters for this program. A brief introduction on every 

important parameter and terminology will be given as we 

go through the sequence. 

9.2.2 Tool Creation and Selection 

One of the most important decisions to make is to select a tool with the right shape and size to use. 

Before starting with the Tool parameter settings, we must first know about the types of Tool 

cutters. The Milling Tool Cutters are categorized into three forms of cutters. Hence, when selecting 

a cutter, it is important to take into consideration the size, shape, and profiles of the design parts. 

For example, if the corner radius of a pocket is 5 mm, the pocket should be finished by a cutter 
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with a diameter less than or equal to 10 mm. Otherwise it will leave material at the corners. There 

are other special forms of cutters available in markets that are manufactured to suit different needs. 

Flat End Mill Cutters 

These cutters have a sharp tip at the end of the cutter as shown in the figure below. These cutters 

are used for finishing parts that have flat vertical walls with sharp edges at the intersection of the 

floors and walls. 

  

Ball End Mill 

These cutters have the corner radii exactly equal to half the diameter of the shank. This forms the 

ball shaped profile at the end. These cutters are used for roughing and finishing operations of parts 

or surfaces with freeform features. 

  

Bull Nose Cutters 

These cutters have small corner radii and are widely used for roughing and/or semi-finishing the 

parts as well as for finishing of inclined and tapered walls. 

  

The cutter that we are going to use to rough out this huge volume is BUEM12X1 (Bullnose End 

Mill with 12 diameter and 1 corner radius).  

 In the Cavity Mill popup menu click on the Create New button in the Tool dialog box 
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 Click New 

 On the New Tool window, select the Mill icon 

  

 Type in BUEM12X1 as the Name and click 

OK 

This will open another window to enter the cutter 

dimensions and parameters. You can also customize 

the list of tools that you would normally use and call 

the predefined cutters from the library. 

 Enter the values as shown in the figure below 
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 Click OK 

9.2.3 Tool Path Settings 

Make sure that the Tool Axis is perpendicular to the top surface on the block. 

 Click on Tool Axis and choose Specify Vector 

 Select the appropriate axis as shown 

 In the Cavity Mill menu click on the Path 

Settings option 

There are different Cut Patterns in which the tool can 

move. The following is a description of each. 

 Follow Part: This is the most optimal strategy where 

the tool path is manipulated depending on the part geometry. If there are cores and cavities in the 

part, the computer intelligently considers them to remove the materials in an optimal way. This is 

widely used for roughing operations. 

 Follow Periphery: This takes the path depending 

upon the periphery profile. For example, if the outer 

periphery of our part is rectangular, the tool path will be 

generated such that it gradually cuts the material from 

outside to inside with a Stepover value. This option is 

mostly used for projections and cores rather than cavities. 

 Profile: This takes the cut only along the profile of 

the part geometry. It is used for semi-finishing or 

finishing operations.  

 Trochoidal: This cutter is huge and is used for removing a large amount of material. The bulk 

of material is removed by gradual trochoidal movements. The depth of cut used will be very high 

for this strategy. 

 Zig: This takes a linear path in only one direction of flow. 
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 Zig Zag: This tool takes a zigzag path at every level of depth. It saves time by reducing 

amount of air cutting time (idle running). The climb and conventional cuts alternate. 

 Zig with Contour: This takes the path in one direction either climb or conventional. The 

unique thing is that it moves along the contour shape nonlinearly. 

 For this exercise, select the Follow Part icon from the Cut Pattern drop-down menu since 

we have both projections and cavities in the part 

9.2.4 Step Over and Scallop Height 

Step Over 

This is the distance between the consecutive passes of milling. It can 

be given as a fixed value or the value in terms of cutter diameter. 

The Stepover should not be greater than the effective diameter of the 

cutter, otherwise it will leave extra material at every level of cut and 

result in an incomplete milling operation. The numeric value or 

values required to define the Stepover will vary depending on the 

Stepover option selected. These options include Constant, Scallop, 

Tool Diameter, etc. For example, Constant requires you to enter a 

distance value in the subsequent line. 

Scallop Height 

Scallop Height controls the distance between parallel passes according to the maximum height of 

material (scallop) you specify to be left between passes. This is affected by the cutter definition 

and the curvature of the surface. Scallop allows the system to determine the Stepover distance 

based on the scallop height you enter. 
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 For the Stepover, select %Tool Flat and change the Percent to 70 

 

9.2.5 Depth Per Cut 

This is the value to be given between levels to slice the geometry into layers and the tool path cuts 

as per the geometry at every layer. The cut depth value can vary for each level. Levels are 

horizontal planes parallel to the XY plane. If we do not give cut levels, the software will 

unnecessarily try to calculate slices for the entire part and machine areas that are not in our interest. 

 Change the Common Depth per Cut value to 0.5 

Now we will add the level ranges. This will split the part into different levels along the Z-direction 

to be machined. 

 Click on Cut Levels 

This will pop up a dialog box of Cut Levels. You need 

to set the level of the cut. You can either point to the 

object till which the cut level is or provide it as a 

Range Depth value. We are not going to mill up to the 

bottommost face of the part, but up to the floor at 40 

mm from top. Therefore, we must delete the last level. 

 Change the Range Type to User Defined 

 Change the Range Depth to 80 

 Select OK 

9.2.6 Cutting Parameters 

 On the Path Settings menu, click Cutting 

Parameters 

 Under the Strategy tab button, change the Cut 

Order from Level First to Depth First 
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Changing the cut order to Depth First orders the software to generate the tool path such that it will 

mill one island completely up to the bottom-most depth before jumping to another island. The 

Depth First strategy reduces the non-cutting time of the program due to unnecessary retracts and 

engages at each depth of cut. 

 Click on the Stock tab 

 Change the value of the Part Side Stock to 0.5 

This value is the allowance given to every side of the 

part. If you want to give different values to the floors 

(or the flat horizontal faces) uncheck the box next to 

Use Floor Same As Side and enter a different value for 

Part Floor Stock. 

 Click OK 

9.2.7 Avoidance 

 Click the Non Cutting Moves 

 Click the Avoidance tab 

This window consists of several avoidance points of 

which we are concerned with the following points: 

From Point 

This is the point at which the tool change command 

will be carried out. The value is normally 50 or 100 

mm above the Z=0 level to enhance the safety of the 

job when the cutter is changed by the Automatic Tool 

Changer (ATC). 

 Click From Point  

 Choose Specify in the Point Option field 

 In the Point Dialog, enter the coordinates of 

XC, YC and ZC as (0, 0, 50) 
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 Click OK 

Start Point 

This is the point at which the program starts and ends. This value is also 50 or 100 mm above the 

Z=0 level to enhance safety. It is also the point at which the machine operator checks the height of 

the tool mounted on the spindle with respect to the Z=0 level from the job. This cross checks the 

tool offset entered in the machine. 

 Click on Start Point 

 Choose Specify  

 Enter the coordinates (0, 0, 50) in the Point Dialog 

 Click OK to exit the Point Constructor 

Clearance Plane is the plane on which the tool cutter will retract before moving to the next region 

or island. This is also known as Retract Plane. Sometimes the Clearance Plane can be the previous 

cutting plane. However, when the tool has to move from one region to another, it is necessary to 

move to the Clearance Plane before doing so. The value of the Clearance Plane should be at least 

2 mm above the topmost point of the workpiece or fixture or whichever is fixed to the machine 

bed. 

 Click on the Transfer/Rapid tab 

 Choose Plane in the Clearance Option 

 Choose the XC-YC Plane from the drop-

down menu in Type tab 

 Under the Offset and Reference tab enter the 

value of 3 as the Distance 

 Click OK twice to go back to the Cavity Mill 

parameters window 

9.2.8 Speeds and Feeds 

 Choose Feeds and Speeds to enter the feed and speed parameters 

Speed 
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Speed normally specifies the revolutions per minute (rpm) of the spindle (spindle speed). However, 

technically the speed refers to the cutting speed of the tool (surface speed). It is the linear velocity 

of the cutting tip of the cutter. The relative parameters affecting this linear speed are rpm of the 

spindle and the diameter of the cutter (effective diameter). 

 Enter the Spindle Speed value as 4500 rpm 

For the Surface Speed and the Feed per Tooth, you should enter the recommended values given 

by the manufacturers of the cutter (for this example, click on the calculator button near spindle 

speed). By entering these values, the software will automatically calculate the cutting feed rate and 

spindle speed. You can also enter your own values for feed rates and spindle speeds. 

Feeds 

There are many feeds involved in a single program. 

The most important is the Cutting feed. This is the 

feed at which, the tool will be in engagement with the 

raw work-piece and actually cutting the material off 

the work-piece. It is the relative linear velocity, at 

which the cutter moves with respect to the job. 

The other feeds are optional. Some machine control 

systems use their default retracts and traverse feed. In 

those cases, even if you do not enter the values of 

other feeds, there would not be any problems. Some 

control systems may look for these feed rates from the 

program. It can be slightly less than the machine’s 

maximum feed rate. 

 Enter the Cut value as 1200 mmpm 

 Click OK 
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9.3 PROGRAM GENERATION AND VERIFICATION 

9.3.1 Generating Program 

Now we are done entering all the parameters required 

for the roughing program. It is time to generate the 

program. 

 Click on the Generate icon at the bottom of the 

window 

You can now observe the software slicing the model 

into depths of cuts and creating tool-path at every level. 

You can find on the model cyan, blue, red and yellow 

lines as shown in the figure. 

9.3.2 Tool Path Display 

Whenever you want to view the entire tool-path of the 

program, right-click on the program in Operation 

Navigator and click Replay. It will give the display as 

shown in the Figure below. 
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You can now observe that next to the program in the Operation Navigator is a yellow exclamation 

point instead of a red mark. This means that program has been generated successfully but has not 

been post-processed. If any change is made in the model, the program will again have a red mark 

next to it. This implies that the program has to be generated again. However, there is no need to 

change any parameters in the program. 

9.3.3 Tool Path Simulation 

It is very important to check the programs you have created. This prevents any improper and 

dangerous motions from being made in the cutting path. It is possible that wrong parameters and 

settings will be given that cause costly damages to the work piece. To avoid such mistakes, NX 12 

provides a Tool-path verification and a Gouge check. 

The Tool-Path verification can be used to view the cutter motion in the entire program. You can 

observe how the tool is engaged and how it retracts after cutting. It also shows the actual material 

being removed through graphical simulation. You can also view the specific zone of interest by 

moving the line of the program. 

 Right-click on the program in the Operation Navigator and choose Tool Path → Verify 

or click on the Verify Tool Path button in the toolbar 

 

This will allow you to set the parameters for visualization of the Tool-Path. 
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 On the Tool Path Visualization window, click 

on the Play icon  to view the motion  

You can also view the visualization in different modes 

by changing the options in the drop-down menu next to 

Display.  

 Click on the 3D Dynamic tab on the same 

window 

 Click on the Display Options button on the same 

window 

 Change the Number of Motions to 50 

 Change the Animation Accuracy to Fine 

 Change the IPW Color to Green 

 Click OK 
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 Click on the Play button  again 

The simulation will look as shown in the figure on 

the right. With this option, you will be able to view 

the actual cutting simulation and material removal 

through computer graphics. It is 3D Dynamic, where 

you can rotate, pan and zoom the simulation when it 

is playing. 

9.3.4 Gouge Check 

Gouge Check is used to verify whether the tool is removing any excess material from the work-

piece with respect to Part Geometry. Considering a Design Tolerance, any manufacturing process 

may produce defective parts by two ways. One is removing excess material, which is also called 

Less Material Condition. The other one is leaving materials that are supposed to be removed which 

is More Material Condition. In most cases, the former is more dangerous since it is impossible to 

rework the design part. The latter is safer since the leftover material can be removed by reworking 

the part. The gouge check option checks for the 

former case where the excess removal of material 

will be identified. 

 Right Click the program in the Operation 

Navigator  

 Choose Tool Path → Gouge Check 

 Click OK 

After the gouge check is completed, a Tool Path 

Report window will pop up. If in case there are any 

gouges found, it is necessary to correct the program. 

Otherwise,  

 Click OK or directly close the popup window 
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9.4 OPERATION METHODS 

9.4.1 Roughing 

In case of milling operation, the first operation should be rough milling before finishing the job. 

The main purpose of roughing is to remove bulk material at a faster rate, without affecting the 

accuracy and finish of the job. Stock allowances are given to provide enough material for the 

finishing operation to get an accurate and good finish job. What we did in the previous part of this 

chapter is generating a roughing program. Now we have to moderately remove all the uneven 

material left over from the previous program. 

9.4.2 Semi-Finishing 

Semi-Finishing programs are intended to remove the unevenness due to the roughing operation 

and keep even part stock allowance for the Finishing operations. Once we are done with the first 

roughing program, semi-finishing is always easier and simpler to perform. 

Now we will copy and paste the first program in the Operation Navigator. In the new program, 

you only have to change a few parameters and cutting tool dimensions and just regenerate the 

program. 

 Right click CAVITY_MILL program in the 

Operation Navigator and click Copy  

 Right-click CAVITY_MILL again and 

choose Paste 

 Right-click the second 

CAVITY_MILL_COPY you just made and click Rename 

 Rename the second program as CAVITY_MILL_1 

You can see that next to the newly created CAVITY_MILL_1 is a red mark, which indicates that 

the program is not generated. 

Let us now set the parameters that need to be changed for the second program. Before we start, we 

should analyze the part geometry to figure out the minimum corner radius for the cutter diameter. 

In our model, it is 5 mm and at the floor edges, it is 1 mm. Therefore, the cutter diameter can be 
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anything less than 10 mm. For optimal output and rigidity, we will choose a Bull Nose Cutter with 

a diameter of 10 and a lower radius of 1. 

 Double click CAVITY_MILL_1 on Operation Navigator to open the parameters 

window 

Just as we did in the previous program, we will create a new cutter. In the Tool tab, you will see 

the cutter you first chose. It will show BUEM12X1 as the current tool. 

 Create a new Mill and name it BUEM10X1 

 It should have a Diameter of 10, a Lower 

Radius of 1 and a Flute Length of 38 

 Click OK 

 Click the Common Depth per Cut as 0.25 in 

the Path Settings 

 

 Then click on Cutting Parameters button 

 Click on the Stock tab 

 Uncheck the box next to Use Floor Same As 

Side 

 Enter 0.25 for Part Side Stock 

 Enter 0.1 for Part Floor Stock 

 Click on the Containment tab button 
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 In the drop-down menu next to In Process Workpiece, choose Use 3D 

In Process Workpiece is a very useful option in NX. The software considers the previous program 

and generates the current program such that there is no unnecessary cutting motion in the No-

material zone. This strategy reduces the cutting time and air cutting motion drastically. The 

algorithm will force the cutter to only remove that material, which is left from the previous 

program and maintain the current part stock allowance. 

 Choose OK to return to the Parameters window 

 Click Feeds and Speeds 

 Enter the Spindle Speed as 5000 

 Then click OK 

The parameters and settings are finished for the semi-finishing program. 

 Regenerate the program by clicking on the Generate icon  

 After the software finishes generating click OK 

Then replay the Tool Path Visualization. The overall Tool Path generated in the second program 

will look like the following figure. You can replay it or check for the gouging in a similar way. 
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9.4.3 Finishing Profile 

So far, we are done with the roughing and semi-finishing programs for the part. There is a small 

amount of material left in the Workpiece to be removed in the finishing programs to obtain the 

desired accurate part geometry. The finishing programs should be generated such that every 

surface in the part should be properly machined. Therefore, it is better to create more than one 

program to uniquely machine sets of surfaces with relevant cutting parameters and strategies rather 

than make one program for all the surfaces. The following illustrates how to group the profiles and 

surfaces and create the finishing programs. 

9.4.3.1 Outer Profile 

This program is intended to finish the outer inclined walls onto the bottom of the floor. Because 

the program should not touch the contour surface on the top, we will give Check and Trim 

boundaries in the program. 

 Repeat the same procedure as before to copy and paste CAVITY_MILL_1 on Operation 

Navigator 

 Rename the program CAVITY_MILL_2 

 Double click CAVITY_MILL_2 to make parameter changes 

 In the popup parameters window, change the Cut Pattern to Profile and the Stepover 

percentage to 40 

 Click on the Specify Trim Boundaries tab 

The Trim Boundaries window will pop up. Make sure 

to carry out the following procedure in the right 

sequence. Keep the default setting of Trim Side to 

Inside. This tells the software that the cutter should not 

cut material anywhere inside the boundary. Trim allows 

you to specify boundaries that will further constrain the cut regions at each cut level. 

 Change the Selection Method to Curves 

 Change the Plane from Automatic to Specify and click on the Plane Dialog 
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A new window will pop up. The window will ask for the mode of selection of the plane on which 

the curves should be projected. This should normally be over the topmost point of the part 

geometry. Precisely, it should be over the MCS. 

 Choose the XC-YC Plane from the drop-down menu under Type 

 Enter a value of 3 next to Distance 

 Click OK 

Now we will start selecting edges from the part. These selected edges will be projected on the Z = 

3 plane as curves and used as the boundary. 

 Select all the top outer edges on the wall along the contour surface as shown in the figure. 

Make sure to select all 8 edges and in a continuous order 

 Choose OK 

 

 Enter the Common Depth per Cut as 0.2 

 Click Cutting Parameters 

 In the popup dialog box, click on Stock tab  

 Enter the Part Side Stock and Part Floor Stock values to be 0.00  
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Intol allows you to specify the maximum distance that a 

cutter can deviate from the intended path into the 

workpiece. 

Outtol allows you to specify the maximum distance that 

a cutter can deviate from the intended path away from the 

workpiece. 

 Enter the Intol and Outtol values to be 0.001 as 

shown in the figure 

 Click OK 

 Click on the Generate icon  to generate the 

program in the Main Parameters window 

 Click OK on the parameters window when the 

program generation is completed 

The finishing program for the outer profile is now ready. You can observe while replaying the tool 

path that the cutter never crosses the boundary that has been given for trim and check. The cutter 

retracts to the Z=3 plane for relocation. 
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9.4.3.2 Inner profile 

 Repeat the same procedure as before to copy and paste CAVITY_MILL_2 on Operation 

Navigator and rename it as CAVITY_MILL_3 

 Double click CAVITY_MILL_3 to edit the parameters or right click on it and choose Edit 

 Select the Specify Trim Boundaries tab and choose Trim Side to be Outside in the popup 

dialog box 

This will prevent the cutter from passing outside the boundary. 

 Change Selection Method to Curves  

 Change the plane manually to be the XC-YC plane and enter the offset distance as 3 

 Click OK 

 Select all the top inner edges along the contour surface as shown in the figure. Again, make 

sure all 8 edges are selected in a continuous order (using Shift+click to de-select a curve). 

 

 Choose OK to return to the parameters window 

 Generate the program 

 Click OK when the generation is finished 

The finishing program for the inner profile is now ready. By replaying the tool path, you can 

observe that the cutter never crosses the boundary that has been given for trim and check.  
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9.4.4 Finishing Contour Surface 

Now we will use a different type of strategy to finish the top freeform surface. 

 Click on the Create Operation icon  in the Toolbar 

 Click on the Fixed Contour icon as 

shown in the figure 

 Choose 1234 for Program 

 Choose WORKPIECE_MAIN for 

Geometry 

 Keep the default name of program 

 Click OK 

 On the Parameters window, under Drive Method, make sure that Boundary is selected 
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 Click icon, which will pop up the Boundary Drive Method window, click on the 

 icon as shown in the figure to open the Boundary Geometry menu 

 Change the Mode to Curves/Edges 

 Select the Material Side to be Outside 

 Select the Tool Position to be On 

 

The Tool Position determines how the tool will position itself when it approaches the Boundary 

Member. Boundary Members may be assigned one of three tool positions: On, Tanto, or Contact. 

 In On position, the center point of the tool aligns with the boundary along the tool axis or 

projection vector. 

 In Tanto position, the side of the tool aligns with the boundary. 

 In Contact position, the tool contacts the boundary. 

 For the Plane, choose User-Defined 

 Again, set the plane to be XC-YC with a Distance of 3 

 Click OK 

 Select the outer loop of the top contour surface as shown in the figure. Remember to select 

the edges in a continuous order 
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 Click OK 

We have trimmed the geometry outside the loop. Now we have to trim the geometry inside the 

inner loop so that the only geometry left will be the area between the two loops.  

 Choose the Mode to be Curves/Edges 

 Choose the Material Side to be Inside and Tool Position to be On 

 Choose the plane to be user-defined at XC-YC with a Distance of 3 

 Select the inner edges of the contour surface as shown 

 Click OK to return to the Boundary Drive Method window 

 

 Change the Stepover method to Scallop and enter the height to be 0.001 and click OK 



NX 12 for Engineering Design 211 Missouri University of Science and Technology 

 

 Click on Cutting Parameters 

 Change the Tolerance values in the Stock tab so 

that the Part Intol and Part Outtol is 0.001 

 Click on the More tab button and enter the value 

of Max Step as 1.0 

 Click OK 

In the main parameters window, 

 Create a new tool and name it BEM10 

 Change the diameter to be 10 mm and the lower 

radius to be 5 mm. 

 Click OK 

 Click on the Feeds and Speeds icon on the 

parameters window 

 Enter the Spindle Speed, Feed Rates (Cut) and 

calculate the others as shown in the figure on 

right 

 Click OK 

 Generate the program  

The contour surface is now finished and you can view the 

simulation by Tool Path Verification. 
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9.4.5 Flooring 

Flooring is the finishing operation performed on the 

horizontal flat surfaces (Floors) of the part. In most of 

the milling processes, flooring will be the final 

operation of them. All the horizontal surfaces will be 

finished. This planar operation runs the cutter in a 

single pass on every face. 

 Click on the Create Operation icon  

 Change the Type to be mill_planar at the top 

of the window 

 Change all the options as shown in the figure 

 Click OK 

 In the parameters window, change the Cut 

Pattern to be Follow Part  
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 Change the percent of the tool diameter for 

Stepover to be 40 

In flooring operations, it is always better to keep the 

Stepover value to be less than half of the diameter of the 

cutter in order to achieve more flatness on the planar 

surfaces. 

Unlike previous programs, we have to select a cut area. 

 Click on the Specify Cut Area Floor as shown  

 Select the highlighted surfaces shown in the 

figure below 

In case you are not able to select the surfaces as shown 

go to Part Navigator and Hide the Blank (to choose the 

blank, you can right click on the blank, use Select from 

List…), select the surfaces and Unhide the Blank again. 

 

 Click OK 

 Click on Cutting Parameters in the main parameter window 

 Choose the Stock tab button and enter the Intol and Outtol values as 0.001 

 Click OK 

 Click on Feeds And Speeds 
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In the main Parameters window, 

 Create a new tool and name it BEF105 

 Change the diameter to be 10 mm and the lower 

radius to be 5 mm 

 Click OK 

Because this is a Flooring operation, it is better to make 

the spindle speed high and the feed rates low compared 

to the previous operations. 

 Enter the values for Spindle Speed, Feed Rates 

(Cut) and calculate the others as shown in the 

figure 

 Choose OK 

 Generate the program. Then replay and verify 

the cutter path 

The following figure shows the Tool Path display for the flooring. 
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9.5 POST PROCESSING 

The primary use of the Manufacturing Application is to generate tool paths for manufacturing 

parts. Generally, we cannot just send an unmodified tool path file to a machine and start cutting 

because there are many different types of machines. Each type of machine has unique hardware 

capabilities, requirements and control systems. For instance, the machine may have a vertical or a 

horizontal spindle; it can cut while moving several axes simultaneously, etc. The controller accepts 

a tool path file and directs tool motion and other machine activity (such as turning the coolant or 

air on and off). 

Naturally, as each type of machine has unique hardware characteristics; controllers also differ in 

software characteristics. For example, most controllers require that the instruction for turning the 

coolant on be given in a particular code. Some controllers also restrict the number of M codes that 

are allowed in one line of output. This kind of information is not in the initial NX tool path. 

Therefore, the tool path must be modified to suit the unique parameters of each different 

machine/controller combination. The modification process is called Post Processing. The result is 

a Post Processed tool path. 

There are two steps involved in generating the final post-processed tool path. 

1. Create the tool path data file, or called CLSF (Cutter Location Source File).  

2. Post process the CLSF into machine CNC code (Post Processed file). This program reads 

the tool path data and reformats it for use with a particular machine and its accompanying 

controller. 
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9.5.1 Creating CLSF 

After an operation is generated and saved, the resulting tool path is stored as part of the operation 

within the part file. CLSF (Cutter Location Source File) provides methods to copy these internal 

paths from the operations in the part file to tool paths within the CLSF, which is a text file. The 

GOTO values are a "snapshot" of the current tool path. The values exported are referenced from 

the MCS stored in the operation. The CLS file is the required input for some subsequent programs, 

such as postprocessors. 

 Click on one of the programs that 

you want to post process in the 

Operation Navigator 

 Click on Output CLSF in the 

Operations toolbar 

A window will pop up to select the CLSF 

Format. 

 Choose CLSF_STANDARD and 

enter a location for the file 

 Choose OK  

The CLSF file will be created. It will be similar to the figure 

below. The contents of the file contain the basic code of the cutter 

motion without any information about machine codes and control 

systems. This file can be used for post-processing any machine 

control. The extension of the file is .cls. 
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Any program that has been output to CLSF or Post Processed will have a green checkmark next 

to it in the Operation Navigator. 

9.5.2 Post Processing 

 Click on a program in the Operation Navigator that you want to post process 

 Click Menu → Tools → Operation 

Navigator →Output →Postprocess or 

from the Home tab as shown 

 Select the MILL_3_AXIS machine and enter a location for the file 

 Select OK 

This will create the Post Processed file for the target machine. You can find the block numbers 

with G and M codes concerning the machine controller type. The extension of the file is .ptp. 
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The final output (filename.ptp) file can be transferred to a machine for conducting an actual milling 

operation. The entire sequence starting from the transfer of the model into the Manufacturing 

module to the transfer of the files to the machine and fabricating the raw piece into the final part 

is called Computer Aided Manufacturing. 


