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Introduction to Fibersim

Fibersim is fully integrated with NX and launched from within the NX user interface. Engineers
define composite parts by creating Fibersim objects, such as laminates, rosettes, plies, and
cores. During definition, engineers associate these Fibersim objects to their corresponding
CAD geometry. In this chapter, the Fibersim user interface will be discussed.

How to start Fibersim.

There are three ways to start Fibersim in NX:

• Press <F9> to start Fibersim.
• [NX8.5] Select Start > All Applications > Fibersim as shown in Figure 1–1.

• [NX8.5] Click  (Fibersim). If the Fibersim icon is not on the screen, make sure
Fibersim toolbar is turned on.

• [NX9/10] Select File > All Applications > Fibersim as shown in Figure 1–2.

• [NX9/10] Click  on the Fibersim ribbon menu.

It will start Fibersim window as shown in Figure 1–3.

Figure 1–1
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Figure 1–2

User Interface.

Figure 1–3 shows the Fibersim user interface when nothing is selected.

Figure 1–3
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• Main Menu: These pull-down menus consist of import, export, basic editing tools, and
utilities.

• Main Toolbar: This toolbar consists of icons to evoke common commands, such as
Create New, Modify, Delete. and etc.

• Application Browser: This browser enables you to choose what you want to see in the
Application Tree. You may choose Fibersim, which will display all available applications
within Fibersim as shown in Figure 1–3, or choose a specific application.

• Application Tree: This tree displays applications available in Fibersim and components
within each application. For more detailed explanation, see Fibersim User Guide 1.2
Fibersim User Interface.

• Documentation Browser: This browser lists parts that exist in the current file.
Commands related to documentation can be performed from right-click menu in this
browser.

• Messages Window: This windows enables you to see what has been done in the current
session of the file.

• Status Bar: This bar displays short messages and status of the commands you perform.
It also displays progress while Fibersim performs tasks, such as highlighting objects,
calculating producibility, creating flat patterns, and etc.

When an object is selected from the Application Tree, the Fibersim user interface updates.
Based on what is selected, it displays commands that can be performed with the selected
objects as shown in Figure 1–4.

Figure 1–4
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Add, Remove, Sort, and Move Columns

When a Fibersim component is selected from the Application Tree, list of objects for the
selected component appears in the Object Display Window. The columns displayed at the top
of the list can be used to sort the list. You can also add or move the columns.

• If you want to sort the list based on a column, click on the header of the column. A small
arrow appears at the top of the column header to represent ascending/descending
order as shown in Figure 1–5. Click on the header again to toggle between ascending
and descending order.

Figure 1–5

• If you want to add or remove a column, right-click on one of the column headers. The
right-click menu should appear as shown in Figure 1–6. The check marks represent the
columns currently displayed. Click on the items to add or remove them from the Object
Display Window.

Figure 1–6
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• If you want to move a column, click and hold on a column header. Drag it over to a
desired location and release as shown in Figure 1–7.

Figure 1–7

Sort, Group, and Find

Sort, Group, and Find filters located in the Main Toolbar are powerful tools that can help you
to work efficiently in Fibersim.

• If you want to sort the list based on one member, it would be more efficient to sort with
columns. However, if you want to sort the list of items based on more than one
member, use this compound Sort tool:

• By default, Sequence, Step and Name sort option exists. This option will sort the
list based on Sequence, Step and Name in order.

• You can create custom Sorts. To create a new Sort:

1. Click on  in the Sort field.

2. Enter a name for the Sort. Typically, it is a good idea to use a descriptive
and unique name, such as Orientation and Name to indicate that it sorts
by Orientation first then by Name.

3. Click on  (Create Sort).

4. Select parameters for 1st, 2nd, and 3rd Member and the order as shown
in Figure 1–8.

5. Click OK.

Figure 1–8
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• If you want to edit objects that share common attributes, such as Specified Orientation,
Zones, or Material, you can use the Group tool. There are some default groups already
created, but you can create custom Groups. To create a new Group:

1. Click on  in the Group field.

2. Enter a name for the Group.

3. Click on  (Create Group).

4. Select values for 1st, 2nd, and 3rd Member.

5. Click OK.

• The Find tool lets you filter the list of objects based on your input. Fibersim will find all
objects that contain your input and filter out the rest. The Find tool is most helpful if you
are looking for a specific object.

• To find a ply named P006:

1. Type [P006] in the Find toolbar and hit Enter.

2. The object list should be updated as shown in Figure 1–9.

Figure 1–9

3. Note that the Status Bar at the bottom indicates the number of objects
that are selected, shown, and available as shown in Figure 1–10.

Figure 1–10

4. To show all objects again, right-click in the Object Display Window, and
choose Show Available.
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Active Laminate

Active Laminate option is new to Fibersim 15. It is located next to the Sort, Group, and Find
options in the main toolbar as shown in Figure 1–11.

Figure 1–11

When a laminate is selected, only the objects that have the laminate as a parent are shown.
For example, if you have multiple laminates and multiple plies that belong to those laminates,
you can filter the list of plies by selecting an active laminate.

Selecting an active laminate will change the available value in the selected/shown/available
status bar to match the number of objects that belong to the active laminate.

For certain cases (e.g. plies) objects can have another object as a parent. In that case,
Fibersim will look at the parent’s parent to find a laminate.
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Highlighting Contexts in Fibersim

There are many different highlighting contexts in Fibersim, and they vary depending on the
object displayed. For the ply object there are 7 separate contexts, as described below. To

view the highlighting contexts, click on  in the Main Toolbar. You should see the options
shown as Figure 1–12.

Figure 1–12

Figure 1–13 describes some of the different highlighting contexts for the ply object.

Figure 1–13

Net Boundary Net Boundary + Net Simulation Net Shading

Extended Boundary
+ Net Boundary

Extended Boundary
+ Extended Simulation

Extended Shading
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Options

There are three types of options in Fibersim; EnCapta options, Fibersim options - global, and
Fibersim options - specific to part. They control different aspects of the application.

EnCapta Options control the User Interface of Fibersim. To access EnCapta options, select
Tools > Options > EnCapta Options from the Fibersim window. EnCapta options dialog box
should appear as shown in Figure 1–14.

Figure 1–14

Fibersim Options have some controls for global settings and others for part specific. To
access Fibersim Options, select Tools > Options > Fibersim Options from the Fibersim
Window. Fibersim options dialog box should appear as shown in Figure 1–15.

As noted in Figure 1–15, the top section of the dialog box has global setting controls i.e.
display colors for Fibersim components and zone text display options. Part-specific settings
are located at the bottom of the dialog box.

Figure 1–15

Global settings

Part-specific
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Design Checker

The Design Checker is a utility that can be used to check the basic geometry and design of
the composite part for an error.

The Geometry check portion of the Design Checker will validate boundaries, holes, and
origins on all appropriate objects; Laminate, Ply, Core, Zone, Layer, Core Layer, and etc. The
Design check portion of the utility will run producibility on all the plies and check that plies do
not exceed material width. In addition, Fibersim will report if the ply does not have an
up-to-date flat pattern.

To run the Design Checker:

1. Click  (Design Checker) located on the object toolbar.

2. Choose the appropriate tab.

3. Click on  (Link with Link Dialog).

4. Link all the Laminates to run the Design Checker on.

5. Click .

6. Click  or  depending on the selected
tab.

7. View Report for any errors and messages.
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Actions: Ply Table - HTML and Ply Table - CSV

Actions are customizable operations that can be run on any Fibersim data in a given model.
By default Fibersim comes with several pre-prepared actions, including two different Ply Table
reports, as described below.

Ply Table - HTML and Ply Table - CSV commands are quick and simple way to export the ply
table to either HTML or CSV format. They are available from Action Main Menu. The result of
Ply Table - HTML is shown in Figure 1–16.

Figure 1–16

Window Snapping

When working in Fibersim, the program may open multiple windows. The Window Snapping
feature will help you manage these windows better.

Click  (Move Dialog with Parent Dialogs), located at the top left corner of a window as
shown in Figure 1–17.

Figure 1–17

When the top dialog window is moved around, the parent dialog window should move with it.

To Un-snap the windows, click  (Move Dialog with Parent Dialogs) again.
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Chapter 2

Model Setup

This chapter includes:

Exercise 2a: [NX8.5] Create a Model from an Extended Surface
and Planes

Exercise 2b: [NX9/10] Create a Model from an Extended
Surface and Planes

Exercise 2c: [NX8.5] Create a Model from a Solid
Exercise 2d: [NX9/10] Create a Model from a Solid
Exercise 2e: NX Model Setup from Planes and Surface

(Optional)
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Exercise 2a [NX8.5] Create a Model from an
Extended Surface and Planes

User Guide Reference:
2.1 Introduction
2.2 CEE Organization
2.3 Understanding CEE
Data Hierarchy
2.4 Defining Boundaries
for CEE Objects
2.6 Laminates
2.7 Rosettes

In this exercise, you will prepare a NX model for composite design
with Fibersim from an extended surface and planes using NX8 or
NX8.5. The completed model displays as shown in Figure 2–1.

Figure 2–1

Goal After you complete this exercise, you will be able to:

Create Net Boundary geometry
Create Extended Boundary geometry
Create a Tool Surface
Create Rosette geometry

Estimated Time 10 min
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Task 1 - Open a part.

1. Open MODEL_SETUP_A.prt. The model displays as shown in
Figure 2–2.

Figure 2–2

Task 2 - Create Net Boundary geometry.

1. Select Insert > Curve from Bodies > Intersect as shown in
Figure 2–3.

Figure 2–3

2. For the Set 1 face, select Loft_Surface.

rastheim
Cross-Out

rastheim
Inserted Text
Derived Curve
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3. Select all six planes displayed in the model by making a selection
box around the part as shown in Figure 2–4.

Figure 2–4

4. Click .

5. Select Insert > Associative Copy > Extract Geometry as shown
in Figure 2–5.

Figure 2–5
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6. Select Composite Curve for Type.

7. Ensure that the Stop at Intersection ( ) option is enabled as
shown in Figure 2–6.

Figure 2–6

8. Select the curves in the location and order shown in Figure 2–7.

Figure 2–7

9. Under Settings, select Hide Original option and General for Joint
Curves. as shown in Figure 2–8.

Figure 2–8

10.Click .
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11. Select Curve from the Selection Filter list as shown in Figure 2–9.

Figure 2–9

12.Select the composite curve in the model.

13.Right-click and select Properties.

14.Click on the General tab.

15.Enter [Ext_Boundary] for Name and Feature Name.

16.Click .

17.Select the composite curve again.

18.Right-click and select Edit Display.

19.Change the color to Magenta (Color ID: 181) and width to 0.13mm
as shown in Figure 2–10.

The thinnest line width is
used to minimize conflicts
with Fibersim highlighting.

Figure 2–10

20.Click .

Task 3 - Create Extended Boundary geometry.

1. Select Insert > Curve from Curves > Offset in Face.

2. Select Ext_Boundary for Curve.

3. Select Loft_Surface for Plane.

rastheim
Cross-Out

rastheim
Inserted Text
Derived Curve
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4. Enter [0.5] (12.7mm) for Section1:Offset1 as shown in

Figure 2–11. Click on  (Reverse Direction), if necessary, to
match the Figure 2–11.

Figure 2–11

If the Offset in Face
command fails, flip the
curve direction of the
composite curve or change
the Tolerance to 0.01.

5. Under Settings, select General for Join Curves field as show in
Figure 2–12.

Figure 2–12

6. Click .

7. Select the Spline of the Offset in Face.

8. Right-click and select Properties.

9. Click on the General tab.

10.Enter [Net_Boundary] for Name and Feature Name.

11. Click .

12.Select Net_Boundary.

13.Right-click and select Edit Display.

rastheim
Inserted Text
in the graphics window.
If selected from the navigator you are only allowed to rename the feature.

rastheim
Inserted Text
Other points in the exercise include the "in" unit in the value.
Refer to Step 10 on page 2-10.
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14.Change the color to Cyan and width to 0.13 mm as shown in
Figure 2–13.

Figure 2–13

Alternatively, you can
select Format > Layer
Settings to open Layer
Settings.

15.Press <Ctrl> + <L> to open Layer Settings and hide
MASTER_LINES layer category. (Make sure that Category
Display is enabled.)

16.Click .

Task 4 - Create a Tool Surface.

1. Select Insert > Trim > Trimmed Sheet as shown in Figure 2–14.

Figure 2–14

2. Select Loft_Surface for Target and Ext_Boundary for Boundary
Objects.

rastheim
Inserted Text

rastheim
Inserted Text
Click OK.

rastheim
Cross-Out

rastheim
Inserted Text
Now called Trim Sheet

rastheim
Inserted Text
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3. Select the appropriate option for Region to keep the geometry
shown as in Figure 2–15.

Figure 2–15

4. Click .

5. Select Edit > Surface > Reverse Normal. Fibersim uses the tool
surface normal to determine the direction of the layup (male or
female tool). To ensure the correct normal direction on the tool
surface, the recommended practice is to use the Reverse Normal
command.

6. Select LOFT_SURFACE and ensure that the normal direction
points -Z direction as shown in Figure 2–16. (Press <W> to display
WCS)

Figure 2–16

7. Since the surface normal is pointing to the desired direction, click

.

rastheim
Inserted Text
I had an additional blue curve on the right side of the surface showing in my part. I hid it.

rastheim
Inserted Text
in the 
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Task 5 - Create Rosette geometry.

1. Click  (Point).

2. In the Point type drop-down list, select Point on Face.

3. Indicate a placement point somewhere in the middle of the Tool
Surface.

4. Click .

5. Select Point from the Selection Filter list.

6. Select the created point.

7. Right-click and select Properties.

8. Enter [Rosette_Origin] for Name and Feature Name.

9. Click  (Line).

10.Select the following:

• Start Option: Point > select Rosette_Origin
• End Option: Along XC
• Start Limit: At Point
• Distance: 0 in (0 mm)
• End Limit: Value
• Distance: 3 in (76.2 mm)

The Line Definition dialog box updates as shown in Figure 2–17.

Figure 2–17

rastheim
Inserted Text
Click OK
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11. Click .

12.Select Curve from the Selection Filter list.

13.Select the created line.

14.Right-click and select Properties.

15.Enter [Zero_Direction] for Name and Feature Name.

16.Click .
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Exercise 2b [NX9/10] Create a Model from an
Extended Surface and Planes

User Guide Reference:
2.1 Introduction
2.2 CEE Organization
2.3 Understanding CEE
Data Hierarchy
2.4 Defining Boundaries
for CEE Objects
2.6 Laminates
2.7 Rosettes

In this exercise, you will prepare a NX model for composite design
with Fibersim from an extended surface and planes using NX9. The
completed model displays as shown in Figure 2–18.

Figure 2–18

Goal After you complete this exercise, you will be able to:

Create Net Boundary geometry
Create Extended Boundary geometry
Create a Tool Surface
Create Rosette geometry

Estimated Time 10 min
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Task 1 - Open a part.

1. Open MODEL_SETUP_A.prt. The model displays as shown in
Figure 2–19.

Figure 2–19

Task 2 - Create Net Boundary geometry.

1. Select Intersection Curves from the Curves tab as shown in
Figure 2–20.

Figure 2–20

2. For the Set 1 face, select Loft_Surface.
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3. For the Set 2 face, select all six planes displayed in the model by
making a selection box around the part as shown in Figure 2–21.

Figure 2–21

4. Click .

If you do not see Extract
Geometry under More,
make sure that you are
using Advanced Role on
the Roles tab.

5. Select More > Extract Geometry from the Home tab as shown in
Figure 2–22.

Figure 2–22

rastheim
Inserted Text
These OK buttons are a different color than the last exercise.
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6. Select Composite Curve for Type.

7. Ensure that the Stop at Intersection ( ) option is enabled as
shown in Figure 2–23.

Figure 2–23

8. Select the curves in the location and order shown in Figure 2–7.

Figure 2–24

9. Under Settings, select Hide Original option and General for Joint
Curves. as shown in Figure 2–25.

Figure 2–25

10.Click .
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11. Select Curve from the Selection Filter list as shown in
Figure 2–26.

Figure 2–26

12.Select the composite curve.

13.Right-click on the curve and select Properties.

14.Select the General tab.

15.Enter [Ext_Boundary] for Name and Feature Name.

16.Click .

17.Select the composite curve again.

18.Right-click and select Edit Display.

19.Change the color to Magenta (Color ID: 181) and width to 0.13
mm as shown in Figure 2–27.

The thinnest line width is
used to minimize conflicts
with Fibersim highlighting.

Figure 2–27

20.Click .

rastheim
Inserted Text
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Task 3 - Create Extended Boundary geometry.

1. Select Offset Curve in Face from the Curve tab as shown in
Figure 2–28.

Figure 2–28

2. Select Ext_Boundary for Curve.

3. Select Loft_Surface for Face or Plane.

4. Enter [0.5] (12.7mm) for Section1:Offset1 as shown in

Figure 2–29. Click on  (Reverse Direction), if necessary, to
match the Figure 2–29.

Figure 2–29

If the Offset in Face
command fails, flip the
curve direction of the
composite curve or change
the Tolerance to 0.01.

5. Under Settings, select General for Join Curves field as show in
Figure 2–30.

Figure 2–30

6. Click .

rastheim
Inserted Text
"in" unit not showing
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7. Select the curve of the Offset in Face.

8. Right-click and select Properties.

9. Select the General tab.

10.Enter [Net_Boundary] for Name and Feature Name.

11. Click .

12.Select the curve of the Offset in Face again.

13.Right-click and select Edit Display.

14.Change the color to Cyan (Color ID: 31) and width to 0.13 mm as
shown in Figure 2–31.

Figure 2–31

Alternatively, you can
select Menu > Format >
Layer Settings to open
Layer Settings.

15.Press <Ctrl> + <L> to open the Layer Settings window.

16.Hide MASTER_LINES layer category. (Make sure that Category
Display is enabled.)

17.Click .

Task 4 - Create a Tool Surface.

1. [NX9] Select Trimmed Sheet on the Surface tab as shown in
Figure 2–32.

Figure 2–32

rastheim
Cross-Out
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1. [NX10] Select Trim Sheet on the Surface tab as shown in
Figure 2–33.

Figure 2–33

2. Select Loft_Surface for Target and Ext_Boundary for Boundary
Objects.

Hide all the Datum Planes
from the Part Navigator.

3. Select the appropriate option for Region to keep the geometry
shown as in Figure 2–34.

Figure 2–34

4. Click .

5. Select Reverse Normal from the Surface tab as shown in
Figure 2–35. Fibersim uses the tool surface normal to determine
the direction of the layup (male or female tool). To ensure the
correct normal direction on the tool surface, the recommended
practice is to use the Reverse Normal command.

Figure 2–35
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6. Select Loft_Surface and ensure that the normal direction points
-Z direction as shown in Figure 2–36. (Press <W> to display WCS)

Figure 2–36

7. Since the surface normal is pointing to the desired direction, click

.

Task 5 - Create Rosette geometry.

1. Click  (Point) from the Curve tab.

2. In the Point type drop-down list, select Point on Face.

3. Indicate a placement point somewhere in the middle of the Tool
Surface.

4. Click .

5. Select Point from the Selection Filter list.

6. Select the created point.

7. Right-click and select Properties.

8. Enter [Rosette_Origin] for Name and Feature Name.

9. Click  (Line) from the Curve tab.
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10.Select the following:

• Start Option: Point > select Rosette_Origin
• End Option: Along XC
• Start Limit: At Point
• Distance: 0 in (0 mm)
• End Limit: Value
• Distance: 3 in (76.2 mm)

The Line Definition dialog box updates as shown in Figure 2–37.

Figure 2–37

11. Click .

12.Select Curve from the Selection Filter list.

13.Select the created line.

14.Right-click and select Properties.

15.Enter [Zero_Direction] for Name and Feature Name.

16.Click .
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Exercise 2c [NX8.5] Create a Model from a
Solid

In this exercise, you will prepare a solid NX model for composite
design with Fibersim using NX8 or NX 8.5. The completed model
displays as shown in Figure 2–38.

Figure 2–38

Goal After you complete this exercise, you will be able to:

Extract a Tool Surface from a Solid
Create Net Boundary geometry
Extend a Tool Surface to account for manufacturing
trim
Create Extended Boundary geometry
Extract a Ply Edge from a Solid
Create Rosette geometry

Estimated Time 15 min
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Task 1 - Open a part.

1. Open MODEL_SETUP_B.prt. The model displays as shown in
Figure 2–39.

Figure 2–39

Task 2 - Extract Tool Surface from Solid.

1. Click  (Extract Geometry).

2. Select Face for Extract Geometry Type and Single Face under
Face Option as shown in Figure 2–40.

Figure 2–40
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3. Select the rear surface of the solid as shown in Figure 2–41.

Figure 2–41

4. Click .

5. Select the extracted surface.

6. Right-click and select Properties.

7. Click on the General tab.

8. Enter [Tool_Surface] as shown in Figure 2–42.

Figure 2–42

9. Click .
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Task 3 - Create Net Boundary geometry.

1. Click  (Extract Geometry).

2. Select Composite Curve for Extract Geometry Type.

3. Select the 6 edges of the surface and set Joint Curves to General
as shown in Figure 2–43.

Figure 2–43

4. Click .

5. Select Curves for Selection Filter.

6. Select the composite curve.

7. Right-click and select Properties.

8. Enter [Net_Boundary] for Name and Feature Name.

9. Click .

10.Select Net_Boundary.

11. Right-click and select Edit Display.

12.Change the Color to Cyan (Color ID: 31) and Width to 0.13 mm.

13.Click .

rastheim
Cross-Out

rastheim
Inserted Text
Use the "Connected Curves" selection setting - this will only require selecting one edge.
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Task 4 - Create an Extended Tool Surface.

In this task, you will extend the net tool surface to provide a 0.6 in
(15mm) material excess for the manufacturing trim.

1. Select Insert > Trim > Trim and Extend.

2. Select the 6 edges of Tool_Surface and enter [0.6 in] (15 mm) for
Distance as shown in Figure 2–44.

Figure 2–44

3. Click .

4. Select Edit > Surface > Reverse Normal.

Fibersim uses the tool surface normal to determine the direction of the
layup (male or female tool). To ensure the correct normal direction on
the tool surface, the recommended practice is to use the Reverse
Normal command.

5. Select Tool_Surface and note the arrow in the middle of the
surface indicating the normal direction of the surface as shown in
Figure 2–45. (Press <W> to display WCS.)

Figure 2–45

rastheim
Cross-Out

rastheim
Inserted Text
By Distance is no longer an option in the NX 11 dialog. Only Until Selected and Make Corner.
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6. In this case the normal direction should point -Z direction. Click
 to reverse the direction of normal.

7. Click  to exit Reverse Normal command.

Task 5 - Create an Extended Tool Boundary.

1. Following the steps described in Task 3, extract the boundary
edges of the Tool_Surface. Rename the new boundary as
[Extended_Boundary], and change the color and line width to
Magenta and Thin Width.

2. The model should display as shown in Figure 2–46.

Figure 2–46

Task 6 - Extract a Ply Edge from a Solid.

The Extended Boundary curve created in Task 5 provides the
dimensions for the full plies. In this task, you will create a curve that
will provide dimensions for the shorter plies in the thicker area of the
part.
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1. Show Body (right-click in the Part Navigator and select Show).

2. Click  (Project Curve) and select the edges of the solid as
shown in orange in Figure 2–47.

Figure 2–47

3. Select Tool_Surface for Objects to Project To.

4. Click .

5. Hide Body from the Part Navigator.

Task 7 - Create Rosette geometry.

1. Click  (Point).

2. In the Point type drop-down list, select Point on Face.

3. Indicate a placement point somewhere in the middle of the Tool
Surface.

4. Click .

5. Select Point in the Selection Filter list.

6. Right-click and select Properties.

7. Enter [Rosette_Origin] for Name and Feature Name.

8. Click  (Line).

rastheim
Cross-Out

rastheim
Inserted Text
Only 1 edge
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9. Select the following:

• Start Option: Point > select Rosette_Origin
• End Option: Along XC
• Start Limit: At Point
• Distance: 0 in (0 mm)
• End Limit: Value
• Distance: 3 in (76.2 mm)

The Line Definition dialog box updates as shown in Figure 2–48.

Figure 2–48

10.Click .

11. Select Curve in the Selection Filter list.

12.Right-click and select Properties.

13.Enter [Zero_Direction] for Name and Feature Name.

14.Click .
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Exercise 2d [NX9/10] Create a Model from a
Solid

In this exercise, you will prepare a solid NX model for composite
design with Fibersim using NX9. The completed model displays as
shown in Figure 2–49.

Figure 2–49

Goal After you complete this exercise, you will be able to:

Extract a Tool Surface from a Solid
Create Net Boundary geometry
Extend a Tool Surface to account for manufacturing
trim
Create Extended Boundary geometry
Extract a Ply Edge from a Solid
Create Rosette geometry

Estimated Time 15 min
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Task 1 - Open a part.

1. Open MODEL_SETUP_B.prt. The model displays as shown in
Figure 2–50.

Figure 2–50

Task 2 - Extract Tool Surface from Solid.

1. Select More from Feature > Extract Geometry from the Home
tab as shown in .

Figure 2–51
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2. Select Face for Type.

3. Select the rear surface of the body as shown in Figure 2–52.

Figure 2–52

4. Click .

5. Select the extracted face.

6. Right-click and select Properties.

7. Select the General tab.

8. Enter [Tool_Surface] as shown in Figure 2–53.

Figure 2–53

9. Click .

rastheim
Inserted Text
Different OK dialog again in this exercise.
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Task 3 - Create Net Boundary geometry.

1. Select Extract Geometry from the Home tab again and select
Composite Curve for Type.

2. Select the 6 edges of the surface and set Joint Curves to General
as shown in Figure 2–54.

Figure 2–54

3. Click .

4. Select Curve from the Selection Filter list.

5. Select the composite curve.

6. Right-click and select Properties.

7. Enter [Net_Boundary] for Name and Feature Name.

8. Click .

9. Select Net_Boundary.

10.Right-click and select Edit Display.

11. Change the color to Cyan and Width to 0.13mm.

12.Click .
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Task 4 - Create an Extended Tool Surface.

In this task, you will extend the net tool surface to provide a 0.6 in
(15mm) material excess for the manufacturing trim.

1. [NX9] Select More from Feature > Trim and Extend from the
Home tab as shown in Figure 2–55.

Figure 2–55

2. [NX9] Select the 6 edges of Tool_Surface and enter [0.6 in] (15
mm) for Distance as shown in Figure 2–56.

Figure 2–56

3. [NX9] Click .

1. [NX10] Select Extend Sheet from the Surface tab as shown in
Figure 2–57.

Figure 2–57

rastheim
Cross-Out

rastheim
Inserted Text
No distance option in NX 11
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2. [NX10] Select the 6 edges of Tool_Surface and enter [0.6 in] (15
mm) for Offset as shown in Figure 2–56.

Figure 2–58

3. [NX10] Click .

4. Select Edit Surface > More > Reverse Normal from the Surface
tab.

Fibersim uses the tool surface normal to determine the direction of the
layup (male or female tool). To ensure the correct normal direction on
the tool surface, the recommended practice is to use the Reverse
Normal command.

5. Select Tool_Surface and note the arrow in the middle of the
surface indicating the normal direction of the surface as shown in
Figure 2–59. (Press <W> to display WCS.)

Figure 2–59

6. In this case the normal direction should point -Z direction. Click

 to reverse the direction of normal.

7. Click  to exit Reverse Normal command.
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Task 5 - Create an Extended Tool Boundary.

1. Following the steps described in Task 3, extract the boundary
edges of the Tool_Surface. Rename the new boundary as
[Extended_Boundary], and change the color and line width to
Magenta (Color ID: 181) and 0.13 mm.

2. The model should display as shown in Figure 2–60.

Figure 2–60

Task 6 - Extract a Ply Edge from a Solid.

The Extended Boundary curve created in Task 5 provides the
dimensions for the full plies. In this task, you will create a curve that
will provide dimensions for the shorter plies in the thicker area of the
part.

1. Right-click on Body from the Part Navigator and select Show.
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2. Click  (Project Curve) from the Curve tab and select the
edges of the solid as shown in orange in Figure 2–61.

Figure 2–61

3. Select Tool_Surface for Objects to Project To.

4. Click .

5. Hide Body from the Part Navigator.

Task 7 - Create Rosette geometry.

1. Click  (Point) from the Curve tab.

2. In the Point type drop-down list, select Point on Face.

3. Indicate a placement point somewhere in the middle of the Tool
Surface.

4. Click .

5. Select Point from the Selection Filter list.

6. Select the created point.

7. Right-click and select Properties.

8. Enter [Rosette_Origin] for Name and Feature Name.

9. Click  (Line) from the Curve tab.

Select this curve.
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10.Select the following:

• Start Option: Point > select Rosette_Origin
• End Option: Along XC
• Start Limit: At Point
• Distance: 0 in (0 mm)
• End Limit: Value
• Distance: 3 in (76.2 mm)

The Line Definition dialog box updates as shown in Figure 2–62.

Figure 2–62

11. Click .

12.Select Curve from the Selection Filter list.

13.Select the created curve.

14.Right-click and select Properties.

15.Enter [Zero_Direction] for Name and Feature Name.

16.Click .
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Exercise 2e NX Model Setup from Planes
and Surface (Optional)

In this exercise, with minimal instruction, you will prepare a NX model
for composite design with Fibersim. The completed model should
display as shown in Figure 2–63.

Figure 2–63

Goal After you complete this exercise, you will be able to:

Create Net Boundary geometry
Create Extended Boundary geometry
Create a Tool Surface
Create Rosette geometry

Estimated Time 15 min
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Task 1 - Open a part.

1. Open MODEL_SETUP_C.prt. The model displays as shown in
Figure 2–64.

Figure 2–64

Task 2 - Create a Net Boundary.

1. Create a Net Boundary by intersecting the Master_Surface with
the planes LEFT, RIGHT, TOP, and BOTTOM and then trimming
the resulting curves to create a closed loop.

2. Modify the graphic properties of the Net Boundary. The resulting
model should display as shown in Figure 2–65.

Figure 2–65
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Task 3 - Create an Extended Boundary.

1. Create an Extended Boundary by offsetting the Net Boundary by
0.788 in (20 mm) on the Master Surface.

2. Modify the graphic properties of the Extended Boundary so that
the resulting model displays as shown in Figure 2–66.

Figure 2–66

Task 4 - Create a Tool Surface.

1. Create a Tool Surface by trimming the Master Surface with the
Extended Boundary.

Task 5 - Create the Rosette geometry.

2. Create a point in the middle of the Master_Surface and rename it
[Rosette_Origin].

3. Create a 3.937in (100mm) line that starts at the Rosette Origin and
is aligned with the part’s Y-direction. Rename the line as [Zero
Direction].
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4. The model is now ready for composite design with Fibersim and
should display as shown in Figure 2–67.

Figure 2–67
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Chapter 3

Introduction to Ply-Based Design

This chapter includes:

Exercise 3a: Basic Part with 8 Full-body Plies
Exercise 3b: Reinforcement Plies, Sequencing, and Cutouts
Exercise 3c: Flat Pattern
Exercise 3d: Design to Extended
Exercise 3e: Wrapped Ply
Exercise 3f: Create Basic Part
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Exercise 3a Basic Part with 8 Full-body Plies

User Guide Reference:
2.6 Laminates
2.7 Rosettes
2.8 Plies
B.3.2 Mirror Laminate

In this exercise, you will cover a part with eight full-body plies. The
completed model displays as shown in Figure 3–1.

Figure 3–1

Goal After you complete this exercise, you will be able to:

Create a Laminate
Create a Rosette
Create a single full-body ply
Create three full-body plies simultaneously
Mirror four plies about the laminate neutral axis

Estimated Time 10 min
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Task 1 - Create a Laminate.

1. Open INTRO_PLY_A.prt. The model displays as shown in
Figure 3–2.

Figure 3–2

Alternatively, you can go to
Start (or File) > All
Applications > Fibersim
or click on the Fibersim
icon to start Fibersim.

2. Press <F9> to start Fibersim.

3. In the Application Tree, select Laminate under Basics. as shown
in Figure 3–3.

Figure 3–3

Alternatively, you can
highlight Laminate,
right-click in the main
Fibersim window, and
select Create New.

4. Click  (Create New).
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5. In the Laminate’s Standard form, enter the following parameters:

• Name: Cowl
• Step: 1

6. Next to Default Material, click  (Link with Database Link Dialog)
to open the link Material via Default Material dialog box.

7. Click checkbox for PPG-PL-3K and click  to link the
material to the laminate.

Task 2 - Link Geometry.

1. Next to the Layup Surface field, click  (Link Geometry) as
shown in Figure 3–4.

Figure 3–4

2. In NX, select the surface as shown in Figure 3–5.

Figure 3–5

3. Click .
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4. Use the same procedure to link the following geometry:

• Net Boundary: Net Boundary (Cyan Boundary)
• Extended Boundary: Extended Boundary (Magenta Boundary)

5. The Laminate Standard form updates as shown in Figure 3–6.

Figure 3–6

If you need to delete a
Laminate, select its name
in the list, right-click, and
select Delete.

6. Click  to complete the laminate creation and return to
the list view. Select the Cowl laminate from the list view to display
the laminate on the NX model as shown in Figure 3–7. The arrow
represents the layup direction, which is inherited from the laminate
surface normal.

Figure 3–7



Fibersim 15 Pro - NX

3–6 CT2245_FS15NX_2 ©2016 Siemens PLM Software

Task 3 - Create a Rosette.

1. In the Application Tree, select Rosette under Basics as shown in
Figure 3–8.

Figure 3–8

2. Click  (Create New).

3. Click  (Link Geometry) next to Origin.

4. Select only the Existing Point filter as shown in Figure 3–9.

Figure 3–9

5. Select Rosette Origin.

6. Click .

7. Select Zero Direction for Direction.
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8. The Rosette form updates as shown in Figure 3–10.

Figure 3–10

9. Click  to complete the rosette creation and return to the
list view.

Task 4 - Create a single full-body ply.

1. In the Application Tree, select Ply under Basics as shown in
Figure 3–11.

Figure 3–11

2. Click  (Create New).

3. For the P001 ply, enter the following parameter:

• Step: 10

4. Click  to complete the ply creation and return to the list
view.
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Task 5 - Create 3 full-body plies simultaneously.

1. In Object Count, enter [3] as shown in Figure 3–12.

Figure 3–12

2. Click  (Create New).

For [20,10], the 20 means
that the first newly created
ply has the number 20 and
the other ply numbers are
generated in increments of
10.

3. In the Step field, enter [20,10] as shown in Figure 3–13.

Figure 3–13

4. Press <Ctrl> + <T> to toggle to Table mode. The new plies, P002,
P003, and P004, display in the table view as shown in
Figure 3–14.

Figure 3–14
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5. In the Specified Orientation field, enter [45], [90], and [-45] as
shown in Figure 3–15.

Figure 3–15

6. Press <Ctrl> + <T> to return to Form mode.

7. Click  to complete the creation of the three new plies
and return to the list view. The four plies P001, P002, P003, and
P004, are listed as shown in Figure 3–16.

Figure 3–16

Task 6 - Mirror four plies about the laminate neutral axis.

1. Select Tools > Operations > Mirror Laminate as shown in
Figure 3–17.

Figure 3–17
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2. The Mirror Laminate dialog box opens as shown in Figure 3–18.

Figure 3–18

3. For the Start Component, click  (Link with Link Dialog) as
shown in Figure 3–19.

Figure 3–19

4. Click checkbox for P001 as shown in Figure 3–20.

Figure 3–20

5. Click .

6. Repeat Steps 3 through 5 to link P004 to End Component. The
Mirror Laminate form updates as shown in Figure 3–21.

Figure 3–21
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7. In the New Step field, enter [50] as shown in Figure 3–22.

Figure 3–22

8. Click .

9. The Fibersim message window opens prompting you that four
components were generated successfully as shown in
Figure 3–23.

Figure 3–23

10.Click .

11. In the Mirror Laminate dialog box, click  to complete the
mirror operation and return to the list view. The updated list of plies
P001 to P008 displays as shown in Figure 3–24.

Figure 3–24

12.Close Fibersim.

13.Save the model.
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Exercise 3b Reinforcement Plies,
Sequencing, and Cutouts

User Guide Reference:
2.8 Plies
B.2.3 Composite
Sequence Manager
2.10 Design Stations
2.11 Cutouts

In this exercise, you will create reinforcement plies and interleave
them using the Composite Sequence Manager. You will also create a
cutout and run an analysis comparing the results. The re-sequenced
list of plies is shown in Figure 3–25.

Figure 3–25

Goal After you complete this exercise, you will be able to:

Create Reinforcement Plies
Use the Composite Sequence Manager to interleave
reinforcement plies
Rename plies to match the lay-up order
Create Design Stations and run a core sample
analysis
Create a Cutout
Run an analysis and verify the results

Estimated Time 15 min
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Task 1 - Open a part.

1. Select File > Open and select INTRO_PLY_B.prt.

If you completed Exercise 3a, you can continue working with
INTRO_PLY_A.prt instead. The model displays as shown in
Figure 3–26.

Figure 3–26

Task 2 - Create Reinforcement Plies.

1. Press <Ctrl> + <L> to open the Layer Settings window in NX.

Enable Category Display
option to see the category
names in the Name
column.

2. In the Layers list, show Reinforcement Plies layer category as
shown in Figure 3–27. The model displays the boundaries for
reinforcement plies as shown in Figure 3–28.

Figure 3–27
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Figure 3–28

3. Click .

4. Press <F9> to start Fibersim.

5. In the Application Tree, select Ply under Basics.

6. For Object Count, enter [6] as shown in Figure 3–29.

Figure 3–29

7. Click  (Create New).

8. In the Geometry area, click  (Link Geometry) for Net > Origin.

9. Make sure that the Existing Point filter is selected as shown in
Figure 3–30.

Figure 3–30
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10.Select LH Reinforcement Origin.

11. Click .

12.For Boundary, click  (Link Geometry).

13.Select LH Reinforcement.

14.Click .

15.Press <Ctrl>+ <T> to switch to Table mode. The new plies display
as shown Figure 3–31.

Figure 3–31

16.In the Specified Orientation field, enter [45], [0], [45], [45], [0], and
[45] as shown in Figure 3–32.

Figure 3–32
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17.Click  to display the new plies as shown in Figure 3–33.

Figure 3–33

Task 3 - Use the Composite Sequence Manager to interleave the
reinforcement plies.

1. In the ply toolbar, click  (Composite Sequence Manager).

2. Drag and drop the plies to rearrange them in the following order: 1,
9, 2, 10, 3, 11, 4, 5, 12, 6, 13, 7, 14, and 8. The updated list is
shown in Figure 3–34.

Figure 3–34

3. Click .
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Task 4 - Create RH plies using Create Based On.

1. Select the Name column to sort the plies by name and ensure that
P001 is at the top as shown in Figure 3–35.

Figure 3–35

Alternatively, you can
select P009, press and
hold <Shift> and then
select P014 to highlight the
range of plies.

2. Click P009 in the list and drag down to P014 to highlight the plies
from P009 to P014.

3. With the six plies highlighted, right-click and select Create Based
On as shown in Figure 3–36.

Figure 3–36
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4. New plies P015 to P020 are created and displayed as shown in
Figure 3–37.

• Make sure the new plies are shown in Form mode as in
Figure 3–37. You can press <Ctrl> + <T> to switch from Table
mode to Form mode.

Figure 3–37

5. On the Standard tab, in the Geometry area, click  (Link
Geometry) for Net > Origin.

6. Turn on the Point on Surface option as shown in Figure 3–38.

Figure 3–38

7. Rotate the model and indicate a location on the surface in
approximately the location shown in Figure 3–39.

Figure 3–39

Indicate a point.
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8. Click .

9. Click  (Link Geometry) for Boundary.

10.Deselect LH Reinforcement by <Shift> + selecting.

11. Select RH Reinforcement.

12.Click .

13.Click  to display the modified plies in the list view as
shown in Figure 3–40.

Figure 3–40
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14. In the Sort drop-down list, select Sequence, Step and Name. The
list of plies updates as shown in Figure 3–41.

Figure 3–41

Task 5 - Rename the plies to match the layup order.

1. Click in the list of plies, press <Ctrl> + <A> to select all of the plies,
right-click, and select Modify.

2. In the Name field, enter [P001,1] and press <Enter>.

3. Click .
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Task 6 - Re-sequence the plies to increments of 1 using the
Composite Sequence Manager.

1. Click  (Composite Sequence Manager).

2. Click  (Sequence Options) as shown in
Figure 3–42.

Figure 3–42

3. Modify the following parameters:

• Initial Step: 1
• Step Increment: 1

4. Select the Cowl laminate from the list and click  (Resequence).
The Step column updates with increments of 1 as shown in
Figure 3–43.

Figure 3–43

5. Click .
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Task 7 - Create a Cutout.

1. In NX, press <Ctrl> + <L> to open the Layer Settings window.

2. Turn on the Cutout Layer Category to show Cutout geometry. The
model displays the cutout geometry as shown in Figure 3–44.

Figure 3–44

3. Click .

4. Press <F9> to start Fibersim.

5. In the Application Tree, select Cutout under Basic as shown in
Figure 3–45.

Figure 3–45

6. Click  (Create New).

7. For the Origin, click  (Link Geometry).

8. Make sure that the Existing Point selected and select Cutout
Origin.
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9. Click .

10.For the Boundary, click  (Link Geometry).

11. Select Cutout Boundary.

12.Click  twice to save COUT001.

Task 8 - Verify the results.

1. In the Application Tree, select Ply under Basics.

2. Highlight all of the plies in the list and click  (Net Producibility)
from the object toolbar area.

3. In the message window indicating that the material width has been
exceeded, click .

4. In the Application Tree, select Laminate under Basics.
Double-click on Cowl laminate to display its form.

5. Select the Analysis tab.

6. Click . The results display. Compare the Net results
and the with Cutout results as shown in Figure 3–46.

Figure 3–46

7. Click .
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Task 9 - Create Design Stations and discuss the various types of
core sample analysis.

User Guide Reference:
2.10 Design Stations

1. In the Application Tree, select Design Station under Basic as
shown in Figure 3–47.

Figure 3–47

2. Click  (Create New).

3. In the Design Station Standard form, in the Core Sample Type
drop-down list, select All.

4. In the Design Station toolbar, click  (Core Sample).

5. A Fibersim message window opens prompting you that the core
sample has completed successfully as shown in Figure 3–48.

Figure 3–48

6. Click .
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7. Core Sample Analysis report is displayed as shown in
Figure 3–49.

Figure 3–49

8. Scroll down to display the Detailed Design Station Information as
shown in Figure 3–50.

Figure 3–50
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9. Scroll down further to display the Laminate Rating Analysis as
shown in Figure 3–51.

Figure 3–51

10.Click  to close the report and return to the list view.

11. Close Fibersim.

12.Save the model.
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Exercise 3c Flat Pattern

User Guide Reference:
2.5 Flat
Pattern/Producibility
Simulations

In this exercise, you will create a flat pattern. The completed model is
shown in Figure 3–52.

Figure 3–52

Goal After you complete this exercise, you will be able to:

Run Producibility
Generate a Flat Pattern
Create the Flat Pattern Placement geometry in NX
Set the Flat Pattern Placement Plane and Orientation
Regenerate the Flat Pattern

Estimated Time 15 min
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Task 1 - Open a part.

1. Select File > Open and select INTRO_PLY_C.prt.

If you completed Exercises 3a and 3b, you can continue working
with INTRO_PLY_A.prt or INTRO_PLY_B.prt instead. The model
displays as shown in Figure 3–53.

Figure 3–53

2. Launch Fibersim by pressing <F9>, if required.

3. In the Application Tree, select Ply under Basics.

4. Double-click on P002 to display its details in the Standard form.

Task 2 - Generate Flat Pattern.

1. Click  (Net Producibility).

2. Click  (Generates the Net Flat Pattern).

3. Click  to save P002.
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4. The Flat Pattern geometry is created on the default XY plane, as
shown in Figure 3–54. Note that it is flipped in the opposite
direction of the ply boundary direction.

Figure 3–54

Task 3 - Create Flat Pattern Placement geometry in NX.

The default location for flat patterns can easily be changed. Fibersim
will subsequently position all flat patterns directly onto a
user-specified plane with a user-specified orientation. In this task, you
will create the geometry in NX for defining a user-specified plane and
orientation to be in the same direction as the ply boundary.

1. Close Fibersim.

2. In NX, click  (Display WCS) to turn on WCS.

Alternatively, you can
select WCS > Dynamics
from the Format pull-down
menu.

3. Double click on WCS.

4. Move the WCS to an approximate location shown in Figure 3–55
and rotate X axis by 180° around the Z axis.

Figure 3–55
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5. Click  (Datum Plane).

6. In the Type drop-down list, select XC-YC plane.

7. Click .

8. In the part navigator, rename the plane as [Net FP Placement
Plane].

9. Click  (Datum Axis).

10. In the Type drop-down list, select XC-Axis.

11. Click .

12. In the part navigator, rename the datum axis as [Net FP
Orientation].

Task 4 - Set the Flat Pattern Placement Plane and Orientation.

1. Press <F9> to start Fibersim.

2. In Fibersim, select Tools > Options > Fibersim Options. The
Fibersim dialog box opens. Select the Flat Patterns tab if it is not
already selected, as shown in Figure 3–56.

Figure 3–56

3. Double click on Fiber Direction to modify the Flat Patterns
options.
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4. In the Net Placement area, next to the Plane field, click

 (Link Geometry).

5. Select Net FP Placement Plane and Click .

6. In the Net Placement area, next to the Orientation field, click

 (Link Geometry).

7. Select Net FP Orientation and click .

8. In the Fibersim Options dialog box, click  twice to save
the change.

Task 5 - Regenerate Flat Pattern.

1. Highlight P002 from the Ply List.

2. Click  (Generates the Net Flat Pattern) on the toolbar.

3. The Flat Pattern updates. as shown in Figure 3–57. Note that it is
now flipped in the correct direction, aligned with the ply boundary
direction.

Figure 3–57

4. Close Fibersim and save the model.
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Exercise 3d Design to Extended

User Guide References:
2.6.2 Laminates Form

In this exercise, you will explore the Design to Extended (Design to
Manufacturing) method. You will create a ply object for the pad-up
areas indicated in Figure 3–58 using the Design to Net (Design to
Engineering) method first. After reviewing the result, you will do the
same using the Design to Extended method and compare the results.

Figure 3–58

After you complete this exercise, you will be able to:

Understand when to use the Design to
Manufacturing method vs. the Design to Engineering
method
Create a Laminate for the Design to Manufacturing
method

Estimated Time 15 min

Desired
Pad-up
Regions
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Task 1 - Open a part.

1. Open INTRO_PLY_D.prt. The model displays as shown in
Figure 3–59.

Figure 3–59

2. Press <F9> to start Fibersim.

Task 2 - Create a Design to Net Laminate and a New Rosette.

1. In the Application Tree, select Laminate under Basics.

2. Create a new laminate with the following parameters as shown in
Figure 3–60:

• Name: Engineering Lam
• Step: 1
• Default Material: PPG-PL-3K
• Layup Surface: TOOL SURFACE
• Net Boundary: NET BOUNDARY (cyan curve)
• Extended Boundary: EXTENDED BOUNDARY (magenta

curve)
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Figure 3–60

3. Click .

4. In the Application Tree, select Rosette under Basics.

5. Create a new rosette with the following parameters as shown in
Figure 3–61:

• Origin: ROSETTE ORIGIN
• Direction: ZERO DIRECTION

Figure 3–61

6. Click .

Task 3 - Create a New Ply for the Pad-up Area.

1. In the Application Tree, select Ply under Basics.

2. Click  (Create New).
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3. Enter [10] for Step.

4. Select the indicated point for Origin as shown in Figure 3–62.

Figure 3–62

5. Click .

6. For Boundary, select the indicated curve as shown in Figure 3–63.

Figure 3–63

7. Click .

8. Click  (Extended Producibility) in the ply toolbar area.

9. Review the model and note that the Extended Boundary is not
ideal as shown in Figure 3–64.

Figure 3–64

10.Click .

Select this curve.
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Task 4 - Create a New Laminate.

1. In the Application Tree, select Laminate under Basics.

2. Right-click on Engineering Lam and select Create Based On.

3. Modify the following parameters as shown in Figure 3–65:

• Name: Manufacturing Lam
• Design Boundary: Extended

Figure 3–65

4. Click .

Task 5 - Create a New Ply.

1. In the Application Tree, select Ply under Basics.

2. Click  (Create New).

3. Enter the following parameters:

• Parent: Manufacturing Lam
• Step: 10

4. Link the same point and curve for Origin and Boundary under
Extended as outlined in Task 3.

5. Click  (Extended Producibility) to generate Extended
Producibility.
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6. The model should display as shown in Figure 3–66. Note that the
pad-up areas are covered with one continuous ply by using the
Design to Extended method, which is how the part will be
manufactured.

Figure 3–66

7. Click on the Analysis tab. Review and compare the analysis
results between Net and Extended.

8. Click  to save the ply object.

9. Close Fibersim and save the model.
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Exercise 3e Wrapped Ply

In Fibersim, you can now define a ply that overlaps itself by selecting
the "Wrapped" checkbox and defining a Start and End curve for the
overlapping region. In this exercise, you will define a simple wrapped
ply.The completed model is shown as in Figure 3–67.

Figure 3–67

Goal After you complete this exercise, you will be able to:

Define a ply that overlaps itself
Run Producibility
Generate a Flat Pattern

Estimated Time 10 min
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Task 1 - Open a part.

1. Select File > Open and select WRAPPED_PLY.prt. The model
displays as shown in Figure 3–68.

Figure 3–68

Task 2 - Create a Laminate and Link Geometry to CATIA.

1. Press <F9> to start Fibersim.

2. In the Application Tree, select Laminate.

3. Click  (Create New).

4. Link or enter the following parameters:

• Step: 1
• Material: PPG-PL-3K
• Layup Surface: Laminate (blue surface)
• Net Boundary: Net 1, Net 2 (cyan curves)
• Extended Boundary: Extended 1, Extended 2 (magenta

curves)

5. Click .

Task 3 - Create a Rosette and Link Geometry to CATIA.

1. In the Application Tree, select Rosette.

2. Click  (Create New).
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3. Link or enter the following parameters:

• Origin: Origin (located at the bottom of the surface)
• Direction: Direction (located at the bottom of the surface)

4. Click .

5. ROS001 displays in model as shown in Figure 3–69.

Figure 3–69

Task 4 - Create a new Wrapped Ply.

1. In the Application Tree, select Ply.

2. Click  (Create New).

3. Enter [10] for Step.

4. On the Standard tab, select the checkbox for Wrapped as shown
in Figure 3–70.

Figure 3–70

5. Click  to close the simulation message.
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6. Click  (Link Geometry) next to Start Curve.

7. Select Start.1 as indicated in Figure 3–71.

Figure 3–71

8. Click .

9. Link End.1 for End Curve as indicated in Figure 3–72.

Figure 3–72

Task 5 - Run simulation and generate a flat pattern.

1. Click  (Extended Producibility) and review the result in NX.

2. Click  (Extended Flat Pattern).

3. Click  to save P001.

Select this curve.

Select this curve.
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Task 6 - Create another ply with orientation of 45.

1. Click  (Create New).

2. Click  (Link Geometry) next to Boundary under Geometry >
Net.

3. Select Start.2 (third curve from the top).

4. Click .

5. Fibersim gives you a warning message as shown in Figure 3–73.

Figure 3–73

6. Click  to close the message window.

7. Back in the Fibersim window, note that the Wrapped option is not
available because the ply no long has a valid two-domain
boundary.

8. Click  (Link Geometry) next to Boundary under Geometry >
Net.

9. Click  (Deselect All).

10.Click .

11. Click the checkbox for Wrapped.

12.Click  to close the message about simulation.

13.Link the following geometry to the parameters:

• Start Curve: Start.2 (third curve from the top)
• End Curve: End.2 (the last curve)
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14.Enter the following parameters:

• Specified Orientation: 45
• Step: 20

15.Click  (Extended Producibility) and review the result in CATIA.

16.Click  (Extended Flat Pattern).

17.Click  to save P002.

18.Close Fibersim.

19.Save and close the model.
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Exercise 3f Create Basic Part

User Guide Reference:
2.6 Laminates
2.7 Rosettes
2.8 Plies
2.5 Flat
Pattern/Producibility
Simulations

In this exercise, with minimal instruction, you will cover a given model
with full-body plies. The final flat pattern should display as shown in
Figure 3–74.

Figure 3–74

Goal After you complete this exercise, you will be able to:

Create a Laminate
Create a Rosette
Create four full-body plies
Run Producibility
Generate a Flat Pattern
Set the Flat Pattern Placement Plane and Orientation
Regenerate a Flat Pattern

Estimated Time 10 min
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Task 1 - Open a part.

1. Select File > Open and select INTRO_PLY_E.prt. The model
displays as shown in Figure 3–75.

Figure 3–75

Task 2 - Create a Laminate and Link Geometry to NX.

1. In Fibersim, create a Laminate with the following parameters:

• Name: Skin
• Step: 1
• Material: PPG-PL-3

2. Link the following geometry as shown in Figure 3–76:

Figure 3–76

Extended Boundary

Layup Surface

Net Boundary

(Magenta)

(Cyan)
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3. The Laminate’s Standard form should update as shown in
Figure 3–77.

Figure 3–77

Task 3 - Create a Rosette.

1. Create a Rosette named [ROS001] and link the following
geometry as noted in Figure 3–78:

Figure 3–78

Origin

Direction
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Task 4 - Create four full-body plies.

1. Create four plies with a Step of [10,10] and the following
orientations:

• P001: 0
• P002: 45
• P003: -45
• P004: 90

Task 5 - Run Producibility.

1. Run Net Producibility on P001.

Task 6 - Generate a Flat Pattern.

1. Using P001, generate the Net Flat Pattern. It should display as
shown in Figure 3–79.

Figure 3–79

Task 7 - Set the Flat Pattern Placement Plane and Orientation.

1. Change the default Flat Pattern placement by linking the following
geometry from the NX Part Navigator:

• Plane: Net FP Placement Plane
• Orientation: Net FP Orientation
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Task 8 - Regenerate the Flat Pattern.

1. Generate the Net Flat Pattern again using P001. It should now
display as shown in Figure 3–80.

Figure 3–80
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Chapter 4

Producibility

This chapter includes:

Exercise 4a: How Geometry Affects Producibility
Exercise 4b: How Simulation Options Affect Producibility

(Simulation Skin)
Exercise 4c: How Simulation Options Affect Producibility

(Two-Stage)
Exercise 4d: Resolving Producibility Issues
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Exercise 4a How Geometry Affects
Producibility

User Guide Reference:
2.5 Flat Pattern/
Producibility Simulations
2.12 Darting
B.3.7 Splice Ply

In this exercise, you will see how geometry affects producibility by
changing ply origins and orientations. You will also create splices and
darts to resolve producibility issues.

Goal After you complete this exercise, you will be able to:

Change the ply origin point to observe the impact on
producibility and flat pattern
Change the ply orientation to observe the impact on
producibility and flat pattern
Create a Splice to resolve material roll width issues
Create Slit darts and V-shape darts to resolve
bridging and wrinkling

Estimated Time 15 min without optional steps

30 min with optional steps
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Task 1 - Open a part.

1. Open PRODUCIBILITY_A.prt. The model displays as shown in
Figure 4–1.

Figure 4–1

Task 2 - Create a Flat Pattern of P001.

1. Press <F9> to start Fibersim.

2. In the Application Tree, select Ply under Basic.

3. Select P001 from the list.

4. Click  (Net Producibility) in the ply toolbar and click
in the message box prompting you that the material width has
been exceeded.

5. Click  (Generates the Net Flat Pattern).

6. Click  to save.
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7. The P001 producibility results and flat pattern geometry display as
shown in Figure 4–2.

Figure 4–2

Task 3 - Create P002 from P001 and specify a different origin.

In this task you will create a new ply, P002, based on P001 and
change its origin. You will then note how the results compare with
P001.

1. Right-click on P001 and select Create Based On.

2. In the Step field, enter [20].

3. Next to the Origin field, click  (Link Geometry)

4. Press <Ctrl> + <L> to open the Layer Settings window.

5. Make sure that the option for Category Display is turned on, and
turn on the P002 GEOM category as shown in Figure 4–3.

Figure 4–3
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6. Click .

7. Make sure that the Existing Point filter is on as shown in
Figure 4–4.

Figure 4–4

8. Select P002 Origin as noted in Figure 4–5.

Figure 4–5

9. Click  twice save P002.

10.Click  (Net Producibility) in the ply toolbar and click
in the message box prompting you that the material width has
been exceeded.
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11. Click  (Generates the Net Flat Pattern) to create a Net Flat
Pattern of P002. The results display as shown in Figure 4–6. P001
Producibility is shown for comparison purposes.

Figure 4–6

Task 4 - Create P003 from P002 and specify a different
orientation.

In this task you will create a new ply, P003, based on P002 and
change its origin. You will then note how the results compare with
P002.

1. In the ply list, select P002, right-click and select Create Based On.

2. In the Step field, enter [30].

3. In the Specified Orientation drop-down list, select 45.

4. Click  (Net Producibility) and click  in the message
box prompting you that the material width has been exceeded.

P002 Producibility

P001 Producibility

P001 Flat Pattern

P002 Flat Pattern
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5. Create a Net Flat Pattern of P003. The results display as shown in
Figure 4–7. P002 Producibility is shown for comparison purposes.

Figure 4–7

6. Click  to save P003.

7. A comparison between the flat patterns and producibility of the
0 degree P002 ply and the 45 degree P003 ply is shown in
Figure 4–8.

Figure 4–8

P002 Producibility

P003 Producibility

P003 Flat PatternP002 Flat Pattern

Ply Origins

P002 Flat Pattern 0°
P003 Flat Pattern 45°



Fibersim 15 Pro - NX

4–8 CT2245_FS15NX_2 ©2016 Siemens PLM Software

Task 5 - Create P004 from P002 and specify a width offset.

In this task, you will create P004 based on P002 and address the
exceeded material width issue by specifying a width offset and
splicing P004 into two plies: P004A and P004B.

1. In the ply list, select P002, right-click and select Create Based On.

2. In the Step field, enter [40].

For manufacturing
purposes, it might be more
applicable to run
Extended Producibility to
allow for the actual width of
the bolt of material.

3. Click  (Net Producibility) and click  in the message
box prompting you that the material width has been exceeded.

4. Select the Net Geometry tab and expand Material Width Lines
area as shown in Figure 4–9. Note that the Material Width Offset is
0.

Figure 4–9

5. Click . The material width offset with a value of 0
displays in NX as shown in Figure 4–10.

Figure 4–10
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6. A recommended best practice is to set the material width line to be
as centered as possible on the part for strength purposes. In the
open Fibersim - Material Width Lines dialog box, enter [-18] inches

(-457.2 mm). Click  to display the material width line
to the center as shown in Figure 4–11.

Figure 4–11

7. Click .

8. Click  to save P004.

Task 6 - Create a Splice Ply of P004A and P004B.

1. Back in Fibersim, list of plies are shown in Figure 4–12.

Figure 4–12
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2. Highlight P004 and click  (Splice Ply). The Fibersim - Splice Ply
dialog box opens as shown in Figure 4–13.

Figure 4–13

3. Next to the Splice Curves field, click  (Link Geometry).

4. Select the material width curve as shown in Figure 4–14.

Figure 4–14

5. Click . The Fibersim - Splice Ply dialog box updates with
the selected curve as shown in Figure 4–15.

Figure 4–15

Select this curve
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6. Click  to perform the splice.

7. The Fibersim message box opens, prompting you that two plies
were spliced successfully as shown in Figure 4–16.

Figure 4–16

8. Click  twice.

9. The P004 spliced plies display in the ply list as P004-A and
P004-B as shown in Figure 4–17.

Figure 4–17
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10. In the ply list, highlight P004-A and P004-B. The plies are
highlighted in blue on the NX model. Note that the Splice utility
generates an origin at the centroid of the ply that did not contain
the origin as shown in Figure 4–18.

If the generated origin is
suitable, you can use
them. However, in many
cases you will have to
select a suitable origin that
is based on the size of the
part, which can limit the
access to certain areas.

Figure 4–18

Generated Origin
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Task 7 - Move the origins of P004A and P004B to a new location.

In this task, you will move the generated origins created with P004A
and P004B to more reliable origins, resulting in a better producibility.

1. Highlight P004-A and P004-B, right-click and select Modify as
shown in Figure 4–19.

Figure 4–19

2. Press <Ctrl>+ <T> to switch to Table mode.

3. In the Origin column for P004-A, click  (Link Geometry).

4. Press <Ctrl> + <L> to open the Layer Settings window.

5. Turn on the P004 GEOM Layer Category.

6. Click .

7. Make sure that the Existing Point filter is selected.

8. Select the point indicated in Figure 4–20.

Figure 4–20

9. Click .
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10.Using the same procedure as step 3 through 9 and link P004-B to
the point indicated in Figure 4–21.

Figure 4–21

11. Click  twice to save the plies.

Task 8 - Compare the Flat Pattern of P002 to the Spliced Result of
P004.

1. In the ply list, highlight P004-A and P004-B and click  (Net
Producibility).

2. Click  (Generates the Net Flat Pattern).

3. Click . The Net Flat Patterns of P004-A and P004-B
display as shown in Figure 4–22.

Figure 4–22
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4. A comparison between the flat patterns of the P002 ply and the
spliced P004 ply is shown in Figure 4–23 with the P004A and
P004B flat patterns arranged side-by-side. Note the material
difference as well.

Figure 4–23

Task 9 - Create a new ply and check the producibility.

In this task, you will create P005 based on P002 and check the
producibility.

1. Turn on P005 GEOM category in the Layer Settings window.

2. In the ply list, select P002, right-click and select Create Based On.

3. In the Ply’s Standard form, enter the following parameters:

• Name: P005
• Step: 50
• Specified Orientation: 45

4. Next to the Net > Boundary field, click  (Link Geometry)

5. Hold <Shift> and select P001 Boundary to deselect.

Material Difference

Ply Origins

P002 Flat Pattern 0°

P004-4BFlat Pattern 0°



Fibersim 15 Pro - NX

4–16 CT2245_FS15NX_2 ©2016 Siemens PLM Software

6. Select the boundary indicated in Figure 4–24.

Figure 4–24

7. Click .

8. Click  (Net Producibility) and click  in the message
box prompting you that the material width has been exceeded.

9. Click  to save P005.

10.Switch to the NX window to display the producibility results as
shown in Figure 4–25.

Figure 4–25

Select this curve
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To identify material excess and shortage and to characterize
deformation regions, observe the red fiber cell behavior in relation to
the ply origin. The red fiber cell behavior for Bridging (material
shortage) and Wrinkling (material excess) is shown in Figure 4–26.

Figure 4–26

Task 10 - Create a Slit Dart.

In this task you will attempt to address the producibility issue by
creating a Slit dart and applying it to P005.

1. Double-click P005 to modify.

2. In the P005 Standard form, select the Net Geometry tab.

3. Next to the Darts field, click on the arrow portion of the icon
(Link with Link Dialog) and select Slit Dart as shown in
Figure 4–27.

Figure 4–27

BRIDGING

SHORTENING
ALONG A LINE

THROUGH THE
PLY ORIGIN

WRINKLING

LENGTHENING
ALONG A LINE

THROUGH THE
PLY ORIGIN

PLY ORIGIN
UNDEFORMED
FIBER CELL
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4. Fibersim - link Slit Dart via Darts window as shown in Figure 4–28.

Figure 4–28

5. Click  (Create New).

6. Next to the Base Curve Points field, click  (Link Geometry).

7. Turn on the Point on Face option as shown in Figure 4–29.

Figure 4–29

8. Indicate twice on the surface at approximately the two points
shown in Figure 4–30.

Always indicate dart points
in order from the interior of
the ply to the boundary.

Figure 4–30

9. Click .

Second indication point

First indication point
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10.Click . The Slit Dart form updates as
shown in Figure 4–31.

Figure 4–31

11. Click  to save SlitDart001.

12.Click  to return to the P005 form.

13.The P005 Net Geometry form updates with the dart information as
shown in Figure 4–32.

Figure 4–32
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Task 11 - Run Net Producibility and Generate the Net Flat Pattern.

1. Click  (Net Producibility) and click  for the warning
message.

2. Click  (Generates the Net Flat Pattern) and click  for
the warning message.

3. Click  to save P005.

4. The producibility and flat pattern results should be as shown in
Figure 4–33. P005 displays a bridging situation, indicating that
there is a material shortage. Note the overlapping flat pattern.

Figure 4–33

Task 12 - Create a V-Shape Dart to resolve bridging.

In this task you will address the bridging producibility issue by
removing the Slit Dart from P005 and creating a V-Shape Dart
instead.

1. Double-click P005 to modify.

2. In the ply P005 Net Geometry tab, next to the Darts field, click

 (Link with Link Dialog). The Fibersim - link Darts via Darts
dialog box opens.

The simulation does not
complete even though there
are no red fibers, this is still
a non-producible result.

The flat pattern overlaps
itself, indicating that a
V-Shape Dart is needed,
not a Slit Dart.
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3. Select the SlitDart001 option to clear the current selection as
shown in Figure 4–34.

Figure 4–34

4. Click on Slit Dart and select V-Shape Dart as shown in
Figure 4–35.

Figure 4–35

5. Click  (Create New).

6. The V-Shape Dart’s form displays as shown in Figure 4–36.

Figure 4–36
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7. Next to the Base Curve Points field, click  (Link Geometry).

8. Indicate twice on the surface at approximately the two points
shown in Figure 4–37.

Figure 4–37

9. Click .

10.Next to the Second Curve Points field, click  (Link Geometry).

11. Indicate once on the surface at approximately the point shown in
Figure 4–38.

Figure 4–38

12.Click .

Second indication point
First indication point

Indicate a point here.
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13.Click . The V-Shape Dart form updates as
shown in Figure 4–39.

Figure 4–39

14.Click  to save VShapeDart001.

15.Click  to return to the P005 form.

Task 13 - Run Net Producibility and Generates the Net Flat
Pattern.

1. Click  (Net Producibility) and click  for the warning
message.

2. Click  (Generates the Net Flat Pattern).

3. Click  to save P005.
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4. Switch to the NX window to display the producibility and flat
pattern results as shown in Figure 4–40.

Figure 4–40
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Task 14 - (Optional) Create a Patch Ply.

In this task you create a Constant Curve Offset to create a Patch ply
to cover the gap.

1. In Fibersim, select Tools > Curve Creation > Curve Offset.

2. Click  (Create New) and link the following geometry:

• Curves to Offset: the curves generated from the V-Shaped Dart
• Surface: Tool Surface (OML)
• Direction Point: Indicate a point outside the Dart curve as shown

in Figure 4–41
• Boundary Curves: Net Boundary

Figure 4–41

3. Enter the following parameters:

• Number of Curves: 1
• Offset Value: 1 in (25.4 mm)
• Corner Type: Straight

4. Click .

5. Click  twice.

6. Click .

7. Create a ply using the following parameters:

• Name: P006
• Step: 60
• Specified Orientation: 0
• Net > Boundary: Curves generated from previous steps
• Origin: indicate a point within gap as shown in Figure 4–42
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Figure 4–42

8. Run Net Producibility and create a Net Flat Pattern to display the
results as shown in Figure 4–43. Now a full-coverage ply exists
with a 1 inch (25.4 mm) overlap.

Figure 4–43

9. Click  to save P006.

Task 15 - (Optional) Create a P007 Ply, Splice Ply and a Slit Dart.

In this task, you will create a new ply with a specified orientation of 45.
Then, splice and create a slit dart to resolve producibility issues.

1. Show P007 GEOM layer category in the Layer Settings window.

2. In the ply list, select P003, right-click and select Create Based On.

3. In the Ply’s Standard form, enter the following parameters:

• Name: P007
• Step: 70

4. Click  to save P007.

5. Highlight P007 and click  (Splice Ply).
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6. Link the following geometry:

• Splice Line Curve: Splice Line 1 P007, Splice Line 2 P007

7. Click .

8. Click  twice.

9. Modify the origins of the spliced plies to use the following origins:

• P007-A: P007A Origin
• P007-B: P007B Origin
• P007-C: P007C Origin

10.Run Net Producibility on the spliced plies, P007-A, P007-B, and
P007-C. The results display as shown in Figure 4–44.

Figure 4–44

11. Modify P007-C.

Make sure that the Point
on Face filter is turned on.

12.Create a slit dart with two points as shown in Figure 4–45.

Figure 4–45

First indication point

Second indication point
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13.Run Net Producibility on P007-C to display the results as shown in
Figure 4–46.

Figure 4–46

14.Close Fibersim and save the model.
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Exercise 4b How Simulation Options Affect
Producibility (Simulation Skin)

User Guide Reference:
2.8 Plies
2.5 Flat Pattern/
Producibility
2.5.2 Using Simulation
Surfaces

In this exercise, you will see how simulation options, such as holes
and simulation skin, affect producibility. The Net Flat Patterns you will
create with each simulation option are displayed in Figure 4–47.

Figure 4–47

Goal After you complete this exercise, you will be able to:

Create a ply using a Fiber Spacing Factor
Add holes to the ply and observe the impact on the
Flat Pattern
Set a Simulation Skin and observe the impact on the
Flat Pattern

Estimated Time 10 min

Before holes With holes Simulation Skin
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Task 1 - Open a part.

1. Open PRODUCIBILITY_B.prt. The model displays as shown in
Figure 4–48.

Figure 4–48

Task 2 - Create a Full-body Ply using the Fiber Spacing Factor.

In this task you will review the Laminate and Rosette that have
already been created and then create a full-body ply using a Fiber
Spacing Factor of [0.5].

1. Press <F9> to start Fibersim.

2. In the Application Tree, select Laminate under Basics.

3. Select Sim Skin from the list. In the NX window, Fibersim displays
the associated tool surface and layup direction.

4. In the Application Tree, select Rosette under Basics.

5. Select ROS001 from the list. In the NX window, Fibersim displays
the associated geometry.

6. In the Application Tree, select Ply under Basics

7. Click  (Create New).

8. In the Ply’s Standard form, enter the following parameters to
create a full-body ply:

• Name: P001
• Step: 10
• Specified Orientation: 0
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For small features, it is
necessary to reduce the
Fiber Spacing Factor to
conform the simulated
fibers to the surface.

9. Select the Simulation Options tab.

10.For the Fiber Spacing Factor, enter [0.5].

11. Click  (Net Producibility) and click  in the message
box prompting you that the material width has been exceeded.

12.Click  (Generates the Net Flat Pattern) to create a Net Flat
Pattern of P001.

13.Click  to save the ply P001.

14.Switch to the NX window and review the producibility and flat
pattern results as shown in Figure 4–49.

Figure 4–49



Fibersim 15 Pro - NX

4–32 CT2245_FS15NX_2 ©2016 Siemens PLM Software

Task 3 - Add holes to ply P001.

In this task, since the ply material will not be required to cover the
enclosed blue boundaries as shown in Figure 4–50, you will modify
ply P001 and add three holes.

Figure 4–50

Press <Ctrl> + <L> to
launch Layer Settings
window.

1. Show HOLES layer category in the Layer Settings window.

2. Press <F9> to start Fibersim.

3. In the Ply list, double-click P001 to modify it.

4. Select the Net Geometry tab.

5. Next to the Holes field, click  (Link Geometry).

6. Select the three curves: Hole 1, Hole 2, and Hole 3 as shown in
Figure 4–51.

Figure 4–51

Ply material will not be required to
cover the enclosed blue boundaries
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7. Click .

8. Click  (Net Producibility) and click  in the message
box prompting you that the material width has been exceeded.

9. Click  (Generates the Net Flat Pattern) to create a Net Flat
Pattern of P001. Note that the outside part of the flat pattern has
not changed.

10.Click  to save P001.

11. Switch to the NX window and review the producibility and flat
pattern results as shown in Figure 4–52.

Figure 4–52
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Task 4 - Set a Simulation Skin.

In this task, since a simulation surface must accurately reflect the
topology of the tool surface to be covered by material, you will modify
ply P001 and set a Simulation Skin that does not include the Boss
features as shown in Figure 4–53.

Figure 4–53

Press <Ctrl> + <L> to
launch Layer Settings
window.

1. Show SIMULATION_SKIN layer category and hide
LAMINATE_SURFACE in Layer Setting. Note that the Sim_Skin
surface does not include the bosses.

2. Press <F9> to start Fibersim.

3. In the Ply list, double-click P001 to modify it.

4. Select the Simulation Options tab.

5. Next to the Simulation Surface field, click  (Link Geometry).

6. Select Sim_Skin and click .

7. Click  to save P001.

8. Show LAMINATE_SURFACE layer category and hide
SIMULATION_SKIN in Layer Setting.

9. Press <F9> to start Fibersim.

10.Select P001 from the list of plies.

11. Click  (Net Producibility) and click  in the message
box prompting you that the material width has been exceeded.

12.Click  (Generates the Net Flat Pattern).

Simulation Skin does not include Boss features.
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13.Switch to the NX window and review the producibility and flat
pattern results as shown in Figure 4–54.

Figure 4–54

14.The producibility simulation now follows the Simulation Surface
and ignores the bosses in the laminate surface as shown in
Figure 4–55. The new flat pattern is much cleaner because it is not
affected by the bosses in the laminate surface.

Figure 4–55
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15.The Producibility and Flat Pattern Comparison of Tasks 2, 3, and 4
is shown in Figure 4–56.

Figure 4–56

Task 5 - (Optional) Create a Splice through a Hole.

Fibersim enables splicing
through holes.

1. In the ply list, double-click P001 to modify it.

2. Generate a Material Width Line using a Material Width Offset of
[24] inches (609.6 mm).

3. Splice P001 into two plies, P001-A and P001-B, using the
following parameters:

• Splice Curves: curve created with Material Width Line
• Overlap: Yes
• Overlap Distance: 1 in (25.4 mm)

Before holes With holes Simulation Skin
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4. Run Net Producibility and create a Net Flat Pattern to display the
results as shown in Figure 4–57.

Figure 4–57

5. Close Fibersim and save the model.
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Exercise 4c How Simulation Options Affect
Producibility (Two-Stage)

User Guide Reference:
2.5 Flat Pattern/
Producibility Simulations
2.8 Plies
2.5.3 Performing
Multi-Stage Simulations
2.12. Darting

In this exercise, you will see the ply development using a two stage
simulation. The completed standard simulation and two-stage
simulation net flat patterns display as shown in Figure 4–58.

Figure 4–58

Goal After you complete this exercise, you will be able to:

Compare the standard simulation to a Biased
Geodesic simulation
Add a First Stage Region
Create V-Shape Darts to alleviate the inside corners
Create Slit Darts to alleviate the outside corners

Estimated Time 20 min

Two-stage simulation (red line)
 Standard simulation (black line)
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Task 1 - Open a part.

1. Open PRODUCIBILITY_C.prt. The model displays as shown in
Figure 4–59.

Figure 4–59

Task 2 - Create a ply and run the standard simulation.

In this task you will review the Laminate and Rosette that have
already been created and create a full-body ply.

1. Press <F9> to start Fibersim.

2. In the Application Tree, select Laminate under Basics.

3. Select Center Support from the list. In the NX window, Fibersim
displays the associated tool surface and layup direction.

4. In the Application Tree, select Rosette under Basics.

5. Select ROS001 from the list. In the NX window, Fibersim displays
the associated geometry.

6. In the Application Tree, select Ply under Basics.

7. Click  (Create New).

8. In the Ply’s Standard form, enter the following parameters to
create a full-body ply:

• Name: P001
• Step: 10
• Specified Orientation: 45

9. Select the Simulation Options tab.

10.For the Fiber Spacing Factor, enter [0.5].
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11. Click  (Net Producibility). Click  to the message that
appears.

12.Switch to the NX window to display the producibility results as
shown in Figure 4–60.

Figure 4–60

Task 3 - Run a Geodesic simulation and compare it to the
standard simulation.

See the User Guide in
section 2.8 Plies for more
information on Propagation
Method and Propagation
Direction.

1. On the Simulation Options tab, set the following parameters:

• Propagation: To Curve
• Constraint curve: Geodesic
• Fiber Angle From Curve: 45

2. Click  (Net Producibility) and close the warning message.

3. Click  to save P001.

4. Switch to the NX window to display the producibility results as
shown in Figure 4–61.

Figure 4–61
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Task 4 - Add a First Stage Region.

In this task you will add a First Stage Region. The First Stage Region
is used to define an area of simultaneous material contact (e.g., if
material is placed on a flat surface). The simulation solves completely
within this region before attempting to conform to the other areas and
solving to the defined ply net boundary. The First Stage Boundary in
this task is shown in Figure 4–62.

Figure 4–62

1. Show FIRST_STAGE_REGION layer category in the Layer
Settings window.

2. Press <F9> to start Fibersim.

3. In the Ply list, double-click P001 to modify it.

4. On the Simulation Options tab, next to the First Stage Region field,
click  (Link Geometry).

5. Select the blue boundary noted as the First Stage Boundary
shown in Figure 4–62.

6. Click .

7. Click  (Net Producibility) and close the warning message.

First Stage Boundary
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8. Switch to the NX window to review the producibility results as
shown in Figure 4–63.

Figure 4–63

Task 5 - Create a V-Shape Dart to alleviate the left inside corner.

1. Back in the modify Plies window, select the Net Geometry tab.

2. Next to the Darts field, click on the arrow portion of the icon
(Link with Link Dialog) and select V-Shape Dart.

3. Click  (Create New).

4. Next to the Base Curve Points field, click  (Link Geometry).

5. Make sure that the Point On Face filter is enabled.

6. Zoom in on the left inside corner and indicate on the surface at
approximately the two points shown in Figure 4–64. These will
form the first leg of the V that will cut out the red fibers.

The first indicated point is
the apex of the V-shape.

Figure 4–64

First indication point

Second indication point
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7. Click .

8. Next to the Second Curve Points field, click  (Link Geometry).

9. Indicate on the surface at approximately the point shown in
Figure 4–65. This will form the second leg of the V.

Figure 4–65

10.Click .

11. Click .

12.Click  to save VShapeDart001.

13.Switch to the NX window to display the completed V-Shape Dart
as shown in Figure 4–66.

Figure 4–66

Indicate a point here.
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Task 6 - Create a V-Shape Dart to alleviate the right inside corner.

1. Use the procedure from Task 5 to create a V-Shape Dart on the
right inside corner. The two Base Curve Points are shown in
Figure 4–67 and the Second Curve Point is shown in Figure 4–68.

Figure 4–67

Figure 4–68

2. Click .

3. Click  to save VShapeDart002.

First indication point

Second indication point

Indicate a point here.
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4. Ensure that both V-Shape darts are linked to the ply as shown in
Figure 4–69.

Figure 4–69

5. Click .

6. Click  (Net Producibility) and close the warning message.

7. Switch to the NX window to display the producibility results with
the V-Shape darts as shown in Figure 4–70.

Figure 4–70

Task 7 - Create Slit Darts to alleviate the outside corners.

1. Back in Fibersim, next to the Darts field, click  (Link with Link
Dialog).

2. In the Darts menu, select Slit Dart as shown in Figure 4–71.

Figure 4–71
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3. Click  (Create New).

4. Select the Curve option as shown in Figure 4–72.

Figure 4–72

5. Next to the Base Curve field, click  (Link Geometry)

6. In NX, show SLIT_DARTS layer category in the Layer Settings
window.

7. Select the spline on the right when looking at the model from the
back (SLIT DART RIGHT) as shown in Figure 4–73.

Figure 4–73

8. Click .

9. Click .

10.Click  to save SlitDart001.
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11. Switch to the NX window to display the Slit Dart as shown in
Figure 4–74.

The slit dart is a U-shaped
curve that will be added to
the ply boundary.

Figure 4–74

12.Repeat Steps 1 to 11 to create a Slit Dart on the left (when looking
at the model from the back). The spline is named as SLIT DART
LEFT.

13.Ensure that both Slit Darts are linked to the ply as shown in
Figure 4–75.

Figure 4–75

14.Click  to close the Fibersim - link Slit Dart via Darts
dialog box.

15.Click  (Net Producibility).

16.Click  (Generates the Net Flat Pattern) to create a Net Flat
Pattern of P001.

17.Click  to save P001.
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18.Switch to the NX window to display the producibility and net flat
pattern results with the darts as shown in Figure 4–76.

Figure 4–76

Task 8 - Compare the flat pattern to one without a two-stage
simulation.

1. In the ply list, select P001, right-click and select Create Based On
to create the ply P002.

2. In the Step field, enter [20].

3. Select the Simulation Options tab.

4. Next to the First Stage Region field, click  (Link Geometry).

5. Press <Shift> and select the First Stage Region spline to clear the
selection and click .

6. Click  (Net Producibility).

7. Click  (Generates the Net Flat Pattern) to create the Net Flat
Pattern of P002.
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8. Switch to the NX window to display the producibility and net flat
pattern results as shown in Figure 4–77.

Figure 4–77

9. Click  to save P002.

10.The two-stage simulation produces a cleaner flat pattern (green)
than the standard simulation (orange) as shown in Figure 4–78.

Figure 4–78

Standard simulation (orange line)
 Two-stage simulation (green line)
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Exercise 4d Resolving Producibility Issues

User Guide Reference:
2.5 Flat Pattern/
Producibility Simulations
2.5.3 Performing
Multi-Stage Simulations
2.12. Darting

In this exercise, with minimal instruction, you will resolve producibility
issues. The producibility and flat pattern results for the acceptable
solution are shown in Figure 4–79.

Figure 4–79

Goal After you complete this exercise, you will be able to:

Set the Fiber Spacing Factor simulation option
Compare the standard simulation to a Biased
Geodesic simulation
Add a First Stage Region
Create V-Shape Darts to alleviate the inside corners
Create Slit Darts to alleviate the outside corners

Estimated Time 10 min
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Task 1 - Open a part.

1. Open PRODUCIBILITY_D.prt. The model displays as shown in
Figure 4–80.

Figure 4–80

Task 2 - Create a full-body ply.

1. In Fibersim, review the existing Laminate and Rosette.

2. Create a full-body ply with the following parameters:

• Name: P001
• Step: 10
• Specified Orientation: 0

Task 3 - Run the standard simulation.

1. Set the following simulation option for P001:

• Fiber Spacing Factor: 0.2

2. Run Net Producibility on P001. The producibility results should
display as shown in Figure 4–81 and are not acceptable.

Figure 4–81
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Task 4 - Run a Geodesic simulation and compare it to the
standard simulation.

1. Set the following simulation options:

• Propagation: To Curve
• Constraint Curve: Geodesic
• Fiber Angle From Curve: 0

2. Run Net Producibility on P001. The producibility results should
display as shown in Figure 4–82. Note that the simulation result
has changed slightly but is still not acceptable.

Figure 4–82
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Task 5 - Add a First Stage Region.

In this task you will add a First Stage Region. The First Stage
Boundary in this task is shown in Figure 4–83.

Figure 4–83

1. Show FIRST_STAGE_REGION layer category in the Layer
Settings window.

2. Modify P001 and set the following simulation options:

• First Stage Region: 1st Stage Region
• Propagation: Standard

3. Run Net Producibility on P001. The producibility results should
display as shown in Figure 4–84. The producibility display has
changed but is still not acceptable.

Figure 4–84

First Stage Boundary



Fibersim 15 Pro - NX

4–54 CT2245_FS15NX_2 ©2016 Siemens PLM Software

Task 6 - Develop a Darting Solution.

1. Modify P001 and apply the six Darts as shown in Figure 4–85.

Note that an infinite
number of darting solutions
are available to solve this
manufacturing challenge.

Figure 4–85

2. The producibility and flat pattern of an acceptable simulation is
shown in Figure 4–86.

Note that the interior
corners of the channel
experienced a bridging
situation and patches
might need to be created
to provide complete
material coverage.

Figure 4–86
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3. Compare the Net Flat Patterns of the standard simulation and the
two-stage simulation as shown in Figure 4–87.

Figure 4–87

Standard simulation (red line)
 Two-stage simulation (black line)
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Project 1

Producibility

This chapter includes:

Exercise P1: Producibility
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Exercise P1 Producibility

In this project, you will use ply based design to complete a layup
scenario and resolve any producibility issues. The completed model
displays as shown in Figure 1–1.

Figure 1–1

Goal This project will test your knowledge on how to:

Create the required NX geometry
Create Plies
Resolve producibility issues with splicing and
darting

Given The previously created geometry and design details are:

Net and Extended Boundaries have been created
Laminate and Rosette have been created

Estimated Time 2 hr
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Task 1 - Open a part.

1. Open PROJECT1_PRODUCIBILITY.prt. The model displays as
shown in Figure 1–2.

Figure 1–2

2. Review the Fibersim objects already created.

Task 2 - Create a full-body ply.

1. Create a new ply with the following parameters:

• Step: 10
• Orientation: 0

2. Generate net producibility and review the results.

The shape of the tool surface is too complicated for a full-body ply.
You will need to either create separate plies with darts or splice the
full-body ply.

Task 3 - Create ply objects.

1. Cover the part with a layer of 0 degree plies.

2. Resolve any producibility issues.

Task 4 - Cover the part with a layer of 45 degree plies. (Optional)

Repeat the same steps to cover the part with a layer of 45 degree
plies.
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Chapter 5

Rosettes

This chapter includes:

Exercise 5a: Translational Rosette
Exercise 5b: Radial Rosette
Exercise 5c: Spine-Based Rosette
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Exercise 5a Translational Rosette

User Guide Reference:
2.7.2 Rosette Mapping
Types
2.5.1 Simulation Display
Types

In this exercise, you will learn how and why you use Translational
Rosette.

Goal After you complete this exercise, you will be able to:

Create a Translational Rosette
Analyze Producibility for Unidirectional Material
Analyze Fiber Deviation

Estimated Time 10 min

Task 1 - Create a Laminate.

1. Open ROSETTES_A.prt. The model displays as shown in
Figure 5–1.

Figure 5–1

2. Press <F9> to start Fibersim.
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3. In the Application Tree, select Laminate under Basic and click

 (Create New).

4. In the Laminate’s Standard form, enter the following parameters:

• Name: Cone
• Step: 1

5. Next to Default Material, click  (Link with Database Link Dialog)
to open the Fibersim - link Material via Default Material dialog box.

T-24-in is a unidirectional
tape with fibers running in
one direction.

6. Select T-24-in as shown in Figure 5–2 and click .

Figure 5–2

Task 2 - Link the geometry.

1. In the Geometry area of the form, link the Laminate to the NX
geometry as shown in Figure 5–3:

• Layup Surface: Tool Surface
• Net Boundary: Net Boundary

Figure 5–3

2. Click  to complete the Laminate and return to the main
window.
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Task 3 - Create a Standard Rosette.

1. In the Application Tree, select Rosette under Basic and click
(Create New).

2. Enter [Standard Rosette] for Name.

3. Link the following geometry:

• Origin: SR Origin
• Direction: SR Zero Direction

4. Ensure that the Mapping Type is set to Standard as shown in
Figure 5–4.

Figure 5–4

5. Click  to complete the rosette and return to the main
view.

6. Click  (Highlight Type) in the main toolbar and select Field as
shown in Figure 5–5.

Figure 5–5
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7. Activate the NX window. The model displays as shown in
Figure 5–6.

Figure 5–6

The axis of the cone in this
exercise is assumed to be
the primary strength
direction for this particular
part. Therefore, it is
required that the material
fibers be aligned in this
direction.

8. Rotate the model and note that the fiber directions in the middle of
the part are aligned along the rosette’s 0-direction, which in turn, is
parallel to the axis of the cone.

Task 4 - Create a full-body ply.

1. In the Application Tree, select Ply under Basic and click
(Create New).

2. For P001, enter the following parameter:

• Step: 10

3. Click  (Net Producibility). Click  to close the message
box.

4. Select the Simulation Options tab.
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Note that Fibersim
automatically changes the
Simulation Type to
Geodesic for
unidirectional materials.

5. Note that Fibersim automatically changed Propagation to To
Curve as shown in Figure 5–7.

Figure 5–7

6. Activate the NX window. The model should display as shown in
Figure 5–8.

Figure 5–8
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Task 5 - Change the ply origin.

1. Activate the Fibersim window.

2. Select the Standard tab.

3. Click  (Link Geometry) next to the Origin field.

4. Make sure that the Existing Point filter is enabled.

5. In the model, select the Ply Origin 2 point as shown in Figure 5–9.

Figure 5–9

6. Click .

7. Click  (Net Producibility) again. The model should now display
as shown in Figure 5–10.

Figure 5–10
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8. Note that the fiber paths (shown with blue lines) are no longer
aligned with the part axis in the middle of the surface, where the
rosette is located.

The observed misalignment is due to the following:
• The ply origin point is assumed to be where the fabric first

touches the tool surface when laid up on the mold. At this
location, for a 0-degree fabric orientation, the warp direction of
the fabric roll is aligned with the 0-direction of the rosette.
Similarly, for a 45-degree fabric orientation, the warp direction
would be aligned with the 45-degree direction of the rosette, etc.

• However, if the ply origin is selected away from the rosette, the
rosette’s directions need to be transposed to another location,
(the ply origin). This is called rosette mapping.

• With the Standard mapping method (the default option in
Fibersim), orientation is mapped from the rosette so that it
conforms to the part curvature. For example, a simple cube is
shown in Figure 5–11. The arrows on the sides, top, and bottom
of the cube indicate the 0-direction mapped to that location.

Figure 5–11

• Since Standard mapping always takes surface normals into
account, the result is always intuitively correct. Therefore,
Standard mapping should be used on the majority of parts.

• Standard mapping might cause a problem if the same starting
0-direction must be maintained no matter where on the surface
you pick the ply origin. For this specific part, that should be the
direction along the cone axis.

• You will learn how to handle this requirement using
Translational rosette mapping method in Task 6 and 7.
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Task 6 - Analyze the Fiber Deviation.

1. Next to the Origin field, click  (Link Geometry).

2. Select SR ORIGIN.

3. Click .

4. Select the Simulation Options tab.

5. In the Result Display drop-down list, select Deviation as shown in
Figure 5–12.

Figure 5–12

6. Click  (Net Producibility). The model should now display as
shown in Figure 5–13.

Figure 5–13
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Warning (3 deg) and Limit
(5 deg) angles can be
adjusted in the Deviation
area in the Rosette form.

7. The Deviation results display the amount of deviation between the
simulated fiber orientations and the rosette’s orientation as
follows:

• White fiber paths indicate the difference under 3 degrees.
• Yellow fiber paths indicate areas where the deviation is

between 3 and 5 degrees.
• Red fiber paths indicate areas where the deviation in direction

exceeds 5 degrees.

8. Note that the deviation angles are computed between the fiber
paths and the mapped rosette directions. Therefore, it is also
important to select the proper type of rosette mapping to correctly
assess the fiber deviations.

9. Click  to save P001.

Task 7 - Create a Translational Rosette.

Translational rosette mapping is a direct point-to-point translation
technique, as shown in Figure 5–14. The 0-direction is directly
translated, while the other fiber orientations are calculated by rotating
the translated 0-direction around the tool surface normal to the point.

Figure 5–14

Commonly, point-to-point translation mapping used in surfaces of
revolution where you want the 0-direction to always be parallel to an
axis.
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However, Translational mapping does not apply to the majority of
parts. For example, the cube shown in Figure 5–15, uses
Translational mapping. Note that point-to-point translation fails on two
of the six faces.

Figure 5–15

Translational Rosette requires the creation of a reference plane that is
only used to determine the Rosette’s directions rather than laying up
actual plies.

1. In the Application Tree, select Rosette under Basic

2. Click  (Create New) and rename the rosette as [Trans
Rosette].

3. Link the following geometry:

• Surface: TR Ref Surface
• Origin: TR Origin
• Direction: TR Zero Direction

4. Set the Mapping Type to Translational as shown in Figure 5–16.

Figure 5–16

5. Click .
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Task 8 - Compare Rosettes.

1. Highlight Standard Rosette from the list of objects.

2. Click  (Compare Rosettes) in the main toolbar as shown in
Figure 5–17.

Figure 5–17

3. Click  (Link with Link Dialog) next to the Comparison Object
field.

4. Link Trans Rosette and click .

5. Activate the NX window. The model displays as shown in
Figure 5–18.

Figure 5–18

6. Click  to close the Rosette Comparison window.

7. Click  (Highlight Type) in the main toolbar.

8. Clear the option for Field.
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Task 9 - Change the ply’s rosette to Translational.

1. In the Application Tree, select Ply under Basic.

2. Double-click P001 to modify.

3. Select the Standard tab.

4. In the Rosette drop-down list, select Trans Rosette as shown on
Figure 5–19.

Figure 5–19

5. The ply form should update as shown in Figure 5–20.

Figure 5–20
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Task 10 - Analyze Fiber Paths

1. Select the Simulation Options tab.

2. In the Result Display drop-down list, select Deformation as shown
in Figure 5–21.

Figure 5–21

3. Click  (Net Producibility). The model should display as shown in
Figure 5–22.

Figure 5–22

4. Note that all of the fiber paths are oriented along the part axis.

5. Select the Standard tab.

6. Click  (Link Geometry) next to the ply Origin field.
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7. Select Ply Origin 2 in the model, as shown in Figure 5–23.

Figure 5–23

8. Click .

9. Click  (Net Producibility). The model should now display as
shown in Figure 5–24.

Figure 5–24

10.Note that the fiber paths are now aligned with the part axis at the
new ply origin.

Rosette mapped to the new ply origin
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Exercise 5b Radial Rosette

User Guide Reference:
2.7.2 Rosette Mapping
Types

Radial Rosette mapping is a specialized form of translation, used for
spherical-shaped parts, such as satellite dishes and dome covers.

In Radial mapping, the point-to-point translation takes place with the
0-direction always set in a radial direction from the center of the part
as shown in Figure 5–25. Therefore, the Radial Rosette origin must
be always placed in the exact center of the part.

Figure 5–25

In this exercise, you will create a laminate consisting of four plies
butt-spliced onto a model of a satellite dish. The completed model is
shown in Figure 5–26.

Figure 5–26
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Goal After you complete this exercise, you will be able to:

Create a Radial Rosette
Create butt-spliced plies on multi-domain surfaces
Analyze Producibility and Fiber Deviation

Estimated Time 5 min

Task 1 - Open a part.

1. Select File > Open and select ROSETTES_B.prt. The model
displays as shown in Figure 5–27.

Figure 5–27

Task 2 - Create a Laminate.

1. Press <F9> to start Fibersim.

2. In the Application Tree, select Laminate under Basic and click

 (Create New).

3. In the Laminate’s Standard form, enter the following parameters:

• Name: Dish
• Step: 1
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4. Next to Default Material, click  (Link with Database Link
Dialog).

5. Select PPG-PL-3K and click .

6. In the Geometry area of the form, link the Laminate to the NX
geometry as shown in Figure 5–28:

• Layup Surface: Tool Surface
• Net Boundary: Net_Boundary_1, Net_Boundary_2 (two cyan

lines)
• Extended Boundary: Extnded_Boundary_1,

Extended_Boundary_2 (two magenta lines)

Figure 5–28

7. Click  to save the Laminate and return to the main
window.

Task 3 - Create a Radial Rosette.

1. In the Application Tree, select Rosette under Basic and click
(Create New).

2. Link the following geometry:

• Origin: Rosette Origin
• Direction: Zero Direction
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3. Set the Mapping Type to Radial. The form should display as
shown in Figure 5–29.

Figure 5–29

4. Click .

Task 4 - Create the first ply.

1. In the Application Tree, select Ply under Basic and click
(Create New).

2. Enter [10] for Step.

3. Link Gore_1_Origin for Net > Origin. The ply form should update
as shown in Figure 5–30.

Figure 5–30
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4. Click  (Net Producibility). The warning message box opens as
shown in Figure 5–31, because the Net Boundary of the ply
consists of two disconnected contours. Click  to close
the message box.

Figure 5–31

5. Click  (Link Geometry) next to the Boundary field and select
the curves Radial 1 and Radial 2, as shown in Figure 5–32, to
re-limit the ply to the first quadrant of the surface.

Figure 5–32

6. Click .

7. Click  (Net Producibility). (Ignore the warning message that
opens prompting you about the material width.)



Rosettes

CT2245_FS15NX_2 ©2016 Siemens PLM Software 5–21

8. The model should display as shown in Figure 5–33.

Figure 5–33

9. Click  to complete the P001 ply and return to the main
view.

Task 5 - Create the remaining three plies.

1. Set the Object Count to [3] as shown in Figure 5–34.

Figure 5–34

2. In the ply list, select P001, right-click and select Create Based On.

3. Press <Ctrl> + <T> to switch the ply form to the table view and
select the Net Geometry tab. The form should display as shown in
Figure 5–35.

Figure 5–35
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4. Note that the Origins and Boundaries (highlighted in Figure 5–35)
of the new plies are incorrect (because they were copied from the
first ply). Therefore, they need to be re-linked to the correct NX
geometry.

5. Link the Origins of the new plies as follows:

• P002: Gore_2_Origin
• P003: Gore_3_Origin
• P004: Gore_4_Origin

6. Link the Boundaries of the new plies as follows:

• P002: Radial_2, Radial_3
• P003: Radial_3, Radial_4
• P004: Radial_4, Radial_1

7. The ply form should update as shown in Figure 5–36.

Figure 5–36

8. Click  to complete the plies and return to the main view.

Task 6 - Analyze the producibility of all of the plies.

1. In the ply list, multi-select P001 through P004 as shown in
Figure 5–37.

Figure 5–37
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2. Click  (Net Producibility). (Ignore the warning message box
that opens prompting you about the material width.)

3. Activate the NX window. The model should display as shown in
Figure 5–38.

Figure 5–38

4. Rotate the model and note that the fiber directions in the middle of
the quadrants are aligned along the radial direction of the surface,
This is done using the Radial Rosette.

5. Close Fibersim and save the model.
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Exercise 5c Spine-Based Rosette

User Guide Reference:
2.7.2 Rosette Mapping
Types

Spine-Based Rosettes are used for spine-based part, such as
stringers and floor beams. 0 direction of a Spine-Based Rosette
follows a direction curve, whereas traditional rosettes yield an
idealized 0 direction over an entire part as shown in Figure 5–39.

Figure 5–39

In this exercise, you will create Flat Patterns to compare the results
from different types of Rosette mapping types and Simulation options.

Goal After you complete this exercise, you will be able to:

Create a Spine-Based Rosette
Analyze Producibility utilizing Spine-Based
Simulation
Create Flat Pattern

Estimated Time 15 min
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Task 1 - Open a part.

1. Select File > Open and select ROSETTES_C.prt. The model
displays as shown in Figure 5–40.

Figure 5–40

Task 2 - Create a Laminate.

1. Press <F9> to start Fibersim.

2. In the Application Tree, select Laminate under Basic and click

 (Create New).

Press <Ctrl> + <T> to
toggle between the form
and table view.

3. In the Laminate’s Standard form, enter the following parameters:

• Name: LAM001
• Step: 1

4. Next to Default Material, click  (Link with Database Link Dialog)

and select PPG-PL-3K and click .
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5. In the Geometry area of the form, link the Laminate to the NX
geometry as shown in Figure 5–41:

• Layup Surface: Tool Surface
• Net Boundary: Net Boundary

Figure 5–41

6. Click  to complete the Laminate and return to the main
window.

Task 3 - Create a Standard Rosette.

1. In the Application Tree, select Rosette under Basic and click
(Create New).

2. Change the rosette name to [Standard Rosette] and link the
following geometry as noted in Figure 5–42:

• Origin: Origin
• Direction: Spine

Figure 5–42

Origin

Spline
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3. Ensure that the Mapping Type is set to Standard as shown in
Figure 5–43.

Figure 5–43

4. Click  to save ROS001.

Task 4 - Create a full-body ply and a flat pattern with Standard
Rosette.

1. In the Application Tree, select Ply under Basic and click
(Create New).

2. Enter [10] for Step.

3. Select the Simulation Options tab.

4. Enter [0.3] for Fiber Spacing Factor.

5. Click  (Net Producibility).

6. Click  (Generate the Net Flat Pattern) and click .

7. Switch to NX and review the flat pattern created. Flat pattern for
P001 is shown in Figure 5–44.

Figure 5–44
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Task 5 - Create a new ply based on the first ply.

In this task, you will create a new full-body ply based on the first ply
you created, but use a different simulation option to see how it affects
the flat pattern.

1. Right-click on P001 and select Create Based On.

2. Change Step to [20].

3. Select the Simulation Options tab.

4. Select To Curve from the list for Propagation.

5. Select the Curve option under Constraint Curve.

6. Link Spine for Constraint Curve as shown in Figure 5–45.

Figure 5–45

7. Click  (Net Producibility).

8. Click  (Generate the Net Flat Pattern) and click .

9. Switch to NX and review the flat pattern created. Flat pattern for
P002 is shown in Figure 5–46.

Figure 5–46
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Task 6 - Create a Spine-Based Rosette.

In this task, you will create a Spine-Based Rosette to be used later
with Spine-Based Simulation.

1. In the Application Tree, select Rosette under Basic and click
(Create New).

2. Change the rosette name to [SpineBased Rosette] and link the
following geometry:

• Origin: Origin
• Direction: Spine

3. Change the Mapping Type to Spine-Based and turn on the option
for Reverse Spine Direction as shown in Figure 5–47.

Figure 5–47

4. Click  to save SpineBased Rosette.

Task 7 - Create a full-body ply and a flat pattern with SpineBased
Rosette.

1. In the Application Tree, select Ply under Basic and click
(Create New).

2. For the P003 ply, enter the following parameter:

• Step: 30
• Rosette: SpineBased Rosette

3. Select the Simulation Options tab.

4. Enter [0.3] for Fiber Spacing Factor.
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5. Select Spine for Simulation Method.

6. Click  and review the results in NX window.

7. Change Results Display to Deviation and review the results in NX
window.

8. Click  (Generate the Net Flat Pattern) and click  to
save P003.

9. Switch to NX and review the flat pattern created. Flat pattern for
P003 is shown in Figure 5–48.

Figure 5–48

10.Close Fibersim and save the model.
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Chapter 6

Utilities

This chapter includes:

Exercise 6a: Curve Creation and Ply Drop-off Utilities
Exercise 6b: Fiber Path Curve
Exercise 6c: Symmetric Laminate
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Exercise 6a Curve Creation and Ply Drop-off
Utilities

User Guide References:
B.5.2 Curve Creation
B.5.5 Curve Offset
B.3.6 Ply Drop-Off
B.5.4 Boundary
Simplification

In this exercise, you will use various utilities to create curves and ply
drop-offs. The completed model displays as shown in Figure 6–1.

Figure 6–1

Goal After you complete this exercise, you will be able to:

Create a curve using Curve Creation
Create a Curve Offset - Constant
Create a Curve Offset - Directional
Use Ply Drop-off
Use Boundary Simplification
Use Publish the Fibersim Composite Format

Estimated Time 15 min
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Task 1 - Open a part.

1. Open UTILITIES_A.prt. The model displays as shown in
Figure 6–2.

Figure 6–2

Task 2 - Create a curve using Curve Creation.

1. Press <F9> to start Fibersim.

2. In the Application Tree, select Laminate and Rosette under
Basic, to review the existing Fibersim objects.

3. In the Application Tree, select Ply under Basic to display the two
plies: P001 and P002.

Press <Ctrl> + <L> to open
the Layer Settings window.

4. Show the HOLE_GEOMETRY layer category in the Layer Settings
window. The four points display as shown in Figure 6–3.

Figure 6–3
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5. Press <F9> to start Fibersim.

6. In Fibersim, select Tools > Curve Creation > Curve Creation as
shown in Figure 6–4.

Figure 6–4

7. Next to the Surface field, click  (Link Geometry) and select the
Tool Surface.

8. Click .

9. Next to the Points to Connect field, click  (Link Geometry).

10.Make sure that the Existing Point filter is enabled as shown in
Figure 6–5.

Figure 6–5

The curve will be created
by connecting the selected
points in the order of
selection.

11. Select the four points: Hole1, Hole2, Hole3, and Hole4 as shown
in Figure 6–6.

Figure 6–6

Hole.1Hole.2

Hole.3
Hole.4
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12.Click .

If Close Curve is not
selected, the points will be
connected in order without
connecting the last point to
the first one.

13.Select the checkbox for the Close Curve option. The Fibersim -
Curve Creation window updates as shown in Figure 6–7.

Figure 6–7

14.Click .

15.Click  The model updates with the curve as shown in
Figure 6–8.

Figure 6–8
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Task 3 - Use Curve to create a Hole.

1. In the ply list, double-click on P002 to modify it.

2. In the Geometry area, next to the Holes field, click  (Link
Geometry) and select the curve you just created as shown in
Figure 6–9.

Figure 6–9

3. Click . A warning message about the origin should
display as shown in Figure 6–10.

Figure 6–10

4. Click  to close the message.
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5. In the Geometry area, next to the Origin field, click  (Link
Geometry) and indicate a new origin outside the hole boundary as
shown in Figure 6–11. (Make sure to enable Point on Face
selection filter.)

Figure 6–11

6. Click  twice to save P002.

Task 4 - Create a Constant Curve Offset.

Press <Ctrl> + <L> to open
the Layer Settings window.

1. Show the Reinforcement layer category in the Layer Settings
window. The two reinforcement boundaries and two origins display
as shown in Figure 6–12.

Figure 6–12

Indication Origin
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2. Press <F9> to start Fibersim again.

3. In Fibersim, select Tools > Curve Creation > Curve Offset as
shown in Figure 6–13.

Figure 6–13

4. Select the Constant Offset tab.

The Direction Point
determines the side of the
selected curves on which
the offset curves are
created.

5. Click  (Create New) and link the following geometry:

• Curves to Offset: RH Reinforcement Boundary
• Surface: Tool Surface
• Direction Point: Indicate a point outside the RH Reinforcement

Boundary as shown in Figure 6–14
• Boundary Curves: Net Boundary

Figure 6–14

Direction Point
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6. Enter the following parameters:

• Number of Curves: 3
• Offset Value: 0.25 in (6.35 mm)
• Corner Type: Fillet

7. Click  in the message box as shown in Figure 6–15.

Figure 6–15

8. Click  twice to save the curve offset.

9. Switch to the NX window to display the constant curve offset as
shown in Figure 6–16.

Figure 6–16

Task 5 - Change the Constant Offset Curves to be Directional.

1. Select the Directional Offset tab and double-click on
CurveOffset001 to modify.

The linked rosette
determines the 0 and 90
degree offset directions.

2. Enter the following parameters:

• 0 degree Offset Value: 0.25 in (6.35 mm)
• 90 degree Offset Value: 0.5 in (12.7 mm)

3. Click .



Fibersim 15 Pro - NX

6–10 CT2245_FS15NX_2 ©2016 Siemens PLM Software

4. The Fibersim message window opens, prompting you that the
curve offset was generated successfully as shown in Figure 6–17.

Figure 6–17

5. Click  twice.

6. Click .

7. Switch to the NX window to display the directional offset curves as
shown in Figure 6–18.

Figure 6–18

Task 6 - Create Plies from Directional Curve Offsets.

1. In the ply list, for the Object Count, enter [4] as shown in
Figure 6–19.

Figure 6–19
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2. Click  (Create New).

3. Link the following geometry: (Make sure to disable Point on Face
selection filter.)

• Origin: RH Reinforcement Origin

4. Press <Ctrl> + <T> to switch to Table mode.

5. In the Standard tab, select the following for the Specified
Orientation column:

• P003: 0
• P004: -45
• P005: 90
• P006: 45

6. In the Net Geometry tab, for the Boundary column, link the
geometry as shown in Figure 6–20.

Figure 6–20

7. Click  to save the plies.

Task 7 - Create 4 plies based on existing plies.

1. In the ply list, highlight P003, P004, P005, and P006, right-click
and select Create Based On.

2. Press <Ctrl> + <T> to switch to Form mode.

P003: Blue line
P004: Red line

P005: Yellow line
P006: Green line
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3. Link the following geometry:

• Origin: Indicate a point inside the LH Reinforcement
Boundary.

• Boundary: LH Reinforcement Boundary
Because they were
created based on the RH
Reinforcement plies, the
LH Reinforcement plies
are already sequenced.

4. Click

Task 8 - Create a Ply Drop-off.

1. In the ply list, highlight P007, P008, P009, and P010, if they are
not already highlighted.

You can also find Ply
Drop-Off in the main menu
by selecting Tools >
Operations.

2. In the Ply toolbar, click  (Ply Drop-Off) as shown in
Figure 6–21.

Figure 6–21

3. Specify the following parameters as shown in Figure 6–22:

• Direction: Outside
• Offset Distance: 0.25 (6.35 mm)
• Corner Type: Fillet

Figure 6–22
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4. Click .

5. The Fibersim message window opens, prompting you that the
generation of ply drop-offs is complete as shown in Figure 6–23.

Figure 6–23

6. Click  twice.

In Fibersim, select P007
through to P010 one at a
time to display each ply in
NX.

Note that this Ply Drop-Off
result is the same as the
Constant Curve Offset.

7. Switch to the NX window to display the new plies as shown in
Figure 6–24.

Figure 6–24

Task 9 - Show the ply drop-off using a 3D cross-section.

You can also find 3D
Cross Section in the
Documentation menu in
the Application Tree.

1. In the Ply toolbar, click  (3D Cross Section) as shown in
Figure 6–25.

Figure 6–25

2. Select CrossSection001 and click  (Generates the 3D cross
section).
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3. Zoom and orient the model to display the cross-section details as
shown in Figure 6–26.

Figure 6–26

4. Click .

Task 10 - Boundary Simplification.

1. In Fibersim, select Tools > Curve Creation > Boundary
Simplification as shown in Figure 6–27.

Figure 6–27

2. Click  (Create New).

3. Next to the Components field, click  (Link with Link Dialog).
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You can also press <Ctrl>
+ <L> to link the selected
plies.

4. Press <Ctrl> + <A> to select all of the plies, right-click, and select
Link to link the selected plies.

5. Click .

Internal Boundary
Curves Only will not
create closed boundaries,
but only the boundary
curves that are not shared
with the laminate
boundary.

6. Click  to display the default options as shown in
Figure 6–28.

Figure 6–28

7. Click .

8. Click  in the message box prompting you that the
boundary features were generated successfully.

9. Click  to save BNDSMP001.

10.Click  and close Fibersim.

11. Review the boundaries generated under Group "FIBERSIM
BOUNDARY SIMPLIFICATI" as shown in Figure 6–29.

Figure 6–29
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Exercise 6b Fiber Path Curve

User Guide Reference:
B.5.1 Fiber Path Curve
Creation

In this exercise, you will create two Fiber Path Curves to use for Net
Boundary to address deviation producibility issues. The completed
model is shown in Figure 6–30.

Figure 6–30

Goal After you complete this exercise, you will be able to:

Display Fiber Deviation for a Ply
Create a Fiber Path Curve
Add Fiber Path Curves to a Net Boundary
Create a Net Flat Pattern

Estimated Time 10 min
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Task 1 - Open a part.

1. Open UTILITIES_B.prt. The model displays as shown in
Figure 6–31.

Figure 6–31

Task 2 - Set the Simulation options.

1. Press <F9> to start Fibersim.

2. In the ply list, highlight P001 and click  (Net Producibility).

3. Double-click on P001 to modify.

4. Select the Simulation Options tab and set the following simulation
options as shown in Figure 6–32:

• Results Display: Deviation

Figure 6–32

5. Click  to save P001.



Fibersim 15 Pro - NX

6–18 CT2245_FS15NX_2 ©2016 Siemens PLM Software

Task 3 - Display Fiber Deviation for a Ply.

1. Switch to the NX window and display the producibility results as
shown in Figure 6–33.

Figure 6–33

For more information on
Deviation options, see the
Rosettes chapter.

The Deviation results display the amount of deviation between the
simulated fiber orientations and the rosette’s orientation as
follows:
• White fiber paths indicate deviation under 3 degrees.
• Yellow fiber paths indicate areas where the deviation is

between 3 and 5 degrees.
• Red fiber paths indicate areas where the deviation in direction

exceeds 5 degrees.

Task 4 - Create the First Fiber Path Curve.

You can also find the Fiber
Path Curve Creation
utility in the main menu by
selecting Tools > Curve
Creation.

1. In the ply list, select P001. In the Ply toolbar, click  (Fiber Path
Curve Creation) as shown in Figure 6–34.

Figure 6–34
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An indication must be
made on the surface, not
on the fiber path curve.
Fibersim will not create an
indication point unless it is
not on the displayed
curves.

2. Next to the Fiber Path Position field, click  (Link Geometry) and
indicate a point on the surface closest to the last full-yellow fiber
path as shown in Figure 6–35. (Make sure to enable the Point on
Face selection filter.

Figure 6–35

3. Click .

4. Click .

5. Click  in the message box prompting you that the curve
was generated successfully.

IndicationPoint.1
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Task 5 - Create a Second Fiber Path Curve.

1. Next to the Fiber Path Position field, click  (Link Geometry).

2. Create a second fiber path curve by indicating a point on the other
side of the surface nearest to the last full-yellow fiber path as
shown in Figure 6–36.

Figure 6–36

3. Click .

4. Click .

5. Click  in the message box prompting you that the curve
was generated successfully.

6. Click .

Task 6 - Modify P001 to use the new Fiber Path Curves.

1. In the ply list, double-click on P001 to modify it.

2. Select the Standard tab.

3. Next to the Boundary field, click  (Link Geometry).

IndicationPoint.1
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4. Clear the existing splines by <Shift> selecting and select the two
new fiber path curves, as shown in Figure 6–37.

Figure 6–37

5. Click .

6. Select the Net Geometry tab.

7. Next to the Markers field, click  (Link Geometry) and select the
original material width curves as shown in Figure 6–38.

Figure 6–38
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8. Click .

9. Click  (Net Producibility).

10.Click  (Generates the Net Flat Pattern).

11. Click  to save P001.

12.Switch to the NX window to display the producibility and net
pattern results. Note that the flat pattern satisfies the fiber
deviation limits as shown in Figure 6–39.

Figure 6–39

13.Close Fibersim and save the model.

Material Width Lines
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Exercise 6c Symmetric Laminate

User Guide Reference:
B.4.1 Symmetric Laminate

In this exercise, you will use the Symmetric Laminate utility to create
a second laminate dataset, by copying component data to a
symmetric part. The completed model displays as shown in
Figure 6–40.

The Symmetric Laminate
utility differs from the
Mirror Laminate utility,
which mirrors plies about a
user-defined step value on
the same laminate.

Figure 6–40

Goal After you complete this exercise, you will be able to:

Create a Symmetric Laminate

Estimated Time 15 min



Fibersim 15 Pro - NX

6–24 CT2245_FS15NX_2 ©2016 Siemens PLM Software

Task 1 - Open a part.

1. Open UTILITIES_C.prt. The model displays as shown in
Figure 6–41.

Figure 6–41

Task 2 - [NX8.5] Mirror CAD features about a symmetry plane.

Task 2 is different for each CAD system. Find the appropriate Task 2
and follow instructions.

1. In NX, click  (Extract Geometry) as shown in Figure 6–42.

Figure 6–42
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2. Select Mirror Body from the Extract Geometry Type pull-down
list.

3. Select the body and the mirror plane as shown in Figure 6–43.

Figure 6–43

Mirror Plane

Body
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4. Click .

5. Select Insert > Curve from Curves > Mirror as shown in
Figure 6–44.

Figure 6–44

6. Select Net Boundary, Extended Boundary, and Zero Direction
for the curves and the mirror plane as shown in Figure 6–45.

Figure 6–45

Mirror Plane

Zero Direction

Extended Boundary

Net Boundary
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7. Click  and the model updates as shown in Figure 6–46.

Figure 6–46

8. Select Insert > Datum/Point > Point.

9. Create a point at the end of the mirrored Zero Direction Curve as
shown in Figure 6–47.

Figure 6–47
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Task 2 - [NX9/10] Mirror CAD features about a symmetry plane.

1. Select Mirror Geometry from the Home tab > Feature group >
More as shown in Figure 6–48.

Figure 6–48

2. Select the following geometry as shown in Figure 6–49:

• Geometry to Mirror: Tool Surface, Net Boundary, Extended
Boundary, Rosette Origin, Zero Direction

• Mirror Plane: Sym Plane
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Figure 6–49

3. Click .

Task 3 - Create Symmetric Laminate and Rosette geometry.

1. Press <F9> to start Fibersim.

2. In the Application Tree, select Laminate under Basic.

3. Click  (Create New).

4. In Name field, enter [Sym Lam].



Fibersim 15 Pro - NX

6–30 CT2245_FS15NX_2 ©2016 Siemens PLM Software

5. Link the following geometry as shown in Figure 6–50:

• Layup Surface: select the mirrored tool surface
• Net Boundary: select the mirrored net boundary
• Extended Boundary: select the mirrored extended boundary

Figure 6–50

6. Click  to save Sym Lam.

7. In the Application Tree, select Rosette under Basic.

8. Click  (Create New) to create ROS002.

Mirrored Net Boundary

Mirrored Extended Boundary

Mirrored Tool Surface
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9. Rename ROS002 as [Sym Ros].

10.Link the following geometry as shown in Figure 6–51:

• Surface: select the mirrored Surface
• Origin: select the mirrored Origin
• Direction: select the mirrored Zero Direction

Figure 6–51

An exact symmetry of ply
orientations requires an
opposite handed
(Left-Hand) rosette.

11. For Hand Direction, select Left as shown in Figure 6–52.

Figure 6–52

12.Click  to save Sym Ros.

Mirrored Origin

Mirrored Zero Direction

Mirrored Surface
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Task 4 - Create a Symmetric Laminate.

1. In Fibersim, select Tools > Derivative Laminates > Symmetric
Laminate as shown in Figure 6–53.

Figure 6–53

2. In the Symmetric Laminate dialog box, click  (Create New).

3. Specify the following parameters to create the symmetric laminate:

• Source Laminate: Cowl
• Source Rosette: ROS001
• Symmetry Plane: Sym Plane
• Symmetric Laminate: Sym Lam
• Symmetric Rosette: Sym Ros

4. The updated Symmetric Laminate form displays as shown in
Figure 6–54.

Figure 6–54
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5. Click  to generate the symmetric laminate.

6. In the message box prompting you that 23 components have
generated successfully as shown in Figure 6–55.

Figure 6–55

7. Click .

8. Note the Report created on the Symmetric Laminate’s Standard
form as shown in Figure 6–56.

Figure 6–56

9. Click  to complete the Symmetric Laminate creation.

10.Click  to close the window.
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Task 5 - Group plies by Parent.

1. In the Application Tree, select Ply under Basic.

2. In the Group drop-down list, select Parent to display the plies
grouped by their parents as shown in Figure 6–57.

Figure 6–57

3. In the Parent ply list, highlight Sym Lam and Cowl, one at a time,
to highlight them in the NX window as shown in Figure 6–58.

Figure 6–58

4. Close Fibersim and save the model.
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Project 2

Monolithic Panel

This chapter includes:

Exercise P2: Monolithic Panel
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Exercise P2 Monolithic Panel

User Guide Reference:
2.8 Plies
B.5.2 Curve Creation
B.5.5 Curve Offset

In this project, you will use ply based design to complete a layup
scenario. The completed model displays as shown in Figure P2–1.

Figure P2–1

Goal This project will test your knowledge on how to:

Create the required NX geometry
Create ply objects
Create a 3D cross-section and confirm layup

Given The previously created geometry and design details are:

Net and Extended Boundaries have been created
Rosette geometry has been created
Planes that define the locations of the substructure
have been created
The substructure is the basis for the ply boundaries

Estimated Time 1 hr 30 min
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Task 1 - Open a part.

1. Open PROJECT2_MONOLITHIC.prt. The model displays as
shown in Figure P2–2.

Figure P2–2
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Task 2 - Review Fibersim geometry.

1. The Winglet Tool Surface, Manufacturing (Extended) Boundary,
Design (Net) Boundary, Rosette Origin, and Zero Direction are
displayed as shown in Figure P2–3.

Figure P2–3

2. The Substructure geometry is shown in Figure P2–4.

Figure P2–4

Design (Net)

Manufacturing (Extended)

Zero Direction

Rosette Origin

Winglet Tool Surface

Boundary

Boundary

Rib 2 Centerline (Rib 2 CL)

Main Spar

Rib 1 Centerline (Rib 1 CL)
Centerline
(Main SparCL)
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Task 3 - Create the required CAD geometry.

1. Create the required CAD geometry for the given plies as shown in
Figure P2–5.

Figure P2–5

6.75 in (171.45 mm)

36 Plies

20 Plies

12 Plies

Aligned to
Main Spar CL

Aligned to Rib 1CL

All plies are PPG-PL-3K

0°

90°

Drop Offs:

0 = 0.25in

90 = 0.5in

(6.35 mm)

(12.7 mm)

4 in (101.6 mm)

Aligned to Rib 2CL
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Task 4 - Create ply objects.

1. Create plies, using given quantity, ply drop-off values and
orientations as shown in Figure P1–7 and Figure P2–7.

Ply Requirements (36 --> 20 Ply Drop)

Figure P2–6

Ply Requirements (20 --> 12 Ply Drop)

Figure P2–7
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Task 5 - Cross-section.

1. Use the Curve Creation Utility to create a curve for a
cross-section. Review the 3D Cross Section and confirm that the
layup matches the design requirements as shown in Figure P2–8.

Figure P2–8
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Chapter 7

Core

This chapter introduces:

Exercise 7a: Core Types
Exercise 7b: Modeled Core with Overcore and IML Laminates
Exercise 7c: Core Panel Design from a Solid (Optional)
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Exercise 7a Core Types

User Guide Reference:
2.9 Cores
5.2 3D Cross Section

In this exercise, you will create various types of cores within Fibersim
Basic. (Note that designing the overcore plies/layers has not yet been
discussed.) The completed model is shown in Figure 7–1.

Figure 7–1

After you complete this exercise, you will be able to:

Create a Virtual Step Core object
Create a Virtual Variable Core object
Create a Virtual Core object
Observe the differences between the different types
of core using cross-sections

Estimated Time 15 min
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Task 1 - Open a part.

1. Open CORE_A.prt. The model displays as shown in Figure 7–2.

Figure 7–2

2. Press <F9> to start Fibersim.

3. Review the Fibersim objects in the model. Note that the model
already contains a Laminate, a Rosette, and four full-body plies as
shown in Figure 7–3. The plies are made of the PPG-PL-3K
material and are oriented to the 0, -45, 45, and 90 deg directions.

Figure 7–3
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Task 2 - Create a Virtual Step Core.

Virtual Step Core is the most commonly used type of core, with the
same bevel angle on all sides and a vertical step at the base.

1. In the Application Tree, select Core under Basic.

2. Click  (Create New). Expand the drop-down list and click

 (Virtual Step Core). The Core definition form is displayed as
shown in Figure 7–4.

Figure 7–4

3. Next to the Material field, click  (Link with Database Link
Dialog).

4. Select the checkbox for Honeycomb material as shown in
Figure 7–5.

Figure 7–5

5. Click .

6. In the Core Members > Geometry area, next to the Origin field,

click  (Link Geometry).

7. Make sure that the Existing Point selection filter is enabled.
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8. Indicate a point in the middle of the 1st Core as shown in
Figure 7–6.

Figure 7–6

9. Click .

10. In the Geometry area, next to the Boundary (1) field, click
(Link Geometry).

If required for a given
design, a curve inside the
core boundary can be
used to define the ribbon
direction of the core.

11. Select the boundary contour of the 1st Core as shown in
Figure 7–7.

Figure 7–7

12.Click .
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13.Enter the following parameters as shown in Figure 7–8.

• Thickness: 1.575 in (40 mm)
• Bevel Angle: 30
• Step Height: 0.095 in (2.413 mm)

Figure 7–8

14.Click  to complete the Core.

Task 3 - Create a Virtual Variable Core.

Virtual Variable Core requires you to define both the Base Boundary
and Top Boundary of the core. The Core bevel angles might be
different on all sides and are defined by differences in the geometric
shape of the Base Boundary and Top Boundary combined with the
core height.

1. In the Application Tree, select Core under Basic.

2. Click  (Create New). Expand the drop-down list and click

 (Virtual Variable Core). The Virtual Variable Core definition
form is displayed as shown in Figure 7–9.

Figure 7–9
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3. Next to the Material field, click  (Link with Database Link
Dialog).

4. Select the checkbox for the Honeycomb material.

5. Click .

6. In the Geometry area, next to the Origin field, click  (Link
Geometry).

7. Indicate a point in the middle of the 2nd Core as shown in
Figure 7–10.

Figure 7–10

8. Click .

9. In the Geometry area, next to the Boundary (1) field, click
(Link Geometry).

10.Select the outer contour of the 2nd Core as shown in Figure 7–11.

Figure 7–11

11. Click .
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12. In the Core Top area, next to the Boundary (4) field, click  (Link
Geometry).

13.Select the inner contour of the 2nd Core as shown in Figure 7–12.

Figure 7–12

14.Click .

15. In the Core Top area, in the Thickness (3) field, enter [1.575 in] (40
mm). The form updates as shown in Figure 7–13.

Figure 7–13

16.Click  to complete the Core.
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Task 4 - Create Two Virtual Cores.

Virtual Core only requires explicitly defining geometry for the Base
Boundary. The cross-sectional shape of the Core is then implicitly
defined by specifying numeric values for thickness, bevel angle, etc.

1. In the Object Count field, enter [2] to create two cores
simultaneously as shown in Figure 7–14.

Figure 7–14

2. Click  (Create New). Expand the drop-down list and click

 (Virtual Core). The Virtual Core definition form is displayed as
shown in Figure 7–15.

Figure 7–15

3. Next to the Material field, click  (Link with Database Link
Dialog).

4. Select the checkbox for the Honeycomb material.

5. Click .
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6. Enter the following parameters in the Core Top area as shown in
Figure 7–16.

• Thickness: 1 in (25.4 mm)
• Bevel Angle: 30°

Figure 7–16

7. Press <Ctrl>+ <T> to switch to the Table view. The updated form
displays as shown in Figure 7–17.

Figure 7–17

8. For the VC001 core, next to the Origin field, click  (Link
Geometry).

9. Select the indicated point as shown in Figure 7–18.

Figure 7–18
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10.Repeat the steps 8 and 9 for the VC002 core, selecting the point in
the middle of Core004 curve as shown in Figure 7–19.

Figure 7–19

11. Click . If a warning box appears, click OK.

12.Link the Boundary geometry (in the Boundary column) for both
Cores as follows:

• VC001: select the Core003 curve
• VC002: select the Core004 curve

13.The updated form displays as shown Figure 7–20.

Figure 7–20

It is a recommended best
practice to return to Form
Mode to prevent future
confusion.

14.Press <Ctrl> + <T> to return to Form mode.

15.Click  to complete both Cores.

Task 5 - Create 3D cross-sections.

1. Switch to NX and press <Ctrl> + <L> to launch Layer Settings
dialog box.

2. Show the Cross_Section_Curve layer category.

3. Click .
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3D Cross Section can
also be found in the
Fibersim Documentation
menu.

4. Press <F9> to start Fibersim.

5. In the Core toolbar, click  (3D Cross Section) as shown in
Figure 7–21.

Figure 7–21

6. Click  (Create New).

7. The cross-section form displays as shown in Figure 7–22.

Figure 7–22

8. Next to the Cross Section Curve field, click  (Link Geometry).

9. Select the Cross Section Curve 1 as shown in Figure 7–23.

Figure 7–23

10.Click .
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11. Enter the following parameters:

• Component Type: Ply
• Style: Draped
• Ply/Layer Offset Scale: 20 (Note that this parameter is used to

exaggerate the offset distances between plies in the
cross-section for better visibility.)

• Core Offset Scale: 1 (Note that this parameter is used to scale
the core dimensions. A value of [1] means that the core(s) in the
cross-section will be displayed at real size.)

12.Click .

13.Click  to complete the cross-section.

14.Switch to the NX window. The model displays as shown in
Figure 7–24.

Figure 7–24

15.Zoom in to examine the cross-sections of the cores. Note the
different bevel angles in the VVC001 core, and the step geometry
in VSC001 core as shown in Figure 7–25.

Figure 7–25

Different bevel angles Step geometry
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16. In the 3D Cross Section list, highlight CrossSection001,
right-click and select Create Based On to create a 3D Cross
Section for Cross Section Curve 2.

17.Display both cross-sections (multi-select them in the Fibersim
window), and hide the NX geometry. The model should display as
shown in Figure 7–26.

Figure 7–26
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Exercise 7b Modeled Core with Overcore
and IML Laminates

User Guide Reference:
2.9 Cores
9.7 Laminate Tab
2.10 Design Stations

In this exercise, you will create a Modeled Core object and create
overcore and IML laminates. This will demonstrate the process of
defining a core panel, display the results on producibility, and indicate
why multiple laminates must be used.

After you complete this exercise, you will be able to:

Create a Modeled Core object
Create an Overcore Laminate
Re-sequence the overcore plies to reflect the
overcore topology
Create an IML laminate with a descending sequence
order
Interrogate the model using three Design Stations

Estimated Time 15 min

Task 1 - Open a part.

1. Open CORE_B.prt. The model displays as shown in Figure 7–27.

Figure 7–27
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Task 2 - Create a Modeled Core object.

1. Press <F9> to start Fibersim.

2. In the Application Tree, select Core under Basic.

3. Click  (Create New).

4. In the drop-down list, click (Modeled Core) as shown in
Figure 7–28.

Figure 7–28

5. Enter the following parameters as shown in Figure 7–29:

• Parent: OML
• Step: 50
• Material: Honeycomb
• Thickness: 0.5 in (12.7 mm)
• Origin: OML_PLY_ORIGIN
• Boundary: CORE_BOUNDARY

Figure 7–29
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6. Click  to save MC001.

7. Click  (Composite Sequence Manager) to review the
component stack as shown in Figure 7–30.

Figure 7–30

8. Click .

Task 3 - Create an Overcore Laminate.

1. In NX, hide the OML_Geometry layer category and show the
OverCore_Geometry layer category in Layer Settings window.

2. Press <F9> to start Fibersim.

3. In the Application Tree, select Laminate under Basic.

4. Click  (Create New).
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A different alphabetically
ordered Sequence letter is
assigned to each laminate
(Sequence A = OML;
Sequence B = Overcore).

5. Enter the following parameters as shown in Figure 7–31:

• Name: Overcore
• Parent: OML
• Sequence: B
• Step: 100
• Layup Surface: Overcore
• Net Boundary: Overcore_Net_Boundary
• Extended Boundary: Overcore_Extended_Boundary

Figure 7–31

6. Click  to save the Overcore.

Task 4 - Link the plies to Overcore Laminate

1. Select Ply from Basic menu.

2. Select P005, press <Shift> and select P008 to multi-select plies
P005, P006, P007, and P008 as shown in Figure 7–32.

Figure 7–32
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3. With the four plies selected, right-click and select Modify.

4. For the Parent field, select Overcore from the pull-down list as
shown in Figure 7–33.

Figure 7–33

5. Click  (Link Geometry) next to Origin field in the Net Geometry
area.

6. Select OVERCORE_PLY_ORIGIN.

7. Click .

8. For reference, the component sequence and steps are shown in
Figure 7–34.

Figure 7–34
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Task 5 - Run Net Producibility and generate Net Flat Patterns.

In this task, the Fiber Spacing Factor is reduced for plies (P005 to
P008) to ensure that the simulation follows the core ramps accurately.
The simulation results should closely conform to the topological
changes in the simulation surface (default laminate surface).
Changing the Fiber Spacing Factor in this situation will result in a
more accurate flat pattern for the plies covering the core object as
shown in Figure 7–35.

Figure 7–35

1. Select the Simulation Options tab.

2. For the Fiber Spacing Factor, enter [.3].

3. Click  (Net Producibility) to run Net Producibility.

4. Click  (Generates the Net Flat Pattern) to create a Net Flat
Pattern of P005, P006, P007, and P008.

5. Click  to save.

6. Close the Fibersim window.

1.0 Fiber Spacing

Non-optimized results

0.3 Fiber Spacing

Desirable results
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7. Switch to the NX window. In the Part Navigator, highlight
NET_FP_P001 to NET_FP_P008 to display the net flat pattern
results. Note the bulges in the updated flat patterns due to the
different topology of the Overcore surface as shown in
Figure 7–36.

Figure 7–36

Task 6 - Create an IML laminate with a descending sequence
order.

For a layup that progresses in opposite directions (closed mold or caul
plate with bag side loading operations), as shown in Figure 7–37, the
Sequence-Step order of the second laminate is typically defined as
Descending. In this task you will change the Overcore laminate to be
an IML laminate with a descending sequence order.

Figure 7–37

1. Hide OVERCORE_GEOMETRY and show IML_GEOMETRY
layer category in the Layer Settings window.

2. Press <F9> to start Fibersim.

Orange FP: Tool Ply

Blue FP: Overcore Ply

SKIN NORMAL DOWN

SKIN NORMAL UP

IML

OML

IML

CORE001
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3. Create a new Laminate with the following parameters as shown in
Figure 7–38:

• Name: IML
• Parent: OML
• Step: 100
• Sequence Order: Descending
• Layup Surface: IML
• Net Boundary: IML_Net_Boundary
• Extended Boundary: IML_Extended_Boundary

Figure 7–38

4. Click  to save the IML laminate.

5. Modify P005, P006, P007, and P008.

6. Change Parent to IML.

7. Click  to save the changes to P005, P006, P007, and
P008.

Task 7 - Update the P005 to P008 Flat Patterns.

1. In the Ply listing, make sure P005 to P008 are highlighted.

2. Click  (Net Producibility).

3. Click  (Generates the Net Flat Pattern) to create a Net Flat
Pattern of P005, P006, P007, and P008.
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4. Switch to the NX window to display the net flat pattern results as
shown in Figure 7–39.

Figure 7–39

Task 8 - Interrogate the model using three Design Stations.

1. In the Application Tree, select Design Station under Basic as
shown in Figure 7–40.

Figure 7–40

2. Click  (Create New).

3. For the Laminate field, select OML from the pull-down list.

4. Click  (Link Geometry) next to Origin.
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5. Hide IML_GEOMETRY and show the Design Stations layer
category in the Layer Settings window.

6. Select DS001_Origin as shown in Figure 7–41.

Figure 7–41

7. Click .

8. In the Design Station Standard form, expand the Core Sample
Type drop-down list and select Summary if it is not already
selected.

9. Click  (Core Sample). The Fibersim message box opens
prompting you that the core samples have completed successfully
as shown in Figure 7–42.

Figure 7–42

10.Click  twice to go back to the Design Station list.
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11. Enter [2] in the object counter as shown in Figure 7–43.

Figure 7–43

12.Right-click on DS001 and select Create BasedOn.

13.Press <Ctrl> + <T> to switch to the List View.

14.Link the following geometry for Origin.

• DS002: DS002_Origin
• DS003: DS003_Origin

15.Press <Ctrl> + <T> to switch to the Form View.

16.Click  (Core Sample).

17.Click  twice.

18. In the Design Station list, double-click on DS001.
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19.Scroll down to view the results of the core sample for DS001. The
measured thickness of the core is less than the specified
thickness, as shown in Figure 7–44, because the origin point lies
on a core ramp.

Figure 7–44

20.Click .

21. In the Design Station listing, double-click on DS002 to display the
DS002 core sample results as shown in Figure 7–45. The
measured thickness of the core is equal to the specified thickness
because the origin point lies within the constant thickness region.

Figure 7–45

22.Click
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23.In the Design Station listing, double-click on DS003 to display the
DS003 core sample results as shown in Figure 7–46.

Figure 7–46

24.Close Fibersim and save the model.

A core is not
present at this
Design Station
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Exercise 7c Core Panel Design from a Solid
(Optional)

User Guide Reference:
2.9 Cores
5.2 3D Cross Section
2.10 Design Stations

In this exercise you will design a multi-laminate composite part with a
core, starting from a solid NX model with minimal guidance.

The solid model of the part is shown in Figure 7–47. The part consists
of 16 full-body plies made of PPG-PL-3K pre-preg fabric [cured
thickness 0.0075 in (0.1905 mm)], and a 0.394 in (10 mm) thick core
made of foam. Eight plies are laid underneath the core, and another
eight plies are placed over the core. Therefore, the total thickness of
the part is 0.454 in (11.5316 mm) in the core area and 0.06 in (1.524
mm) in all other areas.

Figure 7–47

After you complete this exercise, you will be able to:

Create an OML Laminate
Create a Modeled Core
Create an Overcore Laminate
Review the design-in-progress with Design Station
and 3D Cross Sections
Analyze producibility and obtain Flat Patterns for
OML and Overcore plies

Estimated Time 20 min
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Task 1 - Open the part.

1. Open CORE_C.prt. The model displays as shown in Figure 7–48.

Figure 7–48

Task 2 - Review the part.

The model is already prepared for composite design with Fibersim,
with all of the necessary surfaces and curves extracted, etc. In this
task, you will review the prepared geometry.

1. In NX, press <Ctrl> + <L> to open Layer Settings window as
shown in Figure 7–49.

Figure 7–49
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The Tool_Lam_Geom layer category contains the geometry required
to create the undercore plies:

• Tool Surface: Surface extracted from bottom of solid model.
• Tool Net Boundary: Boundary edges of Tool Surface.
• Tool Rosette: Geometric set containing origin and

zero-direction of rosette.

2. Hide Tool_Lam_Geom and show the Overcore_Lam_Geom
layer category set as shown in Figure 7–50.

Figure 7–50

The Overcore_Lam_Geom layer category contains the geometry
required to create the overcore plies:

• Overcore Surface: Surface extracted from top of solid and
offset by 0.12 in (3.048 mm), the total thickness of the overcore
plies.

• Overcore Net Boundary: Boundary edges of Overcore
Surface.

• Overcore Rosette: Geometric set containing origin and
zero-direction of rosette.
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3. Hide Overcore_Lam_Geom and show both the
Tool_Lam_Geom and Core_Geom layer categories as shown in
Figure 7–51. Note that the Core_Geom category contains the
Core Boundary curve (extracted from the solid edges and
projected onto the Tool Surface).

Figure 7–51

4. Click .

Task 3 - Create the OML Laminate.

1. In Fibersim, create a laminate with the following parameters:

• Name: OML Laminate
• Sequence: A
• Step: 1
• Default Material: PPG-PL-3K
• Layup Surface: Tool_Surface
• Net Boundary: Tool_Net_Boundary
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2. The laminate form is shown in Figure 7–52.

Figure 7–52

3. Create a new Rosette with the following parameters:

• Name: OML Rosette
• Origin: TOOL_ROSETTE_ ORIGIN
• Direction: TOOL_ZERO_DIRECTION

4. Create eight full-body plies with the following parameters:

• Name: Accept the default
• Sequence: A
• Step: 10,10
• Orientations (P001 to P008): 0, 45, 90, -45, 45, 90, -45, 0

5. The plies are shown in Figure 7–53.

Figure 7–53

6. Create a Design Station (DS001) at OML Rosette and run a core
sample to verify that the total thickness of the OML Laminate is
currently 0.06 in (1.524 mm) (8 plies with 0.0075 in (0.1905 mm)
each cured thickness).
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Task 4 - Create a Modeled Core.

Note: Show the Core
geometric set to locate the
Boundary.

1. Create a new core with the following parameters:

• Name: MC001
• Type: Modeled Core
• Parent: OML Laminate
• Sequence: A
• Step: 90
• Material: Foam-3.1
• Origin: TOOL_ROSETTE_ORIGIN
• Boundary: Select all 4 curves
• Thickness: 0.394" (10 mm)

Task 5 - Create an Overcore Laminate.

1. Create a laminate with the following parameters:

• Name: Overcore Laminate
• Sequence: B
• Step: 1
• Sequence order: Ascending
• Default Material: PPG-PL-3K
• Layup Surface: Overcore_Surface
• Net Boundary: Overcore_Net_Boundary

2. The laminate form is shown in Figure 7–54.

Figure 7–54
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3. Create a new Rosette with the following parameters:

• Name: Overcore Rosette
• Surface: Overcore_Surface
• Origin: Overcore_Rosette_Origin
• Direction: Overcore_Zero_Direction

4. Create eight new full-body plies, with the following parameters
(ignore the warning messages regarding the invalid Net Boundary
type):

• Name: Accept the default names
• Parent: Overcore Laminate
• Rosette: Overcore Rosette
• Sequence: B
• Step: 100,10
• Orientations (P009 to P016): 90, 45, 0, -45, 45, 90, -45, 0

5. The plies are shown in Figure 7–55.

Figure 7–55

6. Create a new Design Station (DS002) and verify that the thickness
of the Overcore Laminate is 0.06 in (1.524 mm) (eight plies, each
with 0.0075 in (0.1905 mm) cured thickness).

Task 6 - Create 3D Cross Sections.

1. Create two 3D Cross Sections with the following parameters:

• Name: CrossSection OML
• Laminate: OML Laminate
• Cross Section Curve: OML_Xsec_Curve (in the

Cross_Sec_Curves layer category)
• Ply/Layer Offset Scale: 1
• Core Offset Scale: 1
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• Name: CrossSection Overcore
• Laminate: Overcore Laminate
• Cross Section Curve: Overcore_Xsec_Curve (in the

Cross_Sec_Curves layer category)
• Ply/Layer Offset Scale: 1
• Core Offset Scale: 1

2. In NX, hide all other layer categories except for Fibersim_Geom
and Part_Body in Layer Settings window.

3. In Fibersim, multi-select both 3D Cross Sections. The model
should display as shown in 4..

Figure 7–56

4. In NX, change the render style to Static Wireframe.

5. Zoom in on the cross-section and verify whether the laminate
thickness, etc., matches the original solid model as shown in
Figure 7–57.

Figure 7–57
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Task 7 - Create flat patterns for the undercore and overcore plies.

1. Run Net Producibility (set the Fiber Spacing Factor as [0.2]) and
create a Net Flat Pattern for the P001 ply.

2. Run Net Producibility (set the Fiber Spacing Factor as [0.2]) and
create a Net Flat Pattern for the P009 ply.

3. In the Fibersim window, highlight plies P001 and P009. Examine
the differences in the flat patterns for the undercore (P001) and
overcore (P009) plies as shown in Figure 7–58.

Figure 7–58

4. Close Fibersim and save the NX model.

NET_FP_P009NET_FP_P001
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Chapter 8

Documentation

This chapter introduces:

Exercise 8a: 3D Documentation
Exercise 8b: Generating a Ply Book and Ply Table
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Exercise 8a 3D Documentation

User Guide Reference:
1.5 Documentation
5.1 Introduction
5.2 3D Cross Section
5.3 Explode Laminate
5.5 3D Text Annotations

In this exercise, you will use the Documentation tools available in
Fibersim to create 3D cross-sections and annotations, and to
generate an exploded view of the ply stack-up. The completed model
displays as shown in Figure 8–1.

Figure 8–1

Goal After you complete this exercise, you will be able to:

Generate and update 3D cross-sections
Create a core sample annotation
Generate a ply table
Create a ply callout
Generate a material table

Estimated Time 20 min
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Task 1 - Review the model.

The model and much of the Fibersim data have already been
completed. This exercise will focus on the documentation tools of
Fibersim.

1. Open DESIGN_AND_DOC_A.prt. The model displays as shown
in Figure 8–2.

Figure 8–2

2. Show the CROSS_SECTION_CURVE_1 and
CROSS_SECTION_CURVE_2 layer categories as shown in
Figure 8–3. These curves determine where on the Tool Surface
the cross-section will be created. The curves have been created
on the Tool Surface. The Tool Surface is the skin for the Hood
laminate on which the cross-section will be generated.

Figure 8–3

3. Click .

Cross Section Curve 1

Cross Section Curve 2
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Task 2 - Generate 3D Cross Section.

In this task, you will create two 3D cross-sections. 3D cross-sections
enable you to visually inspect the laminate stack and help in the
manufacturing of the composite part.

1. Press <F9> to start Fibersim.

2. From the Application Browser select Documentation as shown in
Figure 8–4.

Figure 8–4

3. In the Application Tree, select 3D ross Section under 3D
Documentation.

4. Click  (Create New).

5. Specify the following parameters as shown in Figure 8–5:

• Laminate: Hood
The Cross Section Curve
determines where on the
Tool Surface the
cross-section will be
created.

• Cross Section Curve: CROSS SECTION 1
• Ply/Layer Offset Scale: 10

Figure 8–5
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6. Click  (Generates the 3D cross section) and click .

7. Review the 3D Cross Section curves generated on the model. The
Cross Section tool adds color to the cross-section curves based
on ply orientations for each material.

8. Click  (Create New).

9. Create a second cross-section using the following parameters:

• Laminate: Hood
• Cross Section Curve: Cross Section 2
• Ply/Layer Offset Scale: 10
• Boundary Type: Extended
• Profile Type: Rectangle

10.Click  (Generates the 3D cross section) and click .

11. Review the 3D Cross Section curves generated on the model.

In this task, you created the cross-sections as display geometry. To
display the cross-section you must select it in Fibersim. If you want to
create the cross-sections as actual CAD Geometry, select the Create
Cross Section Geometry option in the create 3D Cross Section
dialog box.

Task 3 - Re-sequence the plies in the Hood laminate and update
3D cross sections.

1. In the Application Tree, select Ply under Source.

2. Click  (Composite Sequence Manager).

3. In the Laminate drop-down list, select Hood.

4. In the list of objects, select P009 and drag it under Overcore 2, as
shown in Figure 8–6.

Figure 8–6
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5. Drag and drop the plies as described in Table 8–1 and shown in
Figure 8–7:

Table 8–1

Figure 8–7

6. Click .

7. In the Application Tree, select 3D Cross Section under 3D
Documentation.

8. Press <Ctrl> and select both CrossSection002 and
CrossSection001. The cross-sections display on the model.

Ply Place after:

P013 P009

P010 P005

P014 P010

P011 P006

P015 P011

P012 P007

P016 P012



Documentation

CT2245_FS15NX_2 ©2016 Siemens PLM Software 8–7

9. Zoom in on the cross-section at the location shown in Figure 8–8.

Figure 8–8

10.Activate the Fibersim window.

11. Move the Fibersim window so that the highlighted cross-section
displays in the CAD window.

12.With both cross-sections highlighted, click  (Generates the 3D
cross section). The cross-sections update to reflect the changes
made to the stackup.

13.Close the Fibersim window.

Task 4 - Create a Core Sample annotation.

In this task you will create a core sample annotation. Core Sample
annotations enable you to display design station results in a 3D text
object. Since Design Stations have not been created in the model,
you will also need to create one on-the-fly. The model used in this
exercise already contains annotations. To create a Fibersim
annotation, you must first create an annotation in the 3D model to be
populated with the Fibersim data.

Zoom in to this area
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1. In the NX Layer Settings window, show the
DESIGN_STATION_ORIGIN and ANNOTATIONS; and hide
CROSS_SECTION_CURVE_1 and CROSS_SECTION_CURVE2
as shown in Figure 8–9.

Figure 8–9

2. Click .

3. Press <F9> to start Fibersim.

4. In the Application Tree, select Core Sample under 3D
Documentation > Annotations.

5. Click  (Create New).

6. Next to the Design Station field, click  (Link with Link Dialog).

You can also right-click in
the main Fibersim window
and select Create New.

7. Click  (Create New).

8. In the Laminate drop-down list, select Hood.

9. Click  (Link Geometry) next to Origin.

10.Select DESIGN STATION ORIGIN as shown in Figure 8–10 and
click .

Figure 8–10



Documentation

CT2245_FS15NX_2 ©2016 Siemens PLM Software 8–9

11. Click  (Core Sample). In the message window, click .

12.Click  to save the Design Station definition.

13.Ensure that the DS001 design station that was just created is
linked and click  to link this station to the Core Sample.

An annotation must
already be created in the
model.

14.Next to the Annotation Leader field, click  (Link Geometry).

15. In the NX window, select the Core Sample note and click
.

16.The Fibersim window re-activates. Mouse over the NX window
again to update the note, as shown in Figure 8–11.

Figure 8–11

17.Click  to save the Core Sample note.

If necessary, reposition the
note in the NX model to
better format the text.

18.Close Fibersim.

Task 5 - Create a Ply Table annotation.

In this task, you will create an annotation that will display ply and core
information on the Hood laminate in a pre-existing 3D text annotation.

1. Press <F9> to start Fibersim.

2. In the Application Tree, select Ply Table under 3D
Documentation > Annotations.

3. Click  (Create New).

4. In the Laminate drop-down list, select Hood.
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5. Link Annotation Leader to the Ply Table annotation. The model
updates as shown in Figure 8–12.

If the Status of the Ply
Table is Out-of-date, click

 (Generates the ply
table).

Figure 8–12

6. Click  to save the Ply Table annotation.

Task 6 - Create a Ply Callout annotation.

In this task, you will create an annotation that will display all of the ply
and core objects at a specified point on the Hood laminate.

1. In the NX Layer Settings window, show the
PLY_CALLOUT_ORIGIN layer category.

2. Click .

3. Press <F9> to start Fibersim.

4. In the Application Tree, select Ply Callout under 3D
Documentation > Annotations.

5. Click  (Create New).

6. In the Laminate drop-down list, select Hood.
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The callout point and
annotation leader must
already exist in the model.

7. Link the following geometry:

• Annotation Leader: Ply Callout
• Callout Point: Ply Callout Origin (See Figure 8–13.)

Figure 8–13

8. Enter [3] for Number Of Names Per Line.

9. Click  (Generates the callout). In the message window, click
. The model updates as shown in Figure 8–14.

Figure 8–14

10.Click  to save the Ply Callout annotation.

Task 7 - Create a Material Table annotation.

In this task, you will create an annotation to display all of the materials
used in a given laminate(s).

11. In the Application Tree, select Material Table under 3D
Documentation > Annotations.

Callout Point - PLY CALLOUT ORIGIN

Annotation Leader
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12.Click  (Create New).

13.Next to the Laminates field, click  (Link with Link Dialog).

14.Press <Ctrl> + <A> to select all three laminates.

You can also right-click on
one of the highlighted
laminates and select Link
or press <Ctrl> + <L>.

15.Right-click and select  (Link).

16.Click .

17.Link the Annotation Leader to the Material Table annotation. The
model updates as shown in Figure 8–15.

Figure 8–15

18.Click  to save the Material Table annotation.

19.Close Fibersim and save the model.
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Exercise 8b Generating a Ply Book and Ply
Table

User Guide Reference:
5.4 Flat Pattern Layout
5.6.1 Ply Book
5.6.2 Ply Table

In this exercise, you will generate a 2D drawing of a composite part.
2D drawings are useful as a method of passing on the necessary
information for the manufacturing the part. A sheet from the ply book
that is generated in the drawing is shown in Figure 8–16.

Figure 8–16

Goal After you complete this exercise, you will be able to:

Utilize Flat Pattern Layout tool
Create a Ply Book
Place a Ply Table on a drawing sheet

Estimated Time 25 min
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Task 1 - Open a part.

1. Select File > Open and select DESIGN_AND_
DOC_B.prt.

If you completed Exercise 8a, you can continue working with
DESIGN_AND_DOC_A.prt instead. The model displays as shown
in Figure 8–17.

Figure 8–17

2. For clarity, hide ANNOTATION layer category in the Layer
Settings window.

Task 2 - Create a Flat Pattern layout.

In this task, you will use the flat pattern layout utility to manipulate how
the flat patterns display in the CAD window.

1. Press <F9> to start Fibersim.

2. In the Application Tree, select Ply under Source.

3. Press <Ctrl> + <A> to select all of the plies.

You can also right-click on
one of the highlighted plies
and select Modify or press
<Enter>.

4. Right-click and select Modify.

5. Select the Simulation Options tab.

6. In the Fiber Spacing Factor field, enter [0.6].

7. Click  (Net Producibility). In the message window, click

.

8. Click  (Generates the Net Flat Pattern).
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9. Click  to save the plies. The model displays as shown in
Figure 8–18.

Figure 8–18

Flat patterns need to be
created before the flat
pattern layout utility is
used.

10. In the ply list, highlight all of the plies by pressing <Ctrl> + <A>.

11. In the Ply Toolbar, click  (Flat Pattern Layout).

You can also find Flat
Pattern Layout in the
Documentation menu in
the Application Tree.

12.Enter the following parameters, as shown in Figure 8–19:

• Grid Origin X: -25 in (-635 mm)
• Cell Width: 50 in (1270 mm)
• Cell Height: 50 in (1270 mm)
• Row Direction: -Y
• Column Direction: X

Figure 8–19

13.Click .
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14.Click  and close Fibersim. The model displays as shown
in Figure 8–20.

Figure 8–20

Task 3 - Prepare a drawing for ply book insertion.

In this task, you will add two views to an existing drawing. These
views will be associated with the flat pattern and boundary diagrams
in Fibersim in the next task. In the drawing, the tables, frame, and title
block have already been created.

1. In NX, Click Start > Drafting.

2. In the Part Navigator, double-click on Sheet "SH1" under
Drawing.

3. In NX, press <Ctrl> + <L> to open Layer Settings window.

4. Enter [1] in the field next to Work Layer.

5. Click .

6. Select File > Import > Part.

7. Select Specify for Destination Coordinate System.
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8. Click .

9. Browse to Drawing_template_A-Size.prt in
TEMPLATES_FOR_DES_AND_DOC folder.

10.Click .

11. Change the Coordinates to Absolute - Displayed Part as shown
in Figure 8–21.

Figure 8–21

12.Click  twice and OK to the warning message about the
unit conflict.

13.Click  to exit the Import command.

14. In NX, hide all layer categories except for OML and 0 layer

category in the Layer Settings window, and click .

15.Press <Ctrl> + <Shift> + <M> to switch to Modeling.

16.Rotate the view to orient the model as shown in Figure 8–22.

Figure 8–22



Fibersim 15 Pro - NX

8–18 CT2245_FS15NX_2 ©2016 Siemens PLM Software

17. [NX8.5] Select View > Operation > Save As.

17. [NX9/10] Select Menu > View > Operation > Save As.

18.Enter [BOUNDARY-VIEW] in the Name field and click .

19.Press <Ctrl> + <Shift> + <D> to switch to Drafting

20. [NX8.5] Select Insert > View > Base.

20. [NX9/10] Select Base View on Home tab.

21.For Model View, select BOUNDARY-VIEW from the pull-down.

22.For Scale, select Ratio from the pull-down and enter [10] in the
second field as shown in Figure 8–23.

Figure 8–23

23.Place the view as shown in Figure 8–24 and press <Esc> to
cancel the projection view creation.

Figure 8–24
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24.Back in NX, hide OML layer category in the Layer Settings

window, and click .

25. [NX8.5] Select Insert > View > Base.

25. [NX9/10] Select Base View on Home tab.

26.For Model View, leave TOP view for Model View to Use.

27.For Scale, select Ratio from the pull-down and enter [10] in the
second field.

28.Place the view as shown in Figure 8–25 and press <Esc> to
cancel the projection view creation.

Figure 8–25

Task 4 - Generate the Ply Book.

1. Press <F9> to start Fibersim.

2. In the Application Tree, select Ply Book under 2D
Documentation.

3. Click  (Create New).

4. In the Laminate drop-down list, select Hood.

5. Next to Source Objects field, click  (Link with Link Dialog).

6. Press <Ctrl> + <A> to select everything.

You can also right-click on
one of the highlighted
laminates and select Link.

7. Click  (Link).

8. Click .
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9. Next to the Template Sheet field, click  (Link Geometry).

10.Select the border of the Plybook Template sheet in NX, as shown
in Figure 8–26, and click .

Figure 8–26

11. Select the Text Setup tab.

12. In the dialog box, in the Text Associations area, click  (Create
New with Geometry Selection).

13.Select the following text in the drawing, as shown in Figure 8–27:

a. A
b. 10
c. Name
d. Mat
e. Ori
f. LAM_NAME
g. 123-456-ABC

Figure 8–27

b
c
d
e

f
g

a



Documentation

CT2245_FS15NX_2 ©2016 Siemens PLM Software 8–21

14.Click .

15. In the Text.Seq row, expand the Source Member drop-down list
and select Sequence, as shown in Figure 8–28.

Figure 8–28

16.Enter the remaining Text Links as shown in Figure 8–29:

• 10: Step
• Name: Name
• Mat: Material
• Ori: Orientation
• LAM_NAME: Laminate Name
• 123-456-ABC: Laminate Part Number

Figure 8–29

17.Select the Diagram Setup tab.
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18. In the Flat Pattern Views window, select the Ply Book object type
as shown in Figure 8–30.

Figure 8–30

19.Click  (Create New with Geometry Selection) and select Flat
Pattern Diagram.

20. In the drawing, select the Top view and click .

21.Click .

22. In the Boundary Views window, select the Ply Book object type.

23.Click  (Create New with Geometry Selection) and select
Boundary Diagram.

Multiple flat pattern views
can be created on one
page if required. In this
case, all ply boundaries will
display in one boundary
view.

24. In the drawing, select the Boundary-View and click .

25.Click .

26.Turn on the option for Display Layup Information. The Diagram
Setup tab displays as shown in Figure 8–31.

Figure 8–31
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27.Click  (Generates the sheets for the ply book).

28.Click  to close the message window. When you
generate the Ply book, some of the sheets generate an error.
These sheets are views of the core. Since cores do not have a flat
pattern associated with them, the flat pattern view cannot be
generated.

29.Click .

30.Close Fibersim and review the generated sheets.

Task 5 - Create a Ply Table.

1. [NX8.5] Select Insert > Sheet.

1. [NX9/10] Select New Sheet on Home tab.

2. Select Standard Size option and A size if not already selected.

3. Enter [Table] in the Drawing Sheet Name field.

4. Click .

5. Select File > Import > Part.

6. Select Specify for Destination Coordinate System.

7. Click .

8. Browse to Drawing_template_A-Size.prt in
TEMPLATES_FOR_DES_AND_DOC folder.

9. Click .

10. In the Reference CSYS area, select Absolute - Displayed Part
for the Reference field.

11. Click .

12.Ensure that the Coordinates is set to 0,0.

13.Click  and OK to the warning message about the unit
conflict.

14.Click  to exit the Import command.
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15. [NX8.5] Select Insert > Table > Tabular Note.

15. [NX9/10] Select Tabular Note on Home tab.

16.Enter [4] for Number of Columns.

17.Place the table in the drawing as shown in Figure 8–32.

Figure 8–32

18.Click .

19.Press <F9> to start Fibersim.

20. In the Application Tree menu, select Ply Table under 2D
Documentation.

21.Click  (Create New).

22. In the Laminate drop-down list, select Hood.

23.Next to Source Objects field, click  (Link with Link Dialog).

24.Press <Ctrl> + <A> to select everything.

You can also right-click on
one of the highlighted
laminates and select Link.

25.Click  (Link).

26.Click .

27.Next to the Template Sheet field, click  (Link Geometry).
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28.Activate the NX window and select the border of the drawing, as
shown in Figure 8–33.

Figure 8–33

29.Click .

30.Select the Table Setup tab.

31. In the Table Associations area as shown in Figure 8–34, click

 (Create New with Geometry Selection).

Figure 8–34

Click icon in the
Table Associations
area in the dialog box
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32. In the NX window, select the table as shown in Figure 8–35, and
click .

Figure 8–35

33. In the Table.1 row, click  as shown in Figure 8–36.

Figure 8–36

34.Double-click on the first row to modify it.

35.Enter [ORIENTATION] in the Column Title field.

36. In the Data Field drop-down list, select Orientation and click
.

37.Repeat Steps 34 through 36 for each of the other rows, as shown
in Figure 8–37.

Figure 8–37

Select this table
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38.Click  to close the Fibersim - link Table Column via
Define Columns dialog box.

39.Click  (Updates or generates the sheets).

40.Click  in the message window.

41.Click  to save the Ply Table.

42.Close Fibersim.

43.Activate the NX window. The last sheet of the drawing contains the
Ply Table that was created, as shown in Figure 8–38.

Figure 8–38

44.Save and close the drawing and model.
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Project 3

Core Panel

This chapter includes:

Exercise P3: Core Panel
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Exercise P3 Core Panel

User Guide Reference:
2.9 Cores
2.5 Flat Pattern/
Producibility Simulation
B.3.7 Splice Ply

In this project, you will use both plies and modeled cores to complete
a layup scenario. The completed model displaying the four cores is
shown in Figure P3–1.

Figure P3–1

Goal This project will test your knowledge on how to:

Create Ply and Modeled Core objects
Define the Overcore laminate
Run Net Producibility
Splice plies to address material width producibility
problem
Create a Net Flat Pattern

Core 1

 Core 3

Core 2

Core 4 (in behind)



Fibersim 15 Pro - NX

P3–3 CT2245_FS15NX_2 ©2016 Siemens PLM Software

Given The existing geometry and design details are:

Net and Extended Boundaries have been created
OML laminate has been created
Rosette geometry has been created
Core CAD geometry has been created
Overcore CAD geometry has been created

Estimated Time 1 hr 30 min

Task 1 - Open a part.

1. Open PROJECT3_CORE.prt. The model displays as shown in
Figure P3–2.

Figure P3–2
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Task 2 - Review the model.

1. Review the setup of layers by showing/hiding each category as
shown in Figure P3–3. (Make sure that the Category Display
option is turned on.)

Figure P3–3

Task 3 - Create Ply and Core objects

1. When creating an OML laminate, select the sheet edge of the
model for the extended boundary.

2. The ply details on the OML surface are:

• Four full plies with a material of PPG-PL-3K with Specified
Orientation of 0, +45, 90, and -45.

• One adhesive ply with a material of Film-Adhsv

3. The Core material details are:

• Core 1: Honeycomb
• Core 2: Foam-3.1
• Core 3: Honeycomb
• Core 4: Foam-3.1
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Task 4 - Cross section details

1. The cross section for Core 1 is shown in Figure P3–4.

Figure P3–4

2. The cross sections for Core 2 and 4 are shown in Figure P3–5.

Figure P3–5

3. The cross section for Core 3 is shown in Figure P3–6.

Figure P3–6
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Task 5 - Define the Overcore laminate.

Create the Overcore laminate using the Overcore CAD geometry.

• Select the sheet edges of Overcore_Surface for the extended
boundary of Overcore laminate.

Task 6 - Create four plies on the Overcore surface.

Create one adhesive ply and four full plies with Specified Orientation
of -45, 90, +45, and 0 on the Overcore surface.

Task 7 - Confirm layup.

Create cross sections using the provided CAD geometry to confirm
that the layup matches the design requirements.
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Chapter 9

Introduction to Multi-Ply Design

This chapter includes:

Exercise 9a: Basic Multi-Ply Design
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Exercise 9a Basic Multi-Ply Design

User Guide Reference:
3.3.2 Overlay Zone
3.7 Offset Specifications
3.8 Laminate
Specifications
3.9 Material Specifications

In this exercise, you will learn the basics of Multi-Ply design on a
simple composite part.

Goal After you complete this exercise, you will be able to:

Define simple Overlay Zones
Generate Layers from Overlay Zones
Create Material Specification
Create Laminate Specification

Estimated Time 20 min

Task 1 - Open a part.

1. Open MULTI_PLY_A.prt. The model displays as shown in
Figure 9–1.

Figure 9–1

2. Press <F9> to start Fibersim.
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3. From the Application Browser, select Advanced as shown in
Figure 9–2.

Figure 9–2

Task 2 - Review the existing Laminate.

1. In the Application Tree, select Laminate under Design as shown
in Figure 9–3.

Figure 9–3

2. Double-click Hood from the object list to modify.

3. Note that the Design Boundary is set to Extended as shown in
Figure 9–4.

Figure 9–4
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4. Click  to close without saving.

Task 3 - Define Full Body Overlay Zone.

1. In the Application Tree, select Overlay Zone under Design as
shown in Figure 9–5.

Figure 9–5

2. Click  (Create New).

3. Create Overlay Zone window is displayed as shown in Figure 9–6.

Figure 9–6

4. Enter [4] for Target Ply Count.

Task 4 - Create Material Specifications for OZ001.

1. Under Material Specifications, click  (Create New).

2. Click  (Link with Database Link Dialog) for Material.

3. Link PPG-PL-3K and click .

4. Select [+/-45] from the pull-down list for Orientation.
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5. Enter [2] for Ply Count.

6. Right-click on MS005 and select Create Based On as shown in
Figure 9–7.

Figure 9–7

7. Select [0/90] from the pull-down list for MS006’s Orientation.

8. Click  to save OZ001.

Task 5 - Define Core Overlay Zone.

1. Click  (Create New).

2. Enter [Core] for Name.

3. Link the Core curve for Boundary as shown in Figure 9–8.

Figure 9–8

4. Enter [1] for Target Ply Count.

Core
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Task 6 - Create Material Specifications for Core.

1. Under Material Specifications, click  (Create New).

2. Click  (Link with Database Link Dialog) for Material.

3. Link Foam-3.1 and click .

4. Enter [.5] (12.7 mm) for Core Material Thickness.

5. Click  to save Core.

Task 7 - Define Center Pad Overlay Zone.

1. Click  (Create New).

2. Enter [Center Pad] for Name.

3. Link CENTER_PAD for Boundary as shown in Figure 9–9:

Figure 9–9

4. Enter [3] for Target Ply Count.

CENTER_PAD
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Task 8 - Create Laminate Specification for Center Pad.

1. For Laminate Specification, click  (Link with Link Dialog).

2. Click  (Create New).

3. Enter [3p] for Name.

4. Select Red for Color.

5. Click  (Create New) to create a new Material Specification.

6. Click  (Link with Database Link Dialog) for Material.

7. Link T-24-in from the list.

8. Click .

9. Create two more Material Specifications based on the first
Material Specification.

10.Enter [45] and [-45] for the newly created Material Specifications
Orientation as shown in Figure 9–10.

Figure 9–10

11. Click  to save 3p.

12.Make sure that 3p is linked and click .

13.Click  to save Center Pad.
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Task 9 - Generate Layers.

1. Click  (Zone to Layer Analysis) in the Overlay Zone toolbar as
shown in Figure 9–11.

Figure 9–11

2. Click .

3. Click  to close the message window.

4. Review the report.

5. Click  to close the Zone to Layer Analysis window.

6. In the Application Tree, select Layer under Design.

This part is designed to the
extended boundary. 7. Click (Highlight Type) on the main toolbar as shown in

Figure 9–12.

Figure 9–12

8. Make sure that Extended Boundary is checked on.
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Press <Ctrl> + <A> to
select all of the layers.

9. Multi-select all layers to highlight. The model displays as shown in
Figure 9–13.

Figure 9–13

Task 10 - Generate Plies.

1. Activate Fibersim window, and make sure that all layers are
selected.

2. Click  (Generate Plies) in the Layer toolbar as shown in
Figure 9–14.

Figure 9–14

3. Click  to close the message window.

4. In the Application Tree, select Ply under Manufacturing.

5. Review the generated plies.
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Task 11 - Generate a Core.

1. In the Application Tree, select Core Layer under Design.

2. Select CLYR001 from the list. The model displays as shown in
Figure 9–15.

Figure 9–15

3. Click  (Generate Core) in the Core Layer toolbar.

4. Click  to close the message window.

5. In the Application Tree, select Core under Manufacturing.

6. Review the generated core.
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Task 12 - Define Latch1 and Latch2.

1. In the Application Tree, select Overlay Zone under Design.

2. Enter [2] in the object counter as shown in Figure 9–16.

Figure 9–16

3. Click  (Create New).

4. For Name, enter [Latch1,1].

5. For Laminate Specification, select 4p from the pull-down list.

6. Enter [4] for Target Ply Count.

7. Press <Ctrl> + <T> to switch to Table View.

8. Right-click on one of the columns and turn on Origin and
Boundary columns as shown in Figure 9–17.

Figure 9–17
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9. Click  (Link Geometry) for Latch1’s Origin.

10.Turn on the Point on Face selection filter.

11. Select a point in the Latch1’s boundary as shown in Figure 9–18.

Figure 9–18

12.Click .

13.Click  (Link Geometry) for Latch1’s Boundary.

14.Link LATCH1 curve as shown in Figure 9–19.

Figure 9–19

15.Click .

16.Repeat steps 9 through 15 to assign Origin and Boundary as
shown in Figure 9–20.

Figure 9–20

17.Click  to save LATCH1 and LATCH2.

Select LATCH2 for Boundary

Indicate a point here
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Task 13 - Update Layers.

1. Click  (Zone to Layer Analysis) in the Overlay Zone toolbar.

2. Click .

3. Close the message window and review the report.

4. Click  to close the Zone to Layer Analysis window.

5. In the Application Tree, select Layer under Design.

6. Review the generated layers.

Task 14 - Generate Plies.

1. Multi-select all Layers in the list and click  (Generate Plies) as
shown in Figure 9–21.

Figure 9–21

2. Wait until confirmation message opens and then click
to close the message.

3. In the Application Tree, select Ply under Manufacturing. Note
that 15 Plies have been created from the Layers.

4. Review the generate plies.

5. Close Fibersim and save the model.
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Chapter 10
Transition Manipulation (Multi-Ply Based Design)

This chapter includes:

Exercise 10a: Basic Offset Specification Options
Exercise 10b: Splitting and Extending Transitions
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Exercise 10a Basic Offset Specification
Options

Userguide Reference:
3.7 Offset Specifications

In this exercise, you will move Zone Transitions by adding and
modifying Offset Specifications to meet the design requirements
below:

• A transitions must be centered about the boundary curve
• B transitions must be distributed along the surface
• C transitions must be offset from the tangent edges by 5 mm.

The completed model is shown below.

Figure 10–1

Goal After you complete this exercise, you will be able to:

Use Initial Offset to move the zone transitions
Use Center Based Offset to center the zone
transitions
Use Offset Distance to modify the spacing of the
zone transitions
Use Fill to Curve option

Estimated Time 15 min

A

B

C
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Task 1 - Open a part.

1. Open MULTI_TRANSITION_MAN_A.prt. The model displays as
shown in Figure 10–2.

Figure 10–2

Task 2 - Review the Existing Geometry.

1. Press <F9> to start Fibersim.

2. In the Application Tree, select Overlay Zone under Design.
Review the existing Overlay Zones in the model.

3. In the Application Tree, select Zone Transition under Design.
Note that all zone transitions are currently using the 5 mm as
shown in Figure 10–3.

Figure 10–3

4. Multi-select all of the Zone Transitions using <Ctrl> + <A>.
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5. Activate the NX window. The zone transitions display as shown in
Figure 10–4.

Figure 10–4

6. In the Application Tree, select Layer under Design.

7. Multi-select all layers.

8. Activate the NX window. The layers display as shown in
Figure 10–5.

Figure 10–5

Task 3 - Create a new Offset Specification with Centered option.

In this task you will modify the zone transitions to center them by the
OZ001 boundary.

1. In the Application Tree, select Offset Specification under
Specification.

2. Right-click on 5mm and select Create Based On.
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3. Enter [5mm Centered] for Name.

4. Click  in the Transition Positioning area.

5. Select Center Based as shown in Figure 10–6.

Figure 10–6

6. Click .

7. The Offset Specification form updates as shown in Figure 10–7.

Figure 10–7

8. Click  to save 5mm Centered.

Task 4 - Apply the new Offset Specification to a Zone Transition.

1. In the Application Tree, select Zone Transition under Design.

2. Double-click on ZT003 to modify.
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3. Link 5mm Centered for Offset Specification as shown in
Figure 10–8. Close the confirmation message window.

Figure 10–8

4. Click .

5. Highlight all layers and review the change in the NX window.

Task 5 - Modify ZT002.

1. In the Zone Transition list, double-click on ZT002.

2. Click  (Link with Link Dialog) next to the Offset Specification
field.

3. Click  (Create New).

4. Enter [50mm Total] for Name.

5. Expand Advanced Spacing area as shown in Figure 10–9.

Figure 10–9
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6. Click Total Distance Based Offset.

7. Enter [50] (1.968 in) for the Total Distance field.

8. Click .

9. Link 50mm Total from the list as shown in Figure 10–10 and click

.

Figure 10–10

10.Click  to close the message.

11. Click  to save ZT002.

12. In the Application Tree, select Layer under Design.

13.Highlight all layers and review the model in NX. The model
displays as shown in Figure 10–11.

Figure 10–11

Note that the layer boundaries follow the zone transition’s base curve
shape.
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Task 6 - Modify ZT003 - Fill to Curve option.

1. In the Application Tree, select Zone Transition under Design.

2. Double-click ZT002 to modify.

3. In the Offset Specification area, select Fill to Curve as shown in
Figure 10–12.

Figure 10–12

4. Click  (Link Geometry) next to the Last Drop-off Curve field.

5. Change the shading mode to Shaded with Edges.

Make sure that all 26
curves are selected for the
edge.

6. Select the highlighted edge as shown in Figure 10–13.

Figure 10–13

7. Click .

Select this edge.
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8. Expand Advanced Settings and clear the Orthogonal Trim from
Base Curve option as shown in Figure 10–14.

Figure 10–14

9. Click  to save ZT002.

10. In the Application Tree, select Layer under Design.

11. Highlight all layers and review the model in NX. The model
displays as shown in Figure 10–15.

Figure 10–15

Task 7 - Modify ZT001.

1. In the Application Tree, select Zone Transition under Design.

2. Double-click on ZT001 to modify.

3. Click  (Link with Link Dialog) next to the Offset Specification
field.

4. Click  (Create New).

5. Enter [20:1] for Name.
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6. Click Material Ratio Offset under Advanced Spacing as shown in
Figure 10–16.

Figure 10–16

7. For Multiple of Thickness, enter [20].

8. Click .

9. Link 20:1 from the list and click .

10.Click  to close the confirmation message.

11. Enter [5] mm (.197 in) for Initial Offset Adjustment as shown in
Figure 10–17.

Figure 10–17

12.Click  to save ZT001.
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13.Select all layers and review the model in NX. The finished model is
as shown in Figure 10–18.

Figure 10–18
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Exercise 10b Splitting and Extending
Transitions

Userguide Reference:
3.7 Offset Specifications

In this exercise, you will use advanced Offset Specification tools and
options to detail ply drop-off areas.

The completed model is shown in Figure 10–19.

Figure 10–19

Goal After you complete this exercise, you will be able to:

Use Zone Transition Splitter
Extend Zone Transitions along a curve

Estimated Time 15 min
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Task 1 - Open a part.

The part is already
populated with Laminate,
Rosette, and Overlay
Zones.

1. Open MULTI_TRANSITION_MAN_B.prt. The model displays as
shown in Figure 10–20.

Figure 10–20

Task 2 - Review the existing geometry.

1. Press <F9> to start Fibersim.

2. Review the existing Laminate and Rosette in the model.

3. In the Application Tree, select Layer under Design.

4. Press <Ctrl> + <A> to highlight all layers.

5. Review the model in NX and zoom into the circled area in
Figure 10–21.

Figure 10–21
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6. Note that the further you get from the baseline, the more
misaligned the layer boundaries are as shown in Figure 10–22.

Figure 10–22

The design requirement is to have the right and left side layers butt up
against the nose layers. In order to achieve this, the offset for the
circumferential drop must be different than the horizontal drop. In the
next task, you will split the zone transition to do this.

Task 3 - Split the Zone Transition on the left side.

1. In the Application Tree, select Zone Transition under Design.

2. Right-click on any column headers and select Standard > Thicker
Zone as shown in Figure 10–23.

Figure 10–23
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3. Select the Zone Transition with Left Side as Thicker Zone.

4. Click  (Zone Transition Splitter) from the Zone Transition
toolbar as shown in Figure 10–24.

Figure 10–24

5. Select Non-Tangency Angle for Splitting Method.

6. Click .

7. Switch to NX and note the red circle at the corner as shown in
Figure 10–25. The red circle indicates the location of the split.

Figure 10–25

8. Back in Fibersim, click .

9. Click  twice to save and close Zone Transition Splitter.
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Task 4 - Modify the vertical section of the split zone transition.

1. From the Zone Transition list, double-click on ZT003-B (the
vertical section) to modify.

2. For Offset Specification, select 1" from the list.

3. Enter [-2] in (-50.8 mm) for Initial Offset Adjustment as shown in
Figure 10–26.

Figure 10–26

4. Click  to save ZT003-B.

Task 5 - Review Layers.

1. In the Application Tree, select Layer under Design.

2. Highlight all layers. The model displays as shown in Figure 10–27.

Figure 10–27

Note that the further you get from the corner, the more misaligned the
layer boundaries are. This is because the vertical Zone Transition is
extending tangentially to the original, rather than along the
circumferential intersection curve.
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Task 6 - Modify the trimming option.

1. In the Application Tree, select Zone Transition under Design.

2. Double-click ZT003-B to modify.

3. Select the Trimming tab.

4. Turn on the Extend Along Reference Curve option for At Start as
shown in Figure 10–28.

Figure 10–28

5. Click .

6. Highlight all layers and review the model. The model displays as
shown Figure 10–29.

Figure 10–29

Task 7 - Modify the Zone Transition on the right side.

1. Repeat Task 3 - 6 for the right side zone transition to line up the
boundaries to butt against the nose layers. Note that you will need
to extend the zone transition along the reference curve at END.
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Chapter 11

Layer Definition (Multi-Ply Based Design)

This chapter includes:

Exercise 11a: Layer Sequencing (Multi-Ply Based Design)
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Exercise 11a Layer Sequencing (Multi-Ply
Based Design)

Userguide Reference:
B.3.4 Step Utility
5.2 3D Cross Section
B.2.3 Composite
Sequence Manager

In this exercise, you will learn how to sequence layers on a simple
composite part.

The required layer sequence is shown in Figure 11–1.

Figure 11–1

Goal After you complete this exercise, you will be able to:

Interrogate Layer Sequence using 3D Cross Section
utility
Resequence Layers using Step Utility
Resequence Layers using Composite Sequence
Manager
Resequence Layers using step-based Material
Specifications

Estimated Time 15 min
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Task 1 - Open a part.

The part is fully populated
with Laminate, Rosette,
Overlay Zones, and
Layers.

1. Open MULTI_LAYER_DEFINITION_A.prt. The model displays as
shown in Figure 11–2.

Figure 11–2

2. Press <F9> to start Fibersim.

3. In the Application Tree, select Layer under Design and
multi-select all layers in the list.

4. The model displays as shown in Figure 11–3. The colored
lines/curves represent Layer boundaries, color-coded accordingly
to their material direction.

Figure 11–3

5. Review the layers in the Layer list. Note all layers within each
Zone group have the same step value.
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Task 2 - Create 3D Cross Section.

1. In the Layer list view, click  (3D Cross Section) from the Layer
toolbar.

2. In the form, click  (Create New).

3. In the 3D Cross Section form, enter the following parameters as
shown in Figure 11–4:

• Component Type: Layer
• Style: Schematic
• Ply/Layer Offset Scale: 5
• Cross Section Curve: Show and link XSection from the Part

Navigator

i
Figure 11–4

4. Click  and  to close the 3D Cross
Section form.
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5. Activate NX window. The model displays as shown in Figure 11–5.

Figure 11–5

6. Zoom into the right side of the cross-section as shown in
Figure 11–6. Note that the layer sequence Fibersim created by
default is different from what is required.

Figure 11–6

7. Click  to close the 3D Cross Section form.
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Task 3 - Sequence T-12-in Layers using Step Utility.

1. Click  (Step Utility) as shown in Figure 11–7.

Figure 11–7

2. In the form that opens, click  (Create New). The Step Utility
form displays as shown in Figure 11–8.

Figure 11–8

Only materials that exist in
the part will be listed.

3. Next to the Material field, click  (Link with Database Link
Dialog) and in the link Material form, select T-12-in material as

shown in Figure 11–9. Click .

Figure 11–9

4. Click .
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5. When the confirmation message displays, click  to
close the message.

6. Click  and  to close the Step Utility form.

7. Select Sequence, Step and Name from the Sort pull-down list as
shown in Figure 11–10.

Figure 11–10

8. The list of Layers displays as shown in Figure 11–11.

Figure 11–11

9. Note that all layers of T-12-in are now interleaved as required, but
layers of PPG-PL-3K material are yet to be properly sequenced.
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Task 4 - Update the 3D Cross Section.

1. In the Layer list view, click  (3D Cross Section) from the Layer
toolbar.

2. Select CrossSection001 from the list.

3. Click  (Generate 3D Cross Section).

4. Review the updated 3D Cross Section in NX.

5. Click  to close the 3D Cross Section window.

Task 5 - Finalize the stackup using Composite Sequence
Manager.

1. Click  (Composite Sequence Manager) as shown in
Figure 11–12.

Figure 11–12
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2. The Composite Sequence Manager form opens as shown in
Figure 11–13.

Figure 11–13

3. Drag and drop PPG-PL-3K layers in the following sequence:

• LYR019 after LYR017
• LYR020 after LYR019
• LYR022 after LYR013
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4. The reordered list should update as shown in Figure 11–14.

Figure 11–14

5. Click .

6. Enter [10] for both Initial Step and Step Increment.

7. Click  (Resequence). The list updates as shown in
Figure 11–15. Note that the Step values are ordered in regular
increments as required.

Figure 11–15
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8. Click  to close the Composite Sequence Manager
form.

9. Press <Ctrl> + <A> to select all layers.

10.Right-click and select Modify.

11. Enter [LYR001,1] for Name.

12.Click .

Task 6 - Update the 3D Cross Section.

1. In the Layer list view, click  (3D Cross Section) from the Layer
toolbar.

2. Select CrossSection001 from the list.

3. Click  (Generate 3D Cross Section).

4. Activate the NX window. The model displays as shown in
Figure 11–16.

Figure 11–16
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5. Click  to close the 3D Cross Section window.

The same results can be made by assigning step values to Material
Specifications as shown in the next couple tasks.

Task 7 - Assign step-based Material Specifications to Overlay
Zones.

1. In the Application Tree, select Overlay Zone under Design.

2. Select OZ001, OZ002, and OZ003 from the object list.

3. Right-click and select Modify.

4. For Laminate Specification, select 6p_Sequenced from the
pull-down list.

5. Click on the Laminate Specification link as shown in
Figure 11–17.

Figure 11–17

6. Review the list of Material Specifications for 6p_Sequenced. Note
the step value for each Material Specification.

7. Click  to close without saving any changes to
6p_Sequenced.

8. Click  to save changes to the Overlay Zones.

9. Double-click on Full Body in the Overlay Zone list to modify.

10.For Laminate Specification, select 4p_Sequenced from the
pull-down list.

11. Click  to save changes to Full Body.
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Task 8 - Regenerate the Layers.

1. Click  (Zone to Layer Analysis) from the Overlay Zone toolbar.

2. Click .

3. Review the report and note that Fibersim deleted all layers and
create new ones.

4. Click  to close the Zone to Layer Analysis window.

5. In the Application Tree, select Layer under Advanced > Design.

6. Review the generated layers.

Task 9 - Update the 3D Cross Section.

1. In the Layer list view, click  (3D Cross Section) from the Layer
toolbar.

2. Select CrossSection001 from the list.

3. Click  (Generate 3D Cross Section).

4. Activate the NX window and review the model.

5. Click  to close the 3D Cross Section window.

6. Close Fibersim.
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Chapter 12

Surface Offset (Multi-Ply Based Design)

This chapter includes:

Exercise 12a: Creating Parametric Surface Offset with Ramps
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Exercise 12a Creating Parametric Surface
Offset with Ramps

User Guide Reference:
8.5 Flat pattern Placement
Options
10 Parametric Surface
Offset (PSO) Elements

In this exercise, you will learn how to generate offset surfaces and
solid models based on zones, layers, and plies using Fibersim’s
Parametric Surface Offset object.

Goal After you complete this exercise, you will be able to:

Create a Parametric Surface Offset
Create an IML Surface and a final Solid with Ramps
Update an IML Surface and Solid after design
changes

Estimated Time 20 min

Task 1 - Open a part.

1. Open MULTI_SURFACE_OFFSET_A.prt. The model displays as
shown NX in Figure 12–1.

Figure 12–1

2. Press <F9> to start Fibersim.
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3. In the Application Tree, select Overlay Zone under Design.

4. Multi-select all three Overlay Zones in the list. The model should
display as shown in Figure 12–2.

Figure 12–2

Task 2 - Create a Final Solid with Parametric Surface Offset.

1. Select Tools > Surface/Solid Creation > Parametric Surface
Offset as shown in Figure 12–3.

Figure 12–3
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2. In the form that opens, click  (Create New).

Make sure to check the
Boundary Type before
turning on the option for
Solid creation.

3. Click the checkbox for Extended under Boundary Types and
Create Solid to Net as shown in Figure 12–4.

Figure 12–4

4. Click  to generate the surface.

5. A message window opens prompting you that the parametric

surface offset was generated. Click  twice to close the
message and save PS001.

6. Click  to return to the main Fibersim window.

7. Close Fibersim and switch to NX and review the model. The model
should display as shown in Figure 12–5.

Figure 12–5
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Task 3 - Change the Laminate thickness in one Overlay Zone.

1. Press <F9> to start Fibersim.

2. In the Application Tree, select Overlay Zone under Design. In the
list, double-click OZ003.

3. For the Target Ply Count, enter [16]. In the Laminate Specification
drop-down list, select 16p as shown in Figure 12–6.

Figure 12–6

4. Click .

5. Click  (Zone to Layer Analysis) to open Zone to Layer Analysis
form.

6. Click .

7. Click  twice to close the message box and the Zone to
Layer Analysis form.
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Task 4 - Update the Solid.

1. Select PSO from the Application Browser as shown in
Figure 12–7.

Figure 12–7

2. Select Parametric Surface Offset from the menu.

3. Select PSO001 from the list of objects.

4. Click  (Generates a parametric offset).

5. Click  to close the message box.

6. The solid model updates according to the laminate definition when
edges are displayed, as shown in Figure 12–8.

Figure 12–8

7. Close Fibersim.

8. Save and close the model.
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Chapter 13

Manufacturing Features

This chapter includes:

Exercise 13a: Layer-based Manufacturing Laminate, with
Splice and Dart Groups
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Exercise 13a Layer-based Manufacturing
Laminate, with Splice and Dart
Groups

Userguide Reference:
3.4 Dart Group
3.5 Splice Group
3.6 Laminate Region
B.4.4 Manufacturing
Laminate Creation

In this exercise, you will create a new product consisting of the
layer-populated engineering model and the empty manufacturing
model for concurrent work purposes. You will then create a
manufacturing laminate and transfer the layer data from the
engineering model and create splice groups and dart groups to
resolve producibility issues. The completed manufacturing model
displays as shown in Figure 13–1.

Figure 13–1

Goal After you complete this exercise, you will be able to:

Create a new Product consisting of both the
Engineering and Manufacturing models
Create Manufacturing Laminate and transfer layers
(no springback)
Create Splice Groups for 0 degree plies
Create Overlap Splice Laminate Region
Create Splice Group for 45 degree plies
Create Dart Group for 90 degree plies
Run Producibility to show that all issues have been
resolved

Estimated Time 20 min
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Task 1 - Open fully populated zone-based Engineering part.

1. Open ENG.prt in the MULTI_MAN_FEATURES_A folder. The
model displays as shown in Figure 13–2.

Figure 13–2

2. Press <F9> to start Fibersim.

Note that the Fibersim
objects were created with
Fibersim Elite.

3. Note the Fibersim objects that have already been created.

Task 2 - Open and examine empty Manufacturing part.

1. Open MFG.prt. The model displays as shown in Figure 13–3.

Figure 13–3

2. Press <F9> to start Fibersim.

3. Note that there are no Fibersim objects created.

4. Close Fibersim.
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Task 3 - Create new Product consisting of both parts.

1. In NX, select File > New.

It is important to set the
assembly’s unit to match
the other parts. NX will not
let you make the
mismatched parts to be the
working parts.

2. Select Assembly and make sure that unit is set to Inch.

3. Click .

4. Press <Shift> and select ENG.prt and MFG.prt from the Loaded
Parts list.

5. Make sure that the Positioning field is set to Absolute Origin.

6. Click .

7. The model displays as shown in Figure 13–4.

Figure 13–4
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Task 4 - Create Laminate and Rosette in Manufacturing part.

1. In the Assembly Navigator, right-click on ENG and select Hide.

2. Right-click on MFG, and select Make Work Part as shown in
Figure 13–5.

Figure 13–5

3. Press <F9> to start Fibersim.

4. In the Application Tree, select Laminate under Design.

5. Click  (Create New).

6. Specify the following parameters as shown in Figure 13–6.

Verify that the Parent field
is empty.

• Name: MFG-TOOL
• Step: 1
• Layup Surface: MFG_Tool Surface
• Net Boundary: MFG_Net Boundary
• Extended Boundary: MFG_Ext Boundary

Select the boundaries from
"Select From the List..." to
make ensure that you
select the correct splines.

Figure 13–6

7. Click  to save.

8. In the Application Tree, select Rosette under Design.
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9. Click  (Create New).

10.Specify the following parameters as shown in Figure 13–7.

• Name: MFG-ROS
• Surface: MFG_Tool Surface
• Origin: MFG_Rosette Origin
• Direction: MFG_Zero Direction

Figure 13–7

11. Click  to save.

Task 5 - Create Manufacturing Laminate and transfer layer data.

You can also select

(Manufacturing
Laminate Creation) in the
Laminate toolbar.

1. In the Documents Browser, right-click on assmebly1 and select
Make Storage Document.

2. In the Fibersim main menu, select Tools > Derivative Laminates
> Manufacturing Laminate Creation as shown in Figure 13–8.

Figure 13–8

3. Click  (Create New).
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4. Specify the following parameters as shown in Figure 13–9. Close
the Fibersim message that displays when selecting Engineering
Laminate.

• Engineering Laminate: Shroud
• Engineering Rosette: ROS001
• Manufacturing Laminate: MFG-TOOL
• Manufacturing Rosette: MFG-ROS

Figure 13–9

5. Click . Accept the default options as shown in
Figure 13–10.

Figure 13–10

6. Click .

7. Click .

8. A message window opens prompting you that components were
created as shown in Figure 13–11.

Figure 13–11
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9. Click  and view the report as shown in Figure 13–12.

Figure 13–12

10.Click  to save.

11. Click .

12. In the Application Tree, select Layer under Design.

Click  to see the Active
Laminate field.

13. In the main toolbar area, select MFG-TOOL from the pull-down list
for Active Laminate as shown in Figure 13–13.

Figure 13–13
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Note that the material for
the 45 degree layers is
PPG-PL-3K-36, that is
different than others.

14.Review the list of layers as shown in Figure 13–14. Note that
Figure 13–14 shows layers grouped by Specified Orientation.

Figure 13–14

Task 6 - Create Offset Specification and Stagger Profile.

In this task, you create a constant offset specification and a stagger
profile to use when creating splice groups.

1. In the Documentation Browser, right-click on MFG and select
Make Storage Document.

2. In the Application Tree, select Offset Specification under
Specification.

3. Click  (Create New).

4. Enter [.25] (6.35 mm) for Offset Distance.

5. Click  to save.

6. In the Application Tree, select Stagger Profile under
Specification.

7. Click  (Create New).

8. Leave Stagger Profile Pattern as Linear Ascending as shown in
Figure 13–15.

Figure 13–15

9. Click  to save StaggerProfile001.
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Task 7 - Create Splice Groups for 0 degree plies.

1. In the Application Tree, select Splice Group under
Manufacturing.

2. Click  (Create New).

3. Specify the following parameters.

The Offset Direction is on
the ply origin side of the
splice curve which is the
default direction. Use

to change direction if
required.

• Name: SpliceGroup 0A
• Laminate: MFG-TOOL
• Orientation: 0
• Splice Curves: Splice Curve 1 as shown in Figure 13–16.

Figure 13–16

• Stagger Profile: StaggerProfile001

4. Click .

5. Clear the Only Splice Wider Than Material Width option as
shown in Figure 13–17.

Figure 13–17

Select this curve.
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6. Click  to save the splice group.

7. In the Splice Group list, select SpliceGroup 0A.

8. Right-click and select Create Based On.

9. Specify the following parameters as shown in Figure 13–18.

• Name: SpliceGroup 0B
• Splice Curves: Splice Curve 2 (Remember to clear Splice

Curve 1 first)

Figure 13–18

10.Click to indicate the offset direction on
the ply origin side of the splice curve as shown in Figure 13–19.

Figure 13–19

11. Click  to save the splice group.
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Task 8 - Assign Splice Groups to 0 degree layers and Splice
Plies.

1. In the Application Tree, select Layer under Design.

2. Select Specified Orientation from the pull-down list for Group.

3. Select the 0 degree orientation layer group, right-click, and select
Modify.

4. Next to the Splice Groups field, click  (Link with Link Dialog).

5. Click the checkboxes to link both SpliceGroup 0A and
SpliceGroup 0B as shown in Figure 13–20.

Figure 13–20

6. Click .

7. A message window opens prompting you that the Splice Group
edit may have invalidated origins of spliced plies. Click

.

8. Click .

9. A message window opens prompting you that splice plies were
created successfully as shown in Figure 13–21.

Figure 13–21

10.Click  twice.
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Task 9 - Rename Spliced Plies.

1. In the Application Tree, select Ply under Manufacturing. The
created plies are displayed as shown in Figure 13–22.

Figure 13–22

2. Note that the naming convention follows the order of splicing:

• SpliceGroup 0A creates P009-A
• SpliceGroup 0B creates P009-B-A, P009-B-B and P009-B-C

3. Multi-select the four P009 plies and switch to the NX window to
display as shown in Figure 13–23.

Figure 13–23

P009-B-B

P009-B-C

P009-B-AP009-A
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4. With the four P009 plies highlighted, right-click, and select Modify
as shown in Figure 13–24.

Figure 13–24

5. In the Name field, enter [P009-A,@] and press <Enter>.

6. Click  to save.

7. The renamed P009 plies display as shown in Figure 13–25.

Figure 13–25

8. Use the same steps to rename the other spliced plies (P010, P011
and P012).

Task 10 - Generate Plies for all 45 Degree Layers.

1. In the Application Tree, select Layer under Design.

2. Select the 45 degree layers and in the Layer toolbar, click
(Generate Plies).

3. A message window prompting you that the four plies were created

successfully opens. Click .

4. In the Application Tree, select Ply under Manufacturing.
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5. Group by Specified Orientation and select the 45 degree plies as
shown in Figure 13–26.

Figure 13–26

6. Activate the NX window to view the new plies as shown in
Figure 13–27.

Figure 13–27

Task 11 - Create Overlap Splice Laminate Region.

7. In the Application Tree, select Laminate Regions under
Specification.

8. Click  (Create New) and select  Overlap Splice Region as
shown in Figure 13–28.

Figure 13–28
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An Overlap Splice
Region is used to specify
an area in which plies can
be spliced with an overlap.
Splices outside the overlap
region will be performed as
butt splices.

9. Specify the following parameters:

• Name: OverlapSpliceRegion001
• Laminate: MFG-TOOL
• Origin: Overlap Origin (See Figure 13–29)
• Boundary: Overlap Region (See Figure 13–29)

Figure 13–29

10.Click  to save.

11. In the Application Tree, select Ply under Manufacturing.

12.Ungroup the list and double-click P006 to modify.

13.Click  (Net Producibility).

14.A message window opens prompting you that the material width is

exceeded. Click .

15.Select Net Geometry tab.

16.Expand Material Width Lines area.

17.Specify the following parameters as shown in Figure 13–30.

• Material Width Offset: -10 in (-254 mm)
• Positioning Method: Centered

Figure 13–30

Overlap Origin

Overlap Region
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18.Click .

19.Activate the NX window to display the material width lines as
shown in Figure 13–31.

Figure 13–31

20.In Fibersim, click .

21.Click  to save.

Task 12 - Create Splice Group for 45 degree plies.

1. In the Application Tree, select Layer under Design.

2. Double-click the 45 degree orientation layers to modify.

3. Next to the Splice Groups field, click  (Link with Link Dialog).

4. Click  (Create New).

5. Specify the following parameters as shown in Figure 13–33.

• Name: SpliceGroup 45
• Laminate: MFG-TOOL
• Orientation: 45
• Splice Curves: select the generated material width lines

Material Width Lines
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• Offset Direction: set pointing left to the net boundary from the
first splice curve selected as shown in Figure 13–32.

Figure 13–32

Recess Distance shifts
the beginning of the
overlap splice inside the
overlap region boundary
by the specified amount

• Overlap Distance: 1 in (25.4mm)
• Overlap Region: OverlapSpliceRegion001
• Recess Distance: 0.1 in (2.54mm)

Figure 13–33

6. Click .

7. Clear the Only Splice Wider Than Material Width option.

8. Click  twice to save and assign the SpliceGroup 45.

9. A message window prompting you that Splice Group edit may

have invalidated origins of spliced plies. Click .
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10.Click .

11. A message window opens prompting you that the plies were
created successfully as shown in Figure 13–34.

Figure 13–34

12.Click .

13.Click  to save.

14. In the Application Tree, select Ply under Manufacturing. The
created plies are displayed as shown in Figure 13–35.

Figure 13–35
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Task 13 - Generate 90 degree plies and run producibility.

1. In the Application Tree, select Layer under Design.

2. Select the 90 degree layers and in the Layer toolbar, click
(Generate Plies).

3. A message window prompting you that the ply was created

successfully opens. Click .

4. In the Application Tree, select Ply under Manufacturing.

5. Highlight P003.

6. In the ply toolbar, click  (Net Producibility).

7. Activate the NX window and note the problem areas as shown in
Figure 13–36.

Figure 13–36

Task 14 - Create Slit Darts.

1. In the Application Tree, select Darts under Manufacturing.

2. Click  (Create New) and select Slit Dart.

Problem Areas
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3. Specify the following parameters:

• Name: SlitDart001
• Laminate: MFG-TOOL
• Base Curve Points: IndicationPoint.1 and IndicationPoint.2

as shown in Figure 13–37. (Make sure that the Point On Face
selection filter is enabled.)

Figure 13–37

4. Click .

5. Click  to save.

6. Use the same procedure to create SlitDart002, SlitDart003, and
SlitDart004 in approximate locations as shown in Figure 13–38.

Figure 13–38

IndicationPoint.1

IndicationPoint.2

SlitDart002SlitDart002
SlitDart004

SlitDart003
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Task 15 - Create Dart Group.

1. In the Application Tree, select Dart Group under Manufacturing.

2. Click  (Create New).

3. Specify the following parameters:

• Name: 90 degree Dart Group1
• Laminate: MFG-TOOL
• Orientation: 90

4. Next to the Darts field, click  (Link with Link Dialog).

5. Click the checkboxes for SlitDart001 and SlitDart002 as shown in
Figure 13–39.

Figure 13–39

6. Click .

7. Click  to save the dart group.

8. Use the same procedure to create 90 degree Dart Group2 using
SlitDart003 and SlitDart004.
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Task 16 - Assign Dart Groups to 90 degree layers.

1. In the Application Tree, select Layer under Design.

2. Double-click the 90 degree orientation layer group to modify.

3. Next to the Dart Groups field, click  (Link with Link Dialog).

4. Click the checkbox to link both the 90 degree Dart Group1 and 90
degree Dart Group2 to the layers as shown in Figure 13–40.

Figure 13–40

5. Click

6. Click .

7. A message window opens prompting you that four plies were
darted successfully as shown in Figure 13–41.

Figure 13–41

8. Click .

9. Click  to save.
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10. In the Application Tree, select Ply under Manufacturing.

11. Highlight P003 and click  (Net Producibility) on the Ply toolbar.

12.Activate the NX window and note that the problems have been
resolved as shown in Figure 13–42.

Figure 13–42

13.Close Fibersim.

14.Save and close the model.
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Project 4

C Pillar

This chapter includes:

Exercise P4: C Pillar
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Exercise P4 C Pillar

User Guide Reference:
2.5 Flat Pattern/
Producibility Simulation
B.3.7 Splice Ply

In this project, you will design a C Pillar by resolving producibility
issues and following design guides given by CAE.

Goal This project will test your knowledge on how to:

Create ply layup following CAE design guides
Resolve any producibility issues in important areas
Create flat patterns
Create 3D and 2D documentation

Given The existing geometry and design details are:

Tool surface
Plane that represents the zero direction of the part
Hole geometry
Special area geometry used in CAE design guides

Estimated Time 2 hr 30 min
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Task 1 - Open a part.

1. Open PROJECT4_C_PILLAR.prt. The model displays as shown
in Figure P4–1.

Figure P4–1

Task 2 - Review the Fibersim geometry.

1. The existing OML, Zone, 0 direction, Cutouts, and critical area
geometry are organized in layers as shown in Figure P4–2.

Figure P4–2
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Task 3 - Create a Laminate and Rosette.

1. Using the geometry given, create a Laminate.

2. Create the necessary geometry for Rosette using the 0 Direction
curve, and create a Rosette.

Task 4 - Create Layup.

Analysis has determined that the layup must be:

• 4 Full body layers: two 0/90 deg and two +/-45 deg of DRY-FINE
• Within Center Reinforcement area as indicated in

Figure P4–3:
• Three 0 deg layers of T-24
• One +/- 45 deg layer of DRY-5H-3K

Figure P4–3

• Within End Reinforcement area as indicated in Figure P4–4:
• Two 90 deg layers of T-24
• One +/-45 deg layer of DRY-5H-3K

Figure P4–4



C Pillar

CT2245_FS15NX_2 ©2016 Siemens PLM Software P4–5

• All reinforcement layers must be dropped off 5 mm (0.1969 in)
to avoid stress concentrations.

• Drop-offs must occur on flat surface of the part to help
manufacturing position plies.

• Reinforcements must be interleaved between full-body layers.

Task 5 - Create Cutouts.

Define cutouts in all plies using the given geometry.

Task 6 - Run Net Producibility.

Run Net Producibility on all of the plies and address any issues based
on the CAE design guides below:

• Must resolve deformation problems within the area marked as
critical in Figure P4–5.

• Fibers must not deviate past 8 degrees within the critical area
• No bridging/Tearing conditions must exist throughout the entire

part.
• No darting is allowed within the critical area.
• Splicing is allowed but must be staggered at least 25.4 mm (1

in).
• Butting splices are allowed; overlaps in splicing are not

necessary.

Figure P4–5

Critical Area (Red)
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Task 7 - Generate Flat Patterns.

When all design rules (listed in Task 6) are met, create extended flat
patterns for all plies.

Task 8 - Create 3D Documentation.

Create 3D Cross Sections, Core Sample, Ply Table, Ply Callout, and
Material Table annotations.

Task 9 - Generate Weight Table.

Run weight table action and review the data given.

Task 10 - Generate Ply Book.

Setup and generate a ply book with appropriate template and text that
you feel communicates the layup accurately to manufacturing.
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