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Course overview

Teamcenter Express Collaborative Product Data Management (cPDM) teaches
end users how to use Teamcenter ® Express to create, revise, and manage
data in the context of their everyday tasks and processes.

Course objectives
• Create and manage Teamcenter Express data.

• Effectively use the Teamcenter Express rich client interface.

• Create and use various types of database objects.

• Differentiate between work-in-process and released data.

• Use preconfigured electronic workflows to increase the efficiency of
everyday processes.

• Monitor the release process before and after your involvement.

• Propose, control, and approve product data changes.

Key benefits
The key benefits of this course include:

• Increase productivity by learning through realistic projects.

• Hands-on work sessions to practice using Teamcenter Express.

• Demonstrations of best practices for implementing and using Teamcenter
Express.

Prerequisites
None
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Course overview

Audience
Anyone responsible for consuming, reviewing, and authoring Teamcenter
Express data. The course features the Teamcenter Express rich client
interface. Teamcenter Express has preconfigured roles that correlate to the
user tasks in the application: consumer, reviewer, and author, respectively.
You learn more about roles in Group and role settings, in Lesson 2, Getting
started with Teamcenter Express rich client.

Accessing Teamcenter Express online help
The Teamcenter Express Help Library covers functionality from end-user
tasks to customization instructions.

To access the Teamcenter Express Help Library:

• In the rich client, choose Help→Help→Help Library or press the F2 key.

Tip

If your browser does not display the table of contents, click the
message under the Address box and choose Allow Blocked Content.

• In the thin client, choose Help→Web Collection to access the thin client
help or choose Help→General Collection to access the full library.

To access help for the current application:

• In the rich client, choose Help→Help→Current Application or press the
F1 key.

Note

You cannot access application-specific help in the thin client.

Tip

If your browser does not display the table of contents, click the message
under the Address box and choose Allow Blocked Content.

What is cPDM?
Collaborative Product Data Management (cPDM) is a tool that helps
manage all the processes, applications, and information required to design,
manufacture, and support a product throughout its life cycle.

The goal of a cPDM system is to provide a single, common interface for
managing and accessing all data within an organization.
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Collaborative product data management benefits
Collaborative Product Data Management (cPDM) helps you:

• Maintain a single source of design data, which reduces errors and rework.

• Produce accurate bills of materials.

• Streamline and simplify the management of everyday tasks for
design-through-manufacturing.

• Increase design commonality and reuse by using the powerful and flexible
search capability.

• Reduce errors through more effective collaboration and the elimination of
mistake-prone manual handoffs with manufacturing.

• Manage data from multiple CAD systems in a single, integrated
environment.

• Transition more successfully from 2D CAD to 3D CAD.

• Secure corporate design data while facilitating access by authorized
personnel.

What is Teamcenter Express?
Teamcenter Express is an easy-to-use, preconfigured, collaborative Product
Data Management (cPDM) solution designed to meet the requirements
of mid-sized manufacturing companies. Teamcenter Express is designed
to apply preconfigured best practices to everyday engineering tasks and
processes of the following organizations:

• Small to mid-sized manufacturing companies

• Well-defined departmental workgroups

• Suppliers to OEMs and other product manufacturers

This course helps you become familiar with the commonly used capabilities of
Teamcenter Express. You learn how to enhance the tasks and processes you
work with every day.
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How to use this course
Each lesson contains sections that explain key concepts followed by an
activity to allow you to practice the concepts.

The format of the activities is consistent throughout this course. Steps are
labeled and specify what you should accomplish at any point in the activity.
Below each step are action boxes that emphasize the individual actions that
you must take to accomplish the step.

Activities are in the form of interactive simulations. You work in the
simulations just as you would work in Teamcenter Express.

Note

To view the interactive simulations, use Adobe Flash Player, which you
can download free-of-charge from Adobe Systems Incorporated at the
following URL: http://www.adobe.com.

When working in the simulations, note the following:

• To navigate through the course, use the links in the table of contents
(left), or the green arrows (right).

• When you launch an activity, your browser displays three frames. To
better view the simulation, close the frame on the left, the contents frame.
To close the frame, click the x located just above the contents frame. To

display the contents frame again, click the Contents button .
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• To increase or decrease the width of any of the frames, drag the bar
separating the frames.

• Because you cannot right-click in the interactive simulations, the system
displays a mouse and you must click the right mouse button to proceed.

• You must type values exactly as shown, because the system is case
sensitive. If you type an incorrect value, the system displays an error
message and prompts you to reenter the value.
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• If you lose your place, and you want the system to prompt you about what
you should do next, click anywhere on the screen.
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Lesson

1 Introducing Teamcenter Express

Purpose

The purpose of this lesson is to introduce you to the Teamcenter Express
interfaces.

Objective

After you complete this lesson, you should be able to:

• Understand the Teamcenter Express rich client and thin client uses.

• Start a Teamcenter Express rich client and thin client session.

• Be familiar with the Teamcenter Express rich client and thin client
interfaces.

Help topics

Additional information for this lesson can be found in:

• Getting Started With Teamcenter Express

• Rich Client Interface Guide

• DHTML Thin Client Help
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Teamcenter Express user interfaces
Teamcenter Express user interfaces include the rich client interface and the
thin client interface.

• The rich client interface is used by authors who are responsible for the
design and configuration of product data, manufacturing authors who
are responsible for creating and maintaining processes and process
structures, administrators responsible for configuring and maintaining
Teamcenter Express, and other users who require extensive authoring
access to data stored in the Teamcenter Express database.

• The lightweight thin client interface is used by consumers, manufacturing
consumers, and reviewers who need to view data, including product
structure, approve data attached to a workflow task, or view 2D drawings
and 3D models. The thin client interface is ideal for suppliers, production
staff, and other users who do not require extensive authoring or
administrative access to Teamcenter Express.
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Rich client interface

The Teamcenter Express rich client is a Java application that runs
on client hosts and serves as a gateway to your company’s product
information. You can integrate and run Teamcenter Express’ product data
management applications along with other applications, such as Microsoft
Office applications, custom applications, Java Plug-ins, or CAD/CAM/CAE
applications, all from a common platform. The rich client accesses Teamcenter
Express databases using a remote or local server.

To start a Teamcenter Express rich client session, do one of the following:

• Choose Start→Programs→Teamcenter Express V5→Teamcenter
Express V5.

• Double-click the Teamcenter Express shortcut on your desktop.

Tip

If you do not have a Teamcenter Express shortcut, choose
Start→Programs→Teamcenter Express V5, right-click Teamcenter
Express V5, and choose Send To→Desktop.

The system displays the Getting Started window.
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The area on the left side of the Getting Started window is called the
navigation pane. It provides quick access to the data you use most.

The following are some of the actions you can perform from the Getting
Started window:

• Search for any item in Teamcenter Express.

• Access other Teamcenter Express applications.

• View or edit a product structure or bill of materials (BOM).

• Open your worklist.
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Thin client interface

The Teamcenter Express thin client provides an access point to your data
over the Web using a Web browser configured to use the Sun Java runtime
environment. Thin client access is available to the same Teamcenter Express
server and data as the rich client uses; no thin client software is required on a
Teamcenter Express client.

The following are some of the advantages of the thin client:

• Brings product-related data to the desktop

• Simplifies distribution, maintenance, and upgrade-related issues

• Increases the interaction of data consumers, casual users, and remote
users

• A full install of Teamcenter Express is not required

In this training, you use Internet Explorer as your Web browser.

Tip

As with other frequently visited Web sites, you may find it helpful to
create a bookmark (Favorites) to the Login page.

To start a Teamcenter Express thin client session:

1. In the Web browser Address box, type the address of the
Teamcenter Express application server in the following format:
http://machine_name:port_number/application_name/webclient

machine_name is the network name of the system on which the Web
server is running, port_number is the port on which it is configured to
listen for requests, and application_name is the deployed application
name (default is tc). For example: http://tcx3train:8080/tc/webclient.

The system displays the Teamcenter Login page.

2. Type your user name and password.

3. Click Login.
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The system opens the Home folder in My Teamcenter.

The area on the left side is called the navigation pane. It provides quick
access to the data you use most.

The following are some of the actions you can perform from the thin client
window:

• Search for any item in Teamcenter Express.

• Access other Teamcenter Express applications.

• Open your worklist (previously called the inbox).
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Summary
In this lesson, you learned:

• Teamcenter Express has two user interfaces: the rich client interface
and the thin client interface.

• How to start a rich client and a thin client session.
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Lesson

2 Getting started with Teamcenter
Express rich client

Purpose

The purpose of this lesson is to show you the basics of using the Teamcenter
Express rich client interface and help you become familiar with the
components of the My Teamcenter window.

Objective

After you complete this lesson, you should be able to:

• Start and exit Teamcenter Express.

• Select applications.

• Identify the components of the My Teamcenter window.

• Open the Getting Started window.

• View and change group and role settings.

• Modify details columns.

• Access the online help.

• Work with folders.

• Perform general database searches and reference database objects.

• Use the cut, paste, and append functionality.

Help topics

Additional information for this lesson can be found in:

• Getting Started With Teamcenter Express

• Rich Client Interface Guide

• Structure Manager Guide
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Teamcenter rich client perspectives and views
Within the Teamcenter rich client user interface, functionality is provided
in perspectives and views. Use perspectives and views to rearrange how the
functionality is presented.

Perspectives Are containers for a set of views and editors that exist within
the perspective.

• A perspective exists in a window along with any number
of other perspectives, but only one perspective can be
displayed at a time.

• You can add and rearrange views to display multiple sets
of information simultaneously within a perspective.

• You can save a rearranged perspective with the current
name, or create a new perspective by saving the new
arrangement of views with a new name.

Views Enable you to navigate a hierarchy of information, display
information about selected objects, open an editor, or display
properties.

• Views that work with related information typically react
to selection changes in other views.

• Changes to data made in a view can be saved immediately.

• Any view can be opened in any perspective, and any
combination of views can be saved in a current perspective
or in a new perspective.

2-2 Teamcenter Express Collaborative Product Data Management MT15330-S-041





Getting started with Teamcenter Express rich client

Rich client interface
The rich client interface has a standard menu bar and toolbar with options
that vary depending on the currently active application perspective. You
can place the cursor over a rich client toolbar button to display a tool tip
description.

1 Back and
Forward

The Back and Forward buttons allow you to move
between loaded Teamcenter applications. The
small arrows next to the buttons let you select
from the list of currently loaded applications.

2 Application
banner

The application banner shows the name of the
active application and lists the current user and
role. You can double-click the user and role to
display the User Settings dialog box in which you
can change your current role if multiple roles are
available to your user.

3 Search box The Search box provides predefined quick
searches using dataset, item ID, item name,
keyword search, and advanced search features.

2-4 Teamcenter Express Collaborative Product Data Management MT15330-S-041



Getting started with Teamcenter Express rich client

4 Navigation pane The navigation pane provides quick access to
the data you use most. In addition to finding,
organizing, and accessing your data, you
can configure the display of the Teamcenter
perspective buttons in the navigation pane to
display only those perspectives that you use
regularly to perform your tasks.

5 Application pane The application pane displays the application
perspectives that are open in your Teamcenter
session. By default, the Getting Started
application perspective displays a single Getting
Started view.

Note

Application perspectives are composed of
views that can be moved elsewhere in the
Teamcenter window, or can be dragged out
to the desktop. Such detached views remain
connected to Teamcenter and continue to
function in concert with other views.

6 Getting Started
application
button

Provides access to the Getting Started application.

7 Primary
applications

Primary application buttons provide access to
your most frequently used Teamcenter application
perspectives.

8 Secondary
applications

Secondary application buttons provide access
to Teamcenter application perspectives you use
infrequently.
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9 Clipboard The clipboard contains references to objects that
have been cut or copied from your workspace. The
number of objects on the clipboard is displayed
to the right of the icon.

Note

When you select an information object, such
as an item, in a Teamcenter rich client
application, information about the selected
object is shown in the information center.
The information center is located at the
bottom of theTeamcenter window, to the left
of the clipboard.
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Start Teamcenter Express rich client
1. From the Quick Links section of the navigation pane, click any of the links

or click any of the tabs at the bottom of the navigation pane.

The system displays the logon dialog box.

2. Fill in all required boxes, which are indicated by red asterisks.

3. Select the database to which you want to connect in this session.

4. Click Login.
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Key points

The following are key points on starting Teamcenter Express rich client
interface and applications:

• The rich client interface is a stand-alone program, which allows you to
launch the interface without logging on.

• When you initially start Teamcenter Express, no applications are selected.

• When you select an application, you are prompted to log on.

• As you select applications, the system loads applications into memory.
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Activity: Start Teamcenter Express

This activity takes about five minutes.

Note

Before you start this activity, be sure you are familiar with the
information in How to use this course.

In this activity, you start Teamcenter Express.

Step 1: Start Teamcenter Express.

From your desktop, double-click the Teamcenter Express icon

.

The system displays the Getting Started window.

Step 2: Log on to Teamcenter Express.

From the Quick Links section in the navigation pane, click
(top left).

The system displays the Login dialog box.
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Step 3: Type your user ID and password (bjorn/bjorn).

In the Login dialog box, type your user ID and password
(bjorn/bjorn) and click Login.

Note

You must type values exactly as shown, because the
system is case sensitive. If you type an incorrect value,
the system displays an error message and prompts you
to reenter the value.

The system displays the My Teamcenter window and the Home
folder for Bjorn.

Step 4: Close the navigation pane.

Choose Window→Navigation Pane.

The system closes the navigation pane.

This concludes the activity.

2-10 Teamcenter Express Collaborative Product Data Management MT15330-S-041



Getting started with Teamcenter Express rich client

Select applications
To start applications in the rich client, do one of the following:

• From the Quick Links area, click the button of the application you want to
launch.

• Use the Send To menu command.

For example, to launch Structure Manager, select an item or item revision
object and choose Send To→Structure Manager.

Teamcenter Express Collaborative Product Data Management 2-11



Getting started with Teamcenter Express rich client

Group and role settings
Your system administrator has set up your account. The account consists
of the following:

• Person

Your actual name.

• User Name

Your Teamcenter Express account name.

• Group

Teamcenter Express preconfigured groups during the installation process.
The preconfigured groups are as follows:

– Express_Organization includes all users within the company.

– Engineering.Express_Organization includes all users with
engineering responsibility.

– Management.Express_Organization includes all users with
management responsibility.

A user may be in multiple groups. One group is designated as your
default group.

• Role

Inside a group, you (as a user) can perform multiple roles.

Take, for example, the person Bill Manager. His user name is bill, and he
is in two groups:

• Engineering (default group). Inside this group, Bill performs the
Author role, meaning that he has the capability to create and edit data.

• Management. Inside this group, Bill performs theManager role, which
gives him the capability to review, approve, and/or reject work submitted
for approval.

The My Teamcenter window frame displays the user name, group, and role
for the logged-on user:

Note

Clicking the window frame displays the User Settings dialog box, where
you can change your group, role, and other user information.
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Why have users, groups, and roles?

Using different groups and roles allows you to:

• Manage data access privileges (read, write, and delete).

• Define and control review/approve processes.

• Improve communication by providing information about users, such as
phone numbers and e-mail addresses.

• Organize data according to which group created it.

Teamcenter Express Collaborative Product Data Management 2-13



Getting started with Teamcenter Express rich client

View user, group, and role information

Teamcenter Express displays user, group, and role information in the
Organization Chart.

Note

Only a user with administrator privileges can make changes to the
Organization Chart.

1. Choose View→Organization.

2. To expand the groups and roles, click the + button or double-click the
group or role names.

3. To search for users, groups, or roles, use the buttons at the bottom of the
Organization Chart.
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Verify/change your group and role settings

Changing your group or role may require you to find or access data in the
system. Typically, you work from your default group and your data is created
with that group.

1. Choose Edit→User Setting or, from the window frame, click the user
information display:

The system displays the User Settings dialog box.

2. From the lists, select a group and role.

3. Click OK.

The system updates your group and role settings.
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Activity: Learn about My Teamcenter

This activity takes about 15 minutes.

Note

Before you start this activity, be sure you are familiar with the
information in How to use this course.

In this activity, you familiarize yourself with My Teamcenter.

Step 1: Learn about your Newstuff folder.

Select the Newstuff folder and click the Open button .

The system displays details about the Newstuff folder in the
application pane. There is nothing in your Newstuff folder.

From the toolbar, click the Inbox button .

The system displays the contents of your inbox.

From the toolbar, click the Home button .

Note

The Newstuff folder is still selected.

Verify your access to the Newstuff folder by looking at the
Information Center (bottom right corner of My Teamcenter).

Note

The Information Center displays the protections at a
glance.
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On the toolbar, click the Copy button .

To view the clipboard contents, click the Clipboard button .

Click the Clear clipboard contents button .

Click Close.

Close My Teamcenter by clicking the x on the right side of the
window title bar.

Step 2: Return to your Home folder.

Click the Open My Teamcenter or Worklist link.
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Step 3: View your group and role setting.

Choose Edit→User Setting.

Verify your group and role settings but do not change them.

Click Cancel.

This concludes the activity.
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Modifying properties columns in My Teamcenter
You can modify the properties columns in My Teamcenter by:

• Sorting columns.

• Changing the column width.

• Removing/inserting columns.

• Clicking a column header and dragging it to a new location.

You can also sort the rows in the Details view by column contents and print
the contents of the Details view in table format.

Tip

It is good practice to leave the Object and Type columns as the first and
second columns in the Details view.

Also, display only the column options you view/change frequently. The
more columns you display, the longer it takes to expand the folders
and items.
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Add columns to the Details view

1. In the upper right corner of the Details view, click the Menu button .

2. Choose Column.

The system displays the Column Management dialog box.

3. In the Available Properties list, select attributes and then click the Right
arrow button.

4. Set the display order of the columns using the Up and Down arrow
buttons.

5. Click Apply to insert the columns into the current view.

6. Click Cancel to close the dialog box.

The system dismisses the dialog box and displays the columns you
selected.
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Activity: Modify properties columns

This activity takes about five minutes.

In this activity, you modify the properties columns in My Teamcenter.

Step 1: Add columns for Date Released and Description next to the
Release Status column.

Click the Menu button and choose Column.
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The system displays the Column Management dialog box.

Hold down the Ctrl key and select Date Released and
Description.
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Click .

Click Apply.

Click Close.

The system displays the Date Released and Description
columns in the Details view.
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This concludes the activity.
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Working with folders
Folders are used in Teamcenter Express to organize data. This is a typical
folder symbol in Teamcenter Express: .

Key points

The following are key points about folders:

• Folders can be used as a tool to organize both company-wide and
individual user data.

• Your company may create a visual method of organizing data using folders.

• Any number of folders can reference the same data.

• Folders can be nested to practically any extent desired.

• A folder in Teamcenter Express is not the same as a directory in the
operating system.
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Home, Newstuff, and Mailbox folders

The system automatically creates three folders, and you cannot move or
delete them.

My Teamcenter always contains the default folders:

• Home folder

All objects you want to access with My Teamcenter are placed within your
Home folder or within some folder structure beneath the Home folder.

• Mailbox folder

Is the receiving point for any Teamcenter Express mail sent to you. When
you receive new Teamcenter Express mail, you see an envelope display
next to the clipboard. After expanding your mailbox and reviewing your
messages, the envelope indicator disappears.

• Newstuff folder

Is the default folder for newly created database objects. You can designate
other folders as the default location for newly created database objects.

2-26 Teamcenter Express Collaborative Product Data Management MT15330-S-041



Getting started with Teamcenter Express rich client

Folder object behavior

The folder symbol toggles between a closed and open state.

To expand or collapse a folder, do one of the following:

• Click the + or – button next to the folder symbol.

• Double-click the folder symbol.
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Create folders

Folders are a flexible way to organize your product information. A folder can
contain other objects and/or other folders.

1. Choose File→New→Folder.

Tip

You can also use the Ctrl-f key combination to access the New
Folder dialog box.

The system displays the New Folder dialog box.

Note

Red asterisks indicate required boxes.

2. In the Name box, type a name for your folder. This box has a limit of
32 ASCII characters.

3. (Optional) In the Description box, type a description. This box has a limit
of 240 characters.

4. Click OK.
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Rename folders

You can change the name of the folder you create, as needed.

1. Select the folder you want to rename.

2. Choose View→Properties or right-click and choose Properties.

The system displays the Properties dialog box for the selected folder.

3. Click the Check-Out and Edit button.

The system displays a confirmation dialog box.

4. Click Yes.

5. In the Name box, type a new name.

6. (Optional) In the Description box, change or add text.

7. To save the changes, click Save.

8. To check in the folder, click Check-In.

The system displays a confirmation dialog box.

9. Click Yes.
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Move folders

Reorder the folders in your Home folder structure by moving them up or down.

1. Select a folder.

2. In the upper right corner, click the Menu button .

3. Choose Move→Up/Down.

The system moves the folder up or down one level, as you specified.

Reorder the folders in your Home folder structure by moving them to the
top or bottom.

1. Select a folder.

2. In the upper right corner, click the Menu button .

3. Choose Move→Top/Bottom.

The system moves the folder to the top or bottom of the folder structure,
as you specified.
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Delete folders

When deleting a folder, the contents of the folder are not deleted. The folder
contents remain in the database and you can locate and retrieve them using
the search feature in My Teamcenter.

1. Select the folder you want to delete.

2. On the toolbar, click the Delete button .

The system displays a confirmation dialog box.

3. To list the objects selected for deletion, click the More link.

4. Click Yes.
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Print folders

When you choose to print a folder, the system prints the folder name and a
listing of the folder contents.

1. Select the folder you want to print.

2. Choose File→Print.

3. From the Client Printer list, select the printer to which you want to print.

4. Print a watermark, such as your company logo, by doing one of the
following:

• Entering some text in the Watermark Text box

• To the right of the Watermark Path, clicking the Browse button to
point to a file that contains watermark text or graphic
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Perform a general query
Use the search feature to locate data in the database. Teamcenter Express
uses predefined query forms as templates for entering your search criteria.
These query forms provide a fast, form-based interface to locate data.

Typically, you perform a search to locate data and then transfer it to another
application to begin your work.

Using the General query form, you can search the database for many different
types of workspace objects (for example, folders or datasets).

1. On the toolbar, click the Search button .

The system displays the Search view.

2. Click the arrow to the right of the Change Search button and then
click General.

3. Clear the contents of the query form boxes by clicking the Clear all search
fields button .

4. In the Name box, type the name of the database object of interest.

Tip

If you do not know the exact folder name for which you are
searching, you may use wildcard characters in the Name box to
broaden the search, as follows:

• Use an * (asterisk) to replace a string of any length.

• Use a ? (question mark) to replace a single character.
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5. (Optional) In the Description box, type the description, or part of a
description, that may have been defined by the object’s creator.

6. Click the Type box.

7. In the Value box, type Folder and then press the Enter key.

8. From the Owning User and Owning Group lists, select the appropriate
user and group. If you do not know the owning user or owning group,
leave these options blank to search for an object that you do not own.

9. To set other search options, in the upper right corner, click the Menu
button and select more options for your search.

10. Click the Go button .

The system displays the Search Results view. The name on the query
header matches the name of the query form you used.

Note

The system adds a number to the name of the query so if you run
multiple queries using the same form, you can differentiate between
query results.

11. To see a list of previous searches, in the Search Results view, click the
Previous Searches button .
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Rename search results

Because you can simultaneously open multiple query components in your My
Teamcenter window, you may want to rename the search result to make your
workspace easier to use and to help you remember the details of the search.

1. Right-click the first item in the search results tree and choose Rename.

2. Type a name for your query, such as Find Orientation and then press
the Enter key.

Key points

The following are key points about search results:

• Dynamic display allows you to work with objects in the search results
window.

• The system maintains the active query results between sessions in the
Open Items on the Navigation pane.

• You can compare search results to other search results or to the contents
of your Home folder.

• You can rename, save, or print the search results.

• Use the Summary view to view additional data related to the objects
in the search results.
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Activity: Find and work with folders

This activity takes about 20 minutes.

In this activity, you use the search feature to find the Orientation folder.

Step 1: Find the Orientation folder.

On the toolbar, click the Search button .

The system displays the Search view.

Click the arrow to the right of the Change Search button
and then click General.

Clear the contents of the query form boxes by clicking the Clear
this query form button .

In the Name box, type orient*.

Note

Be sure to type the search term exactly as shown, or the
search will not work (note the *).

Click the Type box.

In the Value box, type Folder and then press the Enter key.
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Click the Go button .

The system displays the search results at the bottom of the
application pane. The name of the pane matches the name of
the query form you used.

Step 2: Rename the search result to help you remember the details of the
search.

Right-click the first item in the search results tree and choose
Rename.

Note

Because you cannot right-click in the interactive
simulations, the system displays a mouse and you must
click the right mouse button to proceed.

Type a name for your query: Folder, Orient* and then press
the Enter key.

The system displays the new name.

Step 3: Close the Search Results view by clicking the x to the right of
the Search Results view title.

Step 4: Close the Search view by clicking the x to the right of the Search
view title.

Step 5: In the Home folder, create a new folder named My Folder.

Choose File→New→Folder.

In the Name box, type My Folder.

Click OK.

The system displays the folder in your Home folder.
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Step 6: Rename the new folder you created.

Select your new folder and choose View→Properties.

The system displays the Properties dialog box for the selected
folder.

Click the Check-Out and Edit button.

The system displays the Check Out dialog box.

Click Yes.

In the Name box, change My Folder to Items.

Click Check-In.

The system displays the Check In dialog box.

Click Yes.

This concludes the activity.
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Referencing database objects
While it appears that object folders contain other objects (because that is
what you see), the folders actually contain pointers or references to the objects.
The distinction is subtle but very important. Several folders can contain
references to the same object. That object, however, is stored only once in
the Teamcenter Express database.

Therefore, these folders provide pointers to the same product information and
allow product information to be shared throughout your enterprise, without
having to make multiple physical copies of the data.
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Using Cut, Copy, Paste, and Append buttons
To modify an object reference, you can select the object and use the Cut,
Copy, and Paste buttons.

To retain the existing objects in the clipboard while adding to the clipboard
contents using the Cut and Copy options, select the Append check box.

Key points

The following are key points about the cut, copy, paste, and append functions:

• These are clipboard options, which means that they place information on
the clipboard (using cut or copy) and paste it to another location.

• These options affect only the references to objects stored in the database;
they do not cut, copy, or paste actual objects.

• Cut takes the object’s reference out of the folder and places it on the
clipboard. It does not delete an object from the database.

Any existing objects in the clipboard are overwritten by the cut objects.

Tip

To actually delete an object from the database, use the Delete option.

• Copy places a new reference to the object on the clipboard; the original
reference to the object remains in the folder.

Any existing objects in the clipboard are overwritten by the copied objects.

• Append, when selected, adds the selected objects to the clipboard contents.

The existing objects in the clipboard are retained.
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Note

The Append check box is located on the Clipboard Contents
dialog box. You can access the clipboard dialog box by clicking the
Clipboard button.
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• Paste places a reference to the object or objects that are in the clipboard
into the selected folders. The object reference is not taken off the
clipboard, so you can perform multiple paste operations.

Tip

To select multiple objects, hold down the Shift key to select objects in a
range or the Ctrl key to select objects in a discontinuous range.
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Activity: Modify object references

This activity takes about five minutes.

In this activity, you use the copy and paste actions to place the 6505-Roller
Skate folder into the Home folder.

Step 1: Find the 6505-Roller Skate folder.

On the toolbar, click the Search button .

Click the Clear this query form button .

In the Name box, type 6505*.

Click the Type box.

In the Value box, type Folder and then press the Enter key.

Click the Go button .

The system displays the search results in the application pane.

Close the Search view by clicking the x to the right of the
Search view title.

Step 2: Copy and paste the 6505-Roller Skate folder into the Items folder.

From the search results, select the 6505-Roller Skate folder.

Right-click and choose Copy.

Select the Items folder and then right-click and choose Paste.

Step 3: Expand the 6505-Roller Skate folder to view its contents.

Click the + button next to the 6505-Roller Skate folder.

This concludes the activity.
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Log off of Teamcenter Express
1. Choose File→Exit.

The system displays the Exit dialog box.

2. Click Yes.
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Activity: Exit Teamcenter Express

This activity takes about five minutes.

In this activity, you exit Teamcenter Express.

Step 1: Exit Teamcenter Express.

From the Teamcenter Express menu bar, choose File→Exit.

The system displays the Exit dialog box.

Click Yes.

Teamcenter Express closes.

This concludes the activity.
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Summary
In this lesson, you learned:

• My Teamcenter is your window into the database.

• The folder symbol toggles between a closed and open state. Double-click
a folder to open or close it.

• To return to the Home folder, click the Home Folder button .

• Display only the column options you view/change frequently.

• To find or access data in the system, you may have to change your group
or role. To verify and/or change your current group/role setting, choose
Edit→User Setting and choose Session.

• Use My Teamcenter to store references to objects you access frequently.

• My Teamcenter always contains three default folders: Home, Mailbox,
and Newstuff.

• To find an existing folder, click Search and perform a general query with
the Type set to Folder. If you do not own the folder, be sure to clear the
Owning User and Owning Group boxes.

• To change the name of a folder, select the folder, choose View→Properties,
type a new name and click OK.

• To delete a folder, select the folder and choose Edit→Delete.

• When you delete a folder, the system does not delete the folder contents.

• For data that you need to access frequently, you should copy/paste a
reference to it in the Home folder.

• The Cut, Copy, and Paste buttons only cut, copy, and paste references to
objects stored in the database; they do not cut, copy, and paste actual
objects.

• To add objects to the clipboard (using the Cut or Copy option) without
overwriting the existing contents of the clipboard, select the Append
check box.

• To select multiple objects, hold down the Shift key to select objects in a
range or the Ctrl key to select objects in a discontinuous range.
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Lesson

3 Finding and viewing data

Purpose

The purpose of this lesson is to demonstrate how to find and view data in
Teamcenter Express.

Objective

After you complete this lesson, you should be able to:

• Execute searches to find item objects.

• View file and form data associated with items.

• Set the Item Display option to filter the item revision display.

• Generate reports.

Help topics

Additional information for this lesson can be found in:

• Getting Started With Teamcenter Express

• Rich Client Interface Guide
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What are items?
Items are the fundamental objects you use to manage information in
Teamcenter Express. Items are generally used for data that is configuration
or revision-controlled.

Use items to collect different types of business data, such as CAD files for
products and document files. Do not, however, use items to store other items.

Each item has a label containing two separate pieces of information:

• Item ID

A unique identifier for that item; no two items can have the same item ID.
Generally, you can think of item ID as part number or document number.

In figure 3-1, S001–3261401 is the item ID.

• Item Name

A short description, usually for logical names, such as bolt, bracket, or the
title of a document.

In figure 3-1, Wheel is the name of the item.

Figure 3-1. Item number/rev

Note

Company standards dictate conventions for the item IDs and item
names used at your site.
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Key points

The following are key points about items:

• An item can be thought of as a package that contains all data related
to that item.

• Each item has at least one item revision.

• Items store all revisions of the item.
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What are item types?
The term item describes all types of items that exist in the system. To
effectively search for an item in the system, you should search for a specific

type of item. This is the item symbol in Teamcenter Express: .

Siemens PLM Software provides the following types of items in the initial
setup for Teamcenter Express:

Document Commonly used for data stored in the system that
represents revision or configuration controlled documents,
such as procurement specifications, test procedures, and
design specifications. Generally, you search for this type of
item to retrieve the files (word processor or spreadsheet,
for example) associated with the type of document.

Engineering
order (EO)

Holds all data related to an engineering change. Also
used as part of workflow to route change information.

Item Commonly used for data stored in the system that
represents manufactured products, such as parts,
subassemblies, end-items, and tools. Generally, you
search for this type of item to retrieve CAD files and other
file representations of part data, such as 2D or 3D images
of drawings or models, or to view the bill of materials for
your product.

Review_Pckg Holds data to be shared through e-mail with people who
do not have Teamcenter Express.

Standard Used for standard or purchased parts. Companies
may decide to use this item type; however, it is not a
requirement.
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Find items
Teamcenter Express uses predefined saved queries as the basis for most
searches. These saved queries provide a fast form-based interface to the
database. Your system administrator can make other queries on an as-needed
basis.

1. On the toolbar, click the Search button .

2. Click the arrow to the right of the Change Search button and then
click Item.

Note

The Item query form includes the Item ID search attribute, which is
not found on the General query form.

3. To search for a particular item in the database based on its name, type
a name in the Name box.

4. To search for a particular item in the database based on the part number
or document number, type an item ID in the Item ID box.

5. To search for an item based on its type (for example, document or item),
use the Type box to select the type of interest.

6. To display the search results, click the Go button .
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Tip

If you only want to search for item ID, item name, dataset name, or
keyword, use Quick Search, at the top of the navigation pane.
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Special considerations
• Blank search boxes are not used for the search, meaning all values for

the box apply in the search.

• By default, the search is case insensitive, returning objects matching both
uppercase and lowercase.

• To broaden your searches, use the wildcard character * in the Name or
Item ID boxes. If you do not know the exact name or item ID, use:

– * (asterisk) to replace a string of any length.

– ? (question mark) to replace a single character.

• To access additional search criteria and specifications, at the top of the

Search view, click the Menu button and then select Preferences.

• To access the advanced search criteria, which is normally defined by
the Teamcenter Express administrator (such as doing a search within a

search), click the arrow to the right of the Change Search button
and then select a type of search.

3-8 Teamcenter Express Collaborative Product Data Management MT15330-S-041



Finding and viewing data

Viewing objects
You can view objects as follows:

• From the search results window

After you find an item, you can view the data from the search results or
you can transfer the item to another application to begin your work.

For example, you can expand the 07305-00-06 item to view the item
revision contents.

• From the Home folder

Viewing the objects from the Home folder is the same as viewing them
from the search results view. The difference is that objects in the Home
folder are there until you remove them. The advantage of keeping a
reference to the object in the Home folder is that you do not have to
perform the search to view the object at a later time.

Because the search results may be different a day or a month from now,
you may want to retain the query so you can access it during a later
session to access the results. The following activity shows how you
rename a query results view so you can easily recall what it contains. The
system displays the query view from session to session until you close
it (right-click and choose Close).
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You can also view objects graphically, using the Relation Browser (right-click
the object and choose Send To→Relation Browser). The associated Properties
view displays the properties of the selected object.

In the Relation Browser, you can right-click items and datasets and perform
operations on them.
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Activity: Find items

This activity takes about 15 minutes.

In this activity, you search for items and create references to them in the
Home folder.

Step 1: Find the 1250-Axle item.

Click the Search button .

In the Item ID box, type 1250.

Click the Go button .

The system displays the search results.

Step 2: Copy a reference to the 1250-Axle item into the Home folder.

From the search results, select the 1250-Axle item.

Right-click and choose Copy.

Return to the Home view, right-click Home and choose Paste.
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Step 3: Find all items for wheel components.

Return to the Search view.

Click the arrow to the right of the Change Search button
and then click Item.

Click the Clear this query form button .

In the Name box, type wheel.

Click the Go button .

The system finds the items in the database that are named
Wheel.
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Step 4: Rename the search results.

Right-click the first item in the search results tree, rename it
to Find Wheel, and then press the Enter key.

Step 5: Copy a reference to the 1503-Wheel item into the Home folder.

From the search results, select the 1503-Wheel item.

Right-click and choose Copy.

Return to the Home view, right-click Home and choose Paste.
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Step 6: Find all items with a name that begins with wheel.

Return to the Search view.

In the Name box, type wheel*.

Click the Go button .

Note

The system found more items this time because of
the wildcard character in the Name box. To enhance
performance, the system displays a maximum of 30
objects. The search page indicates if there are more
objects that met your search criteria, giving you an
opportunity to load them.
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Click the Next Page button .

Step 7: Rename the search results to Find Wheel*.

Step 8: Find an item that has the item ID BBDS5453.

Tip

To display more information for the item search, click the
More link.

Step 9: Copy a reference to the BBDS5453 document into the Home folder.

This concludes the activity.
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Compare search results
You can compare the results of one search to those of another search. Suppose
you want to compare the results of the following two queries:

• Item ID=15*

• Item ID=*15*

1. Execute a search using item Item ID=15*.

2. Rename the search results to Find 15*.

3. Execute a search using item ID=*15*.

4. Rename the search results to Find *15*.
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5. Right-click the first item in the search results tree and choose the
Compare To menu to select the other search.

The Compare Report dialog box displays the contents of the selected
components:

• Differences between the selected components are highlighted in green.

• Identical objects have a transparent background.

• The object currently selected is highlighted in a different color.
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• Use the arrows to click through each difference, one at a time.
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Activity: Compare search results

This activity takes about five minutes.

In this activity, you compare the results of two searches.

Step 1: Compare the results of the Find Wheel and Find Wheel* searches.

In the search results tree, right-click Find Wheel* and choose
Compare To→Find Wheel.

The system displays the Compare Report and highlights in
green the differences between the selected components.
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Step 2: Close the Compare Report dialog box.

This concludes the activity.
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View the contents of items
To view data in Teamcenter Express, search for the item of interest, then
expand the item to view the item revisions and other data about the item.

• The 1503-Wheel item has three item revisions: 000, 001, and 002.

• The numerical value 60 next to the 000 item revision indicates that it
has a release status.

• The in-process symbol indicates that the 001 item revision is in a
workflow process.

• The absence of a symbol indicates working data.
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Item revisions
Item revisions manage changes (revisions) to items.

Item revision labels are similar to item labels. The main difference is that
this label shows a revision identifier appended to the item ID.

Key points

The following are key points about item revisions:

• An item revision object can also be thought of as a package that contains
data for that item revision.

• Item revisions are what most users commonly access; use them to manage
changes and track history.

• When you create an item, the system automatically creates the first item
revision with it. As you make revision changes to the item, the system
creates additional item revision objects to represent the revision changes
in Teamcenter Express.
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Item revision release status
When viewing the revisions of an item in Teamcenter Express, you should
always observe the release status of the item revision. The release status
property of the object informs you about the function or purpose of the data.

The following list shows possible values for release status. This list is an
example developed for this training material. Your company may have a
different list of possible release status values with different meanings.

• 60

Data stored with item revisions that have obtained this status are
considered production data. The data is in a write-protected mode,
meaning it cannot be changed unless a new revision letter is created.

• Pre-Released

Data stored with item revisions that have obtained this status are also
in a write-protected mode and cannot be changed unless a new revision
letter is created. However, the data is not intended for production use.
The designer or engineer can arbitrarily apply this status to freeze the
data for use for building prototypes or for providing preliminary data
to customers and suppliers.

• ECPending

Data stored with item revisions that have obtained this status are not in a
write-protected mode and can still be changed. This status informs the
consumer of the data that this revision is currently in an engineering
change process. At the successful completion of the process, the release
status value changes to released.
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• (Empty Value)

If the item revision has no value for status, it is said to be working data,
meaning that someone is currently working on the data contained in the
item revision.

• Approved

Pertains to items of type document.
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Display items
You use the Options dialog box to define the behavior and display of objects in
Teamcenter Express. The system saves the changes you make in the Options
dialog box to the system database. For more information about setting
options, see My Teamcenter Guide.

In this section, you learn how to set conditions in the revision display filter so
that only certain item revisions display in the item hierarchy.

1. Choose Edit→Options.

2. Under the General options folder, select Item and click the Display tab.

The Display tab shows the Revision display filter form, which by default
is set to Show all revisions.

3. To enable access to the display filter settings, select the Show displayable
revisions only check box.

The system displays the Display Revision Relation dialog box.

4. Select the Displayable Revisions check box.

5. Click OK.
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6. To set the display filter, use the Rule and Condition options.

7. Click OK.

The system applies the filter, and displays in the item hierarchy only the
item revisions that meet the display filter criteria.

To view a list of the item revisions that do not meet the display filter
criteria, expand the More entries in the item hierarchy.
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Activity: Set the item display filter

This activity takes about 15 minutes.

In this activity, you set the item display filter to limit the revisions that
display in My Teamcenter to those that are released.

Step 1: Display the Options dialog box.

Choose Edit→Options.

Under the General options folder, select Item and click the
Display tab.

The Display tab shows the Revision display filter form.
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Step 2: Set the display filter.

Select the Show displayable revisions only check box.

Select the Displayable Revisions check box and click OK.

The system gives you access to the Rule and Condition options
for setting the filter.

Add a row to the table by clicking .
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To access the Rule list, double-click the cell in the Rule column
and select Release status.

To access the Condition list, double-click the cell in the
Condition column and select 60.

The system now limits the display to item revisions that are
released.

Step 3: To accept the entries and close the Options dialog box, click OK.

The system applies the filter, and displays in the item hierarchy
only the item revisions that meet the display filter criteria.

Step 4: Check the result of setting the item display filter.

In your Home folder, expand the 1250-Axle and 1503-Wheel
items and item revisions.

To view the item revisions that do not meet the display filter
criteria, expand the More entries in the item hierarchy.

Step 5: Set the revision display filter back to Show all revisions.

Choose Edit→Options.

Click the Display tab.

3-30 Teamcenter Express Collaborative Product Data Management MT15330-S-041



Finding and viewing data

Select the Show all revisions check box.

The Rule and Condition columns and options are shaded,
indicating that the filter is not active.

Click OK.

The system applies the filter and displays all item revisions
in the item hierarchy.

This concludes the activity.
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Item revision contents
When you expand an item revision, Teamcenter Express displays the item
revision contents.

Key points

The following are key points about item revision contents:

• Item revisions generally contain objects referred to as forms and/or
datasets.

– Forms represent attribute data for the item.

– Datasets represent physical data files for the item.

• Item revisions may also contain other objects, such as folders, and even
other item revisions.

• The contents of an item revision are dependent on the item type and how
a company chooses to organize data in the system.

The following sections describe the types of data you can have in an item
revision.

Requirement data

Requirement data is data that documents requirements for the item revision,
without explicitly defining the product. In the following example, the
BBDS5453 document is a design specification that was used during the
design of the part number 1250-Axle component:
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ItemRevision master data

The ItemRevision Master is a form that displays additional attributes, or
characteristics, specific to the item revision. Companies may change the
design of this form so that it collects and presents attribute data specific to
their business needs.

Selecting the form and the Viewer view displays the form contents.

Manifestation data

Manifestation data is data that is directly derived from the specification
data but is not considered defining data. For CAD-defined items, drafting,
manufacturing, and analysis data is often found under this heading:

Teamcenter Express Collaborative Product Data Management 3-33



Finding and viewing data

Reference data

Reference data may exist in a variety of different formats depending on the
type, purpose, and status of the item revision.

The following example shows a release checklist text dataset:

Specification data

Specification data is considered the defining data for the item revision. The
following example shows a UGMASTER dataset that contains the CAD
model data of a part definition. The UGMASTER dataset is specific to the
NX integration with Teamcenter Express:

To view all the files for the dataset, select a dataset and choose View→Named
References.
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Rendering data

The DirectModel is a 3D image format of the part model for viewing with
rich client Visualization. If you select the object and choose the Viewer view,
the file displays in the rich client Visualization application, if it is available
on your workstation.
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Activity: View item, form, and file (dataset) data

This activity takes about 10 minutes.

In this activity, you view form data contained within an item.

Step 1: View the data for the 1250/000-Axle item revision.

Expand the 1250-Axle item.

There are two item revisions for this item: revision 000 is
released, revision 001 is in progress. There is no value for
release status.

Expand the 1250/000-Axle item revision.

Double-click the 1250/000 item revision master form .
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The system displays the item revision master form.

To close the form, click Cancel.

Teamcenter Express Collaborative Product Data Management 3-37



Finding and viewing data

To view the part, choose the DirectModel object and
choose the Viewer view.

Step 2: Clean up the Home folder.

Choose the Details view.

Click the – button next to the 1250-Axle item.

Cut all the items (not folders) from the Home folder and paste
them into the Items folder.

Tip

To cut and paste, use the Cut and Paste buttons
from the toolbar.

This concludes the activity.

3-38 Teamcenter Express Collaborative Product Data Management MT15330-S-041



Finding and viewing data

Generate reports
Use the My Teamcenter Tools→Reports command to generate and view
reports.

Some default report designs are delivered with Teamcenter Express. Your
administrator can also create report designs using the Report Designer
application available in the Administration application group.

1. Choose Tools→Reports→Report Designer Reports.

2. Select a report design.

3. Adjust the query criteria and sorting options for the report.

4. Choose the output format for the report.

• Report contents can be sent to a comma-delimited file or output
formats defined by your site administrator.

• Output formats may include HTML and XLS files.

• Reports sent to an HTML output format are displayed in a browser.

• Reports sent to an XLS output format are displayed in a spreadsheet.

Tip

You can save or print the report using the Save and Print options
available in the output format tool you choose for the report.
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Activity: Generate a report

This activity takes about 10 minutes.

In this activity, you practice generating a report and viewing it in your
browser.

Step 1: Select the report design to use for the report.

From the My Teamcenter menu bar, choose
Tools→Reports→Report Designer Reports.

The system displays the Report Creation Wizard.

Select Admin - Object Ownership.
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Click Next.

The system displays the Fill in criteria form.

Step 2: Review and, if necessary, adjust the query criteria for the report.

Note

For this activity, we set the criteria as shown in the
simulation.

Click the Query Options button .

The system displays the Options dialog box. You use this
dialog box to view and adjust the additional criteria and sorting
options for the report.

Click the Sort Options tab.
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In the Name row, click the box in the Order By column and,
from the list, choose Descending.

Click OK.
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Step 3: Send the report contents to a comma-delimited file.

Click Finish.

The report generator determines how many items meet the
query criteria and displays an alert dialog box.

Click Yes.

The system displays the report.

Step 4: Click Close.

This concludes the activity.
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Summary
In this lesson, you learned:

• You generally use items to model revision-controlled data.

• An item can be thought of as a package that contains all data related
to that item.

• To search for items, from the query list, choose Item.

• Each item has at least one item revision.

• Item revisions store specific information about a particular revision of
an item.

• You can control which item revisions display in the item hierarchy using
the Item Display option.

• An item revision can contain different types of forms and datasets.

• A dataset is an object that stores and manages a collection of data files for
a particular application and purpose.

• Release status is an attribute assigned to an object after the object has
successfully gone through a Teamcenter Express workflow process.

• Report output can be created as a comma-delimited file, an XLS
spreadsheet file, or an HTML file that displays in a browser.

• Reports can be viewed, saved, and printed using the output tool you
choose when generating a report.
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Lesson

4 Creating data in Teamcenter
Express

Purpose

In this lesson, you create data using the Teamcenter Express interface.

Objective

After you complete this lesson, you should be able to:

• Create an item in Teamcenter Express.

• Populate forms within Teamcenter Express.

• Create a new dataset for an item created in Teamcenter Express.

• Perform an implicit and explicit checkout.

• Change ownership of data.

• Create a new item based on an existing item revision (File→Save As).

• Create a new revision of an existing item (File→Revise).

• Open an earlier version of a dataset.

Help topics

Additional information for this lesson can be found in:

• Getting Started With Teamcenter Express

• Rich Client Interface Guide
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Verifying user settings
Before creating any new data, you should verify that your user settings are
set to the correct values.

The user information display in the window frame shows your user settings:

If needed, change your user settings as explained in Lesson 2, Getting started
with Teamcenter Express rich client.

Having the correct user settings is important because any new data you
create inherits the Owning Group property from the user setting of the
user that created the data. The Owning Group property of the data is an
important property of the data in the context of access control (Read,Write,
Delete, and so on).
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Create items in Teamcenter Express
Use the New Item dialog box to create an item or add a new revision to an
existing item.

1. Select the folder to which you want to add the item and choose
File→New→Item.

Tip

You can also use the Ctrl-t key combination to access the New Item
dialog box.

The system displays the New Item dialog box.

2. From the list of types on the right, select Item.
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3. Click Next.

The system displays the Enter Item Information form.

Note

Red asterisks indicate required boxes.

Note

To let the system automatically populate the ItemID and Revision
ID boxes with an automatically-generated default item ID and
revision, click Assign. Otherwise, complete steps 4 and 5.

4. In the ItemID box, type a unique identifier for that item; no two items
can have the same item ID.

5. In the Revision ID box, type a unique revision identifier for the item
revision.

Note

Many companies use a special revision identifier to designate
the initial revision of any part or assembly. For example, some
companies use 000 for the first revision.

6. In the Name box, type a name for the item. The name is a short
description usually for logical names, such as bolt, bracket, or buckle.

Note

Some companies define specific conventions to use when assigning
an item name.

7. (Optional) In the Description box, type a description.
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8. (Optional) Select a Unit of Measure.

9. Click Finish.

The system creates the new item in the folder you selected.
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Create items using automatic part numbering

Out of the box, Teamcenter Express is configured to automatically generate
part numbers. If, however, your company has a unique part numbering
system, your system administrator can configure Teamcenter Express to
use your company’s system. Once the administrator configures and enables
Teamcenter Express to use your company’s system, you can select from
hierarchical lists of values to automatically generate part numbers.

When the administrator enables automatic part numbering, the New Item
dialog box includes a new option, as shown next:

1. Choose File→New→Item.

The system displays the New Item dialog box.

2. From the list of types on the right, select Item.

3. Click Next.

The system displays the automatic part numbering options, as set up by
your system administrator to meet your company’s requirements.
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4. From the lists, select the values you want to use.

5. In the Number box, type a value or click Assign.

6. Click Finish.

The system creates the part number with your specifications.

Delete an item

When deleting an item, the system also deletes the item master, item
revisions, and item revision masters.

The objects referenced by the item or item revision are not deleted. You can
access the referenced objects from the database using the Search option. You
can delete the contents of an item before deleting the item.

1. Select the item you want to delete.

2. Click the Delete button .
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Print an item

Printing an item prints the item name and the property values of the item.

1. Select the item you want to print.

2. Choose File→Print.

Rename an item

If you have write access to an item and the item does not have status, you can
change its name and/or its item ID. You can rename the following item types:
document, item, standard, and engineering order.

For more information about status, see Release status, in Lesson 5, Viewing
product structure.

1. Select the item you want to rename.

2. Verify that the item you want to rename does not have any status
associated with it.

3. Verify that you have write access (lower right corner).

Note

If you do not have write access for the selected item, the system
displays a red circle with a white dash on the write access symbol.

4. Choose Tools→Item Rename.

5. Type a new name and/or item ID.

6. Click OK.

Teamcenter Express Collaborative Product Data Management 4-9



Creating data in Teamcenter Express

Activity: Create an item in My Teamcenter

This activity takes about five minutes.

In this activity, you create a non-CAD item in Teamcenter Express.

Step 1: Create an item.

In My Teamcenter, select the Items folder.

Choose File→New→Item.

The system displays the New Item dialog box.

From the list of types on the right, select Item.

Click Next.

In the Item ID box, type BBMS2146_000 and press the Enter
key.

In the Rev box, type 000 and press the Enter key.

In the Name box, type Grease and press the Enter key.

From the Unit of Measure list, select OZ.

Click Finish.
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Click Close.

The system creates the new item in the Items folder.

Expand the Items folder to see the item you just created.

This concludes the activity.
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Activity: Create an item using automatic part numbering

This activity takes about five minutes.

In this activity, you create an item using the automatic part numbering
functionality.

Note

This functionality was enabled for this activity.

Step 1: Create an item.

In My Teamcenter, select the Items folder.

Choose File→New→Item.

The system displays the New Item dialog box.

From the list of types on the right, select Item.

Click Next.

The system displays the Compose Item ID form.

From the Component Type list, select BE (assembly).

Click Assign.

Click Next.

Click Assign.

In the Name box, enter Test.

Click Finish.

Click Close.

Step 2: View the newly created item.

Expand the Items folder to see the item you just created.

This concludes the activity.
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Populating items
Now that you created an item, the next step may be filling out forms and
adding file data to the item.

Populate the item revision master forms

Every time you create a new item or new item revision object, the system
automatically creates the item revision master form.

To access the item revision master form, expand the item and item revision
object.

To open a form to edit it, double-click the form and click Check-Out and Edit.
Or, select the form and choose the Viewer view.

Note

This form has been customized for this training class.
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Activity: Populate the item revision master forms

This activity takes about five minutes.

In this activity, you populate the item revision master form.

Step 1: Add data to the BBMS2146 item revision master form.

Expand the BBMS2146 Grease item and item revision objects.

Double-click the item revision master form,
BBMS2146_000/000.

Click Check-Out and Edit.

In the Release Reason box, type Test.

To save the changes and close the form, click Check-In.
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Step 2: View the data you entered in the form.

Choose the Viewer view.

The system displays the form in the Viewer.

This concludes the activity.
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What is a dataset?
Datasets manage data files created by non-Teamcenter Express applications.
Datasets are typically stored in item revisions. The symbol preceding the
dataset name may vary depending on the associated application. The
following are some example datasets.

Symbol Type File Purpose

Text .txt Text document

MSWord .doc,
.docx

MSWord document

MSExcel .xls, .xlsx MSExcel spreadsheet

DirectModel .jt 3D visualization models

UGMaster .prt UG part files

SE Part .par Solid Edge files

When you start non-Teamcenter Express applications from Teamcenter
Express, the files these applications generate are maintained by Teamcenter
Express. The object you use to manage these third-party files is called a
dataset.

Dataset object behavior

Double-clicking a dataset launches a software application and loads a file in
the application.
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Item and item revision relations
When you add data to an item revision, it is important that you define the
correct relation between the added data and the item revision. Teamcenter
Express uses the relation definition to control internal Teamcenter Express
functions.

Companies typically use many pieces of information that in some way
describe or relate to an item or item revision. Teamcenter Express uses the
concept of a relation to describe these associations (relationships).

When you create or add certain objects inside an item or item revision
structure, Teamcenter Express automatically defines many item or item
revision relations. These relation types are:

• Revision (for item revisions)

• BOM view and BOM view revision

For example, when you add a new item revision to an existing
item,Teamcenter Express automatically defines the new item revision as a
revision relation.
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In addition to the automatically defined relation types, the following relation
types are used with items and item revisions:

• Specification relations

Are detailed methods, designs, processes, and procedures used to satisfy
requirements. The specification fully defines the item revision.

• Manifestation relations

Are nondefining snapshots of a particular aspect of an item or item revision
at a particular moment in time. For example, numerically-controlled (NC)
program files are a common manifestation.

• Requirement relations

Are criteria that must be satisfied by this item or item revision. However,
requirements often do not specify how this criteria should be satisfied. For
example, a requirements relation might specify maximum weight for an
item revision but not how to construct it.

• Reference relations

Describe a general nondefining relationship of a object to an item or item
revision. This relation type can be thought of as a miscellaneous relation
type.

These relationships are typically defined when you paste an object reference
into an item or item revision using Edit→Paste or Edit→Paste Special.

Teamcenter Express Collaborative Product Data Management 4-19



Creating data in Teamcenter Express

Activity: Create datasets

This activity takes about 10 minutes.

In this activity, you create a dataset for the grease item. You create the
dataset using an existing .txt file.

Step 1: Create a dataset with a specification relation to the grease item.

Select the BBMS2146_000/000-Grease item revision.

Choose File→New→Dataset.

The system displays the New Dataset dialog box.

In the Name box, add - Spec Sheet to the end of the default
name.

Note

Be sure to enter a space between - and Spec Sheet.

Click the Import file button .

The system displays the Import File dialog box.

Double-click the bbms2146.txt file.

Click OK.

The system creates the dataset with the specifications relation.

Step 2: Create a dataset with a reference relation to the grease item. To
have a reference relation between the text dataset and the item
revision, create the dataset in the item revision and then cut and
paste to put it back into the item revision with a different relation.
If you create the dataset directly in the item revision, the dataset
has a specification relation to the item revision.

Choose File→New→Dataset.
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In the Name box, add - Suppliers to the end of the default
name.

Note

Be sure to enter a space between - and Suppliers.

Click the Import file button .

Double-click the bbms_supplier.txt file.

Click OK.

The system creates the dataset with the specification relation.

Select the BBMS2146_000/000-Suppliers dataset and click the
Cut button .

Select the BBMS2146_000/000-Grease item revision and
choose Edit→Paste Special, not Paste.

Note

You choose Edit→Paste Special instead of Edit→Paste
because Paste Special allows you to indicate how you
want to paste the dataset.

The system displays the Paste dialog box.

Select References.

Click OK.

The text dataset now has a reference relationship to the item
revision.

This concludes the activity.
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Dataset checkout
Use checkout and checkin procedures to ensure that two users do not
simultaneously update database objects. The capability to perform a checkout
is important because, in a group write environment, users must protect the
data while they work on it.

You can perform implicit and explicit checkout, as explained next.

Implicit checkout

Whenever you open a dataset to modify it, Teamcenter Express automatically
performs an implicit checkout. This means that nobody else can modify the
dataset while you work on it.

When you complete the modifications by closing the editing session, the
system automatically checks the dataset back into the database (the implicit
checkout is reversed).

Explicit checkout

You perform explicit checkouts manually.

The following are characteristics of an explicit checkout:

• Performing an explicit checkout locks a dataset against modifications by
other users whether you are currently editing the file or not.

• While a dataset is checked out, the user that performed the checkout has
write access, while other users have read access.

• (Optional) Use the Change ID box to correlate checked-out objects with
pending change management (Change Viewer) jobs.

• When checking out a dataset, you can also export the associated file to the
operating system by selecting the Export Dataset On Checkout check box.

To learn about dataset checkin and canceling checkout, see Check in data, in
Lesson 10, Releasing data.
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Activity: Modify the dataset

This activity takes about five minutes.

In this activity, you observe the implicit (automatic) checkout/in process and
perform an explicit (manual) checkout/in on a dataset object.

Step 1: Observe implicit checkout.

Select the BBMS2146_000/000-Grease item revision.

In the Details view, note the Checked Out column. This column
shows the checkout status of the dataset.

The checked out status of the BBMS2146_000/000-Suppliers
dataset indicates that the dataset is not checked out.

Double-click the BBMS2146_000/000-Suppliers dataset to
open it.
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To update the Details view, reselect the
BBMS2146_000/000-Grease item revision.

The dataset is currently checked out.

Close the text editor.

The dataset is no longer checked out.

Step 2: Modify the dataset.

Double-click the BBMS2146_000/000-Suppliers dataset.

In the box outlined with a gray box, type ACME Grease
Company and then press the Enter key.

Save the text file.

Close the text editor.
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Step 3: Perform an explicit checkout.

Choose Tools→Check-In/Out→Check-Out.

In the Comments box, type Long-term editing and then press
the Enter key.

Click Yes.

To update the Details view, reselect the
BBMS2146_000/000-Grease item revision.

The dataset is currently checked out. It remains in this state
until you choose to perform an explicit checkin.
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Step 4: Perform an explicit checkin.

Select the BBMS2146_000/000-Suppliers dataset and choose
Tools→Check-In/Out→Check-In.

When the system displays the message: OK to check in?,
click Yes.

To update the Details view, select the
BBMS2146_000/000-Grease item revision.

The dataset is no longer checked out.

This concludes the activity.
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View/modify dataset named references
Datasets can manage several different file types. These file types are called
named references. Use the Named References dialog box to view or modify
the named references for a dataset.

1. Select the dataset whose named references you want to view.

2. Choose View→Named References or right-click and choose Named
References.

The system displays the Named References dialog box.

3. To copy and paste named references between the Named References
dialog boxes of different datasets, use the Cut, Copy, and Paste buttons.
This method is easier than exporting the files and then importing them
back into the different datasets.
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Select dataset versions
When you make changes to datasets, Teamcenter Express creates new
dataset versions. You use these versions to track and undo changes by
reverting to a previous version of the dataset.

1. Select the dataset whose versions you want to view.

2. Choose File→Open With.

The system displays the Open With dialog box.

3. Specify a particular version of the dataset.

4. Specify an application (tool) to use for the current editing session.
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Key points

The following are key points about dataset versions:

• As work progresses and you successively modify a particular dataset, new
versions are added to the database but version-0 always references the
latest version of the dataset.

• The default version is the latest. In most cases, you should work with this
version unless you have some specific reason to open an earlier version.
This may be the case if you want to undo changes made in the latest
version.

• Normally, you only see the version-0 dataset in the My Teamcenter
workspace area; Teamcenter Express hides other dataset versions to
reduce clutter.

• Teamcenter Express manages multiple dataset versions until the version
limit is reached.

When the version limit is exceeded, the earliest version of the dataset is
purged from the database to make room for the new version.
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Note

Use the Latest Dataset Versions check box in the Preferences dialog
box to either show or hide dataset versions in search results. To display

the Preferences dialog box, click the Menu button and then select
Preferences.

Select the Latest Dataset Versions check box only if you want to show
dataset versions.
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Activity: Open an earlier version of a text dataset

This activity takes about five minutes.

In this activity, you view the named references of the
BBMS2146_000/000-Suppliers dataset and open a previous
version of the dataset.

Step 1: View the named references of the BBMS2146_000/000-Suppliers
dataset.

Select the BBMS2146_000/000-Suppliers text dataset.

Choose View→Named References.

The system displays the Named References dialog box.

Close the Named References dialog box.

Step 2: Open an earlier version of the BBMS2146_000/000-Suppliers
dataset.

Choose File→Open With.
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Select the Version list to see the previous versions of the
dataset.

Choose the second-to-last version number,
BBMS2146_000/000-Suppliers;1.
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Expand the Text Editor tool.

Select bbms_supplier.txt and click OK.

The previous version of the text file opens in a text editor.
The line of text added to this file in an earlier activity is not
included in this version of the dataset.

Exit the text editor.

This concludes the activity.

Teamcenter Express Collaborative Product Data Management 4-33



Creating data in Teamcenter Express

Change ownership
The owning user and owning group properties of the data can be modified
before the data is released.

Note

After release, the capability to change these properties is restricted to
the system administrator.

1. Select the object (multiple objects can be selected) whose ownership of
data you want to change.

2. Choose Edit→Change Ownership.

3. To select the owning user as a member of the owning group, click the New
Owning User button and navigate the organization chart.

4. To change only the owning group, select the current owning user as a
member of the new owning group.
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Create a new item from an item revision
For non-CAD items, use the File→Save As command to create a new item
from an existing item revision.

Note

Use Save As only to create items. To create item revisions, use the
Revise command.

1. Select an existing item revision object as the basis of the new item and
choose File→Save As.

The system displays the Save As dialog box.

2. To automatically generate the next available item ID and revision, click
Assign, or manually type an item and revision ID.

Note

The unit of measure and item type are carried over from the original
item and cannot be modified.

3. To create the new item and dismiss the dialog box, click Finish. To create
the item and continue to define data for the item, click Next.
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Create the next revision of an item revision
For non-CAD items, use the File→Revise command to create the next revision
of an existing item revision.

1. From the tree or the Details view, select an item revision to be the basis of
the new revision and choose File→Revise.

The system displays the Revise dialog box with the item ID and name of
the item revision already entered in the form.

2. Assign a value to the Revision ID box for the new item revision.

• To automatically generate the next available revision in the Revision
ID box, click Assign, or assign the revision manually by entering it in
the Revision ID box.

• (Optional) Type a description and select a unit of measure.
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• To continue, click Next.

The system displays the item master form.

3. Select and type information in the revise forms, as needed.

You can define the item master data or, using the links in the Steps
section, select another form and type the related information.

Note

The values for the item master and other information forms default
to the values from the source item revision. You can retain the
default values or define other information for the new item revision
using these forms.

4. Click Finish.

5. Click Close.

The system creates the item revision and displays it beneath the item
revision originally selected in the tree.
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Activity: Perform a Save As and Revise operation

This activity takes about 10 minutes.

In this activity, you perform Save As and Revise operations on an item of
type document.

Step 1: Create a new item of type document in the Newstuff folder.

In My Teamcenter, select the Newstuff folder and choose
File→New→Item.

From the list of types on the right, select Document.

Click Next.

To get the item ID and revision, click Assign.

Type a name (for this activity, use Test).

Click Finish and then click Close.
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In the Newstuff folder, expand the document and document
revision.

The system automatically creates a text dataset because of the
business rules that are in place.

Step 2: Create the next revision of the document based on the existing
revision.

Select the document revision and choose File→Revise.
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Click Finish and then click Close.

The system creates a new revision and a new dataset.

Step 3: Create a new document based on an existing document revision.

Choose File→Save As.

Click Assign.

Note

The system increments the item ID.
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Click Finish and then click Close.

The system creates the new document based on the existing
document.

Expand the new document and document revision.

This concludes the activity.
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Summary
In this lesson, you learned:

• Items are the fundamental objects you can use to manage information in
Teamcenter Express.

• Use item revisions to manage changes (revisions) to items.

• Use datasets to manage data files created by other software applications.

• To create a new item based on an existing item revision, use File→Save
As.

• To create the next revision of an existing item revision, use File→Revise.
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Lesson

5 Viewing product structure

Purpose

The purpose of this lesson is to demonstrate how to view product structure
using the Structure Manager application.

Objective

After you complete this lesson, you should be able to:

• Identify an item as an assembly.

• View product structure.

• Print product structure using Structure Manager.

• Compare product structure.

• View an assembly in Structure Manager.

• Change revision rules and view the results in Structure Manager.

Help topics

Additional information for this lesson can be found in the Structure Manager
Guide.
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What Is Structure Manager?
Structure Manager is the application within Teamcenter Express for creating,
viewing, and modifying product structure and its associated occurrence data.

You can use Structure Manager to do the following:

• Browse product structure

Allows you to see what the assembly structure of a product looks like, to
navigate around it easily, and find components when their location in
the structure is not known.

• Build and edit structure

Structure Manager offers a simple way to quickly create and modify
structure using cut, copy, and paste.

• Compare structures

You can compare two product structures to highlight any changes.

• Configure product structure

You can set rules to determine which revisions of components are
configured, or which components are effective.

• Load data in NX

Structure Manager allows you to load selected components of the
assembly in NX.

• Protect data from concurrent changes

If another user is editing an assembly (single level) within the product
structure, you are prevented from making changes until the other user
has saved their changes.
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How does Structure Manager work?
Structure Manager displays the information that resides in the BOM view
revision. Using Structure Manager, you can see the assembly structure of a
product, as shown in figure 5-1. You can navigate through the assembly to
find components and then access any data associated with those components.

Figure 5-1. View of assembly in Structure Manager
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BOM view revision object
When an item is an assembly, the system displays a BOM view revision object
for the item revision.

The BOM view revision object symbol, , identifies the BOM view revision
object.

Use BOM view revisions to manage product structure for item revisions. To
display a BOM view revision in Structure Manager, where you can create,
view, and modify product structure, double-click the BOM view revision.
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BOM view types
Teamcenter Express comes with one BOM view type: the view BOM view
type. Some companies rename the BOM view type or create additional BOM
view types. For example, a company could create an assembly BOM view
type to define the structure of the product as it is actually manufactured.
Additional entries for tools and manufacturing can be listed in the assembly
BOM that are not listed in the view BOM.

This training material uses the default view BOM view type. This BOM
view type defines the engineering or design bill of material. Engineers
and designers define a product structure view that best supports their
product development and change processes. This view of the product is often
functional in nature. It does not always reflect the actual assembly-build
sequence of the product for manufacturing.
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Launch Structure Manager
To view assembly structure, open the BOM view revision in Structure
Manager.

To launch Structure Manager, do one of the following:

• Select a BOM view revision and click the Open button .

• Right-click an item, item revision, or BOM view revision and choose Send
To→Structure Manager.

The system displays the selected object in Structure Manager.

When you launch Structure Manager, the menu bar and toolbars include
options specific to Structure Manager.

The revision rule setting for the currently loaded BOM view revision object
displays to the right of the item revision name, in the line above the column
headings.

In this example, the revision rule is Latest Working.
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Product structure display
Product structure is displayed in an indented BOM format similar to those
used in many CAD and enterprise resource planning (ERP) systems.

The product structure is displayed graphically with each component (line
in the BOM) represented by a node.

By looking at the product structure display, you can see which parts are piece
parts and which parts are assemblies. If a node has a + button next to it, it
means it is an assembly and you can expand it by clicking on the + button.
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Activity: View product structure in Structure Manager

This activity takes about five minutes.

In this activity, you become familiar with Structure Manager.

Step 1: Search for the 6120/000-Skate Assembly, Right item revision and
then send it to Structure Manager.

In My Teamcenter, search for the 6120-Skate Assembly, Right
item.

Tip

In the Item ID box, type 6120.

Close the Search view.

To see the BOM view revision, expand the 6120/000-Skate
Assembly, Right item and item revision.

Select the BOM view revision and click the Open button .

The system displays Structure Manager.
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Step 2: Expand the 3120/000-Boot Assembly, Right item.

To expand the 3120/000-Boot Assembly, Right item, click the
+ button.

Step 3: Close Structure Manager.

Close the Structure Manager view by clicking the x to the right
of the Structure Manager view title.

This concludes the activity.
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Modify product structure columns
To modify the product structure columns, right-click a column header and
remove/insert columns or click a column header and drag it to a new location.

Tip

You can also print the display by right-clicking and choosing Print Table.
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Create reports
When working in Structure Manager, you have two ways of creating reports.

To create reports using the Tools menu:

1. In Structure Manager, make sure that the BOM view is selected.

2. Choose Tools→Quick Report→Stock List Report.

The system displays the report in a browser. If you want, you can use the
browser’s print option to print the report.

To create reports using the Table Function Menu:

1. Make sure that a BOM view is displayed in Structure Manager.

2. Right-click the BOM Line column header and choose Print
Table®HTML/Text.
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The system displays the report in the Print dialog box in HTML format.

3. In the Print dialog box, you can do any of the following:

• To display the report in text format, from the top right corner of the
dialog box, select the Text check box.

• To open the report in a Web browser, click the Open in Web browser
button .

• To print the report, click the Print button .

• To save the report to a file, click the Save button .
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Release status
Each item revision has a release status property. The release status of an
item revision is shown in My Teamcenter in the Release Status column of
the Details view.

You can also view release status for an item revision by looking at the Item
Rev Status column in the Structure Manager window.

List of status types

The following is a list of possible values for release status:

• 30

Development release. Data stored with item revisions that have obtained
this status are also in a write-protected mode and cannot be changed
unless a new revision letter is created; however, the data is not intended
for production use. The designer or engineer can arbitrarily apply this
status to freeze the data for use in building prototypes or providing
preliminary data to customers and suppliers.

• 60

Production release. Data stored with item revisions that have
obtained this status are considered production data. The data is in a
write-protected mode, meaning that it cannot be changed unless a new
item revision is created.
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• 90

Obsolete. Data stored with item revisions that have obtained this status
are considered obsolete data. The data is in a write-protected mode,
meaning that it cannot be changed unless a new item revision is created.

• Empty value

If the item revision has no value for status, it is said to be working data,
meaning that someone is currently working on the data contained in the
revision.

Note

This list of release status types is the default one preconfigured in
Teamcenter Express. Your company may have a different list of possible
release status types with different meanings, which can be configured
in Teamcenter Express.
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Revision rules
Revision rules are parameters you set to determine which item revisions are
displayed for an item.

The revision rule keys off the value of the release status for the item revisions
that exist for an item.

By changing the revision rule, you can display different configurations of
an assembly.

In Structure Manager, the current revision rule setting displays to the right
of the item revision name, in the line above the column headings.

The current revision rule is displayed at the top of the Teamcenter Express
Web client window, after your user name, group, and role.

In this example, the revision rule is Latest Working.

Table 5-1 shows two examples of revision rules:

Table 5-1. Revision rules examples

Revision rule Details
Latest Working Precise, Working, Has Status
Any Status, No Working Has Status, Working

Note

Your system administrator configures the revision rules for your site.
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List of revision rules

The revision rules used for this training material are:

• Any Status; Working

Loads the latest statused revisions or, if none exist, the working revisions
of data.

• Latest Working

Loads the latest item revision regardless of its release status. With this
rule in effect, you are able to view work-in-progress item revisions.

• Any Status; No Working

Loads the latest item revision with a release status of Released. With
this rule in effect, you only view item revisions that are released.

• Precise Only

Loads the specific item revision that was in effect the last time the
assembly item revision was saved. If newer revisions of the components
of the assembly have been created since the last time the assembly was
saved, they do not display regardless of wether they have a release status
value or not.

• Released; Config by Date

Loads the item revision with a release status of Released and an
effectivity range that includes the date specified by the user by using
Tools→Revision Rule→Set Date/Unit/End Item.

Note

This list of revision rules is an example developed for this training
material. Your company may have a different list of revision rules.
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Access the revision display filter

Use the revision display filter in My Teamcenter to configure which item
revisions display for an item, based on established revision rules.

1. Right-click an item and choose Send To→My Teamcenter.
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The system launches the My Teamcenter tri-pane window.

The tri-pane window displays the item tree (top left section) and item
revision tree (bottom left section), as well as the standard My Teamcenter
panes.

2. To view additional information about the item, click the Details, Viewer,
or Impact Analysis views.
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3. To sort through item revisions, use the revision display filters accessible
from the Revision Selection button , located between the panes on the
left that display the item and item revision trees.

The system displays the Revision Selection dialog box.

4. From the Revision rule list, select a revision filter option.
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5. To filter the item revisions display, use the revision filter buttons:

Filters the item revisions to those that have Released status.

Filters the item revisions to those that have In-process status.

Filters the item revisions to those that haveWorking status.

In the results list, you can double-click an object to display it in the item
revision tree (bottom left section) or you can select and copy an object to
the clipboard for use in other Teamcenter Express applications.

Key points

The following are key points about the tri-pane window:

• The item tree (upper-left section) is a graphical display of a single item
reference and its associated objects, including all item revisions.

• The item revision tree (bottom left section) is a graphical display of a
single item revision reference and its associated objects.
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Change the default revision rule setting

When you log on to the system, a revision rule is in effect that controls which
item revisions you see listed when you view product structure (BOM). Your
system administrator sets up your default revision rule.

1. Choose Edit→Options.

The system displays the Options dialog box.

2. From the list on the left, select Structure Manager.

3. From the Default Revision Rule list, select the rule of interest.

4. Click OK.
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Set an ad hoc revision rule

Instead of changing your default revision rule, you can change the revision
rule in effect on an ad hoc or as-needed basis.

Note

Your system administrator can add, remove, or modify existing revision
rules for your site.

1. Do one of the following:

• From the Structure Manager menu bar, choose Tools→Revision
Rule→View/Set Current.

• On the Structure Manager toolbar, click the Revision Rule button .

The system displays the View/Set Current Revision Rule dialog box,
showing the list of available revision rules.

2. Select a rule.

3. Click OK.

The system displays in the Structure Manager window the corresponding
change to the assembly.
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Activity: Change a revision rule

This activity takes about five minutes.

In this activity, you view the 1510-Wheel Assy BOM while changing revision
rules to see which item revisions are configured.

Step 1: In My Teamcenter, search for the 1510-Wheel Assy.

Tip

In the Item ID box, type 1510.

Step 2: Send the 1510-Wheel Assy to Structure Manager.

Expand the 1510-Wheel Assy item.

Select the BOM view and click the Open button .

Note

The latest revision is viewable in Structure Manager: in
this case, 1510/002-Wheel Assy.

The system displays the Structure Manager window, showing the
components that make up the wheel assembly.

Note

The 1503/002-Wheel item does not have a value in the Item
Rev Status column. This is because the release status value
is currently Working.

As indicated in the window frame, the revision rule is currently set
to Latest Working. This setting permits the loading of components
in the following order of precedence:

Working components

Components containing a release status (of any type)

Step 3: Change the revision rule to Any Status; No Working and view
the results. When you select Any Status; No Working, the
system loads the latest item revision with a release status of
Released. With this rule in effect, you only view item revisions
that are released.

On the Structure Manager toolbar, click the Revision Rule

button .
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From the Rules list, select Any Status; No Working.

Click OK.

The configured revision of the 1503 revision item object is now 000.

Step 4: Change the revision rule to Working; Any Status and view the
results.

The configured revision of the 1503 item revision is now 002.

Step 5: Change the revision rule to Latest Working and view the results.

The configured revision of the 1503 item revision is still 002.

Step 6: Close Structure Manager.

This concludes the activity.
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Find detailed information while BOM browsing
While browsing the BOM of a product, you may need to find out more specific
information about individual components of the assembly.

For example, while exploring the 1600/000 BOM, you see the 1250/001-Axle
and want to view the part.

1. Select the 1250/001-Axle and send it to My Teamcenter.

2. Select the DirectModel dataset.

3. Choose the Viewer view.

You can also select and view any other files (dataset) or form data associated
with the item revision.
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Activity: View item data from Structure Manager

This activity takes about 20 minutes.

In this activity, you find and view the BOM of 1600-Wheel Assy and then
view file and form data of one of the 1600 components.

Step 1: In My Teamcenter, search for 1600-Wheel Assy.

Tip

In the Item ID box, type 1600.

Step 2: Copy and paste a reference to 1600-Wheel Assy into the Items
folder.

Step 3: Expand the Items folder.

Step 4: Open the 1600-Wheel Assy in Structure Manager.

Expand the 1600-Wheel Assy item and item revisions.
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Select the 1600/000-view BOM view revision and click the
Open button .

The system launches the Structure Manager window showing
the 1600/000-view BOM view revision.

Step 5: View the Visualization data for the 1600/000-Wheel Assy.

On the Structure Manager toolbar, click the Show/Hide Data

pane button .

Select the check box for the 1600/000-Wheel Assy (view).

The system displays the wheel assembly in the Viewer.
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Step 6: View the drawing for the 1250 Axle.

Right-click 1250/001-Axle and choose Send To→My
Teamcenter.

The system displays the contents of the 1250/001 item revision,
including the drawing data.

Select the SH1 dataset under the DWG1250/ object and choose
the Viewer view.
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Step 7: View the item revision master form data of the 1250/001-Axle
item revision.

Select the 1250/001 item revision master form.

The system displays the item revision master form in the
viewer.

This concludes the activity.
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Open multiple product structures in Structure Manager
Structure Manager can have multiple product structures open simultaneously.

In the following example procedure, the product structures for two item
revisions are open in Structure Manager at the same time.

1. In My Teamcenter, search for 1600/001.

2. Send 1600/001 to Structure Manager.

3. Click the Split window button (top right corner).

4. Click in the empty window to select it.

5. From the bottom left of the Structure Manager window, click the Open
object by name button .

The system displays the Open by name dialog box.

6. Search for 1600*.

7. Double-click the result.

8. To return to the one-structure window, in the top right corner of the
window you want to keep, click the Unsplit button .
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Activity: Compare product structures

This activity takes about 15 minutes.

In this activity, you open both the view and BOM data for two items so you
can compare the product structures.

Step 1: Send the 6510-view BOM view revision to Structure Manager.

In My Teamcenter, expand 6510-Skate Assy, Left.

Expand the 6510/000 item revision.

Select the 6510/000-view BOM view revision and click the
Open button .

The system launches the Structure Manager window showing
the product structure for the 6510/000-view BOM view revision.
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Step 2: Display the 6520/000-view BOM view revision in Structure
Manager.

Click the Split window button .

The system splits the window. One side displays the
6510/000-view BOM view revision and the other side is blank.

Click in the blank window.

The system makes the new window active.

From the bottom left of the Structure Manager window, click
the Open object by name button .

The system displays the Open by name dialog box.

In the ID box, enter 6520 and then press the Enter key.

Double-click the result.

The system replaces the blank window with a view of the
6520/000-view BOM view revision.
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Step 3: Compare the two BOM displays.

Choose Tools→Compare.

Select Single Level and click OK.

The system highlights the differences between the two
assemblies.

Close the BOM Compare dialog box.

Choose Tools→Clear Compare.

Close Structure Manager.

This concludes the activity.
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Summary
When an item is an assembly, you see a BOM view revision object that exists
for the item revision.

• Use BOM view revisions to manage product structure for item revisions.

• Opening a BOM view revision object launches Structure Manager.

• Structure Manager is the application within Teamcenter Express for
creating, viewing, and modifying product structure and its associated
occurrence data.

• If you want to view one of the parts in the BOM, you can send the item
revision from Structure Manager to My Teamcenter.

• Item revision configuration using revision rules is done by reading the
release status of the revisions. Release status is an attribute assigned to
an object after the object successfully goes through a release.
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Lesson

6 Sharing data outside of
Teamcenter Express

Purpose

The purpose of this lesson is to show how you can share data with users who
are not Teamcenter Express users.

Objective

After you complete this lesson, you should be able to:

• Create a review package.

• Add objects to the review package.

• Export a review package.

• Modify container file data.

• Import a container file.

Help topics

Additional information for this lesson can be found in Getting Started With
Teamcenter Express.
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Review packages
Before you can share data with users who do not have Teamcenter Express,
you must create a review package. Review packages hold the data you want to
send out. After you create a review package, you export it as a container file to
the local disk, with the option of distributing it through e-mail. You can also
import a container file back into Teamcenter Express and view its contents.

When you create a review package in My Teamcenter, the data in the review
package is accessible with the searching, browsing, and where-used and
where-referenced tools. When you import a container file and the system
creates a review item, the data in that review package is not accessible with
the searching, browsing, and where-used and where-referenced tools.

When you create a review package, the system creates two forms:

• Master form

Stores the name of the review package owner.

• Revision master form

Stores the details of the review package revision and its contents. Some of
the details are used to create a packaging slip when you create a container
file. The system updates the details for each export of the review package.
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Create a review package
You create an item of type review package just as you would create any
other item type.

1. Select the Home folder.

2. Choose File→New→Item.

3. Select Review_Pckg and click Next.

4. Click Assign.

5. Type a name for the review package.

Caution

Do not include spaces in the name.

6. Click Finish.

The system creates the review package item.

Note

If you did not type data in the item master and revision master
forms, you can type data later by clicking the forms, choosing the
Viewer view, checking out the forms, typing the data, checking in
the forms, and clicking Save.

7. Add objects to the review package as explained next.
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Add objects to a review package revision
When adding objects to a review package revision, you can use the Cut and
Paste or the drag-and-drop features, as well as a method of moving objects
that is specific to review packages, as explained next.

1. Before you can add objects to a review package revision, you must make
that review package revision active. To make it active, right-click the
review package revision and select Make Active Review Package.

Note

If you did not make any review package revision active, the system
assumes that the review package revision you created last is
the one that is active. If you are using the Cut and Paste or the
drag-and-drop features, you do not have to worry about making
review packages active.

2. Right-click the object you want to add to the review package revision
and choose Add to Review Package.

The system adds the object to the review package revision.

3. Export the review package revision as explained next.
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Export a review package revision
From My Teamcenter or from Structure Manager, you can export review
packages to the local disk. You can export review packages, as container
files, in two file formats: package collaboration file (.pcf) or .zip file format.
You view the resulting .pcf files in XpresReview, and the .zip files in the
appropriate viewer, depending on the format of the files included in the .zip
file. XpresReview is Siemens PLM Software’ free electronic design review
solution that allows you to easily share multiple documents in a collaborative
environment.

When exporting, you can also choose to e-mail the resulting file. If e-mailing,
note the following:

• The export feature only works with Microsoft Outlook.

• The file path of the attachment should not contain spaces.

• The file path of the attachment should not exceed 2015 characters.

1. Do one of the following:

• To export from My Teamcenter, right-click the review package revision
you want to export and choose Export Review Package.

• To export from Structure Manager, select the item revision you want
to export and choose Tools→Export→Objects. Verify that the Review
Package option is selected.

2. Select the export directory by clicking the Select object from system
button and browsing to the directory where you want to store the
exported review package.

3. From the Container Type list, select how you want to save the review
package to the local disk.

4. (Optional) Type the name of the recipient.

5. If you are exporting as a PCF, from the PCF Options section, select any
permissions to give to the .pcf file.

6. To e-mail the review package, select Attach to Email and type the
recipient’s e-mail.

Tip

If e-mailing several people, separate e-mails with the standard
Microsoft Outlook separator (;).
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7. Click the Select dataset types to be exported button .

Note

If exporting as a .pcf file, the system includes a limited number of
dataset types. If exporting as a .zip file, the system includes all
dataset types. You can move files between the include and exclude
lists using the arrow buttons located between the two lists.

8. Click OK in the Dataset Options dialog box.

9. Click OK in the Review Package Export dialog box.

The system exports the review package as a container file.

10. Modify the data in container files as explained next.
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Modify container file data
You modify data in container files differently, depending on the output format:
.zip or .pcf. In a real-world scenario, the person modifying the files would be
someone who does not have access to Teamcenter Express. After that person
modifies the files, you import them into My Teamcenter.

To modify data in .zip files:

1. Go to the directory where you exported the container file.

2. Double-click the .zip file to open it and double-click the individual files to
display them in the appropriate viewer. For example, a .doc file opens in
a text editor, a .html file opens in a browser, and so on.

3. Modify the files as needed.

To modify data in .pcf files:

1. Go to the directory where you exported the container file.

2. Double-click the .pcf file to display it in XpresReview.

Note

To learn how to work with XpresReview, see its online help
(Help→XpresReview Help).

3. Modify the files as needed.
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Import a container file
When importing a container file into My Teamcenter, you can select the
following object types to which to import the container file:

• Item revision
The system creates a new dataset with the item revision ID, attaches the
dataset to the selected item revision, and attaches the container file to
the dataset as a named reference.

Note

If you select to import the container file to an item, the system
informs you that the container file cannot be imported directly to an
item. Instead, the system imports the file to the latest item revision.

• Folder
The system creates a new review package with an assigned ID, and places
it in the selected folder.

Note

If you do not select anything, the system creates a new review
package in the Newstuff folder and attaches the container file to
the newly created review package revision.

1. Select an object to which to import the container file and choose
Tools→Import→Objects.

2. From the left side of the dialog box, select Review Package.

3. Click the Select object from system button .

4. Double-click the file you want to import.

Note

If you are importing to a folder or an item revision, the To Review
Package box displays the name to be assigned to the imported
revision package. If that is not the name you want, replace it with
another name.

If you do not have a folder or an item revision selected, and are
therefore importing to the Newstuff folder, the To Review Package
box is blank. If you do not type a name in the To Review Package
box, the system assigns a number-based name.
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5. Click OK.

The system creates a new review package and a corresponding dataset
type, such that the container dataset is referenced in the review package
item revision.

6. To open the .pcf or .zip file, double-click the dataset.
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Activity: Share data

This activity takes about 20 minutes.

In this activity, you create a review package, add a DirectModel dataset to
it, and then export it to your local disk. Because this training setup does not
allow for coworkers to modify the data in the container file you exported,
modify it yourself. After you modify it, you import the container file back
into My Teamcenter.

Step 1: Create a review package.

Select the Home folder.

Choose File→New→Item.

From the list of types on the right, select Review_Pckg.

Click Next.

Click Assign.

In the Name box, type RP_dir_mod and then press the Enter
key.

Click Finish.

Click Close.

6-10 Teamcenter Express Collaborative Product Data Management MT15330-S-041



Sharing data outside of Teamcenter Express

Step 2: Activate the review package.

Select the review package.

Right-click the review package and choose Make Active Review
Package.

Step 3: Add a DirectModel dataset to the review package.

Search for an item with Item ID = 1250*.

Close the Search view.

From the search results, expand the 1250-Axle item,
expand the 1250/000-Axle item revision, and then select the
DirectModel dataset.

Right-click the DirectModel dataset and choose Add to
Review Package.

Note

Selecting Add to Review Package prompts the system to
add the review package to the active review package.

Teamcenter Express Collaborative Product Data Management 6-11



Sharing data outside of Teamcenter Express

When the system informs you that it is adding the
DirectModel dataset, click OK.

The system displays the DirectModel dataset in the review
package revision.

To view the dataset, expand the review package and the review
package revision.

Step 4: Export the review package revision.

Select the review package revision.

Right-click the review package revision and choose Export
Review Package.

Note the selections made in this dialog box.

Note

In this activity, you do not e-mail the file, but simply save
it to your local disk.
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Click the Select dataset types to be exported button .

To move all dataset types to the Include Dataset Types list,
click .

Click OK.

Click OK.

The system exports the container file to the specified directory.

Step 5: Modify the data.

Click the C:\Test directory button at the bottom of the window.

Note

When working in Teamcenter Express, you navigate to
the export directory.

Double-click the .pcf file.

The system opens the file in XpresReview.
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Click the Text button (at the bottom of the window).

Click on top of the axle, near the center.

From the list on the left, click <Free Text> and then click the
Add button.

In the Text box, type: Check length and diameter.

Click OK.

From the toolbar, click the Save button.

Close XpresReview.

Close Windows Explorer.

Step 6: Import the modified container file into My Teamcenter.

Choose Tools→Import→Objects.

Click the Select object from system button .

Double-click the .pcf file you exported earlier.
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Click OK.

The system imports the PCF dataset.

This concludes the activity.
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Summary
In this lesson, you learned how to:

• Create a review package.

• Add objects to the review package.

• Export a review package.

• Modify container file data.

• Import a container file.
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Lesson

7 Performing where-used and
where-referenced searches

Purpose

In this lesson, you perform where-referenced and where-used searches.

Objective

After you complete this lesson, you should be able to perform:

• Where-referenced searches.

• Where-used searches.

Help topics

Additional information for this lesson can be found in:

• Getting Started With Teamcenter Express

• Rich Client Interface Guide
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Perform a where-referenced search
You can perform a where-referenced search to find parts and specifications
related to an object.

In the following example procedure, suppose you want to find all locations
where the BBDS5453/000-Axle, High Speed design specification is being
referenced.

1. Select the BBDS5453/000-Axle, High Speed document revision.

2. Choose the Impact Analysis view.

3. From the Where list, select Referenced.

The results of the where-referenced search is a list of all objects that are
related to the design specification.

4. In the Impact Analysis view, double-click the objects whose references
you want to view.

Key points

The following are key points about where-referenced search results:

• Where-referenced displays are connected with blue links.

• The Impact Analysis view allows you to perform either a where-used or
where-referenced search in the same display.

• The relationships are displayed graphically, in the Impact Analysis view.
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Activity: Perform a where-referenced search

This activity takes about five minutes.

In this activity, you perform a where-referenced search on the BBDS5453
design specification document.

Step 1: Perform a where-referenced search to locate all parts affected by
the design specification.

In My Teamcenter, expand the Items folder.

Expand the BBDS5453-Axle, High Speed document.

Select the BBDS5453-Axle, High Speed document revision.

Choose the Impact Analysis view, and from the Where list,
select Referenced.

The system shows the locations where the BBDS5453-Axle,
High Speed document revision is being referenced.

This concludes the activity.
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Perform a where-used search
You perform a where-used search to find assemblies that use a selected item.

In the following example procedure, suppose you want to find assemblies
where the 1503-Wheel is being used.

1. Select the 1503-Wheel item.

2. Choose the Impact Analysis view.

3. From the Where list, select Used.

4. In the Impact Analysis view, double-click the 1503-Wheel item.

Use the where-used rule option to narrow down your search according to
revision rules.
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To specify a revision rule to use in the where-used search:

• From the Rule list, select one of the revision rules.

Key points

The following are key points about where-used search results:

• Where-used displays are connected with red links.

• The where-used search results consist only of item revision objects.

• You can perform iterative expansions of where-used search results by
double-clicking objects displayed in the Impact Analysis view.

• You can specify the depth of the output results: you can choose to
display the where-used results with only One Level, All Levels, or the
Top Level assembly, as explained in Specify depth for where-used and
where-referenced searches

• You can specify the revision rule to use in the where-used search by
selecting a revision rule from the Rule list.
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Activity: Perform a where-used search

This activity takes about 10 minutes.

In this activity, you perform a where-used search on the 1503-Wheel to see
where it is used.

Step 1: Perform a where-used search on the 1503-Wheel item.

Expand the Items folder.

Select the 1503-Wheel item and choose the Impact Analysis
view.

Set the Where option to Used.

The system shows the next higher assemblies that use the
wheel.
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Step 2: Perform a where-used search on 1510/001-Wheel Assy.

From the where-used results display, double-click the
1510/001-Wheel Assy item revision.

The system displays the 2505/000-Frame Assy, which is the
next higher assembly that uses the 1510/001-Wheel Assy.

Step 3: Perform a where-used search on 2505/000-Frame Assy.

From the where-used results display, double-click the
2505/000-Frame Assy.

The system displays the 6510/000-Skate Assy, Left, which is
the next higher assembly that uses the 2505/000-Frame Assy.

This concludes the activity.
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Specify depth for where-used and where-referenced searches
When performing where-used and where-referenced searches, you can specify
the depth of the output results.

From the Depth list, select one of the level display options:

One Level Shows the parent level in the structure.
All Levels Shows all the item revisions that have the selected item as

a component.
Top Level Shows only the top-level assembly that uses the selected item.
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Summary
In this lesson, you learned:

• The Impact Analysis application allows you to perform either a
where-used or where-referenced search in the same display. The
relationships are displayed graphically.

• Perform a where-referenced search to find out where a selected object is
being referenced. Where-referenced displays are connected with blue
links.

• Perform a where-used search to find assemblies that use the selected item
revision. You can choose to display the where-used results with only One
Level, All Levels, or the Top Level assembly. Where-used displays are
connected with red links.

• You can perform iterative expansions of the search by double-clicking the
object button in the Impact Analysis view.
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Lesson

8 Editing product structure

Purpose

The purpose of this lesson is to create and maintain bill of materials (BOM)
data using Structure Manager.

Objective

After you complete this lesson, you should be able to build structure using
Structure Manager.

Help topics

Additional information for this lesson can be found in Structure Manager
Guide.
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Building structure
You can create structure using the following:

• New Item dialog box

• Copy and Paste options

• Add and Paste Special options

Using Copy and Paste

Copying and pasting information into Structure Manager is one method for
building structure. You can do the following:

• Copy more than one item revision to create several components at the
same time.

• Use the Paste command to take items and item revisions from the
clipboard and create components in an assembly in Structure Manager.

• Select several target assemblies to add the components in one operation.

• Copy items and item revisions from other application windows and paste
them into Structure Manager.

Using Paste Special

In Structure Manager, if you want to paste a component multiple times, use
the Paste Special command. This method pastes what is currently in your
clipboard.

To paste a component multiple times:

1. Be sure to have a component copied in the clipboard.

2. Choose Edit→Paste Special.

The system displays the Paste dialog box.

3. In the Number of occurrences box, type how many times you want the
component to be displayed in the BOM.

4. In the Quantity per occurrence box, type the quantity within each
specified occurrence.

5. Click OK.
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Using Add

The Add dialog box is similar to the Paste dialog box. The main difference
between the two dialog boxes is that the Paste dialog box prepopulates the
Item ID (revision) and Name boxes with an item (revision) from the clipboard.
When using the Add dialog box, you specify a component by entering the ID
(rather than pasting from the clipboard).

You can add multiple occurrences, as well as more than one quantity per
occurrence. For example, you may have one occurrence of a rivet with a
quantity per occurrence of 50, or two occurrences of a rivet each with a
quantity of 25.

To add a component multiple times:

1. Choose Edit→Add.

The system displays the Add dialog box.

2. Click the Open object by name button .

The system displays the Open by Name dialog box.

3. In the Name or the ID boxes, type either the name or the ID of the
component you want to add and then click Find.

4. From the resulting list, double-click the component of interest.

The system enters the component information in the Add dialog box

5. In the Number of occurrences box, type how many times you want the
component to be displayed in the BOM.

6. In the Quantity per occurrence box, type the quantity within each
specified occurrence.

7. Click OK.
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Activity: Create assembly structure

This activity takes about 25 minutes.

In this activity, you build an inline skate assembly structure.

Step 1: Create a new recreational skate line top-level item.

Select the Items folder.

Choose File→New→Item.

The system displays the New Item dialog box.

From the list of types on the right, select Item.

Click Next.

The system displays the Enter Item Information form.

In the Item ID box, type 6205_000 and then press the Enter key.

In the Revision box, type 000 and then press the Enter key.

In the Name box, type Rec. Skate Assembly and then press
the Enter key.

Note

When the Unit of Measure box is left blank, no unit of
measure is applied to the item. Usually the box is left
blank when the item cannot be described in terms of a
unit of measure.
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Click Finish.

Close the New Item dialog box.

The system places the new item in the Items folder.

Step 2: Send the top-level assembly to Structure Manager.

From the Items folder, select the 6205_000-Rec. Skate
Assembly item.

Right-click and choose Send To→Structure Manager.

The system displays the item in Structure Manager.

Step 3: Create the Skate Assembly, Left item.

Choose File→New→Item.

Click Next.

In the Item ID box, type 3210_000 and then press the Enter key.

In the Rev box, type 000 and then press the Enter key.

In the Name box, type Skate Assembly, Left and then press
the Enter key.
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Click Finish.
The system places the new item as a child of the
6205_000/000-Rec. Skate Assembly because that is the
assembly you had selected.

Step 4: Create a new Skate Assembly, Right item.
Click Next.

In the Item box, type 3220_000 and then press the Enter key.

In the Revision box, type 000 and then press the Enter key.

In the Name box, type Skate Assembly, Right and then press
the Enter key.

Click Finish.

Close the New Item dialog box.

Step 5: Create the new Boot Assembly, Right item.
Select 3220_000/000-Skate Assembly, Right.

Display the New Item dialog box again (File→New→Item).

Click Next.

In the Item ID box, type 3230_000 and then press the Enter key.

In the Revision box, type 000 and then press the Enter key.

In the Name box, type Boot Assembly, Right and then press
the Enter key.

Click Finish.
The system places the new item in 3220_000/000-Skate
Assembly, Right. Note the + button to the left of the assembly.

Close the New Item dialog box.

Expand the 3220_000 node.
The system displays the new item.

Select 3220_000/000-Skate Assembly, Right again.
Besides the item you created, 3230_000/000-Boot Assembly,
Right, the system displays three additional items (created so
you can finish the simulation faster).
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Step 6: Save Structure Manager.

On the toolbar, click the Save button .

Step 7: Add the 3102 Boot, Right item to Boot Assembly, Right. Because
this item already exists in the database, you use Edit→Add.

In Structure Manager, select 3230_000 and choose Edit→Add.
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In the Item ID box, type 3102 and then press the Enter key.

The system fills in the Add dialog box with information about
the 3102 item ID.

Click Apply.

The system places the 3102 Boot, Right item inside the
assembly and leaves the Add dialog box open.

Step 8: Add 3118 Collar to Boot Assembly, Right.

With the Add dialog box still displayed, in the Item ID box, type
3118 and then press the Enter key.
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Click OK.

The system places the 3118 Collar item inside the assembly
and closes the Add dialog box.

Click the Save button .

Step 9: Find an existing buckle assembly by name and add it to Boot
Assembly, Right with a quantity of three (3).

Return to My Teamcenter and click the Search button .

Tip

To return, click the Back button .

In the Name box, type Buckle Assembly.

Click the Go button .

In the results window, right-click the 4103-Buckle Assembly
and choose Copy.
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Return to Structure Manager.

Tip

Click the Forward button .

Note

In the next action, choose Edit→Paste Special rather
than Edit→Paste because choosing Paste Special allows
you to indicate how you want to paste the item.

Choose Edit→Paste Special.

In the Number of occurrences box, type 3.

Click OK.

The system adds three occurrences of the buckle assembly to
3230_000/000-Boot Assembly, Right.

Expand 3230_000/000-Boot Assembly, Right.
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Click the Save button .

In the steps that follow, you add an existing brake assembly to
6205_000/000-Rec. Skate Assembly.
To demonstrate copying structure between two Structure
Manager windows, you open a second Structure Manager
window for 6120/000-Skate Assembly, Right (which contains a
brake assembly).

You then copy and paste the structure of the brake assembly
from the second Structure Manager window into the
6205_000/000-Rec. Skate Assembly Structure Manager
window.

Step 10: Find 6120-Skate Assembly, Right and send it to Structure
Manager.

In My Teamcenter, in the Search view, click the More button.

Search for the item ID 6120.

From the search results, right-click 6120-Skate Assembly,
Right and choose Send To→Structure Manager.

Step 11: Create side-by-side Structure Manager views.

Click the Split window button .

The system splits the window. One side displays the 6120
assembly and the other side is blank.

Click in the blank window.

The system makes the new window active.

From the bottom left of the Structure Manager window, click
the Open object by name button .

The system displays the Open by name dialog box.

In the ID box, enter 6205* and then press the Enter key.

Double-click the result.

The system replaces the blank window with a view of the
6205/000-view BOM view revision.

Step 12: Copy the existing brake assembly into 6205/00-Rec. Skate
Assembly.

In the 6120/000-Skate Assembly, Right window, select
5101/000-Brake Assembly.
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Click the Copy button .

In the 6205_000/000-Rec. Skate Assembly window, select and
then expand 3220_000/000-Skate Assembly, Right.

Click the Paste button .

The system lists the 5101/000-Brake Assembly under
3220_000/000-Skate Assembly, Right.
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In the top right corner of the 6120/000-Skate Assembly, Right
Structure Manager window, click the x to close the window.

Step 13: Remove Tongue from Boot Assembly, Right (decided that it is not
going to be used).

In 6205_000/000-Rec. Skate Assembly, select
3260_000/000-Tongue, Right.

Remove this line from the BOM by clicking the Remove a line

button on the toolbar.

Save Structure Manager.

This concludes the activity.
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Activity: Complete the product structure for the skate line

This activity takes about five minutes.

In this activity, you add the frame assembly to the recreational skate
assembly.

Step 1: Send the top-level Rec. Skate Assembly to Structure Manager.

To locate the 6205_000-Rec. Skate Assembly item, in My
Teamcenter, expand the Items folder.

Select the 6205_000-Rec. Skate Assembly item.

Right-click and choose Send To→Structure Manager.

The system displays Structure Manager.

Step 2: Add Frame Assembly to Skate Assembly, Right.

In My Teamcenter, search for 2105-Frame Assembly.

Tip

In the Item ID box, type 2105.

Select the 2105-Frame Assembly item.

Right-click and choose Copy.

In Structure Manager, right-click the 3220_000/000-Skate
Assembly, Right item revision and choose Paste.

The system lists the 2105-Frame Assembly item revision
under the 3220_000/000-Skate Assembly, Right item revision.

Expand the 3220_000/000 node.

Save Structure Manager.

This concludes the activity.
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Summary
In this lesson, you learned:

• You can create product structure in Structure Manager using the New
Item dialog box and the Add and Paste Special dialog boxes.

• The main difference between Add and Paste Special is that the Paste
Special dialog box prepopulates the Item ID (Revision) and Name boxes
with an item (revision) from the clipboard.

• Using the Add dialog box, you can specify a component by entering the
item ID (rather than pasting from the clipboard).

• Number of occurrences corresponds to the number of instances of the
component to add to the structure.

• Structure Manager displays the information that resides in the BOM
view revision.

• Use BOM view revisions to manage product structure for item revisions.
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9 Planning and tracking your work

Purpose

The purpose of this lesson is to teach you how to plan and track your work in
Teamcenter Express.

Objective

After you complete this lesson, you should be able to:

• Create schedules, tasks, and milestones.

• Set up notifications and subscriptions.

• Assign resources to tasks.

• Integrate schedules with Teamcenter workflow.

• Manage calendars.

Help topics

Additional information for this lesson can be found in the Schedule Manager
Guide.
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Introducing Schedule Manager
You plan and track your work in Teamcenter Express using Schedule
Manager. As a schedule owner, you can set up a project so that you are the
only one who can update it; you can give others the capability to update
specific tasks or schedule subsections; or you can give everyone on the team
the ability to update the entire schedule.

The Schedule Manager interface presents information in two different views:
a Task list and a Gantt chart. You can resize these views by dragging the
border between the two views.

When you select a task from the Task list, the system displays the
corresponding task bar in the Gantt chart.

Task list

In the left pane, the Task list shows all tasks and milestones in table format.
Columns provide the following information: task ID, task name, start date,
finish date, duration, predecessor task, and successor task. The system
automatically assigns a task number to each task.

Gantt chart

In the right pane, the system displays the schedule as a Gantt chart. The
schedule can be viewed by week, month, quarter, or year. The Gantt chart
provides a visual representation of a project’s tasks. Using your mouse, you
can manipulate items in the Gantt chart.
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Process overview
The following flowchart illustrates the process to plan and track your work
using Schedule Manager.

The sections that follow guide you through each step of the process so you can
successfully learn to plan and track your work using Schedule Manager.
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Create a schedule
You create schedules from My Teamcenter or from Schedule Manager.
Although you can create schedules in both applications, in My Teamcenter you
can only view the schedules. To manage the schedules, you must open them
in Schedule Manager as explained in Open a schedule in Schedule Manager.

1. In either My Teamcenter or Schedule Manager, choose
File→New→Schedule.

2. Select Schedule and click Next.

3. Click Assign.

4. In the Name box, type a name for the schedule.

5. (Optional) Type a description for the new schedule.

6. Click Next.

7. (Optional) In the Customer Name and Customer Number boxes, type the
name and number of the customer to which this schedule applies.

8. Select a time zone.

9. Select the start and due dates.

All tasks and milestones must fall within the start and due dates. After
the schedule is created, you can change the start and due dates using the
schedule Properties dialog box (right-click schedule and select Properties).

10. (Optional) Select options for the schedule.

• Percent Complete is linked to Work Complete

If you change the actual work completed, the percentage completed
changes to equal the percent of scheduled work completed.

If you change the percentage completed, the actual work completed
changes to equal the scheduled work multiplied by the percentage
completed.

• Template

Saves the schedule as a template, which can then be used as a basis
for other schedules.

• Published

Allows other users access to the schedule.

• Public
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Allows published schedules to have the same access rights as
templates.

A public schedule can be seen by anyone who has access to the folder
in which it resides, even people who are not assigned to the schedule.
You are assigned observer rights to a public schedule, unless you have
additional rights.

• Notification Enabled

Sends notifications when specific triggers occur within a schedule.

11. If you have a schedule template you want to use:

• Select the Use an existing Schedule template for this new Schedule
check box.

• Click the Template button.

• In the Choose a Schedule Template dialog box, select the template
you want to use and then click Select.

The selected template displays in the box next to the Template button.

Note

If you used a template for this schedule, the system displays the
start date in the Shift Date box. To change the start date, click the
corresponding button and select a new date.

12. Click Finish.
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Open a schedule in Schedule Manager
After you create a schedule in My Teamcenter, you open it in Schedule
Manager to manage it.

1. Open My Teamcenter.

2. Navigate to a schedule.

3. Perform one of the following:

• Double-click the schedule.

• Right-click a schedule and choose Send To→Schedule Manager.

The Schedule Manager application opens and displays the schedule.
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Create tasks and milestones
After you create a schedule, you can add tasks and milestones to it.

Create a Task
1. In Schedule Manager, select a schedule.

2. Choose File→New→Task.

3. Select Schedule Task and click Next.

4. Click Assign.

5. In the Name box, type a task name.

6. (Optional) Enter a description for the task.

7. Click Next.

8. In the Type box, choose a task type:

• Fixed Work

Keeps the hours constant while duration or resource to task is
modified (default).

• Fixed Duration

Keeps the length of time constant while the work or resource is
modified.

• Fixed Resource

Keeps the resource constant while the work or duration is modified.

Note

Leave the Create Phase Gate Structure check box cleared. For more
information about phase gate structures, see Integrate schedules
with Teamcenter workflow.

9. Select a start and due date by clicking the corresponding date buttons.

10. In theWork Estimate box, type scheduled work for the task. You can enter
information as hours, days, or weeks (for example, 20.5h or 5d or 1w).

You can also click the Work Estimate button to open the Hours Chooser
dialog box where you can enter duration in minutes, hours, days, weeks,
months, and years.
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11. In theWork Complete box, type the amount of work completed, if the task
has already been started. You can enter information as hours, days, or
weeks (for example, 40h or 5d or 1w).

You can also click the Work Complete button to open the Hours Chooser
dialog box where you can enter duration in minutes, hours, days, weeks,
months, and years.

12. Click Next.

13. Assign members to the task.

For information about assigning members to a task, see Assign resources
to tasks.

14. Click Finish.

The system displays the task.

Create a Milestone

Milestones are tasks with zero duration. You can convert a task to a milestone
by setting its duration to zero hours (for example, Program Approval Phase
– Management Approval). You can also convert a milestone into a task by
setting its duration to greater than zero hours.

1. In the Task list, select the task for which you want to create a milestone.

2. Choose File→New→MileStone.

The system adds the milestone to the Task list and labels it Milestone.
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Modify a Milestone
1. In the Task list, double-click the milestone.

The system displays the Properties dialog box.

2. To change the name of the milestone, type a new name in the Name box.

3. To automatically change the milestone’s status to Complete when its
predecessor is complete, set Auto-Complete to true.

4. Click OK.
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Set up notifications and subscriptions
You can use notifications and subscriptions to notify individuals, including
yourself, of important events associated with selected tasks.

Create a notification

You can create notifications to notify you, fellow team members, and even
people outside the team of important events, such as due dates, milestones,
and task completions. When you create the notification rule, you can change
the text of each predefined notification. You can create an unlimited number
of notifications, based on the existing set of notification rules, and you can
configure a notification rule for a schedule to notify the schedule team when a
document has been added to a schedule.

Notifications can be received by any user in the system, a custom e-mail
address, or people meeting the following qualifications: member of a schedule,
member of a group, or member assigned to a task (for a task notification).

1. From the Task list, select one or more tasks.

2. Choose Edit→Notification Rules.

3. In the Notification Rules dialog box, click New.

4. Select a rule from the list and click Next.

Depending on the rule selected, additional dialog boxes may appear.
Complete them as necessary.

5. Select the members to be notified when the rule triggers.

All disciplines in the membership appear in the list. When notifying
disciplines, the system notifies members of the discipline who are also
members of the schedule. When notifying groups, the system looks up and
notifies all group members when an event is triggered.

6. Click the Select button next to Add other members of the organization to
notify recipients who are not currently scheduled resources.

7. Type additional e-mail addresses, separated by commas, and click Next.

8. Type a subject and the message text or use the information provided.

9. Click Finish.
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10. Close the Notification Rules dialog box.

The system adds an envelope on the task icon.

Create a subscription

You can create a subscription for a task that notifies you when a specified
task-related event occurs. Subscriptions are similar to notifications except
that you can send a subscription only to yourself.

You can use the Subscription Rules dialog box to see a list of existing e-mail
subscriptions, create new subscriptions, and modify existing ones.

1. Select one or more objects from the tree. You can select a task or a
milestone.

2. Choose Edit→Subscription Rules.

3. In the Subscription Rules dialog box, click New.

4. Select one of the rules from the list and click Next.

Depending on the rule selected, additional dialog boxes may appear.
Complete them as necessary.

5. Type a subject and the message text or simply use the information
provided.

6. Click Finish.

7. Close the Subscription Rules dialog box.
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Assign resources to tasks
As the project manager responsible for creating a schedule, you define the
resources for the project. As the project scope becomes more defined and you
fill out the schedule by adding tasks and milestones, you are likely to refine
your resource needs.

You can start adding the names of resources who will be working on this
project as you acquire them. These may be the names of actual people, or
they may be disciplines that act as placeholders until you are ready to assign
actual tasks.

Note

You can also assign resources when the task is created.

1. Right-click a task and choose Assignments→Assign to Task.

2. Add resources to the task by clicking their corresponding Assigned box.
To assign:

• A member from a group, click the + arrow to expand the Group folder,
then click the group members corresponding Assigned box. You
cannot assign a group to a task, only its members.

• A discipline to a task, click its corresponding Assigned box. To assign
a member from a discipline, click the + arrow to expand the discipline
folder, then click a member’s corresponding Assigned box.

Note

People in the discipline are people who are members of the
schedule and members of the discipline.

3. Click OK.
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Integrate schedules with Teamcenter workflow
The Teamcenter workflow process divides a project into a series of phases
that define best practice activities. After each phase of the process, there is a
gate or quality control checkpoint. The process evaluates the phase at the
gate to ensure the action plan and request for resources are sound.

In Schedule Manager, a phase-gate initiative is a special type of schedule.
A phase corresponds to a summary task. A gate is a special task, which
provides criteria to determine if the phase has been completed. Tasks within
phases and gates, are then linked to Teamcenter workflow. Phases are not
linked to Teamcenter workflow.

Creating a phase gate initiative in Schedule Manager allows you to submit
tasks to Teamcenter workflow. As tasks are worked on and updated in
Teamcenter workflow, that information is sent to Schedule Manager, where
the corresponding information is updated.

1. Create a schedule as explained in Create a schedule.

2. Create a new task as explained in Create tasks and milestones, being
sure to select Create Phase Gate Structure as you go through the New
Task wizard.

Once created, the schedule displays a phase, two milestones, and a gate.
The phase appears as hatched lines.

3. To add more phases, repeat the process.
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Create deliverables
Deliverables can be associated with schedules and with the tasks within a
phase. For example, a design document may be associated with the develop
design document task.

Create schedule deliverables
1. In Schedule Manager, select a schedule.

2. Choose Schedule→Schedule Deliverables.

The system displays the Schedule Deliverables dialog box.

3. Click Add to add a line.

You can remove a deliverable from the Schedule Deliverables dialog box
by selecting the deliverable and clicking Remove.

4. In the Name box, type a name.

5. Click the Type box and select a type from the list.

6. Repeat steps 3 through 5 to add another schedule deliverable.

7. Click OK.
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Create task deliverables
1. In Schedule Manager, select a task.

2. Choose Schedule→Task Deliverables.

The system displays the Task Deliverables dialog box.

3. Click Add to add a line.

You can remove a deliverable from the Task Deliverables dialog box by
selecting the deliverable and clicking Remove.

4. Click the Schedule Deliverable box and select a deliverable from the list.

5. Click the Submit Type box and select a type from the list.

6. Repeat steps 3 through 5 to add another task deliverable.

7. Click OK.
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Manage calendars

Teamcenter uses four types of calendars that allow you to set up work days,
work hours, holidays, and vacations used by your organization:

• Base calendar

• User calendar

• Schedule calendar

• Schedule user calendar

Calendars define working times. They do not define hours per day.

Schedule, user, and schedule user calendars share a parent base calendar. A
calendar inherits all exceptions from the parent calendar. A calendar can also
inherit the default working times from the parent calendar.

In this training, the focus is on the schedule calendar. For information about
other calendar types, see the Schedule Manager Guide.

Schedule calendar

The schedule calendar allows you to set days off, holidays, and hours in a
day for the current schedule. When a schedule is created, its calendar is the
same as the base calendar. When you change a schedule calendar, the system
automatically recalculates the schedule.

Set daily defaults

You can set daily defaults and hours for specific dates. From the Daily
Defaults section, you can change workdays and change the number of hours
in a day for scheduling purposes.

Note

You can only set daily defaults and hours for schedules that have not
yet been published. That is, when creating the schedule, in the New
Schedule dialog box, you did not check the Published check box.

1. In Schedule Manager, choose Schedule→Schedule Calendar.

2. Select the check box beside a day you want to specify as a working day.

Clear the check box next to a day you want to specify as a nonworking day.
The system automatically resets the hours box to 0.
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Set hours for specific dates
1. Choose Schedule→Schedule Calendar.

2. Select the day or days you want to change (use the Ctrl key to select
multiple days).

3. To change a work day to a nonworking day, select Non Working.

To change the working hours for the selected day(s), select Working
HH:MM and then select the corresponding Details button. In theWorking
Day Exception Details dialog box, update the working hours and click OK.
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Activity: Create a schedule

This activity takes about 20 minutes.

In this activity, you create a schedule, open it in Schedule Manager, create
tasks, and assign tasks to users.

Step 1: Create the schedule.

In My Teamcenter, choose File→New→Schedule.

Select Schedule and then click Next.

Click Assign.

In the Name box, type Schedule A, and press the Enter key.

Click Next.

In the Customer Name box, type ABC Corp, and press the
Enter key.

In the Customer Number box type 12345, and press the Enter
key.

Set Finish Date to November 6.

Tip

Click the button to the right of Finish Date and then
click 6.

Click Finish.

Step 2: Open the schedule in the Schedule Manager application.

Right-click the schedule and choose Send To→Schedule
Manager.

Step 3: Create the task.

In Schedule Manager, select the schedule.

Choose File→New→Task.

Select Schedule Task and then click Next.

Click Assign.

In the Task Name box, type Task 1 and press the Enter key.
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Click Next.
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Set Finish Date to August 28.

Tip

Click the button to the right of Finish Date and then
click 28.

Click Next.

Step 4: Assign the task.

Assign the task to Bjorn by selecting the Assigned check box
to the right of Designer, Bjorn.

Click Finish.

This concludes the activity.
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Summary
In this lesson, you learned:

• The basics of creating and managing schedules.

• How to create tasks and milestones.

• How to set up notifications and subscriptions.

• How to add resources to tasks.

• The basics of integrating schedules with Teamcenter workflow.

• How to create deliverables.

• How to manage calendars.
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Lesson

10 Releasing data

Purpose

The purpose of this lesson is to describe the process of releasing data in
Teamcenter Express.

Objective

After you complete this lesson, you should be able to:

• Differentiate between the two release methods.

• Set release status manually.

• Submit data for review and perform a review task.

• Work with the worklist.

• Identify life cycle states.

• Explain the difference between target and reference objects.

• Use Workflow Viewer and audit files to track processes.

• Delegate tasks.

Help topics

Additional information for this lesson can be found in:

• Workflow Viewer Guide

• Rich Client Interface Guide
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Methods for releasing data
In Teamcenter Express, you can release data either manually or using a
workflow process.

Release data manually

If you want to quickly set the release status on an item revision and not go
through a workflow process, use the Status Manager, as described next. After
you release an item revision, you cannot make any more changes to it.

1. Be sure that you are logged on to Teamcenter Express as a user with
the Author role.

2. Select the item revision you want to release.

3. Choose Tools→Status Manager→20 Checking.

Note

Only users with the Checker or Manager role can select the other
two status options, 60 Released or 10 Check Rejected.

The system changes the status of the selected object to 20.

Note

The rest of this lesson provides information about releasing data using
workflow processes.
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Releasing data using workflow processes

Workflow stems from the concept that, to accomplish an objective, all work
must flow through one or more processes. Workflow is the automation of
those business processes. Using workflow, documents, information, and tasks
are passed between users during the completion of a particular process.

By default, Teamcenter Express provides several workflow templates that
are ready to be used. In addition to the workflows provided with Teamcenter
Express, your site administrator can use Workflow Designer to model
workflow processes, allocate resources, and manage data according to
business rules. You use the worklist to accomplish workflow tasks.

Teamcenter Express provides two applications you can use to accomplish
workflow objectives:

• My Worklist

Allows you to perform and track tasks that have been either assigned to
you or were created by you. The worklist provides you with a list of all the
tasks that you are responsible for, and allows you to complete those tasks.

• Workflow Viewer

Allows you to view the progress of a workflow process, even if you are not
a participating member of that particular process.

A process uses defined tasks to automatically notify selected users requesting
work signoff. The requests are tracked through an electronic worklist and
each request maintains pointers to the data being approved.

A process can have any number of tasks arranged in a serial or parallel
progression. At the time of signoff, each review task has a list of users
allocated to perform the signoff.
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Check in data
You cannot initiate a workflow process on data that is checked out. To remove
the checked-out status of data when you are finished working on it, use either
the Check In or Cancel Checkout commands.

Perform a checkin
1. Select the object you want to check in.

2. Choose Tools→Check In/Out→Check In.

The system prompts you to confirm the checkin.

3. To verify that you’re checking in the correct object, click the More link.

The system displays the name of the object you are checking in.

4. Click Yes.

The system unlocks the data that was checked out.
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Cancel checkout

When you cancel checkout, the system unlocks the checked-out dataset and
returns the data to the original condition it existed in before it was checked
out.

Note

You can only cancel the checkout of datasets.

1. Select the dataset whose checkout you want to cancel.

2. Choose Tools→Check In/Out→CancelCheckOut.

3. Click the More link.

4. Click Yes.
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States of release
A status type (release status) can be set on almost any data, after a process is
completed. The release status property of the object informs you about the
function or purpose of the data. An object’s release status properties include
the release status name and the release status date.

The following shows an example of release status:

Data in the system can be in one of three life cycle states:

• Statused (numerical value)
Data stored with item revisions that have obtained this status are
considered production data. The data is generally in a write-protected
mode, meaning it cannot be changed unless a new revision letter is
created. Teamcenter Express provides a built-in release status (10 to 90)
to be used as designated by your company.

• In-process
The object is in a workflow process.

• Working (empty value)
If the item revision has no value for status, it is working data, meaning
that someone is working on the data contained in the item revision.
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Working with My Worklist
Use the worklist to perform electronic workflow processes. The worklist
contains two folders:

• Tasks to Perform folder contains tasks that you must review and approve
or reject, as needed.

• Tasks to Track folder contains tasks you assigned to other users for
processes you initiated.

The only tasks you see in your worklist are those tasks you must perform or
those tasks for which you are responsible.

Key points

The following are key points about working in the worklist.

Use the worklist to:

• Access tasks.

• Receive new task notification.

• Gain access to the process window.

• Assign users to review the data.

When working with the worklist, the Viewer view provides two views, task
and process, as explained in the next sections.
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Viewing task information
The Task View option in the Viewer view gives you a focused view of the
selected task. The Task View window shows key information about the task
in the form of links that provide access to dialog boxes where you can view or
modify the task information.

Use the Task View pane to perform several operations, as explained next.

View or reassign a responsible party
1. From the Task View window, click the link to the right of Responsible

Party.

The system displays the Assign Responsible Party dialog box.

Note

The default responsible party is the task originator.

2. Assign the responsible party.

3. Click OK.
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View task instructions
1. From the Task View window, click the second link to the right of

Responsible Party, labeled Instructions.

The system displays the Instructions dialog box.

2. View the task instructions the assigned user must perform to complete
the task.

3. Close the dialog box.

View attachments

An attachment is an object associated with a process. There are two kinds
of attachments:

• Target objects

Any objects that are released through a process. Target objects are
assigned a release status when the process completes.

• Reference objects

Objects required to provide information to persons performing tasks.
Reference objects do not get a status change when the process completes.
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1. From the Task View window, click the link to the right of For Review,
labeled Attachments.

The system displays the Attachments dialog box, which lists the target
and reference objects for the selected task.

2. Close the dialog box.

View user, group, and role assignments

View the user group and role assigned to complete the task and, if
appropriate, delegate the task to another user group/role.

1. From the Task View window, click the link under the User-Group/Role
column.

The system displays the Delegate Signoff dialog box.

2. Make any changes as needed.

3. Click OK.
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View or modify decision
1. From the Task View window, click the link under the Decision column.

The system displays the Signoff Decision dialog box for the task.

2. Select a decision.

3. (Optional) In the Comments box, type any comments.

4. Click OK.

Teamcenter Express Collaborative Product Data Management 10-11



Releasing data

Viewing process information
The Process View option in the Viewer view gives you a graphical display of
the overall process as it moves through the different stages of release.

A Review task is a task template that includes select-signoff-team and
perform-signoffs subtasks. Each of these subtasks contain their own dialog
box for executing the respective processes. In the example figure, the
in_Approval task is a review task.

Note

The green arrow indicates which task is active in the process.
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Initiate a process
1. Select the revision object you want to put through a process.

2. Choose File→New→Workflow Process.

Tip

You can also use the Ctrl-p key combination to access the New
Process dialog box.

The system displays the New Process dialog box and places the selected
object on the list as a target.

3. The Process Name box is populated with a name based on the object
you selected. You can, however, change the text in this box. The process
name should be short and descriptive.

4. (Optional) In the Description box, type a description for the process.

5. From the Process Template list, select a process template.

For a description of the process templates, see Process templates provided
with Teamcenter Express.

6. Click OK.
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Process templates provided with Teamcenter Express

Process
template Purpose Approval Status

Development
Release

Signifies that the
development work is
complete.

Initiator
Checker

30

Engineering_
Order

Allows the initiation of an
engineering order and the
completion of the work it
describes.

Initiator
Manager
Checker

60

Obsolescence
Process

Allows parts to be obsoleted. Initiator
Checker

90

Production
Release

Signifies that the product
is ready for production (can
be used in conjunction with
the Development Release
template).

Initiator
Checker

60

Status Change Allows assignment of status. Checker 60
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Activity: Initiate the workflow process

This activity takes about five minutes.

In this activity, you initiate the workflow process. First, you verify that the
data is checked in.

Step 1: Verify that the data being released, 1250-000/000-Axle item
revision, is checked in.

In My Teamcenter, search for 1250-000-Axle.

Tip

In the Item ID box, type 1250-000.

Copy 1250-000-Axle into the Items folder.

– Copy 1250-000-Axle.

– Close the Search view.

– Paste 1250-000-Axle into the Items folder.

Expand the Items folder to locate the part for release,
1250-000-Axle.

Expand the item to show the 1250-000/000-Axle item revision.

Expand the 1250-000/000-Axle item revision.

Select the item revision.

Choose the Details view and review the Checked Out column.

If the data is checked out, you see a Y in the Checked Out
column.
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Step 2: Initiate the 1250-000/000-Axle item revision for release.

Choose File→New→Workflow Process.

The value in the Process Name box defaults to the name of the
object you selected for release.

The system automatically pasted the 1250-000/000-Axle item
revision into the Process Name box with a relation of Target
shown in the Attachments tab.

From the Process Template list, select Production Release.
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Click OK.

The item revision now has in-process status, and the system

displays the in-process symbol to the right of the item
revision name.

This concludes the activity.
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Perform a review task
Once the designer submits data for review, the system distributes the
perform-signoffs task to the appropriate user’s worklist.

1. From your worklist, expand the Tasks to Perform folder.

2. Select the perform-signoffs task.

Note

Before you perform a signoff, make sure your group and role settings
are correct.

3. From the Task View window, click the link under the Decision column.

The system displays the Signoff Decision dialog box for the task.
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4. Do one of the following:

• Click Approve and then click OK.

The system does one of the following:

– If you are the only approver, or last required approver, the process
moves to the next steps.

– If you are one of multiple approvers, and other approvers have
not approved yet, the perform-signoffs task moves to the Tasks
to Track folder.

• Click Reject and then click OK.

Selecting Reject rejects the signoff of the task. This means that your
decision does not count toward the approval/signoff of the task. If
the quorum requires all signoffs to approve, selecting Reject stops
the process.

Depending on how the process is designed, selecting Reject does one
of the following:

– Removes the perform-signoffs task from the worklist and returns
the process to a previous task.

– Moves the perform-signoffs task to the Tasks to Track folder but
keeps the current review task the active process task.
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Activity: Perform a review

This activity takes about 15 minutes.

In this activity, you perform a review to validate the target objects and then
submit the task to a checker. Target objects are any objects that are released
through a process. Target objects are assigned a release status when the
process completes.

Step 1: Locate and view your task.

Click the Inbox button .

Expand Designer, Bjorn (bjorn) Inbox and then expand the
Tasks to Perform folder.

The system displays a perform-signoffs task in your folder.
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Step 2: Approve the data.

Select the perform-signoffs task.

Choose the Viewer view.

To see where the process goes after you approve the data, click
Process View.

In the Process View window, select the top node of the task
tree, Production Release.

The system shows the entire process flow.

Click Task View.

In the Decision column, click the No Decision link.

The system displays the Signoff Decision dialog box.

Click Approve.

Click OK.

The system removes the perform-signoffs task from your Tasks
to Perform folder and replaces it with a select-signoff-team
task.
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Step 3: Assign Johannes Engineer as checker.

Select the select-signoff-team task.

Select */Checker/1.

From the Organization list, expand Checker and select
Johannes Engineer (johannes).

Click Add.

The system adds Johannes to the */Checker/1 list.

Click Apply.

The system places the task in your Task to Track folder, as well
as in Johannes’s Task to Perform folder.

Note

In the next section, you learn how to monitor a process
after it leaves your worklist.
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Step 4: Log on as Johannes (ID is johannes, password is johannes) and
approve the task to release the object.

To speed up the simulation, we log you off and log you back on
(as Johannes Engineer).

Go to your worklist.

Expand Johannes Engineer (johannes), and then from the
Tasks to Perform folder, select the perform-signoffs task.

Choose the Viewer view.

In the Decision column, click the No Decision link.

Click Approve and then click OK.

The system releases the item revision with a status of 60.
Note, however, that because you are logged on as Johannes, the
item revision is not visible to you. To see the status change,
search the database for the 1250-000/000-Axle item revision
and verify that it is released.

Tip

In the Item ID box, type 1250-000.

This concludes the activity.
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Following a process after it leaves your worklist
To monitor a process after it leaves your worklist, use Workflow Viewer or the
audit file, as explained next.

Launch Workflow Viewer

Use Workflow Viewer to track jobs that are currently in a workflow process
(even if you are not a participating member of the process). Workflow Viewer
has all of the features of the Viewer view in My Teamcenter plus some added
capability.

1. In My Teamcenter, select any data identified as in-process ( ).

2. Right-click and choose Send To→Workflow Viewer.

The system displays the Workflow Viewer.

In the Workflow Viewer, you can view the following elements of a workflow
process:

• Task flow

• Task status

• Task attachments

• Participants

• Participants dispositions
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View the audit file

The audit file is a record of all user involvement during the workflow process.

1. In My Teamcenter, select any data identified as in-process ( ) or any
data that went through a process.

2. Choose View→Audit→File.

The system displays the audit file for the selected task.
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Delegate tasks
Use the Out of Office Assistant to forward your tasks to another user’s
worklist while you are out of the office.

1. Click the Inbox button .

2. Choose Tools→Out of Office Assistant.

The system displays the Out of Office Assistant dialog box.

3. Specify how long you will be unavailable and who should perform your
tasks in your absence.

4. Click OK.

Key points

The following are key points about the Out of Office Assistant:

• The worklist redirects tasks assigned to you during your absence to the
selected user.

• System administrators can modify any user’s Out of Office Assistant
settings.
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Summary
Use either the manual method or the workflow method to release status.

When using the workflow method, use the worklist to access tasks, get new
task notification, and gain access to the process window. The only workflow
objects that you see in your worklist are those tasks that you must perform or
those tasks for which you are responsible.

Data in the system can be in one of the following life cycle states:

• Statused (numerical value)

• In-process

• Working (empty value)

As data flows through a process, you work with two kinds of attachments:

• Target objects

• Reference objects

When working with the worklist, the Viewer view provides two views:

• Task view

• Process view

From the worklist, you can choose Tools→Out of Office Assistant to forward
your tasks to another user’s worklist while you are out of the office.
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11 Viewing product data

Purpose

The purpose of this lesson is to demonstrate how to translate CAD files and
documents, and how to use the rich client Lifecycle Visualization application
to create markup information from 2D and 3D visualization data.

Objectives

After you complete this lesson, you should be able to:

• Translate CAD files and documents.

• Locate and view 2D and 3D visualization data using rich client
Visualization.

• Use rich client Lifecycle Visualization to create 3D markup data.

• View 3D markup data in the thin client.

• Create 2D markup data in the thin client.

Help topics

Additional information for this lesson can be found in:

• 2D/3D Viewing Guide

• DHTML Thin Client Help
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Translating CAD files and documents
If Express Translation Services (ETS) is installed and configured at your site,
My Teamcenter displays the Translation menu. Use the Translation menu
to translate CAD files into a format that can be viewed using Teamcenter
Express Visualization or Teamcenter Visualization. For example, you can
translate NX files to formats such as JT and CGM, and Solid Edge files to
formats such as JT and IGS. Moreover, you can translate MSOffice documents
to PDF. For a complete list of formats to which you can translate files, see
the online help.

Note

The commands available on this menu vary depending on the ETS
configuration implemented at your site.

In Teamcenter Express, you can translate data either manually (on-demand
translation) or using workflows, as explained next.

Translate data manually
1. In My Teamcenter, select one or more CAD datasets or MSOffice

documents.

2. From the Translation menu, select a translation option.

When the translation is complete, the system places the translated files
under the appropriate item revision. The translation job can take a few
minutes.

Note

If the dataset is incompatible with the translate option you selected,
the system displays an error message.

3. Monitor the translation status as explained in this lesson, in Monitor
translation status.

4. When the translation job is complete, click to view the results.
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Translate data using workflows

When you release an object, you have the option of translating data as
part of the release process. The two workflow processes that release parts,
Production Release and Engineering Order, are the ones that support
translation. Your system administrator sets the translation preferences for
your company.

To translate data using a workflow, follow the same procedures as you
would when sending data through a workflow, but remembering to use the
Production Release or the Engineering Order processes. For a detailed
example of sending data through a workflow, see Activity: Initiate the
workflow process in Lesson 10, Releasing data.

Monitor translation status

To monitor translation status, choose Translation→Translation Request
Administration.

1. After you have sent data through the translation process, choose
Translation→Translation Administrator Console.

2. Use the State, Service, and Priority lists to set the criteria corresponding
to the requests for which you are searching.

3. Click Query.

Note

For more information about the options available in this dialog box,
see My Teamcenter Guide.

The system shows the status of your translation job. Every time you click
Query the system refreshes the dialog box and displays the latest status.

Note

The first row in the status table shows the most recent translation
job.
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Activity: Translate a Microsoft Word file to PDF

This activity takes about 10 minutes.

In this activity, you translate a Microsoft Word file to PDF.

Step 1: Create a text dataset.

From the Items folder, select the 1503/001-Wheel item revision.

Choose File→New→Dataset.

Click the More link and select MSWord.

In the Name box, type Word_dataset.

Click OK.

Expand the 1503/001-Wheel item revision and double-click the
MSWord dataset.

The system opens the MSWord dataset.

In the box outlined with a gray box, type Creating a text
dataset, and then click the Save button.

Close Microsoft Word.

Step 2: Translate the Microsoft Word file.

Choose Translation→Translate.

Click OK.
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Step 3: Monitor the translation status.

Choose Translation→Administrator Console – ALL.

The system displays the translation status in the Request
Administration Console dialog box.

To see the latest status, click the Refresh All button .

When the status is COMPLETE, the translation job is done and
the system creates the PDF.

Note

When working in Teamcenter Express, the translation
job takes several minutes.

Close the Request Administration Console dialog box.

Double-click the Word_dataset PDF file.

The system displays the PDF file in Acrobat Reader.

Close Acrobat Reader.

This concludes the activity.
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Where is the visualization data?
2D and 3D visualization data exists as dataset objects within an item revision.

There is no limitation of dataset types that may contain visualization data.
Some of the more common dataset types that you can expect to provide
visualization data include:

Common 3D visualization dataset types:

• DirectModel

Common 2D visualization dataset types:

• UGMASTER

• UGPART

• DrawingSheet

• Image

• SEDraft

• ACADDWG

View 2D data
1. Select the image dataset you want to view.

2. Choose the Viewer view.

Rich client Lifecycle Visualization displays the 2D image.
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View 3D data
1. Select the DirectModel dataset you want to view.

2. Choose the Viewer view.

Rich client Lifecycle Visualization displays the 3D image.
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Activity: Locate and view visualization data

This activity takes about 10 minutes.

In this activity, you view an item’s 2D and 3D visualization data using the
rich client Lifecycle Visualization application.

Step 1: View the 2D visualization data.

In your Items folder, expand the 1250-Axle item.

Expand the 1250/000-Axle item revision.

Expand the DWG1250 UGPART.

Select the SH1 image dataset.
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Choose the Viewer view.

After a moment, the rich client Lifecycle Visualization viewer
displays the CGM (2D) file of the part drawing.

To display the 2D Markup toolbar, right-click the Lifecycle
Visualization toolbar and select 2D Markup.
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Step 2: View the 3D visualization data.

From the object tree, select the DirectModel dataset.

The rich client Lifecycle Visualization viewer displays the JT
(3D) file of the part model.

Right-click the Lifecycle Visualization toolbar and select 3D
Measurement.

This concludes the activity.
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Creating 3D markup data
Markup is text or graphical elements that you draw in the Viewer using rich
client Lifecycle Visualization. 3D markups are created on 3D layers of static
JT component parts or assemblies (DirectModel datasets).

Engineering checkers may use 3D markup to communicate comments on
engineering designs to the design engineers.

Key Points

The following are key points about creating 3D markup data:

• To store the 3D markup data, the system creates DirectModel 3D
markup datasets from the DirectModel datasets.

• Teamcenter Express uses the DirectModel 3D markup datasets to
manage 3D markup data.

• You can create multiple DirectModel 3D markup datasets and associate
them with a single JT part or assembly.

• Each DirectModel 3D markup dataset can contain multiple markup
layers.

Creating 3D markup data involves the following steps:

1. View the DirectModel dataset.

2. Create the 3D markup annotation for a 3D markup layer.

3. Save the 3D markup layer.

4. Save the 3D markup dataset.

Teamcenter Express Collaborative Product Data Management 11-11



Viewing product data

Activity: Create 3D markup data in the rich client

This activity takes about 15 minutes.

In this activity, you create 3D markup for 1250-Axle.

Step 1: Create a 3D markup annotation and a 3D markup layer.

Right-click the Lifecycle Visualization toolbar and choose 3D
Markup.

On the 3D Markup toolbar, click the Enable Markup button .

Click the Text button .

To attach the markup text to a point on the model, so it rotates
with the model, click the Anchor Mode button .

Click in the center of the model.

The system displays the Markup Text dialog box.

Click Free Text.

The system displays the Edit Free Text dialog box.

Click Add.
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In the Text box, type Example 3D Markup.

Click OK.

Click OK again.

Step 2: Save the 3D markup layer.

Right-click the Lifecycle Visualization toolbar and choose
Create markup.

On the Create markup toolbar, click the Save 3D Layers button
.

The system displays the Create Markup 3D Dataset dialog box.

In the Dataset Name box, type Layer1_3D_Markup.
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Click OK.

The system informs you that it is saving the layer.

Click OK again.

The system saves the markup layer and displays it under the
DirectModel dataset.

Expand the DirectModel dataset to see the markup layer.

Step 3: Save the markup dataset in Teamcenter Express.

Choose File→Save.

This concludes the activity.
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Working with 3D markup layers

The following are some key concepts about working with 3D markup layers:

• To manage existing layers or add more layers, right-click a layer in the
Markup Layers list.

• To display options for modifying the markup layer content, right-click in
the Viewer view. Depending on where your cursor is positioned when you
right-click, the system displays different menus and options.

• To turn on and off the display of annotation layers, select the check box
next to the annotation layer name.

• Remember to save any new annotation layers or modified annotation
layers.

• Deleting a markup layer is a two-step process: first you remove the named
references, then you delete the layer.
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Delete a layer

1. Remove the named reference for the layer from the DirectModel 3D
markup dataset.

a. Right-click the DirectModel 3D markup dataset and choose Named
References.

The system displays the Named References dialog box.

Note

A 3D markup layer is stored as a VPL-formatted file.

b. In the Named References dialog box, select the layer you want to
delete and click the Cut button .

The system removes the layer from the Markup Layers list.

c. Close the Named References dialog box.
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2. Delete the layer.

• Click theDirectModel 3D markup dataset and then, from the toolbar,

click the Delete button .
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Viewing 3D markup
After creating the 3D markup in the rich client, you can view it in the thin
client, as shown in Activity: View the 3D markup in the thin client. You can
also create markup in the thin client, as shown in Activity: Create 2D markup
data in the thin client.

To learn more about the thin client, see Thin client interface.
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Activity: View the 3D markup in the thin client

This activity takes about 10 minutes.

In this activity, you view in the thin client the 3D markup you created in
the previous activity.

Step 1: Launch the thin client.

In the Web browser Address box, type the address
of the Teamcenter Express application server
(http://tcx3train:8080/tc/webclient) and press the
Enter key.

The system displays the Teamcenter Login page.

Type your user name and password (bjorn/bjorn).

Click Login.

The system opens the Home folder in My Teamcenter.

Step 2: Install Lifecycle Visualization.

Choose Help→Installations→Teamcenter Visualization.

When prompted to save or run the setup file, click Run.

When you see a security message warning of an invalid
publisher, click Run.

The Lifecycle Visualization installation begins.

When the installation is complete, click OK.

Step 3: View the 3D markup.

Expand the Items folder.

Expand the 1250-Axle item.

Expand the 1250/001-Axle item revision.
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To the right of Layer1_3D_Markup, click the View link.

Note

The first time you launch Lifecycle Visualization, the
system prompts you to open or save a some.vvi file.
When prompted, click Open.

The system displays the markup.

This concludes the activity.

11-20 Teamcenter Express Collaborative Product Data Management MT15330-S-041



Viewing product data

Create 2D markup data
Drafting checkers may use 2D markup to communicate comments on the
accuracy of an engineering drawing.

Although 2D visualization data can be associated with various dataset types,
2D markup data can only be associated with the following dataset types:

• DrawingSheet

• Image

2D markup is stored as a Markup2D dataset associated with either an Image
or DrawingSheet dataset.

Creating 2D markup data involves the following steps:

1. View the 2D Image or DrawingSheet dataset.

2. Create the Markup2D dataset.

3. Create the annotations for the 2D markup layer.

4. Save the 2D markup layer.

5. Save the Markup2D dataset.
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Activity: Create 2D markup data in the thin client

This activity takes about 15 minutes.

In this activity, you create 2D markup data for the DWG1250/- image.

Step 1: View the 2D visualization data.

In thin client, click the View link to the right of SH1, nested
under DWG1250/-.

The system displays the Enter Network Password dialog box.

Type your user ID and password and click OK.

The Viewer displays the CGM (2D) file of the part drawing.
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Step 2: Create annotations for the markup layer.

On the Markup toolbar, click the Unrestricted Text button .

The system adds a new layer in the Markup Layers listing.

Click in the upper left corner of the graphics area.

The system displays the Text Editor dialog box.

In the Text Editor dialog box, type Example 2D Markup and
then click OK.

The system places your annotation in the graphics area. It also
adds some symbols next to the name of the new markup layer,
indicating that you must save the layer.
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Step 3: Save the new markup layer.

Choose File→Layers→Save All Layers.

The displays the New Markup Dataset dialog box.

Type a name for the layer, in this case test.

Close the Teamcenter Visualization Mockup dialog box by
clicking the x on the right side.

This concludes the activity.
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Working with 2D markup layers

The following are some key concepts about working with 2D markup layers:

• The annotation is listed as a layer in the layer list and is a CGM formatted
file.

• Right-click a layer in the layer list to manage existing annotation layers
or add more annotation layers.

• Remember to save any new annotation layers or modified annotation
layers. The symbols to the left of the layer indicate that save is required.

• You can turn on or off the display of annotation layers by selecting the
check boxes to the left of the annotation layer name.
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Procedural considerations
The following are some details about working with markup datasets.

When can markup data be created?

Markup data can be created for 2D and 3D visualization datasets at any
time during the data life cycle. For a review of Teamcenter Express life cycle
states, see Lesson 10, Releasing data.

Who can create a new markup dataset?

Generally, there are no restrictions to limit who can create a markup dataset
for a visualization dataset. You can have numerous independent markup
datasets for a single visualization dataset, each having been created by
a different user.

Who can define layers within a markup dataset?

Generally, there are restrictions to limit who can add annotation layers to a
single markup dataset. Some examples of who can create annotation layers
within a markup dataset include:

• Only the creator of the markup dataset.

• All members of the same group as the markup dataset creator.

• Only defined roles within the group that owns the markup dataset.
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Summary
2D and 3D visualization data exists as dataset objects within an item revision.

• To view the data using rich client Lifecycle Visualization, with the Viewer
view active, simply select the dataset in the object tree.

• Markup datasets can only be created and associated with the following
dataset types:

DirectModel

DrawingSheet

Image

• 3D markup data is stored as a DirectModel 3D markup dataset that is
associated with a DirectModel dataset.

• 2D markup data is stored as aMarkup2D dataset that is associated with
either an Image dataset or a DrawingSheet dataset.
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Lesson

12 Managing engineering orders

Purpose

The purpose of this lesson is to describe the process of managing an
engineering order within Teamcenter Express.

Objective

After you complete this lesson, you should be able to:

• Create an engineering order.

• Complete the engineering order request and submit it to the Engineering
Order workflow.

• Approve or reject the engineering order request and route it to the
corresponding branch in the workflow.

• Perform the changes to the product and submit the engineering order
for the final checking.

• Specify the checker and approve the engineering order.

Help topics

Additional information for this lesson can be found in Getting Started With
Teamcenter Express.
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Engineering orders
Engineering order is the process of controlling changes to a product’s
definition and configuration. Engineering order provides an auditable history
of the objects used in a process, making an object’s various usages traceable.
Your site can use engineering order to propose, incorporate, review, and
approve changes, as well as to track and report change history and to notify
members of your organization of changes.

Your company’s business process determine the point in the product life cycle
when an engineering order begins. Regardless of when an engineering order
process starts at a company, it is usually an ongoing process that continues
until the end of the product’s life cycle.

Typically, the change process begins with the creation of an engineering order,
which acts as a template of the different change processes to be used at your
site. Change requests are then created by users using engineering order
workflow process, as needed. When the change requests have been completed
and approved, change notices are typically created.

Figure 12-1 illustrates the engineering order process.

Figure 12-1. Engineering order process

When you create an engineering order, the system automatically creates
forms for the change request and change notice details and four folders that
store data related to the change. Table 12-1 describes the engineering order

folders ( ). You can add a reference part or other data (for example, a
Microsoft Word document from your Home folder, a part from an engineering
database, a capture of the Viewer’s display, a markup of data, and so on)
to the engineering order using copy and paste techniques. This helps to
complete the engineering order request.
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Table 12-1. Engineering order folders

Folder name Description

New Parts Holds the new item revision, if any, resulting from
the change to the revised item revision; it is released
with the engineering order. This assembly is the
final solution to the problem the engineering order is
correcting.

For example, if the revised item revision is a mount
screw that has been decreased, then the entire
mounting assembly is the solution assembly.

At the end of the engineering order process, the system
attaches a release status to the new parts.

When the engineering order is released, the new
parts, and all of their components, are authorized for
production.

The New Parts folder cannot contain objects that have
already been released. A new part can be:

• A new component that replaces an old component
in the parent assembly, which has been placed in
the Revised Parts folder.

• A new assembly that has never been released.

Do not confuse new parts with revised parts. These two
types of objects are mutually exclusive. The revised
part is the final product. New parts are supplementary
objects that are involved in the solution the engineering
order is bringing about.
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Table 12-1. Engineering order folders

Folder name Description

Obsolete Parts Holds the item revision being replaced by the revised
parts.

Typically, the obsolete item is the latest released
version of the object on which the revised part is based.
Therefore, if the obsolete item is rev A, the revised item
is rev B.

Reference Data Holds reference data, which is data that pertains to
the engineering order, such as a document. Reference
data can be used to associated data related to the
engineering order, such as documents, parts, and so on.

Information in this folder does not get a status.

Revised Parts Holds the item revision revised by the engineering
order; it is the item revision being released.

A revised part can be either an assembly, or a piece part.

At the end of the engineering order process, the system
attaches a release status to the revised parts.

When the engineering order is released, the revised
parts, and all of their components, are authorized for
production.
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Activity: Initiate an engineering order

This activity takes about 10 minutes.

In this activity, you initiate an engineering order, which involves the following
steps:

• Creating an engineering order for a part

• Completing the engineering order request

Step 1: Create an engineering order for the 1113-000-Hub item.

Select the Home folder.

Choose File→New→Item.

The system displays the New Item dialog box.

From the list of types on the right, select Eng_Order and then
click Next.

In the Item ID box, type EO000000 and press the Enter key.

Tip

To be sure you type the item ID correctly, you may want
to just copy the item ID from the procedure into the Item
ID box.

In the Revision box, type A and press the Enter key.

In the Name box, type Change1 and press the Enter key.

Click Finish.

The system creates the engineering order, EO000000-Change1.

Close the New Item dialog box.
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Step 2: Complete the engineering order request.

Expand the engineering order object and the engineering

order revision .

Double-click the CR-Change Request form.

Click the Check-Out and Edit button.

When asked to verify that you want to check out the form,
click Yes.

In the Description box, type Engineering Order and press the
Enter key.

Click Check-In.

Search for the 1113-000-Hub item.

Tip

In the Item ID box, type 1113-000.

Close the Search view.

In the Search Results view, expand the 1113-000-Hub item.

Select the 1113-000/A-Hub item revision and click the Copy
button.

In your Home folder, under the engineering order item revision,
select the Obsolete Parts folder and click the Paste button.

Expand the Obsolete Parts folder.

Create a new item revision, 1113-000/B-Hub.

Tip

Select the 1113-000/A-Hub item revision and choose
File→Revise.

The system places the new revision under the
1113-000-Hub item.

Copy the new item revision, 1113-000/B-Hub, and paste it into
the Revised Parts folder.

Expand the Revised Parts folder to verify that the system
copied the item revision.
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This concludes the activity.
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Activity: Complete an engineering order

This activity takes about 20 minutes.

In this activity, you complete the engineering order, which involves the
following steps:

• Starting the Engineering Order workflow process

• Approving the task and routing it to a manager

• As the manager, approving the engineering order request, and then
routing it to the corresponding branch in the workflow

• Performing changes to the product, and then submitting the engineering
order for the final checking

• Specifying a checker for the engineering order

• As a checker, approving the engineering order

Step 1: Start a workflow process to manage the engineering order.

Select the EO000000/A-Change1 engineering order revision

and choose File→New→Workflow Process.

The system displays the New Process dialog box.

From the Process Template list, choose Engineering_Order.

Click OK.

Step 2: Approve the task and route it to a manager, Bill Manager, in the
Engineering group.

Open your worklist, expand the Tasks to Perform folder and
click the (perform-signoffs) task.

Choose the Viewer view.
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Click No Decision.

Click Approve and then click OK.

The system displays a new (select-signoff-team) task in the
Tasks to Perform folder.

Select the (select-signoff-team) task to display it in the Viewer.

Under the Signoff Team→Profiles list, select
Engineering.Express_Organization/Manager/1.

From the Organization list, expand Manager and select Bill
Manager (bill).

Click Add.

Click Apply.

The system routes the workflow to the approver’s worklist,
in this case, Bill.
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Step 3: Log on as Bill (bill/bill), approve the engineering order request, and
then route it to the corresponding branch in the workflow.

To speed up the simulation, we log you off and log you back on
(as Bill Manager).

Open your worklist, expand the Tasks to Perform folder and
click the (perform-signoffs) task.

In the Viewer view, click Attachments.

The system displays the Attachments dialog box.

Expand the engineering order to see its contents.

Close the Attachments dialog box.

Click No Decision.

Select Approve and click OK.

To speed up the simulation, we log you off and log you back
on (as Bjorn Designer).

Open your worklist, expand the Tasks to Perform folder, and
click the select-signoff-team task.

Choose the Viewer view.

To display the active users in the system, under the Profiles
list, click */Author/1.

From the Organization list, expand Author and select
Designer, Bjorn (bjorn).

To add yourself as a reviewer, click Add.

Click Apply.

The system sends the workflow to the selected reviewer’s
worklist, in this case, you.
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Step 4: Perform the changes to the product, and then submit the
engineering order for the final checking.

In your worklist, click the select-signoff-team task.

In the Viewer view, click Attachments.

In the Attachments dialog box, expand the engineering order
item.

Close the Attachments dialog box.

Click No Decision, click Approve and click OK.

The system displays a new (select-signoff-team) task in the
Tasks to Perform folder.

Step 5: Specify the checker for the engineering order.

Select the (select-signoff-team) task.

To display the active checkers in the system, from the Profiles
list, click */Checker/1.

From the Organization list, expand Checker and select
Johannes Engineer (johannes).

Click Add.

The system adds the user to the Profiles list.

Click Apply.

The system sends the workflow to the selected checker’s
worklist, in this case, Johannes.
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Step 6: As the checker from the Engineering.Express_Organization
group, approve the engineering order.

To speed up the simulation, we log you off and log you back on
(as Johannes Engineer).

In your worklist, expand the Tasks to Perform folder and click
the (perform-signoffs) task.

In the Viewer view, click Attachments.

In the Attachments dialog box, expand the engineering order
item revision.

Expand the Obsolete Parts and Revised Parts folders.

Close the Attachments dialog box.

Click No Decision, click Approve, and click OK.

The system releases the engineering order with a status of
60. However, because you are logged on as Johannes, the
engineering order is not visible to you. To see the status
change, search the database for the engineering order.

Tip

In the Item ID box, type EO000000.

This concludes the activity.
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Summary
In this lesson, you learned:

• What an engineering order is.

• How to complete an engineering order process.
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Lesson

13 Working with MS Office
documents

Purpose

The purpose of this lesson is to teach you how to manage Microsoft Office
documents in Teamcenter Express.

Objective

After you complete this lesson, you should be able to:

• Create a document in MS Word and save it to the Teamcenter database.

• Initiate workflow from MS Word.

• Approve workflow using MS Outlook.

Help topics

Additional information for this lesson can be found in:

• Getting Started With Teamcenter Express

• Teamcenter Integrations for Microsoft Office Guide

Teamcenter Express Collaborative Product Data Management 13-1



Working with MS Office documents

Managing MS Office documents in Teamcenter Express
Manage Teamcenter Express workspace objects in real time with Teamcenter
Integrations for MS Office. You can access Teamcenter Express directly
through Teamcenter Integration for MS Office, in the following applications:

• In MS Office 2003, MS Word, Excel, and PowerPoint

• In MS Office 2007, MS Word, Excel, and Outlook

Note

In this training, you learn about the Teamcenter Integration for
MS Office 2007.

The integration is independent of the Teamcenter rich client and thin client.
You can work with Teamcenter Integrations for MS Office while either client
is running. Or, you can work solely through the integration without running
Teamcenter Express.

Benefits of using Teamcenter Integration for MS Office 2007

After you log on to the database, you can do the following Teamcenter tasks
using MS Word, Excel, and Outlook:

• Create and manage folders

• Create and manage items and item revisions

• Create and manage datasets

• Create links to workspace objects

• Create and manage forms

• Search for Teamcenter objects

• Embed workspace objects

• Sign off on items

• Synchronize MS Office document properties with Teamcenter forms

• Submit items to workflow
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Activity: Manage MS Office documents

This activity takes about 20 minutes.

In this activity, you draft a project plan for an upcoming project, and then,
using the workflow functionality, you submit that document to your manager
for approval.

Step 1: Create a document.

Start MS Word 2007.

Click the Teamcenter tab.

The system displays the Teamcenter ribbon.

On the Teamcenter ribbon, click Browse.

The system displays the Teamcenter Login dialog box.

Type your user ID and password and click Login.
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Click the Home folder, and then click the Items folder.

Select the 1504-Wheel item. This is the item with which you
want to associate your project plan.

In the MS Word document, type the text shown next and then
press the Enter key.

Project Plan for the 1504-Wheel Item
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Step 2: Save the document.

On the Teamcenter ribbon, click Save As.

Click Dataset.

The system displays the Teamcenter Save As dialog box.

To expand the Home folder, click the triangle to the left of it.

In the same way, expand Items and 1504–Wheel.

Click the 1504/000–Wheel item revision.
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In the File name box, type 1504_info and then click Save.
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Step 3: From MS Word, send the item revision that includes the document
to the Production Release workflow.

Close the document (MS Office button®Close).

On the Teamcenter ribbon, click Open.

The system displays the Teamcenter Open dialog box.

Navigate to and select the 1504/000-Wheel item revision.

Note that the item revision contains the document you created.

From the right side of the dialog box, double-click the document.

Click the Teamcenter tab.

On the Teamcenter ribbon, click New Process.

The system displays the New Workflow Process dialog box.

From the Process Template list, select Production Release.

Click OK.

On the Teamcenter ribbon, click Browse.

Click Designer, Bjorn (bjorn) Inbox.

Click Tasks to Perform.

Click the arrow to the right of the perform signoffs task.

Click Approve.

Click the arrow to the right of the select signoff team task.

On the right side, click the Select Signoff Team button.

From the Signoff Team list, click */Checker/1.

From the Organization Profiles list, expand Express
Organization→Engineering→Checker.

Select your manager, Johannes Engineer.

In the middle of the dialog box, click the green arrow.

Click OK.
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Minimize MS Word.

Step 4: Approve the document. Unlike in the rich client, when you send
an item revision for approval, the system first gives you the task
to review the item revision, and once you sign off on it, it sends
the task to your designated checker, in this case your manager
(Johannes Engineer).

Start MS Outlook.

From the Teamcenter ribbon, click Browse Teamcenter.

Type your user name and password (johannes/johannes).

Expand Inbox→Tasks to Perform.

Right-click the task you want to approve, 1504/000-Wheel and
select View/Perform task.

On the right side of the window, click Approve .

The system deletes the task from your task list.

This concludes the activity.
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Summary
In this lesson, you learned how to:

• Manage Teamcenter Express in MS Office.

• Create documents in MS Word or MS Excel and save them to the
Teamcenter database.

• Initiate workflow in MS Word or MS Excel and approve workflow using
MS Outlook.
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________________________________________________________________________________

________________________________________________________________________________

Additional comments:

________________________________________________________________________________

________________________________________________________________________________

________________________________________________________________________________



________________________________________________________________________________

________________________________________________________________________________

________________________________________________________________________________

________________________________________________________________________________

________________________________________________________________________________





Teamcenter Express cPDM course agenda

Day 1 Morning

Introduction
Lesson 1
Lesson 2
Lesson 3

Course overview
Introducing Teamcenter Express
Getting started with Teamcenter Express rich client
Finding and viewing data

Afternoon

Lesson 4
Lesson 5
Lesson 6

Creating data in Teamcenter Express
Viewing product structure
Sharing data outside of Teamcenter Express

Day 2 Morning

Lesson 7
Lesson 8
Lesson 9
Lesson 10

Performing where-used and where-referenced searches
Editing product structure
Planning and tracking your work
Releasing data

Afternoon

Lesson 11
Lesson 12
Lesson 13

Viewing product data
Managing engineering orders
Working with MS Office documents
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